Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac Escalade Maintenance and Repair

1468910

Comments

  • i bought a cadillac escalade 2002 from a private so i did get the owner´s manual i wonder if somebody have it,and i also will like to now if there´s a fuse that control the pumps of the rear suspension, i will appreciate if somebody can tell me were is the fuse,or if there something else that can happen to my rear suspension that is lower now.
    thanks
  • steverstever Viva Las CrucesPosts: 41,049
    Check out Where To Find Your Car Owner's Manual Online.

    I wonder if your fuse question is covered by the manual - any owners with similar experiences please jump in.

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • I just purchase a new 07 and have bad air leak noise in the left side rear door. I've had the dealer replace the plastic molding, and the rubber seal around the door and I'm still getting the noise. It seems like the door was not made to fit. any suggestions would be great. :)
  • gwennie2gwennie2 Posts: 1
    Hi. I have a 2002 Escalade EXT, which I purchased new in 2002. It has about 85,000 miles on it now. Recently I had the front brakes and rotors replaced. Now it seems that sometimes when I stop, there is some play in the braking. The vehicle stops, but then it seems that the ABS is kicking in after the vehicle stops. This causes vibration after the vehicle stops, and although the vehicle will stop, it seems unsafe to me. I took the vehicle to a trusted mechanic, and he agrees that the problem is the ABS, but he was unable to specifically diagnose a problem. There are no lights on, and according to him, "no codes." He suggested that I take it to the dealership, but I wanted to do some independent research before I walk into that. Any information is most appreciated. :sick: :confuse:
  • hi my names antonio,, i got the answer for u ,,,, listen it is not your abs,, trust me i had the exact same problem,,, its a wheel bearing assembley it comes complete with the hub and all ,,,, it could be your driverside or passenger or maybe both,,,,trust me look into it ,,, if u jack your car up i bet one of the wheels u will be able to rock side to side,,, like if your looking dead at the tire and rim on either side of the car,, u wil be able to push and pull it,,, so when u go to stop and your almost at a stop the wheel has time to wobble and creates your brake to pulsate ,, abs control,,,,,,,,, your welcome i hope i helped
  • awf_axisawf_axis Posts: 136
    This is a known problem with the 07 models. Here is a link to a Caddy Owners web-site that discusses this issue. Mine doesn't have it, but it has to due with improper door alignment. There is a TSB (Technical Service Bulletin) that has been given to dealers on this, but you have to have a service dept willing to go through the motions.

    http://www.cadillacforums.com/forums/cadillac-escalade-ext-esv-forum-2007/129448- -wind-noise-2007-escalade.html

    Good Luck,

    Dave
  • aricdaricd Posts: 1
    So driving my EXT today in the pouring rain, I hit a flooded section of about 16" or so of slow-moving rainwater (I know, I know, I should have turned around before I even hit that) and I made it about 100 yards into the 'river' before it coughed, sputtered and died...The battery died immediately...

    After a lot of gibberish w/the local tow company and whatnot, about 2 & 1/2 to 3 hours later I was finally able to get towed out of the water...

    NO water came into the cab and the agua level was just shy of the bottom of the door (19" from the ground) on the driver side and a few inches below on the passenger...It does have 24" wheels and 35 series tires, so it may be a touch lower than stock, but I dunno...

    Obviously, the Escalade wouldn''t start after this event, but it did click and clatter and try to start on it's own while I was waiting for my tow...It has an aftermarket alarm system and an automatic start w/that system, so I'm wondering if that may have been the cause of it trying to start even w/the key out of the ignition??...

    So, it's currently 'drying out' on the curb...The battery is dead right now from the alarm system trying to start it (I assume)...

    My wonder is...Now what??...Do I charge that battery after letting it sit overnight and try cranking it up??...

    And I DO realize the sheer stupidity of fording water in an EXT, but what's done is done, I suppose...
  • Kirstie_HKirstie_H Posts: 10,896
    A reporter hopes to speak with current owners of large SUVs who are trying to sell their vehicle and their experience. If you are a consumer with a large SUV that just sold or looking to sell, please respond to ctalati@edmunds.com with your daytime contact information no later than Monday, March 24, 2008.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • madacarmadacar Posts: 1
    Hello,

    I am new to this forum. I am the owner of a 2006 Escalade. I am currently experiencing starting problems where you turn the ignition and engine does not fire or turn. However, I have read several postings on this forum and other respective forums related to starting issues.

    My wife was driving the SUV throughout the day and did not experience any problems with the vehicle starting or handling while driving. The SUV sat for 4 hours and would not start when I was attempting to go get dinner. I immediately, checked the battery and even tried to jump off with no success. However, my dash battery reading was within normal range and all components inside were operational. Next, I began my research by searching several forums and found several possible related issues. I tried several recommendations such as the following: 1) listening for the fuel pump to turn on by having one person turn the ignition while a second person listens to the fuel tank with gas cap off for two clicking sounds that would indicate fuel pump is turning on; 2) Checking the battery voltage; 3)checking cable connections; 4) checking spark plugs and wires; 5) Making sure the vehicle was in correct gear; 6) Try second key due to possible de-programming of original key (key may have been damaged by exposure to magnet or extreme conditions); 7) Checking fuses inside vehicle; and 8) Called the dealership (they repeated what was previous listed 1-7).

    I recently found a listing related to starting issues for Escalades that seemed far fetched, but, it worked (bad steering wheel positioning sensor). The post provided instructions to try turning the steering wheel so many degrees to the left or right while turning key in ignition. It worked! I immediately called the dealership and asked the same person who I called less than 5 minutes ago. I asked have you ever heard of this problem before. His Response: Yes, I have. My Response: Why did you not tell me this when I originally called.... You get the picture. I can only assume some Escalade owners my be experiencing the same problem. It would be reason to believe that if your steering wheel positioning sensor is totally shot then any attempt to turn the steering wheel left or right would be fruitless. However, this may be the answer to many persons problems with random non start problems.

    Oh! My instrument cluster was defective prior to this incident and was not on recall list. However, I reported the problem while under factory warranty and the dealership replaced this $800.00 part free of charge. Specifically, my battery display needle would randomly stick. Then the oil pressure gauge began to do the same. Finally, my speedometer needle would not go past 20 rpm. There is a recall for 2003-2005 and up instrument clusters from GMC/Cadillac Corp. However, I called Corp. and asked could it be possible I have the same instrument cluster that was installed on the 2005 due to part production dates (I have a 06). They would not respond and deferred to the recall for 2003-2005 in. Lucky, I reported the problem while my factory warranty was good.

    Vibration Problems

    I have 2008 22" OEM Cadillac Escalade Wheels on previous Escalade generation 2006 model. To resolve vibration issues I did the following: 1) dealership installed shims (eliminated knocking when turning); 2) New alignment/balancing; 3) New tires (use sensor from factory 2006 17" wheels) (Neo Gen Tires w/ 34-38 psi- varies with season). Wheels will vibrate in steering wheel for about 3 minutes or so when vehicle sits for prolonged periods (i.e. over 8 hrs) until tire pressure distribution settles due to heavy wheels. Believe me these wheels are very heavy. Hope this helps someone.
  • regrahamregraham Posts: 26
    I recently purchased a very low mileage 2007 Escalade. I live in Northern Canada and wanted to install mud guards to protect the paint and help keep it clean. It has the articulating running boards and appeared it would be difficult to make them fit, clear the front tires and front of the board. However, I discovered a simple solution. There are 4 allen bolts securing each board to the articulating mechanism and the boards have a sliding track. Just loosen the 4 bolts, slide the board back about 1/2 - 5/8" and there is room to mount the guard. The inner edge of the guard may have to be trimmed off to avoid rubbing the tire. GM part # to use is #19154428. The back of the board doesn't quite line up with the rear wheel well opening, but it is not overly obvious.
    I have one concern that maybe someone can answer. The rear drivers door isn't aligned flush with the rear panel. It is in at least 1/8" at the mid point and has to be closed quite firmly to close properly. Is this a common alignment problem? If I move the catch out about 1/8" to make it align it will be slightly out at the top. Will it then whistle? Any suggestions?
    Otherwise, I love the vehicle. Very sharp looking and really performs.
  • tom19382tom19382 Posts: 10
    Has anyone out there ever replaced an 02 AWD Escalade's Brake Pads? A friend of mine asked me if I could change hers for her. I Have done it on several other cars and was wondering if the Escalade is pretty straight forward or if there is anything I should know that might be different beforehand. Thanks for all of your help and I look forward to hearing from you.
  • consejeroconsejero Posts: 5
    I have the exact same problem...did you ever figure out what it was?
    please email me if you did.
    consejero@netzero.com
  • tidestertidester Posts: 10,109
    please email me if you did.

    What? And deprive our other members of valuable information? It's best to keep the discussion right here so everyone benefits. :)

    tidester, host
    SUVs and Smart Shopper
  • Hi there - my mom has a 2002 Escalade. A couple of weeks ago, she had to replace the fuel pump for $1100. Since then, she has issues where all of the interior lights will blink strangely, her seat will not move up or back, the security box will light up on her dash display, then her car will not start. My brother replaced the battery for her, but she is still having these issues. The car worked perfectly fine with none of these issues before the fuel pump was replaced. The dealer insists it is not an issue with the new fuel pump, and they have had her car at the dealership "trying to figure out the problem" for 4 days. Could all of this be related to the fuel pump being replaced? Thanks so much for any help. =-)
  • consejeroconsejero Posts: 5
    check the ground strap - First of all, I can't believe how much they charged you for the fuel pump but I guess that's the dealer for you.

    Some mechanics, rather than disconnecting the battery from the car, (specially since some cars have the battery in some really weird places now a day) disconnect the ground strap. It sounds like it's either still disconnected or lose. It should be somewhere under the car. It doesn't have any insulation on it and it looks like silver braded wires.
    Good luck!, please let me know if that's what it was.
  • fraustofrausto Posts: 1
    I just bought an 02 Escalade AWD 6.0 with 60,000 miles, and every time I try to start the SUV, ill turn on the switch and it would just sound like it wants to turn on but it doesn't, it sounds like if it was out of gas, so I let the key go and then I try it again and it turns on fine, it does this most of the times, however there is times (rarely) that turns on right away. I did not notice this when I bought it and when i noticed I thought I was just getting used to the truck, and since I bought it from a private party it has no warranty. has anybody had any similar problems and did you gets yours fix? or any suggestions on what it is?
  • consejeroconsejero Posts: 5
    It sounds like you're losing the prime in your fuel system.
    The fuel system runs on about 40 psi of pressure (there's a little shredder valve (like the one on your wheels) on top of the engine (it has a little black cap on it) that you can hook a gage up to and see what your fuel pressure is, should be 40-45 even when not running)

    It works like this... there's a supply line and a return line from the fuel tank. The fuel pump is inside the gas tank(electric) it sucks fuel and send's it to each individual injector, the engine burns some of the fuel and the excess get's send back to the tank. This is done so you'll always have more fuel than you need. It's kind of a "closed loop" if you will. The fuel travels from the low tank to the high injectors. Vacuum and pressure keep the fuel "at the ready" at the injectors so when you turn the key you have immediate on demand fuel. OK so what may be happening is that you're losing your prime which is your immediate fuel supply. This means that the gas, through gravity, went back to the tank. This is caused by either a faulty injector or a leak in the system somewhere. It can also be a partially clogged fuel filter or the fuel pump going out. The reason sometimes it works may be that you start the car before the fuel has had a chance to leak back to the tank in it's entirety. For example if you shut the car off, wait a few minutes then try it again it will probably start.

    The way to check this is by connecting a fuel pressure gauge to the shredder valve on the fuel rack when the car has been off for a while. Start by checking the pressure, if no pressure you'll probably have to take it somewhere to get it fixed as there's too many things that could be the cause. If you have pressure of some kind, replace the fuel filter, it's an inexpensive fix. It's probably not it but with 60K miles it probably needs replacing anyway. The next thing I would check is the resistance to the fuel pump as a faulty fuel pump is the most logical cause. Fuel pumps go out all the time specially when people make a habit of running their cars on empty since it needs to be completely submerged in fuel for proper lubrication. If it's neither of these things don't panic. Replacing this two items while troublesome is not that pricy and should be done anyway. When a fuel pump goes out, it doesn't care if you're on the freeway of going to church it just goes out and you're stranded. These may be symptoms, the pump may be trying to tell you that it's about to go.
    Besides a loss of prime in the fuel system, it could also be that the pump is not pressurising the system sufficiently to overcome the spring pressure on the injector until it's running for a few seconds.
    Replace the filter and the pump. If the problem persist you'll have to take it to a mechanic, but at least you'll have those two items new in your car... oh yeah, don't buy the cheapest pump either, buy the complete bolt on setup. More expensive but you don't want to be doing this again in a year since you have to lower your fuel tank to gain access.
    good luck, JR
  • cjordiecjordie Posts: 5
    I am very frustrated. I recently bought an 05 with 46000 miles. after my purchase I drove home and on the way the oil pressure needle gradually dropped to 0 and then the pressure light came on. It was towed to the dealer and the oil pressure sender was replaced. after I picked it up, drove home again and on the way the same thing happened. Towed to the dealer again and the oil pressure switch was replaced. Picked it up again and the same thing happened again. The cadillac dealer is at a loss and my car has been with the dealer 23 our of the 25 days that I havve owned it. Could there be another not so obvious problem as to why the gauge will start off fine and then gradually lower to zero when there is enough oil and pressure in the vehicle and no oil leaks. i think the gauge is bad, but i thought that would be an obvious thing to look at.
    Help!!!!!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,116
    Well the dealer could have done the radical, unheard of, bold and unusual action of screwing a mechanical oil pressure gauge into the engine to see what the actual oil pressure was, or reading it through a scanner by plugging in the device.

    You could have low oil pressure due to a plugged oil pump screen, loose oil pump pickup tube, or a faulty oil pump.

    By all means have SOMEBODY determine actual oil pressure. You don't want to be driving on low oil pressure.

    MODERATOR --Need help with anything? Click on my name!

  • cjordiecjordie Posts: 5
    Hello again
    The dealer called me today and stated that they have checked the oil pressure and pump etc, and there are no issues there. They beleive it to be something electrical which is causing the gauge to fall and the low oil pressure light to come on.
    Does anyone have any thoughts about this.

    Help:(
  • vajohnvajohn Posts: 8
    Had the same fright with my 03 ESV. The problem is a faulty gage cluster. GM sent out a "silent recall" on it about a year ago. Dealer should be able to confirm. GM extended warranty to 70K miles.
  • cjordiecjordie Posts: 5
    Just a quick update and still looking ofr answers, the oil pressure sending unit, swihch, and pump have been replaced and the problem is still occurring.
    The mechanic is very adament about it not being the the gauge cluster.
    Vajon was your oil gauge causing you the exact same problems and if so how long was it before the gauge cluster was found to be the culprit?
  • consejeroconsejero Posts: 5
    it's straight forward. I haven't replaced mine yet but did change the ones on my buddy's Chevy 1/2 ton truck which are the same. Remember 70% of your stopping power is coming from the front...get good pads. Make sure your rotors ar also withing tolerances and not grooved.
  • cjordiecjordie Posts: 5
    I am about to pull out my hair:::: the dealer called today and stated that they have not found the cause at this point and have been advised to tear down the engine.
    I don't know how to feel at this point. The dealer keeps ensuring me that they will find the problem and then laughed and said look at things on the other side....if the motor has a problem and they can not find it once it is taken apart, then cadillac will be sending a new motor and at least i will be the only driver on that motor.

    I am so frustrated:( :cry:
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,116
    So they are saying they checked the oil pressure with an analog gauge and it's good and they want to tear down the engine anyway?

    Makes no sense. :cry:

    Let's be rational here: either it's actual low oil pressure in the engine or it's an electrical/gauge issue. One or the other. Either the reading is "true" or it is false.

    If true, tear down engine

    If false, tear apart gauge system

    MODERATOR --Need help with anything? Click on my name!

  • cjordiecjordie Posts: 5
    Yes Sir, thats what they said alright, they started tearing it down yesterday. It appears that after they checked all of these things the problem was still occurring and they could not find the root, so they are tearing down the motor. When they put the new motor in( and i am sure they will since I really don't beleive they will find anything) and the oil light comes on, maybe then some one will listen and go back to the gauge as the cause. I suggested it 3 times and was told, "oh i pretty certain that is not " I really wish you could call them and talk some sense into somebody!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,116
    Well sounds like they already know everything :P

    MODERATOR --Need help with anything? Click on my name!

  • vajohnvajohn Posts: 8
    Absolutely amazing. Well, at least you get a new engine. The dealer gets a lot of $ and GM gets screwed. And afterward, you'll get a new gage cluster too.
  • I got a 2008 Escalade ESV with Direct TV antenna on top 22" rims and custom 14" flipdown monitor in the middle instead of the OEM one.....so far only problem i had was with my gas gauge going up and down for 1 week (such a headache) until dealer replaced fuse which was backordered.
  • I have a 2002 escalade on 24x10 rims. Recently all of a sudden after a car wash I noticed that every time I stopped, the car felt like the abs was kicking in. The next day I took it to the dealer and they said it was a valve and some $1500 module. However now the stability system and abs light are off but it still feels like the abs kicks on. But now there is no codes or abs lights or any indication anything is wrong. Please help, email is sonnyboy1979@yahoo.com
Sign In or Register to comment.