Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Volvo Problems--Questions/Answers Here!

schoemerschoemer Posts: 1
edited March 28 in Volvo
Help! Does anyone else have the coolant warning "stop engine" sign coming on frequently (at least 1x month for the last 6 mo. perhaps) The dealer keeps topping it off (sign comes on when it reaches the minimum level). The engine never shows hot, I never see evidence of a leak in my garage, yet the coolant disappears. The dealer checked and found no leaks. Dealer is not aware of this problem with anyone else, or so they claim. It is getting a bit annoying to say the least! Can't find any problems of this sort on this site except way back in 2000. My car has 55K but this has been happening since before the 50K warranty. Absolutely love the car otherwise!
«1

Comments

  • Did the dealer pressurize the cooling system and watch the pressure over a period of an hour or so?
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,790
    Tell the dealer or an independent shop to stop being lazy and diagnose the problem. Mullins is absolutely right, you need to pressure test the system and perhaps use a detecting dye to find the leak.

    You either have a hidden leak or a head gasket issue going on. Those are the only possibilities.

    MODERATOR

  • I bought a 2000 S80 2.9 and it has been nothing but problems. The transmission dropped at 50k, the onboard digital fuel economy gauge never worked (despite repeated trips to the dealer) and worse off, after three years, the driver's leather seat looks like it has 300k miles in wear. Did we get a lemon, or has anyone else experienced similar problems? This is our fourth and last Volvo. It's enough to make me long for the old 240.
  • jrosasmcjrosasmc Posts: 1,704
    Hmm, sounds like a lemon.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,790
    Well, not so fast here. I heard "3 problems in 50K miles".

    Now the trans is inexcusable, okay, one big demerit

    The gas gauge, well, just about any car made can fart one time electronically.

    The leather seats might have been a lack of instruction on Volvo's part to owner's on how to properly take care of leather. Lots of people really don't know and damage the interiors unknowingly. If the leather is allowed to dry, it will scrape and crack like nobody's business.

    Of course, leathers come in different grades, and I don't think Volvo uses top, top grade--but it should be a decent grade of hide. If it comes from Scandanavia, their hides look great and dress great because they don't use barbed wire but sometimes they aren't so durable. I owned three Saabs and all the leathers went to hell, but that was older stuff than yours, too.

    MODERATOR

  • jrosasmcjrosasmc Posts: 1,704
    Maybe Saab and Volvo didn't use the finest leather back in the day.
  • Since I have so much experience with the S80 problems, I feel that I can tell you this. GET OUT NOW! Seriously though, I just had my radiator replaced at <40,000 miles. I also rec'd low radiator fluid warnings. Three weeks after they replaced it though, I overheated and rec'd a "STOP CAR" message about a half mile from home. I barely chugged home and refilled the coolant. I brought it back in (1 1/2 hours round trip) and they said that there was an air gap in the hose that caused the most recent problem. I have zero faith in this car, so we'll see where I break down next???
  • lancerfixerlancerfixer Posts: 1,308
    The leather in my 740 looks great after 14 years, and I don't have a garage. I imagine the previous owner did. I regularly use Zymol cleaner and protectant (two separate products) on the seats, though.
  • balooobalooo Posts: 24
    I 'd like to have my oil changed by a less expensive service provider then the dealer.
    Does anyone know the "trick" to turning off the the service message?

    Assuming I can take my S80 in for major service intervals makes more sense to me.
    I have 15,100 miles on my S80 and took it in for the 7,500.
    I don't see the point in spending nearly one hundred bucks for what is basically an oil change.
  • I need to replace the windshield wipers on my '99 S80. Went to the auto store, the in-store computer matched me up with (supposedly) the correct wipers - but they are not as wide as the (original) ones on the car. Also, I note that the two wipers are of different sizes ...

    Does anyone know what wipers work as replacements ??? Thanks.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,790
    Get your wipers at the dealer. They cost a bit more but they fit and are of decent quality. This is one of those items where the dealer is your best shot. The big chain stores make lots of mistakes, and even if they don't, sometimes their products are substandard quality. Last thing you want is a nice big scrape mark on your windshield, which is NOT cheap to fix on your car.

    MODERATOR

  • Hi. Can anybody offer me some advice? I am thinking of purchasing 1991 740 station wagon. It looks in good shape. Has 144k miles on it. I am concerned after reading so many bad things about Volvo. I thought they were reliable cars.
    I dont have alot of money to invest in maintenance or upgrades. Any advice on this or a better station wagon? thanks much!
  • lancerfixerlancerfixer Posts: 1,308
    "I dont have alot of money to invest in maintenance..."

    Stop. Move on. Buy a Geo Prizm. Don't get me wrong, I love my 740, but maintenence is not cheap.

    Re: wipers. I'm not sure if the S80 is the same way, but the three Honda/Acuras I've owned have all used a larger driver's side wiper. I downsize by one inch on each side in the winter when I put snow blades on my Accord.
  • I have a 2000 S80 with 60,000 miles that is in the shop at the moment with transmission problems. Isn't this unusal to have transmission problems at 60,000 miles. What should I be alert for with dealing with the dealership?

    Thanks for the help.
  • Just hit 50K on my 2000 Volvo S80 (2.9) I received a message that read "performance reduced". My car is idling rough. Has anyone received this message and know what the problem is?
  • tmarttmart Spring, TXPosts: 1,009
    Where did this message appear?
  • This message appeared on the dashboard message display next to the speedometer. It has now disappeared- I wonder what has happened?
  • 80708070 Posts: 1
    I own a 1991 volvo 240. I love the car but Ive noticed 2 somewhat annoying things with the car.One thing is the servicelight comes ON every 5k miles like its supposed to, then shuts off after 2 minutes which is normal.However,is there any way I can shut this off myself without taking it to the dealer for service? My other problem is that every time my headlights are ON with the rear defrost ON, and then I depress the brake pedal I notice my lightbulb indicator light on the dash comes on, but only when I step on the brakes. When the rear defroster shuts OFF the indicator light doesnt come ON when stepping on the brakes.I know this sounds confusing.As far as I know I do not have any bulbs out or am missing any on the car. Any ideas anyone,because Im stumped? THANKS
  • alcanalcan Posts: 2,550
    1987-93 240 Models

    To reset counter, locate reset lever behind left centre of instrument cluster and push reset lever upward.
  • dabaerdabaer Posts: 7
    regarding the reset of the service light, just ask your service manager. he should tell you. he showed me once, it is a combination of the trip odometer and the radio power switch or something like that. My independent where I get my oil changed has it down and yours shuld too. surely the volvo service manager should tell you.
    I have a 143,000 miles on my 1999 S80 and the whole dealership from parts to mechanics to the cashier know me very well, I am there so much. I can not imagine buying another volvo. it is a grea ride and handler but the maitence and repairs! I was hoping to hear some one positive on the newer models but doesn't sound good.

    I wonder what a cadillac's track record is like?
  • alcanalcan Posts: 2,550
    Procedures vary relative to model and year. The light reset information I posted is correct for 1987-93 240 models.
  • I am nearing the end of the 3 year lease on my 2000 S80. To date, it has been a very reliable car and I am think about buying it at lease termination. My only concerns is that it goes through light bulbs (specifically front headlights). In two and half years, I must have gone through 6 or 8 bulbs. Yeah, I've heard the DRL line ... however, never had that occur in my other DRL equipped cars.

    Question: should I be concerned with the electrical system of the car and NOT purchase an otherwise reliable car? Or do the light bulbs have that low of a lifespan. I have about 30,000 miles on the car.
  • I just took my 99 S80T in for a tapping noise in the engine which I assumed was maybe valves. The dealer said it was the seals in the pick-up tubes that were bad and restricting the flow of oil to the engine. So, they were replaced and when I went to pick-up the car, the same tapping noice was there. Service tech took the car back to the mechanic and 15 minutes later came back with my car and said it was the injectors making the noise. So, 1) can injectors make a tapping noise, if so should I do anything about it and 2) did they fix something that maybe did not need to get fixed?
  • The Brake light in my 2000 V40 comes on when the car gets cold, then goes off after it warms up such as spending the night in the garage. Next cold morning, it comes back on after driving a few miles. Warms up during the day, light goes back off. Fluid reservoir is full, brakes work fine. Any ideas?
  • alcanalcan Posts: 2,550
    Red brake warning light or amber ABS light?
  • It's the red Brake light. The ABS seems to work normally on slippery roads.
  • alcanalcan Posts: 2,550
    David, 3 things provide a ground for the red brake warning light; ignition switch in bulb check position (between Run and Start where all warning lights come on), low fluid level float switch in the master cylinder reservoir, and the parking brake switch. Any chance the parking brake needs adjustment?
  • Many thanks for the quick reply. I don't think it's the parking brake, because I have a different light for that which says Parking Brake, and it comes on when I pull the lever up. I was inclined to believe it was a bad sensor of some sort. Based on your input, maybe something on the float is out of adjustment, or thermal contraction fools it into thinking the level is low. I'll look to see if I can find anything. At least that gieves me some knowledge if I have to take it to the dealer. Thanks again.
  • alcanalcan Posts: 2,550
    Sorry about the parking brake misinfo. Was using generic circuitry. Let us know what the outcome is.
«1
This discussion has been closed.