Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Pickup Owners Hangout

1192021222325»

Comments

  • babbs3babbs3 Posts: 50
    Thanks again steelydan about the tranny info. Do you know who is making the trans. for the Frontier? The funny thing about the 6sp. auto is on two back to back cars the transmission would "search" for a gear and than flare the rpms to almost a red line amount. I thought the idea was to get better mpg. but you just can't if the car is revving up so high. I just may test drive the Frontier but it is good to know that yours' is shifting properly. Again thanks.
  • steelydansteelydan Posts: 133
    I don't know, I will say that the present 4.0L 5 speed combo for the Frontier was introduced way back in 2005, so any bugs were worked out long ago. It has a defeatable OD on the shifter, you would disable the OD when you are towing, but otherwise, I leave it on all the time. It allows the tranny to "lock up" at a low speed ( as low as 25 mph) so that it is more fuel efficient ( like a manual transmission) . I am assuming Nissan makes their own transmissions, this same transmission shows up in the Pathfinder and Exterra in addition to the Frontier.

    Sorry about your present Ford auto transmission troubles, but , while you may not like something else about the Nissan Frontier, the tranny won't be one of them. I stand behind that statement.

    babbs3, don't just take my word , on this very Edmunds site, just look up "Nissan Frontier" test drive/reviews........................read it for yourself ! The transmission is not a problem in the Frontier, period.

    I also read reviews in the following sites: USA Today autos , MSN Autos, and a couple of Nissan owners sites: ClubFrontier.org and NissanFrontier.org.....

    Take care, babbs......
  • babbs3babbs3 Posts: 50
    To Steelydan.....Wonderful news bout the trans. As I mentioned earlier I had 2 Nissans back to back and they were a joy to have. I had 6 years of complete trouble free driving. Never back to the dealer once with a complaint. Too bad I have so much time left on my current lease or I would be tearing the roads up getting to a Nissan dealer. I have been driving for over 40 years and these last two Fords(2010,2011) are trying my last nerve. I have had 22 cars and except for a 1984 Plymouth (piece of crap) I have never had such a problem with any car before. I will visit the forums for the Frontier. Thanks for being so helpful!
  • I recently bought a used 2010 Frontier SE, with a 4 cylinder. It had only 3600 miles when I bought it. I have noticed that the oil level is dropping by about 1/2 qt. per 500 miles. The manual said this is expected during the break- in period. I now have 7600mi. on it and still using oil. I have not noticed any leaks from the heads or oil pan. How long should the break in period last? I have also noticed that when the AC clutch kicks in, there is a noticeable amount of noise increase. Any info would be a great help.
  • cttoazcttoaz Posts: 9
    edited January 2012
    For what its worth, my 1996 4-cyl pick-up makes a lot of noise when the A/C compressor kicks in. To the point that trying to listen to music at a stop light without turning up the volume was frustrating. Adding additional sound deadening to the cab helped out quite a bit, but even still, my much earlier version is a pretty loud vehicle overall.

    Regarding the oil consumption, the 1 qt every 1k miles still falls inside of the parameters of normal even today and is not completely unheard of (though I suspect increasingly rare). This is likely because the only sure fix is a complete tear-down and rebuild of the engine, and the cost of adding oil would be far less than the cost of repairing the engine while the vehicle is still under warranty. If you are using pure synthetic oil, it is possible that the engine still hasn't properly broken in since the piston rings still haven't seated correctly. You might ask a Nissan dealer for info on this. Good luck!
  • steelydansteelydan Posts: 133
    I imagine that 4 cylinder is working pretty hard to move a 4,000 lb truck around, so the oil consumption, while disappointing, is not too far out of line. Make sure you check the oil the same way every time, when the engine is cold, before you start it. Checking the oil when you fill up the gas tank will give you a false reading because it takes awhile for the oil to drain back into the crankcase after you shut if off.

    I know the 4 cylinder gets somewhat better gas mileage, but your noise issue is probably related to the 4 cylinder working too hard, trying to move a 4,000 lb truck around and running the A/C at the same time. But hey, it's a truck , right ?
  • sheffiisheffii Posts: 1
    Every time I run my a/c I can hear a low humming noise coming from behind the glove box. The a/c still works and blows cold air strong. The humming gets louder when moving the fan switch up to point where its almost deafening on 4. Any info or ideas would be greatly appreciated.
  • To jsan1 thanks for coming up with the armrest could you please send or direct me to the brochure on the armrest. Thanks for your time and help .
    views1. berlin.us@verizon.net
  • Alternator has tested good.
    Battery has tested good.
    All fuses are intact.
    Belt is on tight.
    Charges fine when idle but will not continue to charge when driven.
    Any Suggestions
  • Just want to share this tip:

    I went to the Nissan dealer to replace some burnt out instrument cluster bulbs and they are listed at $20 each. This place also sells Volvo parts and the guy said wait a sec, and pulled some Volvo bulbs. They look exactly the same so I bought four and they fit perfectly. The price, $4 per bulb. Couldn't thank the guy enough for saving me $60!
  • Help - My dashboard clock went out along with the radio and the dome lights - apparently on the same circuit. Plugged in a few new fuses and they blow instantly - wheather or not the motor is running. Has anyone seen this? Any adeas on where to look for the short?

    I've spent hours inside the dash. I don't want to have to disassemble large wire clusters... But if I must - was hoping somebody else had seen this ??????
  • 1991nissan1991nissan Posts: 4
    edited January 2013
    Well I have the same problem, but mine happened after my car radio was stolen and wires were cut. I think the clock and dome light are somehow connected to the radio wiring harness. I wasn't planning on getting a new radio but haven't been able to trace the cut wires.

    Blowing fuses without the motor running is very odd. Is this a new radio install?
  • 8ball28ball2 Posts: 9
    Check the switches in your doors. They turn on the dome light when your door opens. They are normally closed switches (power on) until the door closes and breaks the connection. The Positive wire could be grounding out inside your door frame.
  • My 1996 Nissan 2.4 liter pickup developed a loud groaning/screeching (not hissing) noise that seems to be coming from low in the back of the intake. It vanishes briefly when I step on the gas pedal. It's there parked or moving. It's not noticeable at highway speed, but the truck is a bit noisy. My hearing is good. Odometer is about 236,000.
    I've not been able to pinpoint it, even using mechanic's stethoscope. Not related to belts -- still there with belts removed.
    A well regarded local shop spent two days & many man-hours on it, removing & cleaning throttle body & replacing gasket, cleaning PCV, cleaning EGR, pinching & disconnecting vacuum lines, replacing oil filter with Bosch filter, and maybe some other things. No improvement.
    I have no driveability issues. No codes are set. Short term fuel trim is good (< +/- 5%). I have Bluetooth OBD II unit & Torque Pro program on phone that I can use.
    I'd unnecessarily replaced the PCV 10k miles ago due to fuel trim issue -- that turned out to be shorted wire from O2 sensor. Distributor replaced @ 6k miles ago, due to failing coil.
    I'm wondering about the swirl plates, but I think they're closer to the head than where I'm hearing the sound.
    I'll try to record the sound & post it.
    Anyone have hints on where to concentrate my efforts?
    This is my 1st post. Let me know if I've omitted something.
  • I just phoned the shop, and they said they did a smoke test for vacuum leaks & didn't find any.
  • Wow - pretty thorough. Bottom line I think you wrote that it has had no impact on your performance. It could be a bearing in that area starting to go bad but It's really dificult to tell. You may have to wait until it starts to impact your performance.

    An IR cam on the engine after it's been running for a few minutes might tell if there's a lot of frinction on a bad bearing in the area. keep us posted - sounds vexing....
  • Solved:
    Spongy PCV hose that was sold to me by Napa 6,000 miles ago. I'd specifically requested PCV hose.
    En route to local auto parts store I found Long Term Fuel trim ~12%. Kurt & Robin at O'Reilly Auto Parts came out to my car to listen & poke around at idle. Plenty of brainstorming. Found noise would disappear when plugging line from air filter to valve cover. Figured PCV valve might be stuck wide open, & if so could cause excessive crankcase pressure or vacuum. When I accessed PCV valve (removed tire, splash shield, battery negative cable, oil filter) I found the very soft PCV hose. I replaced it with the old, very hard hose I'd removed 6k miles ago, then put stuff back together. When I cranked it to circulate oil into new filter, I could tell it was better. Next morning driving it noise was gone, Long Term Fuel trim went back to 0% (& Short Term Fuel Trim still cycling normally ~ +/- 0% - 5%.)
    I'd read every post in this forum, and lots, lots more. Nothing really seemed to hit the spot. Since finding the problem, I went back & read more about failed PCV hose. It's not uncommon, but I've still not read a description including my sound.
    Thank you for your help. I'll keep the IR camera idea in my quiver. Boy am I glad to be done with this.
    vikingcove
  • Engine flutter/ slight miss. Started after replacing blown head gasket. Milled head. Changed timing guides and chain. Checked distributor cap. cleaned plugs. Changed fuel filter. idle and acceleration is fine but flutter occurs as though in background when backing off acceleration. 355.000 miles. Engine rebuilt at 200,000. Wondering if it is catalytic converter going out or fuel pump developing failure. Each never changed.
  • thegraduatethegraduate Posts: 9,731
    Hi all.

    I recently acquired my recently deceased grandfather's '99 Frontier. It's in good shape, but the service records are spotty at best.

    The good:

    Newish tires (2011 purchased) with good tread

    Oil changes recorded every 5,000-6,000 miles

    Truck saw light duty (light stop and go, 40-50mph roads)

    115,000 miles total, with pristine body/paint/wheels/lights/glass

    The bad:

    "Service Engine Soon" light indicates a bad knock sensor

    A/C squeals horrendously at anything much above idle engine speed (my granddad previously told me that the mechanic said it was not, in fact, a belt, but was the clutch in the compressor)

    Both license plate lights are out, and I've never changed these before

    I don't know what other major and minor service intervals should be taken into account with this truck. Any comments, thoughts, advice, or input is welcome. I drive this truck almost exclusively on the highway at about 70mph and am averaging 27mpg, which is on target for EPA, so I don't believe the engine is running poorly. If the A/C is off, it is quiet and smooth at idle and at speed.

    Thanks!

    TheGrad
  • steelydansteelydan Posts: 133
    Hi Grad,

    Sorry about your Grandfather . I know he would be pleased to know that you are trying to get his former truck shipshape !

    My suggestions:

    1. License plate bulbs are easy to replace yourself. If you can acquire the owners manual for your Nissan (very doable), it will describe how to replace them. Bulbs available at any auto parts store. Take the old one with you .

    2. It's what you did not mention that bothers me a little . I have questions about the maintanence on your 99 Nissan.

    a) when was the radiator/coolant system flushed and refilled ? If you don't know, I would say at 115K, time to do it !

    b) your manual transmission has 80-90W gear oil in it, once again, if you don't know when the MT was ever serviced, do it.

    c) inspect all belts and hoses for wear, fraying, bulging hoses, etc. Put a cardboard box on the driveway under the engine overnight and see if you have any fluid leaks.

    d) I would refer to a mechanic for the knock sensor, at 115K, not surprising .

    e) Your AC compressor will need to be replaced, I would not try to "rebuild it" in any way. I agree that the clutch has probably seized, when you replace the AC compressor , replace the glazed over belt that runs the AC compressor.

    Sounds like your dear Grandfather did not abuse this truck, it just needs some TLC at almost 15 yrs, starting with vital fluids !

    Good luck,


    Brooks Davis
  • thegraduatethegraduate Posts: 9,731
    Thanks for the input. I wasn't planning on purchasing it so soon, so right now, I'm driving it about once a week until I get financially ready to get some maintenance done on it. I know the best thing you can do for an older vehicle is drive it, and not let it sit and rot.

    I will definitely do the coolant and brake fluid. I've had to replace a master cylinder in my old Accord before, I don't want to on the Frontier.

    It doesn't have any leaks (I've checked that much).

    The odd part about the A/C is that it actually does blow nice and cold, but every time it cycles on, it makes the squealing noise if running in gear, at highway speed. At idle, it usually stays quiet. I know I'm on borrowed time with that one.

    Thankfully, my main vehicle is my Sonata I've had for four years (a 2009 model) that's in top shape, so for now it's my daily driver. :)

    Thanks for the input; keep it coming!
  • steverstever Viva Las CrucesPosts: 41,584
    A reporter is looking to talk with a Texas resident who's in the market for a new pickup truck. If you're able to help, please contact pr@edmunds.com with your preferred contact info by Thursday, September 26, 2013.

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • ken_haywireken_haywire Posts: 1
    edited October 2013
    I have a 2000 Nissan frontier just bought it and the ac belt was missing....changed all belts but ac would not work. swapped relays and now it wont start even after switching back relays. any idea what I can do when I turn on switch get a beeping sound
  • Kirstie_HKirstie_H Posts: 10,914
    A reporter would like to speak to a current shopper looking for a midsize pickup. If you'd like to share your story about shopping for a midsize pickup, please email your daytime contact info to pr@edmunds.com no later than Tuesday, 11/5/13 at noon PT/3 p.m. ET.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • nabornabor Posts: 6
    Just purchased a 2013 King Cab SV, V6, auto trans, Super Black, 4x4. Traded in a Mercedes CLK350, finally figured out I'm not a luxury car guy. I love this truck. Only 850 miles so far, but it's so much more fun to drive than the car, and actually better technology. At highway speed the road noise coming from the rear of the truck is annoying however. I can't tell if it is coming from the suicide doors, or from the back panel of the king cab. Does anyone else experience this problem in their king cab?
  • wise1wise1 Posts: 90
    My 1986 nissan pu is vibrating in the drivers and passengers seat after putting on new tires. The guys who installed the tires said the problem is my wheels are old-27 years old- and are no longer round. Anyone with an old nissan pickup have this problem??? They rebalanced them but they still vibrate very badly. The tires I had before were 205-70-14, the new michelins are 195-70-14. which is the factory recommended size. Could this be a suspension problem??? Any help is appreciated. :confuse: :sick:
Sign In or Register to comment.