Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Buick Century Maintenance and Repair

1101113151619

Comments

  • buy1buy1 Posts: 1
    Just wondering if you ever found the cure for P401. I have changed the EGR, The Pipe to the Exhaust, The Map sensor, and a couple of other sensors that I am not sure what they are called. Help Please. :confuse:
  • My daughters 2003 Buick Century is having heating problems. When she turns the heater on it will alternate between hot and cold air. Temp guage is in the correct operating range. Any ideas as to why it doesn't stay on hot?
  • buick century in ac/mode the right side blows cold air, the left side blows hot air both controls areset on cold
  • can any one help ,my century blows heat on one side then blows cold air on the other when both controls levels are in cold position,why////
  • Does anyone have any idea about this problem?
  • joejbjoejb Posts: 4
    Sounds to me liker the bearings are going in the AC compressor.
    This is slowing your belt and causing associated electrical problems,
    the bearings ease up after a bit and problem slacks. Eventually the
    compressor bearings will seize and after a few minutes of engine
    running you'll have a complete engine failure: overheat, oil pressure
    power steering etc.
  • kframekframe Posts: 5
    Hi. The Temperature control on the dash operates a vacuum controlled door that mixes cold air with hot air. It is possible that yours has 2 doors. One may not be getting the vacuum to open or close the door. I'm not sure if yours might have 2 doors (1 left &1 right). That kinda would explain your problem though. Checking the vacuum on these "doors" might not be too easy. Definately requiring removal of under dash panels. Also a Vacuum Pump/Gauge would be helpful in determining weather the doors are operating correctly. Good Luck!
  • yes after a head gasket repair job. driving on freeway thought it was a wind gust until my speed was dropping. seemed like the harder i pushed on the gas peddlethe faster speed dropped. after stopping and restarting i could not go faster than 25 the more i tried to speed up the rumble seemed louder. so far i'm into 500;00in labor alone mechanics miffed. next step is timing belt or chain one mechanic thought 94 had fiber optic timing so ruled out any ideas out there new car maybe
  • ...on the driver's side when driving, but not when applying brakes? Please tell me this isn't going to cost me an arm and a leg. The sound sounds like it's coming from the driver's wheel area. It doesn't do it all the time either...that's what's weird.
  • i recently bought a 96 century with 50,000 miles. it starts and runs great with no serious damage. the car has stalled 4 seperate times and re-started within 5 mins. two of the four times. had it towed the other two times and it restarted normally 6-12 hours later. it seems to happen sporatically with no common traits. can anyone help. MUCH APPRECIATED!!!!!!!
    jonnyleg
  • hagphagp Posts: 2
    Hello,
    I have buick 2005.
    I have changed the oil after the 'change oil' message has appeared and the message still appears.

    How can I make it disappear?

    Thanks
    hagp.
  • The only solution I've heard of is the coolant named Descool. It has been taken off of the market and there are several lawsuits against them for ruining several vehicles. My brother is going through the EXACT same problem right now, and I have been racking my brain thinking about it. So far, this is the only thing I have come up with...Did you look at your water pump? I'm sure you did, but he said that he was hearing a gurgling after he shut it off coming from the coolant system. This I hope is the only thing wrong, the Descool coolant. Buick used it a lot. Was your check engine light blinking too?
  • has anyone else also experienced this problem with the pearcing whining?
  • I just had the same problem yesterday. The dealer wanted to charge $85 to turn it off. I took it to an Auto Parts store that we have in Ohio called AutoZone and they put it on their own handheld computer and cleared it for free. You might want to try that route. It couldn't hurt.
  • Im working on a '94 Buick century 3100 V6 and having trouble changing the head gaskets. Is there a How To article or video that could help or any tips that I could use. Im having trouble getting it apart, where are the bolts to take them apart? Any help will be appraicated.
  • Buick 2004 Century,sevice engine lite came on,put scanner on it,came up with P0480-cooling fan control circuit malfunction, what should I be looking for,wireing,relay or ?? Thanks :)
  • hagphagp Posts: 2
    Thank you all for you replies
  • I have a Buick Century 2003. After getting my oil changed at a quick oil change place, they told me to turn the ignition key to the on position (without starting the engine), and flooring the gas pedal 3 times in quick sucession. The oil change soon light then starting blinking and went off. Apparently, this reset the computer.

    Hope this works in your case.
  • emilyzemilyz Posts: 1
    Hi everyone,

    One day a few weeks ago, all of my power windows on my 1988 Buick Century gave up working at once. This leads me to believe it's a fuse or circuit breaker issue but I'm unsure what to do next. The fuse diagrams I've found do not show a power window fuse that is accessible in the dash fuse box. The information I've found on the circuit breaker says that if the problem was overheating, that the breaker will reset itself. Does anyone have any leads on what I can try before bringing it in to have it looked at?

    Thanks in advance! :confuse:
  • ksouzaksouza Posts: 1
    My 93 Buick century front windows will not go down, but for some reason the front ones go down. Tried changing the fuse but that wasn,t the problem. I wondering if I have to buy new window switches. If anyone knows answers please help.
  • My daughter recently was given a 1993 Century. She was told not to turn off radio by pushing power button because it wouldn't turn on again. Sure enough, she forgot and not it won't turn no how many times you press the power button. It's a Delco original equipment. Suggestions?
  • toddlewtoddlew Posts: 1
    im assuming you meant fronts wont go down but backs do. i had the same problem. the culprit was broken wires. If you open your door youll see the rubber boot covering the wires leading from your door to the main body of the car. I carefully sliced the boot length wise and found 3 broken wires. I used about a 3 inch piece of wire the same gauge as the existing ones and spliced them together. I searched for months and found the solution on another forum. It seems to be a fairly common problem. Hope it works for you.
  • scjkingscjking Posts: 1
    need help to re-attach inside rear view mirror in 98 buick century. Mirror came off and unable to remove the silvery piece to glue to the window. is there away without holding the whole mirror for an hour
  • I hate to tell you this, but that silver piece is built into the windshields. It's like that on most newer model cars. I've had to fix one on my old LeSabre, and I just held it in place for a little wh8ile.
  • elbdog1elbdog1 Posts: 1
    I'm having problems with my 91 buick century. I can't drive 30 miles before my car overheats.One shop says that my crank censor was bad. I changed it and spark plugs and wires. I heard a popping noise from my ignition coil assembly and popping from four censors mounted on the frame of my car, by the radiator. Can anyone help me please. Once it overheats i have to stop for about 1 hour and it will fire right back up. :
  • cfrenchcfrench Posts: 7
    How do you get to the thermostat on a 2001 Buick Century to replace it.
  • sr0156sr0156 Posts: 1
    i just bought a 99 century custom owned by old folks so it was well taken care of its got 3.1 changed the canister underneath the bumber,it was full of sand and junk so we thought that was it. well three days later service engine light came back on. ive heard could be a small leak in a hose from canister to tank to engine, any suggestions?? excellent car driver side electric window button doesnt like to work either but this evap codepo440 is driving me nuts!!! id rather get some advice before going to the dealer and spending a thousand if ya know what i mean. thanks alot if you know anything id appreciate some advice. thanks
  • rjp1952rjp1952 Posts: 1
    I have replaced the instrument cluster on my 2001 Buick Century. The LED odometer and PRNDL was blanked out and I understood the way to fix it was to replace the instrument cluster. I expected the odometer reading to be driven by some on-board computer and it would be correct, but was surprised to see the odometer (although now lit up) was not what it should be (it was less than the original so definitely wrong). Any tips as to how to get it to line up with the original odometer?
  • scubarodscubarod Posts: 4
    hey, i had the same problem. i talk to a tech friend from mg and he told me that if i took it to the dealer i would get charged thru the roof. he told me to check the sensor wires. this is often the problem. they get worn and break. sure enough i took of the wheel and there is was....broken wire. I fixed the wire and problem went away. my abs warning and my trac off light . just last month it did it again. I check the other wheel and sure enough both wires were cut. I fixed them both...20 mins and all done. check it out and save some money!!!!
Sign In or Register to comment.