Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac Owners: Problems & Solutions

2456789

Comments

  • patpat Posts: 10,421
    A tv reporter is hoping to talk with someone who wants to purchase a Cadillac. Please respond to jfallon@edmunds.com with your daytime contact info by May 31, 2005.
    Thanks,
    Jeannine Fallon
    Corporate Communications
    Edmunds.com
  • cciovaccocciovacco Posts: 2
    I am looking to replace a A/C Low Side Temperature Sensor on a 1999 Cadillac Seville SLS. I have the message code of DTC B1321 from the diagnostic system. I also get the "SERVICE AC SYSTEM" from the Driver Information Sensor. I have put a gauge on the A/C system and the pressure is well within normal range. Any advise on where to find the A/C Low Side Temperature Sensor, how to replace it, and what GM Part Number to order would be greatly appreciated - Thanks in advance! Chris in Atlanta :confuse:
  • svansvan Posts: 1
    I have a 2004 DeVille, with 4,575 miles. The check tire monitor keeps coming on. I've taken it to the dealer 5 times, once they said a valve was broken, then they put more air in all the tires. It just comes back on. When the message comes on the the Info Center said at one point, that the PSI was okay, another time the PSI for all 4 tires was different. I'm getting different answers every time, but the problem is not being fixed, and I'm unsure if I now trust any of the other 'computer' generated messages. Dealership says fixed after each trip (5) but it's just come on again - now PSI does not register any thing on the Info Center. Do I have the computer disconnected, or put air in my tires every week? I'm 62 and feel I am just getting the run around. Anyone else have this problem with the message coming on? I do not know what to try next.
  • ccjjccjj Posts: 1
    I am looking for some help. This morning when I went to start my 1990 Cadillac Deville it started sputtering and would start then stall. The onboard diagnostic is reading "No Cam Reference Signal from Ignition Control Module". As I drove to my doctors appointment the car stalled out while going 40 mph, I put it in neutral and was able to restart to make it to my destination. But it keeps stalling out. Is this something I can fix myself? If not, how much would a repair like this cost? Has anyone had to fix this on their Caddy Deville? Any help you can provide would be very much appreciated. Thank you.
  • bgooderbgooder Posts: 1
    I purchased a new 2004 Escalade in August of last year (2004) with P26570417 Goodyear Wrangler HP tires. In the Fall I had a flat tire (right rear) that was caused by a rock puncture. On June 14, 2005 I got in my car to go to work and the right front tire was flat (another rock puncture). On June 21, 2005 I went out to get in my car and go to work.....the left rear tire was flat (another rock puncture). Of course, at this point no one will admit to a problem. So far I've had to pay for a new set of tires. Has anyone else had this problem with these tires??

    bgooder
  • nonedarenonedare Posts: 2
    Your note was last month, but if you are still looking to buy I have a suggestion. There is an extensive computerized system in these cars that detects and reveals systems that do not work correctly or not at all. They also indicate service that is required "soon" on systems that still work but need attention. The owners manual gives some idea how to call up these trouble codes and other info, but it is not easy. Many of the manuals are available as pdf files on the internet if you can't find a hard copy. Having another Cadillac owner help you would be useful.
  • sen69sen69 Posts: 1
    My 98 Concours has two very bad rattles from under car . It sounds like exhaust pipe or muffler,but is not.I just replaced strut mounts to no avail.any help?
  • debsdigsdebsdigs Posts: 1
    Coolant temp indicator comes on when driving uphill. Have checked coolant, engine oil and coolant fans. All seem okay. Found previous owner has altered the pipes to the heater matrix. Alteration doesn't make sense, is possible that coolant flow through engine not correct. Any ideas?
  • stilesstiles Posts: 6
    Seems there are a couple of people out there who are from another planet, two of these talk about voice commands in the 2005 STS, (other than the on-star phone or navigational system) there are no Voice commands in this model! Another talks of AC seats, other than the dimpledseats that allow air to circulate) there is no such thing as AC in the seats only heated seats. We checked this with the dealers and Cadillac, what dreamworld are Ambler and McShane from?
  • I'm from planet earth brother. Could NOT care less where you came from. Regarding cooled seats? I was ASKING about how they function. You call them ventilated which is probably a more descriptive word, in that the seats just blow cool air. Regarding the voice commands that the one guy remarked on, I did NOT know what he was talking about either. That's why I asked. If you don't know the answer and/or a curious you ASK. That's exactly what I did. Not to you though, I do not LIKE "mouths" who poke fun at others via their PC. Get a life slick, then clam up.
  • J101J101 Posts: 1
    Hi all,
    Could any of you please help me? I would appreciate It if anyone could post (pdf.) or post a file on detailed info. with illustrations on installing the rear disk pads on my 96 deville, or direct me to a possible webb page that may show that in detail. I would like to do it myself, but it dose not seem as easy as the front disk pads. I know this seems like a simple question, but I want to make sure I don't mess up all the cables. Thank you.
  • lrichelriche Posts: 1
    I have the opportunity to purchase a 2002 DTS that is in excellent condition, however the car has 105k miles. Does anyone have experience with the durability of Caddys or some advice.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,527
    That's awfully hard to predict on a three year old car as so few have gotten to very high mileage yet.

    If I were you I'd think of it as if it were a human being with a certain life span. Most modern cars, if given good maintenance, have a likelihood of lasting up to around 175,000 to 225,000 before they become really serious money sponges.

    So you might conclude that at the very best, one half your car's life (at least) is over, perhaps as much as 65% of it is "spent". So you should purchase the vehicle accordingly.

    Or to put it another way, if I told you my "engine blew up" at 75,000 miles, you'd find that unusual and say "what a shame". But if I started complaining to you that my engine blew up at 150,000 miles, you might say "well what can you expect?"

    See my point? After 100K, just about anything can happen to any car.

    If you have a luxury car out of warranty, you are, by definition, in high risk territory. So the question of whether it is "worth the risk" depends on what amount of money you are gambling.

    You should use edmunds.com True Market Value pricing (punch the "used cars" button up top of this page) to help you come to some ballpark figure of the car's worth. I'd even bid lower than what Edmunds says.

    MODERATOR

  • noshanknoshank Posts: 2
    Just leased a 05 SRX with voice recognition navigation that doesn't work right. It gets the command wrong the majority of the time. I was first told that Cadillac showed ten other vehicles with the same problem, but they didn't have a fix. Dealer then agreed to put a new unit in the car. That didn't help. Anyone have a similar problem? Anyone have a voice recognition system that works properly?
  • csg2csg2 Posts: 2
    I have a 1995 Concorse. After starting my car, the monitored systems check said my trunk was open, it was not. I opened and closed it and the message remained. I hit the information button and the message went away and has not so far returned. But now, after shutting the car off, the things that use to remain on for ten minutes (radio, wipers, etc.) shut off immediately with the key. any ideas what may have happened here? Everything else seems to be working ok.
  • csg2csg2 Posts: 2
    Well, now it seems that the car thinks the trunk is open all of the time. I guess that would explain why everything shuts off with the key now. The car thinks I popped the trunk and shuts down everything. One thing I now noticed that does not seem to be working is my keyless entry. It won't lock or unlock the doors or open the trunk.
  • Hello everyone. I am new here and just thought I would post a question that has me quit puzzled. I have a 98 STS that when you are sitting still steering the car back and forth sends the front of the car up and down. To make matters worse the car feels like the whole front end is loose when you are driving down the road. The car does this mainly on the left side. I would appreciate any insight to this problem. Thanks
  • I have a 1994 Sedan Deville. I have no heat or a/c. The climate control cluster does not show outside/inside temperature. Fan/defogger do not work. Fuses are ok. What is my problem?
  • Mr Shiftright, please help me with my problem. Im having a hard time starting my 93 cadillac seville sts whenever i have to restart the car. It starts with just a click in the mornings after it has sat overnite. I thought of replacing the fuel pressure regulator as it seemed to get flooded after a few miles of driving. When I opened the engine cover, I saw that the tip of the fuel pressure regulator is not attached to a vaccum line and that the nearby MAP sensor does not have a vaccum line connected to it either, is this usual or what? Also, when I attempted to start the engine without the cover, it came with a very loud roar and i seemed like the engine was surging without stepping on the gas pedal. I also noticed that gas was coming out of the tip of the fuel pressure regulator. What do you think of this and what should I do to check the problem? Thanks in advance

    Tony Boss
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,527
    beats me, I'm not a mechanic. But maybe or can help you when they show up here. If you don't get a response in a couple days, try to re-post this in a forum called "Technical Questions" which you can find by using the "Search Forums" window just to the left of my post here, or e-mail me and I'll tell you how to find that topic.

    MrShiftright

    MODERATOR

  • mdean1mdean1 Posts: 2
    Hi - anyone having experience w/excessive oil burn? I'm burning a quart every 1200 miles - looking for feedback w/someone who owns a this year vehicle.
  • mnjoemnjoe Posts: 36
    wrong. Mine has both voice commands and ventilated seats. Look at the 1SG premium luxury performance package. The ventilated seats work great. They actually wick air and moisture away from you rather than blow cold air on you (as in some other makes). The voice commands seem to be hit or miss. I need to practice and read more about it. The navigation and phone commands work pretty good. The commands for other functions sometimes do (ie: changing the temperature, radio, or cd). Luckily everything is redundant with simple to use knobs. We use it everytime we get in the car, however, to indicate driver 1 or driver 2 ... my wife and I generally only have one key fob with us, but switch off driving (we both want the fun). We have a new STS V8 Premium Luxury Performance (1SG) with AWD and adaptive cruise control/heads-up display.
  • mwaynemwayne Posts: 2
    I am trying to secure the regional general manager's name and address for Nebraska. I am having a reoccuring transmission problem, 5th time, and now cadillac wants me to pay for an entire new trani. Help
  • I drove an 04' Sevile STS at an Alberta Cadillac dealership with just 14,300 kilometers on the clock. Tthe STS was still available as a Canadian model in 04'. a
    the car seemed to ride very firm even at low speeds.The tire pressures were at 36 psi so no doubt dropping back to 30 would take the thump out of the ride but this is below recommended inflations.
    I have found another in the province of Quebec this morning and when I questioned the sales manager of the Chevrolet dealership as to why the car was traded into them with only 12,500 kilometers (7 or 8.000 miles) his reply was "the owner found it rode to hard".
    What is the word on the street in regard to the 03' and 04' models with the new magnaride suspension? GM's advertising hype would have you believing that it would have been softer until called upon the 'firm up'.
  • doyledoyle Posts: 1
    Trunk pull down on 93 deville does not work sometimes. It has refused to work once and later during the night it did pull down and worked about twenty times since then. Now it has refused again. I'm in trouble if it is raining!! What to do and how to fix?
  • Hi
    I have a 95 concourse. while tightning the pos batt. turminal I shorted the wrench on the engine mount, now it won't turn over or show anything on the dash. I checked every fuse I could find and they show good. what's the prob w/ this thing and how can I fix it before my wife kills me.

    Thanks for any help you can give me. Bill
  • also the dome lights are very dim. It acts like there's a direct short someplace taking all the power. But where can it be. The batt is fully charged
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,527
    You may have to remove the cables and clean the ends--be sure you have your radio codes ready beforehand if your car requires code resets or any kind of resets. Check your owner's manual before removing the battery cables.

    MODERATOR

  • Already did that no luck. Checked for a fusible link from batt to fuse block, none there. checked all maxi fuses all ok. checked contunity from batt term. to fuse block, good. checked fuse block for power. reading 12 volt on buss bar and fuse connections. still doesn't do anything.
  • PROBLEM SOLVED :) One of the side post batt terminals was bad. The top posts read good but when I replaced the batt everything was fine. After several hrs of checking wires for continuity and fuse blocks it was as simple as changing the batt. Boy do I feel stupid hehe.
This discussion has been closed.