Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Blazer GMC Jimmy Electrical Problems

145791020

Comments

  • repairdogrepairdog Posts: 948
    Always pull the airbag fuse when working around them.
  • repairdogrepairdog Posts: 948
    If the vehicle starts to stall at idle and then the dash jumps that could be the idle air control (IAC) valve that the PCM adjusts the air mix thru to regulate the idle. Its on the throttle body and the TB must be taken off the upper intake to install a new one and clean the port it fits in.
  • auto9999auto9999 Posts: 86
    Just a follow up on my fast left turn signal. At the scheduled maintenance last week, the dealer's mechanic found that a rear-left turn light bulb was burnt and needed replacement, which I did. Then, magically, the left turning signal returned to the normal clicking speed. It was strange, but it was good. :)
  • e602e602 Posts: 2
    Thanks for that info lawrencec. I ordered it for my 1996 Blazer and will try to replace. For the rest of you having problems finding the part, here you go. $10 after shipping. Hoping it works. Hoping GM made a lot of profit saving pennies using a plastic part instead of a metal part.

    Link to Part

    I will create a web page with pictures and instructions on how to do it if I am succesful. Expect that sometime August 2007 if I'm not too lazy to do so.
  • steverstever Viva Las CrucesPosts: 41,624
    Check out making a CarSpace Guide - they are easy and fun, and the hosting is free.

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • coachhillcoachhill Posts: 13
    Not sure which came first, but I just got a new battery and hoped it would fix my remote door opener problems. Without pressing the buttons on the key fob, the door locks/rear hatch actuators cycle on all by themselves and drained the battery. The remote key fob/opener doesn't work on the doors. I pulled the fuse #7 labled 5Amp Mir/Lks thinking that would kill the door locks. It doesn't, as I later found this is the inside window lock (door locks is #14). Strange, but with this mirror/window fuse out the door and rear hatch actuators work, both from the door panel switch and the remote opener. Of course the mirrors can't be adjusted, but the door locks work. I had thought the problem was with the door actuators but it now appears to be the mirror/window locks. Any suggestions for how to fix this?
    Thanks in advance for any comments!
  • cubs2cubs2 Posts: 1
    I have a question about my turn signals. Short while ago both turn signals stopped working. I was wondering where i can relace the turn signal flashers in a 97' Chevy Blazer (how do i get to the bulbs)
    Thanks
  • whiteb1whiteb1 Posts: 1
    I had a 97 Jimmy, and now I have an 01 Blazer and on both vehicles the driver side power window worked sometimes. Is there a common problem? How reasonable is it to get it fixed in terms of repair costs?
  • scolexscolex Posts: 1
    My 95 blazer has began having similar problems. On ocassion when i go from park to Drive, i can hear the rear window actuator pop open, and the car will drain the battery in a short while. it has happend to me several times now and becomeing quite a nuisance. I removed the brain of the remote starter but that didn't fix the problem. All the wiring under the dash seems to be cleanly done, I dont see any shoddy wiring or crossed leads, so i'm truly confused about it all.
  • roreganroregan Posts: 3
    I am having the same problem on my 2002 blazer
    remote will lock/unlock doors
    rear hatch will not open (no noise)
    mirrors do not work. I did find the below, but have not done any more research. Have you found the solution to the problem? I would appreciate any info on fixing. Please email if you hawe any additional information. rich@roregan.com
    Thanks again

    TSB #151200 -- CUSTOMER MAY COMMENT THAT THE REARVIEW MIRRORS, POWER DOOR LOCKS AND REAR HATCH DO NOT OPERATE. *TT (NHTSA ID #617784, DECEMBER 15 2000)
  • jlflemmonsjlflemmons Posts: 2,240
    Can someone with a '99 through '02 Blazer/Jimmy post the part number of the remote key fob? I am ordering replacements and just want a double check as they are non-returnable special order items.

    Thanks,

    Jim
  • roreganroregan Posts: 3
    GM/Lear 15043458
    FCC ID: KOBLEAR1XT
    Canada: 3521 102 1718

    Straight from the back of my 02 blazer remote. Hope this helps.
  • jlflemmonsjlflemmons Posts: 2,240
    Appreciate your reply. What I have found out is that the remote changed between '01 and '02. The part number I am finding for '98 through '01 is 15732805.

    Make Model Year(s) Application

    Chevrolet Astro
    2000
    RPO AU0, Each

    2001
    RPO AU0, ID #15732805, Each


    Chevrolet Blazer
    1998-2001
    Each, 1st Design


    GMC Envoy
    1998-2000
    Each


    GMC Jimmy
    1998-2001
    Each, 1st Design


    GMC Safari
    2000
    RPO AU0, Each

    2001
    RPO AU0, ID #15732805, Each

    I am hoping the right one shows up on Saturday!
  • jlflemmonsjlflemmons Posts: 2,240
    I checked your part number against the one I had. Yours is for the 2nd design, mine is for the first. GM made a production change at the end of the '01 model year, so the number I found for mine should work.

    Thanks for your response.

    Jim
  • jlflemmonsjlflemmons Posts: 2,240
    and work they did. Got two factory new GM remotes, both programmed up perfectly, and the kids car now has remotes and the factory security systems all work.
  • e602e602 Posts: 2
    Here is a link to a step by step guide I did on how to replace the broken clip on the window actuator rod retainer.

    http://www.blazerforum.com/m_91743/mpage_1/key_/tm.htm#91743
  • roreganroregan Posts: 3
    The problem is a 3 amp fuse under the hood in the fuse box, replace and all 3 problems will be fixed.
  • I'm having the same problems with my 98 Blazer. The mechanic said that it's going to be 400 dollars to fix, I don't buy it. What did you do or what do you suggest?
  • joicy3joicy3 Posts: 3
    I have a 2000 Chevy Blazer, when i turn the key there is an audible click and then i loose all power to the vehicle. The battery light flickers even when the key is removed from the ignition, and i can hear a relay in the TCCM doing its thing. It does not show any stored codes using the code reader. I have periodically gotten it to start but all the lights and gauges in the dash go nuts. I am stumped. Any suggestions would be appreciated.
  • torrelntorreln Posts: 1
    I have a 97 Blazer 4WD and I'm going to try and make this short. I got in an accident (fender bender) about 5 months ago and in this accident, the front driver bumper got bent in. I just went through an inspection and they noticed that my front turn signal light was out. I replaced it and all of a sudden my left turn signal stopped working. It was working off and on and now none of my signals will work. My hazard lights work well, so I know there's not a problem with any of the bulbs. I've checked the relays in the glove box and they seem to work. I also checked the fuses in the fuse box. I was told that maybe one of the wires in the front may be touching metal. I followed all of those lines and nothing is out of place. Can anyone offer any other suggestions?
  • hikick1hikick1 Posts: 39
    I replaced the turn signal lever (aka master control switch)(aka multi function switch) today. I did not have to remove the steering wheel. It took about two hours with me working at a snails pace. I could not get any Chevy dealer to honor the recently expired recall for the $200.00 part. I refused to pay an additonal $200.00 labor to have it installed. I now have both turn signals, hazards, the truck now turns off with the key removed, it doesn't run on anymore with my foot on the brake pedal with key removed, and most functions returned to normal. I got it on Ebay from thepartslady for only $110 including shipping. It is the original GM replacement for the recalled item. The fuel gauge is still bouncing around like it has lost its mind, though. Especially when the air compressor kicks in. Any thoughts?
  • hikick1hikick1 Posts: 39
    I just saw on ebay a fuel level sensor sending unit that states it wil stop the jumping. It is $27.00 with shipping. I am going to purchase one. They are located here in my city. I will let you know if this solves the wild fuel gauge issue.
  • hikick1hikick1 Posts: 39
    hi,

    please see our posts under electrical turn signal problems...

    Good luck...
  • hikick1hikick1 Posts: 39
    will the vehicle start if you start it with the hazards flashing? will the vehicle start with your foot on the brake pedal? My only to starting point guesses because I assume you have a fully charged battery.........
  • hikick1hikick1 Posts: 39
    How are your fuses?
  • hikick1hikick1 Posts: 39
    I had that problem do to water entering the window due to weather stripping leak which had been going on for sometime before I bought the vehicle. I took out the control panel on the door. Detached the individual control pods and cleaned the contact points (the gold round shiny things). I used electrical contact cleaner from advanced auto. It costed $3.00 a can and a stiff hair brush. Only a few sprays are needed. I got them all to work except the top one for my power mirrors. I can't get the left right movement, only up and down.
  • tidestertidester Posts: 10,109
    Turn Signal Problem in Blazer may be helpful.

    tidester, host
    SUVs and Smart Shopper
  • joicy3joicy3 Posts: 3
    I checked my fuses and they are fine. The battery is two weeks old and has been load tested and is in fine working order. I have gotten it started three or four times, but it is intermittent. When it does start it runs fine other then the dash lights and gauges blinking and going up and down. I am thinking it maybe the ignition switch located in the steering column. I am going to re-check my battery cables, and I am going to test the starter/solenoid the way it says in the chiltons book. I dont know if there is any way to check the ignition switch?
  • I unhooked the positive from my battery to see if the alternator was bad and the car was still running, but when I opened the door it just shut off, any suggestions.
145791020
Sign In or Register to comment.