Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Envoy Maintenance and Repairs

tidestertidester Posts: 10,109
edited March 2 in GMC
Got problems? Got solutions? Discuss them here!
«13456

Comments

  • rsqrsq Posts: 1
    On my GMC Envoy, my outside air temperature shows a minus number when it's about 90 degrees outside. My air conditioner doesn't come on because of this. Can I have the sensors removed and manually turn the air conditioner on when I need to? Should it still cost me about $500.00 in labor to have this done? Just got a quote from the dealer for a new sensor - part is about $100, labor is about $500. :sick: BTW, was told by the dealer this is a part that doesn't usually break :mad: :lemon:
  • my 2002 Envoy xl, windshield wipers will not turn off. When the problem first started, if I turned the wipers off, then the engine, after cooling down, the wipers will go off, once the car is restarted. Now they won't go off at all. Where is the wiper fuse? Is there a relay problem. Can the wipers be disconnected, until needed? Any recalls? Thanks, AFF
  • Does anyone know if fuel saving modules work. The ones that say it improves ur gas mileage by 5 to 10mph?....anyone have experiance. I just bought a new envoy xl and gas is the only bad part...i only get like 12 to 14mpg because i drive city soo much. let me know any solutions or if the performance module is effective.
  • I have a 2002 Envoy XL. The engine light came on and the engine began to miss badly. I had my buddy who is a decent "old school" mechanic take a look at it. He ran a diagnostic test on it and it show that "cyclinder 1 was misfiring". He suggested I take it up to Advance Auto and get their free diagnostic to confirm. I did and got the same diagnosis. So my buddy took it apart at the coils and said they were all firing but he demonstrated to me that the throttle body was not opening when you gave it gas. He said I probably would need a new motor for the throttle body but that there was some electrical signals that might send a message to the throttle body not to open such as the drive train, etc. Can you help me with this? Thanks in advance.
  • tidestertidester Posts: 10,109
    Does anyone know if fuel saving modules work.

    You may be interested in this discussion: Gas Saving Gizmos & Gadgets

    tidester, host
  • Our 2002 Envoy will constantly look for a CD to be in the CD player. If we take the cd out and listen to the radio, it will make this whining sound, and sometimes interfere with thr radio. As long as we leave a cd in the player all the time, its fine. Has anyone else seen this?
  • When I put the climate control selector (floor, panel, mix, floor+defrost, defrost) to defrost, the engine RPM goes down for a second then back to normal. This repeats until the engine stalls. This also happens when the AC is turned on. I suspect a vacuum leak but have been told it may be the AC unit itself.

    Has anyone had experience with this issue?
    Thanks,
    Bill
  • the recurculator will shut off after 10 min.and will not come back on. till you push the buton again and shuts of after 10 min
  • I have a 2002 ENVOY with a "service 4 wheel drive" light illuminated. Dealer said it indicates a transfer case control module issue. I checked the switches actual connections. Now.. I want to locate it physically to replace it. (additional note: I just had that same issue with a 2000 Chev Silverado.) I have "keyworded" every aspect of the phrase to try to get help. All I get are OEM parts locators, it seems. Can someone lead me to a chassis electrical (brakedown) site/link? Or better yet tell me of it's location.
  • I have a 05 Envoy XL. I just got it 3 months ago...with about 7000 miles on it. The brakes kind of rattle when i press them...IF i am on the highway and suddenly traffic comes up and i got from like 80 to 30 within 500 ft, the brakes rattle. no noise, just slight shaking...of the brake pedal..Any idea why...
  • I have an 05 Envoy SLE with a stock Delphi Single CD Stereo. I've recently yanked the stereo in hopes of finding out if i can plug a cable directly into the Aux In connections so that I can pump my sirius signal directly to the stereo rather than rely on the FM transmitter (bad reception). After getting the stereo out I've, of course, noticed that there are only the two proprietary bundles going into the back of the stereo as well as the antennae cable and a white plug. (I'm not sure what the white plug is or what it would be used for)

    so I'm wondering if anyone has had any experience with, or accomplished what I'm trying to do here.

    I've also tried the Sirius FM relay kit, but the antennae cable in the back of the stereo doesn't seem to be removable.

    Any help is appreciated.
  • My steering wheel control's are messing up in my 04 envoy. When I adjust the volume it adjust the station. A lot of times it adjust on it's own while I'm cruising down the road. The dealership want's $350.00 to look at it. Does anyone know how to fix the problem or to take apart a steering wheel? Thank you.
    Brian -Gulf Coast
  • I had the same exact problem with cylinder 1 and the vehicle missing. when this happened to me the cruise control stopped working too. i took it to my mechanic and he found the problem was the coil on cylinder 1. after he replaced it my envoy purrrs like a kitten ever since. it cost me about $140.00. give this a try if you havnt had it fixed yet.
  • My back gate on my 2004 Envoy XUV will no longer swing open. When I push the button the glass drops and I hear a click but it does not release. Anyone else run into this issue?
  • I started my suv the other day and backed out of driveway. Then parked in street for a moment to run back into house. Went back out and car would not come out of park. Tried hitting break, moving wheel, rocking car nothing worked it will not go into any gear or neutral.
    please help for possible solutions.
  • 2004 GMC Envoy XL, It's time to have the transmission fluid changed out. Is this something I can do myself or should just go ahead and bring her in and have it done at a shop.

    Thanks.

    Jim
  • my back gate also had this problem It is the relay switch which cost me 200.64. That's 32.88 for the part and the rest for labor.
  • retwinsretwins Posts: 1
    My cigarette lighters do not function... Any ideas on what may be the issue? Could it be something minor that I can handle myself?
  • I have a gmc and have wrote the company they made me pay for a diagnostic and then told me they would not pay for it but I could have a $1000 for a new one. I have nothing but problems with my truck it has already had $3000 worth of work and needs another $1500 and the corp office does not care. I have wrote the competitors to see if they would like to post my store in the shop.
  • I have had every part of my windsheild wipers replaced because I had problems. GM does not recall because they don't stand behind anything
  • I love my 2004 Envoy XUV...but...only once in the 3.5 years that I've owned it has the roof and rear window worked as it should. The roof will open and close, but I get a message to "remove obstruction" or open/close again and again. With the rear window never closing. HELP please, JLM
  • kathysuekathysue Posts: 1
    Occasionally the driver side seatbelt will lock up in the unlatched position and not allow me to pull out on it in order to buckle up. I've tried turning off and turning on the ignition, pulling several times on the seatbelt, putting the gear in park, neutral or drive....Nothing seems to work. Usually a day or two later it will unlatch on its own. But two or three weeks later it will do it again. Any suggestions?
  • nailnetnailnet Posts: 3
    Does any one know the reason for both lowbeams to go out at the same time. Put in new bulbs, it did not help
  • techimantechiman Posts: 3
    I am not sure about your Radio, but I just put an IPod interface on mine and to do that I it goes into the XM cable that was located behind the glove box so maybe this would work for you too.
  • spammerspammer Posts: 2
    Recently, when I am traveling at low speeds my engine is embarrasingly loud. It happens when from the point I start my car. It screams until I enter the freeway and increase spead, at that point the engine finally sounds normal again, but when I get back onto local roads and decrease speed, it gets loud again. What's the problem?
  • 2004 SUV SLT - I had to replace BOTH sensor switches. The flip down and the swing out both went bad at the SAME time. What are the odds.

    I also have had to replace 2 ingnition switches that kept the Envoy from starting.
  • encarboencarbo Posts: 1
    Hello,

    I was wondering if you had the problem fixed. I just encountered the same problem today? Any solutions or advice?

    Thanks in advance.

    Nick
  • I bought a new GMC Envoy Denali in December of 2005. Beginning in May 2006, the check engine light would come on and transmission would start to shift hard -- almost as if it might fail catastrophically. Took it into the dealer, but he couldn't replicate it. A month later, the same thing occurred -- check engine light, into the dealer, he could not replicate it. The third time this occurred, I convinced GM to authorize the installation of a new transmission, which the dealer carried out. Immediately, however, I noticed an unusual amount of "slop" in the transmission. That is, when you would shift it from Park to Reverse, or Park to Drive, it would take a second, two, maybe three to engage.

    Fall came, winter, then spring -- and my wife, who by now is the one mostly driving it, is telling me on occasion, "The car is doing 'it' again." Like many husbands, I didn't want to hear bad news. Besides, on the infrequent times I drove it, the transmission mostly seemed okay -- but still with the "slop" that it had after the new transmission had been installed. Finally, my wife complained that it was doing it all the time. I took it into the dealer for now a fourth time, and guess what? They could not replicate it. I suspect they were beginning to think I was delusional.

    Then, last week on Friday, my wife said it is failing to engage like this regularly, and that it isn't until she revs the engine a little that it catches. This, of course, is now dangerous. Because this could easily happen and she could bump a car or, even worse, a person.

    As I write this, the Envoy has been at the dealer for two days. Tomorrow will be the third day. The dealer called her and has asked her to drive it with a service technician to see "if it is something she is doing." Having driven a number of cars for over 38 years, including stick shifts, I know it is not her. Besides, it does it for me as well.

    Now, there is one common thread here: in each instance since May 2005, the weather has been hot, maybe even oppressively hot -- in the high 80's to mid to upper 90's. One day it was at least 100 degrees. And, it only happens in warm weather when the car has been in stop and go traffic. When it has happened for me, I know the engine was good and warm. You could feel the heat coming from under the hood, which you would with any normal car under such circumstances. No indication of overheating, though.

    If anyone has had this problem and/or knows what might be a solution, I would be deeply grateful to hear from you. We have gotten GM involved and it has been assigned a case number. I suspect that the dealer has done about all he can do at this point without instructions from above -- perhaps, even the regional service representative.

    Thank you in advance for your help.

    Neil
  • dawneedawnee Posts: 59
    My mom is looking at a 2003 GMC Envoy with 62700 miles. She really likes the vehicle, it is an SLT loaded but we noticed when test driving that it makes a ticking noise in the motor area almost sounding like a clock ticking. It does not do it all the time and has done it sitting idle while in drive and park.

    Any ideas or is this a normal sound for something?? She is looking to replace a Pontiac Montana that was totalled 5 wks ago and has to make a decision on this vehicle pretty fast so any thoughts or input would be appreciated. Car is at dealership so it can be checked out there but would like some thoughts.

    Thanks
  • tidestertidester Posts: 10,109
    The ticking is possibly a problem with the valve system (lifters, rocker arm etc.). I would at least have a good mechanic look at it - or just pass on it and look for another car.

    tidester, host
    SUVs and Smart Shopper
«13456
Sign In or Register to comment.