Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Safari/Chevy Astro Electrical Problems

135678

Comments

  • I went to start my van last night and didn't have any power to the headlights or ignition,everything else works fine I just lost all power to the headlights and ignition system.The van cranks just fine but isn't getting power to the ignition to fire it and I don't know what that has to do with the headlights.The book says there is a 40 amp battery fuse under the hood but I have never seen it that would explain the headlights and ignition but finding the fuse is the next problem.I just wondered if anyone out there has has the same problem and had to locate this fuse.Any help would be greatly appreciated.
    dlm1
  • MY 91 RWD WAS STARTING AND RUNNING FINE AND I STOPPED AT A STORE AND TURNED IT OFF FOR 10 MINUTES, WHEN I TRIED TO RESTART IT , IT WOULD,NT EVEN SPUTTER OR ATTEMPT TO START AT ALL ,HAD PLENTY GAS IN TANK AND IT HAS A RECENTLY INSTALLED NEW FUEL FILTER.
    QUESTION: HOW CAN I TEST THE FUEL PUMP WITHOUT TAKING THE TANK DOWN? COULD THE RELAY BE THE PROBLEM OR A FUSE AND WHERE ARE THEY LOCATED? I DISCONNECTED THE GAS LINE ON THE TANK SIDE AND SPUN THE STARTER AWILE BUT NO GAS CAME OUT. HELP!
    THANKS, BOB IN RALEIGH,NC
  • I think you can get a loner tool at Auto Zone or Advance Auto but you'll have to remove engine cover and hook gauge to fuel line to see how much pressure you are getting to know for sure, and of course you can have someone turn the ignition on while you listen for the pump by sticking your head underneath the van by the fuel tank; if the pumps working you can hear it running. If you don't hear anything do a pressure test before replacing pump but it sounds like a pump.GOOD LUCK DLM54
  • mfreimfrei Posts: 3
    My '99 Astro windshield wiper pump is not working. Took it out. Tested the connecter with a voltmeter. Get 3 volts when activated. Hooked up two 1.5 volts to the pump and it runs. But when I hook it all back up, nothing works.

    The rear pump was working. Tested it the same. Read 6 volts at the leads. Now it doesn't work after putting it together.

    I tried priming the lines.

    I can't find any fuses that are bad.

    What am I missing?
  • kenmackenmac Posts: 1
    i have a 1990 astro van and when i turn on my lights the low beams are not working but when i click on my high beams theycome on with my problem. do i need to replace my light switch or dimmer switch?
  • I have a 1996 AWD Safari. The battery in it started draining over night. I had the battery and the charging system checked. I inspected every part of the wiring harness I could see without tearing the van apart. I checked for shorts in the fuse box with my volt meter and found one somewhere in the interior lights. They all work, so I was stumped. So I installed a battery kill switch in the lower dash panel and haven't had any more trouble, except I have to reset my clock every time I drive it if I want it to read right. Also, I don't know if this will harm the computer after a while. I figure if I find the short later I can just leave the switch on.
  • Hello, My 2000 GMC Safari is very difficult to start. If it is jumped or if the battery charger is on it, it starts easily. It starts best usually if you just bump the starter. Cranking will only assure you it won't start, but just drain the battery. The alternator and battery were changed early fall. The alternator was just about stuck at that time. I have always wondered if the fuel pump was weak. It doesn't seem as loud as before when you first turn on the key. Do I have two seperate problems or just one? The spark plugs, coil, Cap and rotor were new last summer. What do I check next????
  • Sounds like it could be bad grounds. I have had success with running a wire from something metal on whatever is malfunctioning to the nearest metal body part. The last such fix was a wiper motor. I clamped a wire with a bared end to it's body with a radiator hose clamp and crimped an eyelet onto the other end, which I put a screw through into an inner body panel where I could reach it easy. Crude but effective.
  • Sometimes this can be fixed by adjusting the rod tht runs alongside the steering column from the dimmer switch to the turn signal lever.
  • spike99spike99 Posts: 239
    My 2001 AWD didn't want to start last Sunday either. First time it didn't start for the last 3 years. Its battery cranked and cranked its starter, it fired a few times but it wouldn't start. Like an old tired frozon dog that didn't want to get out of bed. Left a portable electical heater under its hood and one under its engine for a 8 hours, and re-charged its battery. Even plugged in its block heater for even more good luck. Then, she fired right up under a 5 second crank. I'm thinking bad gas or frozen gas in its system. Might want to give your van better gas or change to a different gas station. Worked for my van.

    BTW: For the Safaris/Astros, it is recommended to keep above 1/4 tanks of fuel. Above 1/2 tank is best. And. park on hills facing downward. Thus, it puts less stress on their "weakly designed" fuel pumps. Works for me...
  • Thanks, but the problem seems to go deeper than that. I always keep the tank above 1/2 a tank and have put fuel injector cleaner in it just about every fill. Living in IOWA it sees ethanol all the time also. It could be a weak fuel pump, but then why does jump starting it or leaving a charger on it help so much? Please reply if this further information helps, Thanks Mark.
  • spike99spike99 Posts: 239
    Last week, my van wouldn't start. Thought it was bad gas / water in the gas. Took to my van to local auto shop and they changed its rotor and distributor cap. Talk about electronic corrosion overload. They also changed its battery. Unknown to me, they said its existing 6 month old battery would only charge up to 90%. The 4.3L engine needs 100% charged battery for best cold morning starts - even when its 90% charged battery can easily crank its engine. So, they changed these 3 items. For the last 2 cold mornings, my Safari van "fires right up". As a suggestion, get your local auto shop to investigate these 3 items as well. Worked on my 2001 Safari van...

    Hope this helps as well...

    .
  • nichunichu Posts: 2
    Hello, I have a 2000 GMC Safari w/ the Mark III conversion package. The issue I have is my reverse lights do not work. I've replaced the bulbs and it is not the bulbs. Where do I go from here? Anyone have any pointers?
  • That would be the PCM and to get the part# you will have to get it out and look for it on the computer itself
  • Check your neutral safety switch located on the driver side of the tranny
  • Check the air box on the pass. side of engine compartment locate the blower motor the wires coming out of it follow them and it will lead you to the blower motor resistor
  • samgkdsamgkd Posts: 2
    I have a 92 Astro that you have to push the headlight switch several times to get the headlights to turn on. Before I tear into it, I was wondering if there might be a relay that the light switch turns on or does the switch carry all the current? If there is a relay, where would it be located?
Sign In or Register to comment.