Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Safari/Chevy Astro Electrical Problems

I have a 2000 Astro AWD. It is an off lease vehicle and wasn't treated very well. When it rains for a period longer than 12 hours, weird things happen to the electrical system. Last time it was the door locks, locking and unlocking on it's own. They would cycle 4 or five time a minute. Now is the fan and the A/C cycling. I also noticed that I am missing a high beam and have checked all the fuses and the bulb?
«1345

Comments

  • I feel that I am having computer issues in my chevy astro. What I am looking for is the name of the comptuer located on the frame just by the driver side front wheel and what does it control. Also, what is its GM part Number.
  • I was wondering if anyone could help me replace a dimmer switch. When I turn the headlights on only my brights work. If i tilt the steering wheel sometimes the low beam will work. Thanx in advance for any help.
  • Hi,
    I'm trying to disassemble a 2002 Montana Door Power window switch to change the bulb inside.
    Could anyone give me a hint as to how to remove the top to get at the bulb?

    Cheers!
    Ralph
  • my asro van2000 has no power how do i fix it?
  • hy4wojhy4woj Posts: 3
    Hello all,

    I was wondering if any of you guys knew whether the radio clock in a 1995 Safari should remain on even when the van is off. I don't remember it staying on before. Basically I have to jump my van off every two days because after sitting up for a couple of days, the battery is totally dead. Now the radio clock only draws .25amps, that shouldn't kill a good battery in 2 days. I took the battery in to AutoZone to have it checked, they say it's good, but I'm having my doubts.
  • cobcob Posts: 210
    It may be a blown fuse check the panel under the dash by the drivers feet. The other thing to check is the wire that connects the lighter it is under the outside cover (dog house) it may have come loose or the last person to service the van from the inside may have failed to plug the wire back into the lighter. In order to remove the cover the lighter and CD player and aux power point wires need to be unplugged.
  • i have a 1993 chevy astro w engine with electrical problems
    the left side of my fuse block is dead, horn, dome, tail lamps ect. i also have no power to the headlight switch. by jumping the head light switch with a hot wire i can back feed the left side of the fuse block. i assume i have a fuse or circuit breaker blown but i can not find it and i can't find a wiring diagram to help it leads me to a convenience center that does not exist. i checked in the engine compartment and i can't find an inline fuse
    i need to know what feeds these items from the source and where any circuit breakers or fuses would be located can anybody help

    thanks
  • I have a similar electrical problem, Did you get an answer?
  • Our 1999 Astro van delvoped an electrical problem where usage of the elctronic door locks
    whether by hand or keyless would blow the fuse after just a few trys. Now our 2004 Astro is doing the same thing... anybody relate ??? any ideas ?????
  • The fuel pump, headlights, dome lights, and horn will not work on our 95 Astro. Everything else is getting power to our knowledge. We replaced the battery cable ends because they were corroded. We replaced a relay under the hood because it had black burned gooey stuff on it around the wire connector. We replaced a burned out blower motor resistor, and now the blower works on all three speeds like it should. We replaced the electrical ignition switch with a new one. We checked tons of wiring for burn and corossion damage to no avail. It sounds like the same problem the one gentleman was having with the left side of the fuse block not getting power to it. Any good ideas on what the problem may be? The problem seems to be intermitent but most times the van just won't start and the electical items mentioned won't work. Thanks.
  • Hey,

    Does anyone by chance know where the blower motor resistor is for a 1995 Safari?????????
  • susieq54susieq54 Posts: 4
    My 1987 Safari van instrument panel lights won't come on. The bulbs and fuse are good. Help Please!
  • wreidwreid Posts: 1
    I replace my fuel pump but the fuse keep blowing is there something else connected to that fuse are what can i check
  • albedo039albedo039 Posts: 3
    Hi
    I have a peculiar problem with the headlighs. Driving with high beam on, it suddenly goes complete black! Switching to low beam gives me low beam all right. When I switch back to high beam, the light stays on for 20 seconds to a couple of minutes, then it goes black again. I have H4 bulbs 100/90W.
    Any ideas?
  • susieq54susieq54 Posts: 4
    I'm afraid I can't do you any good. I'm still waiting to hear from someone on my problem from over a month ago. This web site doesn't appear to be worth its weight in oil when it comes to answers. I wish you luck.

    Very Truly Yours,
    S.Williams

    p.s.

    I responded to your message because it came to my email address. Once again, good luck.
  • albedo039albedo039 Posts: 3
    Hi
    Maybe I can be of some help to solve your instrument panel lights problem.
    Possible cause:
    1 No ignition feed to the instrument cluster
    Remove the large 17 pin connector from the instrument cluster. Using a digital Volt/Ohm meter, measure the voltage from pin A13 to gnd with the ignition in run. The meter should read battery voltage. If the readings are less than battery voltage, or zero, repair the pink/white wire from the ignition switch.

    2 No ground to the cluster
    Measure the resistance from pin A15 and A16 to gnd. If the meter reads anything but 0-0.5 Ohm's, repair the black wires at A15 and A16 to gnd.

    3 Inoperative cluster
    Replace the cluster

    If this doesn't help, check out the forum at astrosafari.com
    I think the guys there are acting more alive than on here ;)

    Respectfully yours

    D A Oestlund
    Bodoe, Norway
    PS! If you send me your email address, I can mail you a copy of the Circuit Diagram for this specific area.
  • susieq54susieq54 Posts: 4
    Mr. Oestlund,

    Thank you so much for your informative response to my instrument panel problem. My husband plans on checking out your suggestions this weekend.

    Yes, I would like a copy of the Circuit Diagram. Please send it to susieq54n@hotmail.com at your earliest convenience.

    Once again, Thank you

    Very Truly Yours,
    Susan Williams
  • kenhickokkenhickok Posts: 2
    Did you find any info on this?? We have a 2000 Astro Van that does this same thing.
  • kenhickokkenhickok Posts: 2
    Our 2000 Astro van is acting weird. All the indicator lights come on all at once intermittently. Sometimes you turn the blower on high and the lights go out. But the blower only seems to work when it wants to. We turn the blower on and the blower sounds like it is working but there is no air blowing. Then other times there is silence when the blower is turned on. Any help would be appreciated. Thank you.
  • jrbudgejrbudge Posts: 7
    I had a similar problem. When the air cleaner housing is removed, there is an aluminum 'connector' sitting on the throttle body. If you lift that up, that's where I found my problem. There was a green(I think) wire that had been pinched in there pretty tightly and from vibration over time it had worn away the outer sleeve of the wire causing it to short out. I can't guarantee it was the same fuse, but I think so.
  • jrbudgejrbudge Posts: 7
    My problem is a combination; when I hit the headlight switch, the lights come on but the instrument panel lights and taillights don't. I recently discovered that if I pressed the bottom half of the switch first everything would work fine. It gets weirder: before discovering the switch trick, when I turned on my hi-beams, the taillights and dash would come on very faintly. But if I kept the hi-beams on for very long, I would lose headlights altogether. So now, after discovering the switch trick, everything seemed fine for a couple weeks until 2 nights ago I was driving with the hi-beams on and everything went black. I discovered this tonight: When I squeezed the headlight switch(the back part that you don't normally see), it would randomly make the headlights and the dash lights go on and off. Sometimes one, sometimes the other, sometimes both. I'm going to get a new switch and hopefully report back with some good news.
  • jrbudgejrbudge Posts: 7
    I was finally able to pinpoint the problem... headlight switch, mine anyways
  • rixterrixter Posts: 1
    I have an old Safari and the cruise stopped working. Intermittent at first and now nothing. Does anybody know where the 'cruise control module' is located? That would get me started! Tks! Rick
  • pcouplandpcoupland Posts: 2
    From reading all the various posts I can now see that my windows that won't open when it gets too warm, or close when it gets too cold are standard. The a/c and fan also only work intermittantly.

    I am considering taking it to a garage to see if they can fix any of these, as the window problem seems to be getting worse, but from reading the archives it looks like this might be a waste of time. Several people say it cost a lot of money and the problems persisted.

    I'm a pretty handy person, though I stopped working on my cars when the engines began to get too complex for me (about 1992).

    Does anyone have any opinions about whether I should try and fix these issues on my own, or if it's worth taking the car to a professional?

    Penny
  • pcouplandpcoupland Posts: 2
    I had no replies to my post after 7 days. I guess this site is just a way of getting spam into more people's inboxes and trying to get them to read the car ads on this page.

    For anyone who ends up on this site searching for info about their safari electrical problems, read on. I took the van to the garage who assured me it would probably be the motor or the circuit breaker. It isn't either. The motor doesn't get power when it warms up and hence doesn't work. This is pretty much what I told them.

    They have now had the van for 24 hours and I need it by the end of the day whatever. They may or may not have found the problem by then..

    So the conclusion - live with the problem, it's a GM thing (as you can tell from all the other posts on this issue). Learn to live without opening windows (or a/c or fans). Garages don't know how to fix it and will charge huge labour costs to tell you what you already told them.

    Penny
    PS I'm also going to stop using my electronic locking system and lock all doors by hand with the key to make sure. If you read the posts on that you'll see that these are also faulty.
  • susieq54susieq54 Posts: 4
    Try astrosafari.com, it's definitely an improvement over this website. My mechanic advised me that these rigs had a history of nothing but trouble, after reading the messages posted here I came to the same conclusion. I sold it two weeks ago. Good Luck to the rest of you Safari owners, try astrosafari.com, you'll actually get some answers there!

    Susan
  • I was driving along a gravel road a few nights ago and just lost power. It happened earlier that day, and start right back once I was off the road. On the gravel road it would do nothing. All that would work and still works is the horn and head lights. Dash lights, emergency flashers, blinkers, and digital dash does not work and it will not turn over or do ANYTHING. Please help me its a great rig other than this problem.
  • fixitrodfixitrod Posts: 67
    On my 1995 Safari w/ 260000 miles the brake lights don't work. I have replaced all bulbs and rear light sockets, high mount light bar and the brake light switch attached to the brake pedal and still no brake lights . The rear lights work however.The fuses are OK Any suggestions appreciated?
  • The driver's cigarette lighter is out, I need my ipod! Where do I look for the fusebox?

    I heard there are two, and I can't find one.

    This is 2000 GMC Safari
  • My daytime running lights (DRL) have stopped working on my 2001 Astro. Regular lights come on automatically as usual. Any advise please. Thank You.
«1345
Sign In or Register to comment.