Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Liberty Electrical and Lighting Problems

17891012

Comments

  • rickc38rickc38 Posts: 20
    Sounds like something is shorted in your wiring harness(es) for the dash or contacts have oxidation on them; try pulling apart some connectors and clean them with switch contact cleaner or something similar. Rainwater has a lot of crap in it and will form a film and short wires in connectors out by bridging the gaps between pins.
  • deemcpeedeemcpee Posts: 2
    Has anyone experienced total electronics failure on their Jeep Liberty? I bought a brand new Liberty in September/October of '09 and last year at around 13K miles I started to experience all lights flashing, car puttering and stopping, all warning lights coming on etc etc. Spent 2 mos at my dealership trying to get it fixed and finally screamed long enough to have them agree to replace the electronics at their cost (Chrysler or the dealership - not sure which) wanted me to replace at mine - despite being under warranty. Fast forward one year and here I am again - exact same issues. All warning lights flashing, nav system "forgetting" my home address, MP3 connection not playing iPod correctly etc etc etc etc. I only have 25K miles on the car so obviously shouldnt be happening - has anyone else experienced it? BTW - been a loyal jeep owner for over 20 years and this is my first issue EVER...thought I had a lemon but they said I didnt...what to do? I'm seriously considering selling and leaving Chrysler completely.
  • We had similar issue where the car had crazy dashboard lights and car stopped running and wouldn't start. Got towed to dealer and the car started fine the next day, and they can't figure out what happened or what to fix. They found 22 communication error messages from the computer, so electrically it's like the car went crazy. Clearly reading these things, Jeep Libertys have a major issue going on electrically. Ours is an 09 that's less then 2 years old. We may lemon law this car if they can't come up with an answer and fix it.
  • you posted back in nov 10 about problems with your 08 jeep having abs. esp, bas, serv 4wd lights lit. i have same symptoms, with no cruise control. did you ever get it repaired.. and if so can you send me a message as to what was the "FIX" crrbsa@aol.com
  • took the 08 liberty into a local dodge dealer monday. they called today said the problem was the rotation detector on the left rear wheel. it is supposed to be ready tomorrow at nine am. i will pick it up in the pm. i had all your symptoms but the mirrors not working.. also my cruise control would not turn on. supposed to be just under 200 bucks . so we will see. from most of the posts i see.. this may be the first visit of several
  • Its so frustrating - my car is now - AGAIN - in the shop. Went to a new dealer in my town and they replaced the entire electronics module on the dashboard - took a week to fix and when I went to pick it up the fuel guage wasnt working so I had to take it back yesterday - now the fuel pump has to be replaced. I have someone at Chrysler that is now my "go to" person but I may be too late to lemon law mine..
  • crrbsa, Hope your local dealer was able to repair your Jeep Liberty. Please post an update once you pick your vehicle up.
    Lisa
    Top Care Specialist
    Chrysler Group LLC
  • Hello, my 2004 Jeep liberty lights go on and off without a reason. It seems to be happening more often. Sometimes when I turn on my high beams, the inside will light up, and vice versa. Meaning I turn on my high beams and the problem goes away. Sometimes the interior lights go off when I use my turn signal as well. Any ideas????
  • Hi there, i have the same problem with my 2002 Jeep Liberty when i decided to upgrade the map light and the cargo light to LED.

    Have you find a solution to that constant 5.3v that runs constantly ?

    Thanks.
  • My 05 Liberty control lights on the column won't work. Everything on the dash works fine though. At night I can't see to use the cruse control, wipers or light adjustment knob. I looks like these lights as well as the instrument cluster (which works) are on the same fuse...so I don't think it's a fuse. I have an aftermarket radio installed and so the radio control buttons on the steering wheel don't work with the new stereo. Could that open connection behind the radio have something to do with it?
  • I've had a similar problem instrument cluster flickers, sometimes warning lights stay on until the vehicle is turned off and turned back on, sometimes just the check engine light sometimes nothing. You can hear the relay click once or twice. As far as i can tell it, thankfully, doesn't effect the headlights as the high beams low beams and fog lights work fine. Anyone have any suggestions? Mine is a 2007 71000 miles on it had it about 2 weeks
  • I have a 2005 jeep liberty 3.7 4x4. Yesterday, all of a sudden, while driving at night, the left signal indicator in the instrument panel stayed on solid (not in a blinking motion). the signal light workes but when I got home the tail light was out and the fuse was blown. I replaced the fuse and the same thing happened. Here is what I found. When driving during the day time and without activating the head lights, the signal light indicator stays off and the signal light works fine. As soon as I turn the headlights on, the indicator light stays on untill the fuse blows ( which is about 2-3 minutes or the minute I turn on the lt turn signal). When I turn on the lt signal light with a new fuse, the signal light and tail light flash together. once the fuse blows, the lt signal light works but no tail light. I have changed bulbs, fuses and cannot figure out why the lt tail light and signal light are working together when they are in two different sockets.

    Where do I start? Is there a part that I can change?????

    Thanks
  • Hey.

    I am having the exact same issue. It started a few months ago. I left it for a while replaced the bulb and fuse a few weeks ago and it worked great until a few days ago when the same problem occurred.

    Please let me know if/how you resolve this issue.
  • sdjohnsonsdjohnson Posts: 1
    My Jeep has electrical issues that result in my windshield wipers going off on their own, the washer fluid flowing freely, and the horn going off without warning. In addition - my car jolts (as if the breaks have been hit) at 70 mph on the freeway while this happens. The only way to get it to stop is to pull over, raise the hood and HIT what I believe to be the fuse box. However, there is no rhyme or reason as to why this continues to happen. This has been going on for months. I am very unsatisfied with this purchase. My car has gone from one I love to one I HATE to drive in fear of it freaking out and causing me to have to pull over at a moments notice. I live in a rural area and pulling over on back country roads is extremely unsafe. Given the number of issues being seen on this site and others, is Chrysler/Jeep considering a Recall or some answer for those of us that own these vehicles? I don't think I should pay for a car that puts me in danger. :( :confuse: :sick: :lemon:
  • rallycomrallycom Posts: 5
    Give Jeep customer care a call, I have found them to be extreamly helpful in resolving weird issues, although other than the window regulators & recently having to replace the ECM (Engine Control Module" I haven't had any issues. The BCM (Body control module) may be "going south" on you, I beleve this controls the electrical power distribution.
    I made "a little noise" about the window regulators & Jeep is gauranteeing them for the life of my vehicle (7 replaced to date)!
    The ECM was throwing an O2 heater circut code, after replacing all 4 sensors twice I narrowed it down to the ECM. Replaced it for $245. the unit comes with a lifetime gaurantee & took 10 minutes to replace.

    Good luck, don't be afraid to yell & scream (although a customer shouldn't have to)

    Best Regards
    Rich Otis aka Rallycom
  • Ok...I'm hoping someone on here might be able to help me before I spend tons of money on my 2006 Jeep Liberty Limited. Here is the problem...when I turn on my headlights my emergency brake light comes on, my headlights go dim to bright then back to dim, my battery light comes, my right turn signal flashes out of control when I use it and when I turn my high beams on my jeep feels like it shifts into a lower gear and my RPM's go crazy. Someone mentioned that it might be the multifunction switch however I was hoping that maybe someone else may have had this problem. Can anyone help?
  • I have a 2009 Jeep Liberty which I've owned since 3/10 and I love it! But, in the past 2 years I've had intermittent issues with it not starting, not cranking, not even turning over. I've replaced the starter twice, replaced the battery with a Sears Die Hard and had it towed to the dealership (Earnhardt Jeep in Mesa, AZ and Carmax in Gilbert, AZ) 6 times only to be told, "Well, it's starts for us" and "unless it does it for us, we can't do anything about it". Several times it's left me stranded because of the intermittent problem. I just don't trust it anymore and am afraid to drive it as I don't want to be stuck anywhere. I do have AAA thankfully and they've been able to assist in getting it to the dealerships for review, but again, with no positive results. I've spent so much in towing and in "diagnostic" charges I'm at my witts end. I really love the look of my Liberty (black with lots of chrome and a slider roof) and it is super fun to drive, but again, I don't want to be stuck somewhere because of the once in a while not starting. I have a therory that there is a short in the ignition switch because, if I keep trying to start it, sometimes after 10 or 20 attempts, it will start. But, several times it has not. I think that the jiggling around on the tow truck has restarted the short and that's why the dealer can't find the problem. Please let me know if this is common and maybe a possible solution as I really hate to part with my Liberty.
  • I have a 2006 jeep liberty renegade and all of a sudden I have no dash lights. Checked the manual and there does not seem to be a fuse problem. Can anyone help me out? tired of driving in a black hole!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,645
    Have you tried wiggling the rheostat that dims and brightens the dash lights? Maybe pressing hard on it, or trying to clean it with electrical cleaner?

    MODERATOR --Need help with anything? Click on my name!

  • Had the same problem in an 07 liberty. Really escalated after that with nothing working in the dash cluster and the headlights not working at all. Replaced the body control module. After a few weeks headlights starting flickering, then dash lights starting going out again. Maybe a bad ground.
  • Hello ttripp378!

    Sorry to hear you are having a concern with your 2006 Jeep Liberty Renegade.

    I checked for Technical Service Bulletins but could not find anything related to no dash lights like you described.

    You may want to consider having the vehicle diagnosed by your local authorized Jeep Service Department or a trusted mechanic.

    Lisa
    Customer Care
    Chrysler Group LLC
  • Check out this service bulletin:

    http://ww2.justanswer.com/uploads/mechanicinacan7/2010-08-07_194241_tsb.pdf

    I have the same issue...a couple of years ago, they replaced my wireless control module when it completely died. Now I am starting to have the intermittent issues.
  • We have a 2002 Jeep Liberty Sport that has no lights. At first we thought it was being caused by the rear right tail light, but when we replaced it, still nothing. We do not have any dash lights either. Could this be a BCM issue? My husband just got laid off from his job, and we don't have much money to get the problem diagnosed. We might be able to purchase a part or two if he can install it himself. Any ideas?
  • billgeddesbillgeddes Posts: 2
    edited November 2012
    If I use the push-to-on feature of the lights above the windshield they'll go on, but not when I open the doors or if I use the rheostat.

    Where do I start looking for the trouble?
  • Jumped into my 2003 liberty to find a solution to your lights. Think I found the reason; I'll try to explain it in my limited knowledge of the names of car parts.
    :-) The signal arm on the left side of the steering wheel has a rotating piece on it that controls the interior lights. If that is "rolled" or switched in the position that turns off the interior lights then the interior lights won't go on when you open the door and neither will the over the windshield press on lights.... the press-on lights seem to be controlled in two ways; one, by the interior light switch (located on the signal arm) and two, by simply pressing them with your fingers. Hope this helps! :-)
  • Just asked hubby what those "press on "lights were called... He said, "dome lights"...LOL
  • LOL!

    I'd call those ones "map lights."

    My signal arm won't turn them on either. Rotating it all the way to the stop one direction will turn all the lights off. All the way the other direction will turn the instrumentation lights to full, but will NOT turn on the map or cargo lights.

    The rear cargo light won't go on even when it's pressed, even though the bulb's good.

    The overhead display shows when the doors are open, so the switches are working...
  • I'm afraid that's all that I can add to this mystery....maybe bringing it in to the dealership or trusted garage will help...just get an estimate before they go 'digging'. :-) :)
  • forgivenin2002forgivenin2002 Posts: 1
    edited February 2013
    I had a tail light out and went to replace it with a new one and come to realize it was the wrong one now i have no lights on the driver side at all could it be a fuse that was blown when i replaced it? Or could it be the whole panel that went out i really hope not My jeep seems to be giving me alot of problems lately first went to walmart for and oil change it came out with check engine light on and smoking under the hood, then there is a clicking noise in the rear on passenger side where the tire is can anyone tell me what that might be?
  • I had so many light issues with my liberty. The drivers and passengers sides run off of separate circuits so it could be the fuse. Google the owners manual if u don't have the original and it will have the fuse breakdown. When my system surged the old tail light bulbs literally melted in their sockets on one side. I pried them out. Cleaned the sockets up and they worked again, for the headlights, I couldn't get the one side to work again. Only the regular headlights. No day times and no brights. So I bought a HID kit ($100), they run off one headlamp only, so I hooked it up to the working headlight and away I went. The dealer thought it was a relay. ($80) it wasn't. It was the wiring harness. Mega bucks. HID solved my problems. Drive it for two years before trading it in. No more light problems.
Sign In or Register to comment.