Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Colorado and GMC Canyon Engine Problems

11820222324

Comments

  • I am also having this prolem but i have a 2.8 ltr 4 cyl. Are they having the same problem with it.
  • gmcustsvcgmcustsvc Posts: 4,134
    flajohn1,

    Were you planning on having the vehicle diagnosed by a GM dealership? Please keep me posted.

    Thank you,
    Caron, GM Customer Service
  • Does anyone have know why depressing the brake pedal would cause the in-dash left turn signal light to illuminate?

    The dash indicator light illuminates as well as ticks. It will flash and tick as rapidly as the brake pedal is depressed, and will stay illuminated as long as the brake is held. When the the right turn signal is engaged, depressing the brake causes the right turn signal to stop ticking, although it flashes normally. When the left signal is engaged, irregular symptoms ranging from normal function to erratic ticking to fast flash and ticking occur. Interestingly, the outside front and rear flashers function correctly.

    Presumably, there's a short causing the problem. I believe it might be a faulty trailer harness loom, although, I'm currently experiencing other electrical issues with this truck such as a fuel cap warning, engine light warning illumination (with no code) ABS brake warning and no-start phantoms. My ABS brakes have not functioned for 3 years even after spending over $1,000 to have them fixed. With a history of electrical problems I've had with this truck, it's never a surprise when something electronic goes a muck, only a mystery. It could be the computing systems on these trucks are defective as I've had regular electrical problems since the day I bought it.

    I appreciate any suggestions that will help minimize the damage. I can't afford to let the dealer play a guessing game with the meter running as I've previously experienced with my never repaired ABS braking system.

    Thank you, from a life-long GM loyalist who will most likely never buy another.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,287
    I'm thinking a bad ground at the tail lights, or perhaps a corroded socket where the bulb goes in. check it out.

    MODERATOR --Need help with anything? Click on my name!

  • Thanks for your tip. Appreciate your help. Have a cap as well and rewired all brake light connections, including the ground. I've taken flasher bulbs out, cleaned, reinstalled, and have same problem. Found the problem goes away when I disconnect trailer loom right side, however, the brake lights don't work at all when loom is disconnected so not 100% sure. Is there a way to test with a meter? Hate to pop for new loom if not the problem.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,287
    Hmmm...I'd need to have a diagram in front of me, but what I'd do is fix the brake lights first without the trailer hookup connected at all. Maybe you lost the regular ground and the trailer loom gives you a half-fast one?

    MODERATOR --Need help with anything? Click on my name!

  • Yeah, thinking like you, I disconnected the trailer loom and thought to check the brakes without it because the factory trailer harness fizzed the 2nd year I had the truck. Unfortunately, you can't simply eliminate the harness. It's a T-connection loom with a converter in-line with the trailer plug. If you eliminate the harness, you're left with two female connectors for the left and right side tail light loom wiring. I'm not sure how to test the tail lights and brakes without it, other than splicing everything (nightmare). Probably should just buy an AM trailer harness, try it, and return it if it doesn't work. Appreciate your suggestions.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,287
    Ah, I see. A factory install sounds like? Electrical issues can be quite a challenge, even for the pros. How much is this harness?

    MODERATOR --Need help with anything? Click on my name!

  • GM trailer converter looms are over $100 as are some after market brands, although I've found a Curt's on-line as low as $24.00. Not sure about differences, quality or otherwise. As mentioned, my original GM factory loom fizzed within 2 years. I replaced it with an AM, which, if bad, has lasted 3 years. Think I'll be spraying the back of plugs with rubber sealer this time.
  • lkhomlkhom Posts: 4
    Tail lights on GM canyon/chey were recalls, they will fix for free
  • lkhomlkhom Posts: 4
    I bought my truck.. brand new right... out the door deal.. and I have gotten more problems w/this truck then any other auto I've owned.. I've owned Fords.. that's what I should have bought...
    I took my canyon back to GM, they said; they used a pressure water wash.. ok, sure.. cuz they give you a car wash with every thing they do.. if they just pop your hood and hmm over it. the Leak came from: the light seal over the bed of the truck.. cargo light. so it was not covered the cutout completly.. when it was raining I sat in my tuck to find the leak.. now... did they do that.. I ordered them to replace all my carpet.. what grief: they scratched my truck.. i had to take it back in.. they didn't put the bolts back on the seats .. I still feel my seats going back at take take off.. from a stop sigh... what do they wait for till i go out the front window?
    and the matting/carpet they put in was for another model.. GM SUCKS! THAT'S ALL I CAN SAY
  • lkhomlkhom Posts: 4
    MIGHT BE DUE TO NEEDING A STARTER... OR JUST STARTS ON AN UP HILL.. IF TRUCK IS WITH NOSE DOWN... NO TRUCK WILL NOT START.. IDLES TOO ROUGH... KONKS OUT WHILE I'M TURNING...
    I HAVE DONE A TUNE UPS EVERY 3 YEARS.. OIL CHANGES EVERY 4,000 MILES, NEW BATTERY AT 6,000 MILES, WATER PUMP AT 70,000 MILES. THE CATI CONVERTER WENT OUT AT 70,000 MILES, I INSTALL NEW BRAKES EVERY YEAR NOW... EVERY 2-3 YEARS, I'VE TAKEN MY DOOR PANEL TO FIX THE WINDOW.. AND TO FIX TO REPAIR MY WINDOW REGULATOR.. WHICH WAS NOT WORKING RIGHT WHEN I BOUGHT THE TRUCK.. (THEM NOT WANTING TO FIX OR REPAIR IT RIGHT) DO IT YOURSELF... , I HAD THE HEATER SMOKING... DO IT MYSELF.. THEY COULDN'T FIND THE PROBLEM? I PULLED THE 3 PIN OUT OF THE CONNECTOR...I'M THINKING NEW STARTER, NEW SOMETHING... THIS STOP AND CROSS YOUR FINGERS.. PRAYING FOR IT TO START.. CALLING TOW AT TIME OF PROBLEM.. WHILE IN THE PROCESS OF TRYING TO START MY TRUCK.. IT HAS ALL THE BELLS AND WHISTLES.. JUST DON'T START/RUN LIKE IT LOOKS.
  • gmcustsvcgmcustsvc Posts: 4,134
    I’m sorry to hear that you’ve not had a good experience with your Canyon and your dealership. Please send us more information by emailing Christina with your name, contact information, VIN, and involved dealership.

    Best,
    Sarah
    GM Customer Service
  • owl1owl1 Posts: 2
    I have an 05 canyon with I-5 82,000 on it and is now in the GM Dealer repair shop with a bad head! Is there any way you could send me a copy of the letter you talked about, as they are telling me it may be as high as 2500.00 to repair!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! you would think that GM would give all people that own an I-4 or I-5 that exteneded warrinty! Thankx dave493@sbcglobal.net :cry:
  • omaitaomaita Posts: 16
    Colorado 2006, Crew Cab, LT, 43,000 miles, never used for hard work, only to carry my daughter's bike.

    Here is another one. The truck just doesn't go forward on D, I'm able to go forward only in 1 and 2. I didn't try 3, reverse is fine. What could be? broken transmission??, Should be that covered by the Performance First extended warranty sold by the dealer when I purchase the truck???
    Every time something happens Dealer just said that is not covered but it's like a favor to me that they take care of it.
  • omaitaomaita Posts: 16
    Yes I had the same problem when the truck was on 20K miles only, after 3 visits, they fixed, replaced ignitor, cables, sensor.
  • omaitaomaita Posts: 16
    Colorado 2006, Crew Cab, LT, 43,000 miles, never used for hard work, only to carry my daughter's bike.

    Here is another one. The truck just doesn't go forward on D, I'm able to go forward only in 1 and 2. I didn't try 3, reverse is fine. What could be? broken transmission??, Should be that covered by the Performance First extended warranty sold by the dealer when I purchase the truck???

    Every time something happens Dealer just said that is not covered but it's like a favor to me that they take care of it.

    I just drop last saturday the truck on the dealer, let's see what they say tomorrow, I have the Performance First Premium Coverage, I don't have a car for this week, hopefully they will cover a rent car as promissed on the extended warranty!!!
  • Omaita,

    How did the dealership visit go for you?

    Best,
    Sarah
    GM Customer Service
  • omaitaomaita Posts: 16
    I drop the truck on saturday, Monday the Dealer called me saying that the transmission is broken and the extended warranty company (Performance First) is going to send somebody to take a look before decide if they are gonna cover it or not.

    Thuesday morning, I went to the Dealer to make sure all the information I have was right. Service Department just said that they were waiting for the "adjuster", who could be there in the next 48 Hrs, but how PF doesn't work Wednesday and Friday, this guy could show up until Monday.
    I said ok, give me the number and I will call PF to see what's going on this claim.

    I called PF and they said that it was not decided yet if the adjuster needs to go or not, and they were waiting for the "diagnostics and estimate of the repairs needed". So I called back to the Dealer left 3 messages, and around 3 pm somebody call me saying that they just send the "diagnostics and estimate of the repairs needed" and PF will send now the adjuster.

    So, I am this thanksgiving week with no car, no answer and just praying that PF or GM will cover the US$ 2,500 that will cost the repairs.

    43K miles on it, purchased in Oct 2006, Performance First Premium Extended Warranty.
  • Thank you for the update - I'm sorry that you are without a car for the holiday. I hope it has still been a good time of family.

    Please keep in touch, either here or by email. Do you have a Service Request number on this so I can keep track of how things are progressing?

    Best,
    Sarah
    GM Customer Service
  • I just bought a 2005 Canyon for work. Seem like all was good then the Fuel Cap Msg came on then the Check Engine light. Had it reset then finally no more Fuel Cap. But then the Check Engine light came on and i was told it was one of three things, the AES?, a vacuume leak, or something like that. The engine appears to be running fine. They said that the code ment the engine was not idleing right. Anyone have a clue on this???? :(
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,287
    I'd be great if you had the number of the code. If you were getting fuel cap codes, then vacuum codes, and a bad idle, I'm thinking you are dealing with the EVAP system---evaporative emissions cannister or purge solenoid, or a vacuum leak in the lines that service this component.

    MODERATOR --Need help with anything? Click on my name!

  • "jjallen", I had a similar situation occur about a year ago, with my '05 Canyon. Since I work part time for an auto parts store, I tried the easiest and quickest potential fix, and replaced the fuel cap. No luck...

    Took it back to the dealer, and they replaced a solenoid, or something like that, in the evap system. Seems to me, I recall them telling me that there was a factory service bulletin on this part...
  • Jjallen07,

    If we can be of any assistance, either in working with a dealership towards diagnosing this or by looking into any warranty/recall information available on your vehicle, please email us with more information (including the last 8 digits of your VIN).

    All the best,
    Sarah
    GM Customer Service
  • I have an 05 Colorado that also displays an irregular fuel cap warning light and engine light. The fuel cap light comes on first, then the engine light. Both lights eventually shut off, then display again anywhere from a few days to a couple weeks later. This has been an ongoing problem for over a year. I noted a low leak code once but often no codes appear, so no one can diagnose the problem. Thankfully, my truck passed my state emission test so I don't believe it has a faulty EVAP system; however, I'm quite certain my truck have a defective electrical system which GM has never addressed.

    I've also have a faulty ABS break system which hasn't functioned properly since the second year I owned the truck. I replaced the right hub bearing assembly once and ABS sensor twice ($600.00) but it didn't fix the problem.

    I also experience no start problems that have been occurring irregularly for 4-5 years. When the truck doesn't start, I simply wait 15 minutes, then it starts. The truck has been into the dealer twice (once for 2 weeks) for this problem, though they have never found a code or diagnosed the issue.

    Any suggestions? Does GM have any answers for the electrical problems that I continue to experience with my truck?
  • Stringpuller,

    Thanks for posting. We can look further into this for you - please send us an email with your name/username and the last 8 digits of your VIN and we can start by checking to see if there are any open recalls on your vehicle.

    All the best,
    Sarah
    GM Customer Service
  • omaitaomaita Posts: 16
    Monday, still no news from the Dealer.
    Criswell, Gaithersburg, MD. Customer No. 292272, RO No. 56904.
  • frahnk2frahnk2 Posts: 1
    edited November 2011
    Does anyone know where I can find a list of "Code" descriptions for the Colorado?
  • I have a 04 Colorado I5 i bought new from our local dealer to replace my s10. First and foremost I love my truck The look the torque band that once i got used to (learn to feather that pedal)always brings a smile and the posi rear end are just a few of the pros. Now here comes the cons and my main issue is not with the truck it's with the dealer. Like alot of the rest of u shortly after my ownership i started getting the rough idle so i mentioned it on a maintanence vsit and i got the maybie bad gas response. Mine never thew any codes so i just started adding lucas and it never totally fixed it but helped to the point i was not real concerned. As the years went on it is progressively getting worse, and then my 1,2,3 on fan went out (another common problem) I turned to the net one night and found a site that explained this and also the potential head problem. I brought in to dealer to fix settings and mentioned my concern,he tells me he really cant hear the ticking first off! (has always reminded me of a friggan diesal with that sound) then tells me he has never even heard of this problem. Now im not possitive on how long ago this was but prob 08 09 so i asked him to look into it, they fixed the switch and i got the run around on the head. This fall with the colder days its been the worst it has ever been. I still have never thrown a code but last night i found this site and after all nite reading I am really concerned now. I have always maintained my truck well and do the xtras like clean throttle body k&n filter synthetic oil most dont even believe it's an 04 say it looks within a year of pulling off the lot new. so with 84,000 miles on a 04 and bringing this to my gm certified dealers atention on more than 1 occasion Where do i stand IF this is noted in my service records and i need $3,000 worth of work done? I'm ok with the problems i have had so far chalking i up to first modle year but a problem i inquired about more than once that will wipe out my savings is something else entirely. I really really like my truck (other than gas milage) should i go after dealer or call GM? Will it make a differance?

    One of the fans
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,287
    edited December 2011
    this might work if you scroll down. The list is "generic codes" only so they might or might not be exactly what you need. If you can have your codes read say by Autozone or Oreilly for free, then we could tell you what they mean.

    http://www.obd-codes.com/trouble_codes/

    MODERATOR --Need help with anything? Click on my name!

Sign In or Register to comment.