Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Elantra Problems 2001-2006

1235»

Comments

  • MrShift@EdmundsMrShift@Edmunds Posts: 43,635
    There might be a trouble code stored for these incidents, and it probably will indicate some kind of misfire. But pinpointing an intermittent misfire code can be quite tedious. Even a dose of bad gasoline (a touch of water) can do this, or old ignition cables, etc.
  • jimbeaumijimbeaumi Posts: 620
    edited April 2011
    It seems like we (mechanic and I) ruled out plugs and wires, especially since the dealer claims to have replaced the wires two years ago. I'm pretty certain they tested these. I will still consider this, of course. Car has not been showing any codes, which is why this is so aggravating.

    What about ignition control module? Would that be affected by moisture? Or should I stick with plugs and wires? Relatively cheap starting point, I would say.

    Thanks for the continuing tips, folks.
  • fordgt40fordgt40 Posts: 1
    new fan,relay,resistor pack & tried new dash control unit.still blows 30 amp fuse under hood.2005 elantra w/65,000 miles.all original,lady driven great shape.I'm lost now.speed 1 & 2 seem ok but fan speed 3 & 4 blow the fuse.circuit braker in place of fuse.blows fuse in 10 or 15 seconds.THANKS for any input!!
  • fushigifushigi Posts: 1,217
    Well, an automotive fan doesn't draw 30 amps so the circuit is shared with other components. You either have a problem with the wiring harness (i.e. a short somewhere) or you have other components on that line that are using enough power to send the total consumption over 30A.

    Considering that it works OK at lower fan speeds (which would use less power) my first assumption would be there's another component (or components - plural) on that fuse that's drawing more than it's fair share.

    When the fuse blows do you notice anything else that stops working (lights, radio, rear defrost, power windows, etc.)?

    A good tech ought to be able to see what all is on that line and check the power draw at the individual component level.
  • 2006 Elantra with 65k miles recently exhibits an intermittent electrical problem when not started for several hous. When the key is turned all the dash lights & elec accessories activate but the engine only gives one click sound and does not start. (yes. the key is turned fully to the start position.) After a few tries the engine does start properly and runs fine. It will re-start after this. Then, after sitting for several hours (usually overnight) it will repeat this exercise. But it only does this intermittently. Not even every day.
    Replaced the battery the first time but it kept doing this. Took it to the dealer and they said the negative battery cable was loose. They tightened it and it was fine for several days. Then it began again. Took it back to the dealer and they said the spark plug wires needed to be replaced. Had them replaced and it was fine for a few days. Now its doing the same thing. There seems to be no pattern as to the frequency of this happening. Your thoughts?
  • I took my 2003 Elantra for a state inspection. (New York) My mechanic would not pass it due to a rusted front cradle. He said the holes for the bolts are rusted out and could not be tightened. He said that the "frame cradle" would cost beteween $1500 and $2000 to replace. He said that he could not find a recall notice for this but it is a common problem and that Hyundai should repair it at their cost (no cost to me)
    The car is a 4 cyl. with 90,000 miles. I also have a 2000 Elantra with 176,000 miles and no
    problems. I was just wondering if anyone had a similar problem since my mechanic said that this is common.
  • I have a 2001 elantra and one day I came to a stop and I could feel my brakes pushed farther to the floor to stop than usual and when I got to my house I could smell what smelled like brake dust so I walked around and check the tires and it was my back left wheel. The rim was hotter than the others. I called my brother in-law, who works a little on cars and he said it could b the drum or bake line. Anyways I drove the car for about a month and I never happened again. Well today I come to a stop and I here this really loud scrapping noise. I take it to my dads and we put the car up on the lift and check the brakes, well my inner brake pads are grinded to the metal and my left rotor is bad. I got the pads and a new rotor, but I don't just don't want to fix what the problem caused before fixing the problem. Would you have any idea what might be the issue here or ha anyone had this problem as well?

    Chris

1235»
Sign In or Register to comment.