Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jaguar XJ-Series Electrical Glitches

Any stubborn electrical issues on your XJ that you'd like to ask about? Post your questions here:
«134

Comments

  • Hi, I have a 1995 XJR 4.0 ltr X300 series. For some time now it has had an intermittent clicking noise from what sounds like a relay on the left hand side of the consul. It seems to be speed related as it seemed to happen once the throttle got a bit stiffer. I lubricated the throttle control body & it still did it. Today it actually stopped totally after the gearbox warrning light came on. This light has come on before very rarely but has never seemed to effect the driving,I know that it is supposed to limp home but it drives fine. If you have any suggestions or thoughts it would be greatly appreciated as I love this car & it is a shame to have this click be so annoying. I can only drive with radio at a certain volume?? Regards, Bruce
  • i have a 1999 supercharge and i dont have a book i need to know if someone can help me to find out what the codes mean
    i am a woman who needs help
  • Did you try Googling the code? What are the codes you are after?
  • hi anyone got any ideas i have a x300 3.2 and if its not driven for a length of time it wont start in park you have to put it in newtral and wiggle the stick around then it starts!!anyone know a quick fix as i want to sell it or i have been told theres a selinoid you can adjust anyone know where or how or has anyone got a replacement they want to sell?thanks ian :cry:
  • The transmission connector has a bad connection and then it enters in limp home mode. You don't have gears, only third gear until you stop it and restart it. Check your trans mounts, excessive movement can cause problems with that connector(it is located on the driver's side of the trans).

    Manuals you can buy from Ebay.
    I bought mine for $36.(the whole leather binder with all the manuals)
  • rekrabrekrab Posts: 1
    Regarding my 1998 XJ8: I have 3 electrical issues, and have been told by the local electrical shop that they are all caused by a faulty computer. 1. The ignition switch does not activate in 3 tries out of 4. Starter checks out ok. 2. Seat does not automatically adjust to set position when car is cranked. All other memory components work fine. 3. Doors lock and then immediately unlock when the plunger is pressed. To lock doors, it is necessary to use the key or the FOB. If this is computer-related, what is the best way to get a good repair done with the least expense? Also, do you have any idea how to get the right part number, if it is a computer that I need? Thanks, Jim in FL
  • fduboisfdubois Posts: 9
    Driving a friends 2004 XJR today when yellow light and Air suspension fault message comes on. Checked fuse and its OK. Anyone ever seen this before? Thanks, Frank
  • We just yesterday purchased a XJ8 1999.

    We had windows tinted. There was water dampness inside car from process.

    On way home, one window automatically went down anf the steering wheel moved.

    Returned and dealer said it would be okay when it dried out.

    Today it is still doing these things.

    Has damage been done? If not, what should or can be done?

    Taking it back tomorrow to dealer.

    Appreciate your direction.
  • unable to find wiring diagram or repair manual for this model? any help?
    battery drains down over-night. belts squeal when first started each morning. battry (amp) guage shows charging.
    eventually goes away after driving.
    FIN control module has been replaced??
    belts are new & tight.
  • i have just purchased a p reg jag 3.2 exec i have an original key fob but was given another better one but the better one is not tuned in how do i do this please anyone thanks archie
  • Go to E-Bay. I found a CD for this there. $14+
  • I am having chimes go off while I am driving down the road.

    Five chimes five times.

    I have a light out on the rear-deck light.

    Could this be it?

    Help !!
  • adougadoug Posts: 6
    I am thinking of buying a 1999-2003 Jaguar XJ8 but have reservations because of the posts I have seen on this board. Can anyone tell me what to expect? I would appreciate any replies.
  • Hi. I have a 2008 XJ VDP. My parking sensors on the front bumper are extremely sensitive. I pick up traffic as it moves in front of and along the front edge of the bumper as cars turn in front of me while stopped. Does anyone know if they can be adjusted to be less sensitive. Thanks Neil
  • I assume they were the same way as the rovers and if they do there is a software patch that reduces the sensitivity of the sensors. Call your dealer and ask about it.
  • Thanks for the info. I'll give it a try.
  • Several months ago my blowers would stop working when running on low speed, but they would come back on and run without quitting when switched to medium. A few months later, they would stop running on medium but would run when switched to high. If turned off, they would have to be switched on several times before they would come on, but if left on between uses of the car, they would begin running when the ignition switch was turned on. Then more recently they will not run at all no matter what I do. Do you know a solution for this problem?
  • kbeerdenkbeerden Posts: 4
    Can any one point me in the right direction, I have a 2000 xj8 and the front drivers window is stuck up.I hear a clicking noise when I push the button but no movement, I have changed the switch and even plug the connection to a differant motor and still no movement,Strange thing my sun roof will not remain open and will close on it own after a few seconds ,are these problems related?
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,648
    If you hear a clicking that is electrical (light click) and coming from the relay box, you could have a bad relay. You'd have to check your owner's manual to see if that relay also operates your sun roof, to determine if there is a connection between these two malfunctions.

    If the clicking you hear is deep with the door, and a heavier mechanical clicking, then I would say (like skipping teeth on a wheel, a sound you can probably feel with your hand against the panel) ) that your window regulator is broken and that there is no relation to the sunroof.

    Visiting Host
  • deadjagdeadjag Posts: 8
    I drove home in a bad electrical storm. Everything worked OK while driving. Next day I tried to startup. Dashlights, audio tones, and interior lights come on but engine just clicks. I get two system messages: 1) check engine and 2) stability control. Checked battery and have 11 volts -- seems OK. Also tried to jumpstart to no avail. I also turned traction control to 'off'. Still get same result -- just an electrical 'click' and 'check engine' message. Seems like I need to reset stability control or check engine in order to start. Any ideas out there? Bob in Chancellorsville :(
«134
Sign In or Register to comment.