Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Maxima Climate Control Questions/Problems

Current milage: 30K

I see two potential problems and would like to know if anyone else is having the same:

(1) Heating Temperature:
Occasionally, temp is tepid despite setting it up high (ex. 80F)

(2) Ventilation Mode:
On the main LCD, the indication - arrow signage tends to switch by its own (when Manual mode, NOT 'Auto' mode) - ex. floor, front, top, etc. Probably 20~30 min. apart or even farther - the symptom happens in very irregular intervals..

I'd appreciate any feedbacks.. Thanks!!

Comments

  • kadskads Posts: 27
    Is this a common problem with 2005 maxima, or just unique to mine?

    The automatic temperature control is nearly worthless, however, the dealer claims it is normal.

    1. Occasionally it locks on in heating or cooling and won't control. Have to shut it off to go back to normal operation

    2. It won't allow cooling compressor below 60F, so on sunny days I have to go to manual mode to get enough outdoor air in upper vents to be comfortable

    3. Cabin temperature is nowhere near setpoint. Had to set it at 80 on a 35F morning to be comfortable. 3 hours later, had it set down to 70 trying to cool the car in 60 ambient.

    Would appreciate any feedback on similar problems and fixes.

    Thanks

    Kads
  • nila2nila2 Posts: 1
    I have a 2006 Maxima with almost exactly the same problems and of course everything is fine when it is at the dealers. I have to turn mine to 80 to even feel warm. I live in Idaho and it does get rather cold! If others are having similar issues if they would post their replies and maybe we could convince someone there is a problem. I bought my Maxima new.
  • poto1xpoto1x Posts: 26
    Thanks for the info CC.

    We're in Dallas, and the AC is more of a problem here. I grew up in S Dak, and understand your concern with the lack of heat.

    Since posting I've had a new, serious issue where the compressor is locked out and can't defrost a fogged windshield.

    Took it back in a second time. Dealer turned on the AC in a 70 F shop ambient, recorded the discharge air temp and proclaimed it works fine. They did tell me it has a temperature lockout on the compressor, first time they said it was 35F, then it was 60F. I don't recommend the dealer, Bankston, after that (or their 2 unsuccessful attempts to fix one of the dash vent grilles).

    Dealer told me to call 1-800-nissan1 and complain. Warned me I'd get a foreign sounding person, but would eventually get to someone knowledgeable. Will be doing just that tomorrow.

    Will be intersted if you find any fixes, or some other folks respond with similar problems or fixes. I'd guess the Infinitis have the same problem.
  • "The automatic temperature control is nearly worthless, however, the dealer claims it is normal."

    This has been my opinion and actual observation of these ridiculous things ever since they became available in cars over 40 years ago. First of all, I've never understood their rationale--you still have to set a temperature, just as on a manual unit--I just do it by "what feels good" at the time. Also, they often wanted to run at whatever speed they chose, but I believe there is more speed control available now. Actually, automatic controls don't often have as much versatility as manual ones, either. They always seem to default to either "Fresh" or "Recirculate" on some pre-arranged scheme of their own choosing, where you can select these at will on the manual ones. I drove a top-line Altima (I know I'm in Maxima, but I think the systems are the same) with the Automatic unit which is standard on Maximas before buying my SE model--I couldn't find a way to simply allow air to come into the cabin with all the controls turned off and set to fresh if I wanted to as I can with the manual unit.
  • Maxima 2001 Anniversary edition: Is the climate control panel illuminated on this model? I got this used and am not sure if I have a bad bulb or this just isn't lit.

    Anyone know how to check & replace such a panel light?
  • Hi, new to this forum and maximas I have a 2005 and when you set climate control it will not cool unless you run the temp down to 61 degrees . if you set the temp at 74 it will drive you out with heat and dosent stop until you run it back down to 61 again. I understand there is a temp control sending probe under left part of dash has anyone ever replaced that or had problem with the control?
  • infanteinfante Posts: 1
    Hi I have the same problem with my maxima 2004 ,it doesn't cool unless I set 60 degrees in auto and just cool the lower blower , Did you fixed already your car could you please me what did you do to solve the problem Thanks a lot
  • I will pull the reciept tomorrow and if you send me your e mail address I will send you what was replaced and it works fine now.
  • patpat Posts: 10,421
    Why not post here what was replaced? Chances are you will help many others besides infante by sharing that info with us. :)
  • value911value911 Posts: 15
    All -- Anyone else having this problem. 2007 Maxima -- can't get the temp from the vent below 46, which is not very cold when I have other cars that get it down to 35-38 from the vent. I am going to end up trading this car if no solutions, as I have a 2004 Quest which has the same problem and it is way too hot in the summer time. Dealer say it is within specs.
  • I know this is an old post but could you let me know what was replaced on your maxima, my 2006 maxima has the same issues. Thanks
  • poto1xpoto1x Posts: 26
    Nissan never did fix the problem officially, however, it hasn't locked on in heating, and the lack of cooling at moderate outdoor temps seems to have eased up, it now cools after dialing down the temperature setting. I'm wondering if they updated the temp control software along the way without mentioning it?

    After 3 tries to fix, they finally replaced the dash louvers that kept sticking along with some other interior and exterior plastic parts that warped, lost their chrome finish, etc

    My fix for the problems--bought a Honda last month.
  • I have a similar problem with my Nissan Maxima 2002 where the AC doesn't go below 60F. If anyone resolved the issue or is aware of the solution please let me know... The problem began abruptly just a month after i bought the pre-owned vehicle. Thanks.
  • alexstorealexstore Posts: 264
    Does anyone know why Maxima Turn ON AC even in freezing temps when in auto? I constantly have to shut it off. It restarts itself after few min. Last year my AC pipe blew and I spent $120 finding the problem and replacing pipe and refrigerant
  • My 2006 Maxima would blow hot above 61° and cold below. I found in the manual how to run a self diagnosis on the ac. The problem on mine was the in-vehicle sensor which was unplugged. It is located on the panel under the steering wheel. We figured someone did some work on the car and had to remove the panel and just forgot to plug it back in.
  • Thank you for the response. I will surely look for the same over the weekend and provide a feedback on it,
    Thanks again.
  • Similar to what Cla240z said, my 2010 Maxima Sport SV either blows cold at 61 or hot at 62. If I turn on auto climate control at 61, it runs the blower on high and the car is an icebox. If i set it to 62, the blower runs on high always and its hot as hell.

    I brought my car in for service today and they couldn't fix it, said they have to talk more with Nissan Tech Support.

    Anyone else have this issue?
  • maxcarmaxcar Posts: 1
    I bought a new 2010 Maxima. I noticed that when I set the Air recirculation botton, the control automatically set A/C on. Is it how the system is setup that the only way to disable A/C is to set Fresh-Air In? In winter time, is it possible to set the "Air Recirculation" on without A/C to turn on?
    I am not sure if this is a defect or now.
    Thanks.
  • lavalle1lavalle1 Posts: 1
    I have a 2004 maxima, recently the ac unit stopped working. The unit is fully charged and when I turn the ac on it will cool for about 2 minutes and then shut off. the ac unit will go on for a few seconds and then shut off. I have been told the pressure sensor is bad, and then I find out there is no pressure senson on the maxima. Does anyone have a simular problem or have an idea what could be wrong. I have also beemn told the the evaporator or dryer could be bad. any help would be appreciated.

    Joe
  • My air condition blower only works at the highest setting which is 4. Unit will not blow at settings 1,2 and 3, Any thoughts?
  • The complete dashboard is dark along with the gear shifter letters. Sounds like a blown fuse?...Any thoughts?

    Rodranier
  • kfdmedkfdmed Posts: 130
    It works as designed.

    The only defect is in your brain.
  • I have a 2002 Maxima, the heat was working fine and then started blowing cold air. I change to defrost for a minute and then back to heat and the heat was hot again. 10 minutes later the same thing happened and I put it on defrost and that did the trick again.
    My electric has cut out a few times in recent weeks - only for a second or 2.
    Twice the car stalled, once it did not.
    I would have to think these are related problems.
    Any suggestions? My battery is old but the car starts fine, I doubt this would matter.
    Thanks
  • mikel61mikel61 Posts: 1
    I have the same problem and I just got back from dealer. The problem is the climate control module located near glove box. part cost around 95 to 100 dollars plus tax and installation. Takes a screw driver and about 5 minutes to install it..
  • I have a 2004 Nissan Maxima also and the other night my ac went out. That morning everything was working fine and later that night when I got into the car there was no heat, air, nor was it defrosting my windows & windshields. One person told me it may be my blower module but I'm not sure haven't had it checked out yet. When I go to turn it on, nothing comes out and it makes no sound. When u were having the problems with you ac was it anything similar to what I'm experiencing and if so what was the problem and what did you have to get to fix it....Thanks, I would appreciate the feedback
  • My ac does not seem to be cooling very well, i have to put it on 60 before it even begins to cool the car off and the same thing with the heater, it has to be on about 80. my car is still under warranty and i have taken it to the dealer 3 times. First time they found a leak and changed the compressor and the second time they changed what he called a "sling door" in the dash, which is still rattling like crazy. They said that the car will not get cold if it is cool outside or some crap like that. is anyone else having this problem?
  • rjaeschkerjaeschke Posts: 1
    I shut off the inside airvent on the passenger sid eof my 2004 Maxima, and now it will not open. Is there a way to pull it out and repair without pulling the entire dashboard out?
  • I have a 99 nissan maxima seems the air blows cold when it wants to I can run temp up and it gets hot when I run it down it doesnt get cold cool but not cold. Freon is good compressor is running I even replaced the dash control still same problen any Ideas??
  • Thank you so much to guide me where the problem was!! MY a/c auto climate control was working fine. I brought my car in to get an auto-start installed in my 2006 Maxima. When I got the car back, my climate control was acting just as described (only got cold when the temp was set at 61 degrees and blew hot air when the temperature was set 62 and above). The fans blew full blast in both modes. So, going off of what was posted by Cla240z, I took off the plastic panel under the steering wheel (there are only 2 screws (one under the fuse panel door and the other on the lower right of the panel)). On the back bottom right of the plastic panel there is a sensor that had nothing connected to it. But dangling from under the dash were a hose looking thing and a wire with a plug on it it. Both the hose and plug went directly into sensor on the plastic panel. I started my car, and the climate control works again! woo hoo!! Thanks again.
  • maxima90maxima90 Posts: 1
    Hi,

    I have nissan maxima 2012 SV and its really a wonderful car. It smooth in acceleration and runs great.

    The only issue (might not be) i have with this car is its sluggish when i turn on A/C at any speed. I normally use A/C at 75 degrees auto when i drive. Is there a best approach to run the A/C when i drive please advise...
Sign In or Register to comment.