Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Navigator Electrical Problems

1235»

Comments

  • You need to clean out your cal vent. Mine was full of pine needles, and when it rained, it would back up into the car. I also had problems with my locks, but sprayed them with a lubricant, and they work fine now.
  • kyfdxkyfdx Posts: 28,056
    You need to clean out your cowl vent.

    fixed it.. ;)

    MODERATOR
    Prices Paid, Lease Questions, SUVs

  • swm1swm1 Posts: 1
    I have a 1999 navigator 2wd with the old style 5.4 engine. The battery light came on. The truck ran fine for a couple of days and then died on my wife when pulling into our drive. The battery was completely dead. i figure it was the altenator so I took it off and carried to autozone for testing. The altenator passed on the tester. I have now charged the battery and will reinstall the altenator when I get home today. The Serpentine belt looked good and felt tight when I took the alt. off. I did get a new belt and will put it on when I put the alt. back on today. If the alt. and the battery is good, and the belt is not slipping where should I look next. :confuse:
  • jkopplinjkopplin Posts: 1
    im having the same exact prob. with my 98 navigator somtimes it charges and somtimes it doesnt but it has a brand new alternator on it and it tests fine ive called ford dealers and they say its because i dont have a ford alternator on it but all shops i talk to say it doesnt matter. have you figured it out yet ? thanks
  • debutler1debutler1 Posts: 2
    I work with search and rescue dogs and I need the inside light to go off after a short time even with my doors or tailgate open...how can I do that? It's a 98 navigator and at one time it worked like that but something or someone has changed. I need the lights off but the tailgate open. Also the running lights on the running board. There are times when my tailgate is open for hours so the dogs get the air they need....I really need help on this one I've read the mannual and haven't gotten anywhere with it.
  • shanie1shanie1 Posts: 1
    the same thing is happing to my 2003 I have a question what is a Prndl error no park assist ? did you find help? what can I do?
  • debutler1debutler1 Posts: 2
    I haven't heard anything about how to fix the problem sure would like to know how to make the interior lights go off after awhile while the back is open.
  • Read the Navigator No Start Questions sub-forum. go from post number 18 and onward. it discusses the GEM Module Fuse block relay issue. There is an issue with the fuse box in this year that causes a relay to overheat due to the issue.
  • Good morning! I own a 2003 Lincoln Navigator. It's raining here in Connecticut :) My "truck" just started leaking on the inside~both sides~Front~Appears to be coming from the screws on the handles that help you pull yourself up into the vehichle, if u use those :), or The roof rack, eye am not sure~Just wanted to let you know about this AND is there a fix for this? I have always had GREAT customer service with Ford/Lincoln. I would never buy anything else but a Ford/Lincoln. Thank you in advance~I'll check back later~
  • I have an '04 Navigator. For almost 3 years, it has had a problem. That problem is now very bad.

    When I try to start it, all that I can hear is a click from some device behind the glovebox. If I try to start it enough times, it will eventually start. Sometimes, I try for literally 10 minutes, with pauses in between the times I try to start it.

    I turn the key to engage the starter, and it clicks. This sounds exactly the same as if I try to start the car with the shifter in D. If I try enough times, it will eventually start. However, I have recently noticed that just prior to the very few times that it does start, there is a bit louder click that occurs in almost the same location of the click that occurs when it does not start. This "bit louder" click occurs only a fraction of a second prior to the starter engaging, and it then it runs great.

    I have taken it to multiple people, it IS DEFINITELY NOT the battery, or a battery connection. Sometimes, a PRNDL error occurs, but not always. It is very intermitent, and is really getting to me. I took it to a Ford dealership a couple months ago, and they were "pretty sure" it was a junction box. However, I have had one person after another lately tell me they knew what it was, and then that is not the case.

    Does anyone have any ideas, or any troubleshooting I can do to narrow this down??? It is a great vehicle, but this is becoming a huge hassle. This problem used to occur only from about May-September (high humidity here in Indiana), but it is still acting up into October this year, so it is getting progressively worse.

    SOMEONE PLEASE HELP!!!
  • Sounds like an ignition switch where you put your key into or your neutral start switch. Good luck
  • Have to take of battery gnd cable? Happened yesterday. disconnected battery-went back out two hours later connected and parkinfg lights came on again. disconnected.
    Next day in evening-connected battery-no lights on. Drove car got dark out turned lights on came back home turned car off. Parking lights remained on. disconnected battery. Rained the other night.

    Any thoughts or ideas would be aprreciated! or what be even better if a navigator electrical expert could tell me exactly what the problem is. module. fuse. gem.switch
  • If the cowl drain in front of the windshield gets filled with debree, rain water stands in there and backs up into the electrical relays. You need to clean this out and it should help your problem. I had the same thing happen to me.
  • Ok here is the update.
    1.) Removed the headlight switch -let it hang by connectors.
    2.) Started navigator; turned headlights on.
    3.) Unplugged diimer switch-result headlights stayed on
    4.) Unplugged headlights switch-headlights went OUT!
    5.) Plugged dimmer switch back in- headlighhts still out
    6.) Plugged headlights in headlights ON!
    7.) Ordered new headlight switch with dimmer and autolamp
    (actually bought a used one on ebay for $25)

    note: While the headlight switch/dimmer/autolamp are all unplugged the dash lights turn on when the car is started. I cannot find which fuse shuts off the dashboard lights where the speedometer is and all that stuff.

    The battery was drained because I did not take the gnd cable off the battery, even though the head light switch assembly has been removed.

    Pretty puzzling.
  • How much mileage can a 2003 Lincoln navigator take.. mine is at 164k.. and were in 2011
  • wilfrwilfr Posts: 4
    Hi Kathleen, we have a 2006 Navi Ultimate. Like driving it fine, lots of issues though !!! Had a lot covered under warranty. We now have just 50,000 miles on it and are out of Ford warranty and had "LEAKING" PROBLEMS !!!
    To address your situation, have the "drain ports" for your sunroof blown out with compressed air. Most likely, as in our case, they are plugged with needles or leaves and road dirt, we even had water come out of the DVD player on the ceiling. However, that was not the worst !!! We had multiple leaks around the top of the "Firewall", so much so that the lower part of the door opening frame was full of water !!! Carpets totally soaked and water running around the computer modules inside the right foot well compartment, passenger side.
    We had everything taken apart in a body shop. They found lots of areas that had absolutely "NO" !!! sealant on it, including cable grommets. Sadly enough, It cost us $1,300.00 to have this done !!!! To have this happen to a 5 year old "TOP OF THE LINE LUXURY" vehicle is totally unexceptable !!! I will be writing to Lincoln about this, Not good for their name.
    Anyway, good luck with your truck in every respect. Hope I helped you out.

    Cheers, Wilf
  • I own a 2003 Lincoln navigator which i ve had parked for 5-6 years. The issue I am having is that the dash board doesn't light up. The gauges at one point did illuminate (red) but not the dash board (Back round) . Also the entire truck has lost air in the suspension and is sitting on the ground. I was told by a service repair facility (gas station) that there is a bad sensor that is not keeping the system raised. Lastly, the A/C stopped working. No cold air would come out but heat is okay. I had the system recharged and this did nothing.

    My questions are:

    Is the compressor the issue with the A/C?

    Is there a bad sensor of some sort and what is the part number?

    Do I need to replace the dash board or should it be re built?

    And are these common issues with these vehicles?

    I welcome any and all input..

    S. Blackmon
  • Not sure if we have related problems but my suspension keeps dropping during cooler weather which is a relay switch I believe since compressor was already replaced, now air is not working which I had a mechanic tell me the freon all drained out and have a bad pump so I just had more freon added and different repair place said pump was fine. Now it was raining today and sounded like something was shorting out under the steering wheel(sounded like something was frying until I pulled over and turned off blinker) while driving. But also noticed last week odometer light keeps going on and off and lights were dimmed inside when taking truck out of garage. That may have been due to automatic lights turning on. Have you found solutions?
  • If the a/c turns on but doesn't blow cold...common problem for navs...there is a door that switches back n forth between hot n cold depending on what you are using...but the motor that drives it usually breaks the door not sure if it's too powerful but it's most likely the problem...there is a tutorial on YouTube on how to fix it but if you are not to handy I would suggest getting it fixed by a professional...in the case of your suspension there is a ride height sensor (don't know part number but u can Google search u t)which controls how high or low ur suspension will sit...does the compressor still come on to try n raise the truck? Not to sure about the dashboard...but it could be as simple as a blown fuse these navigators are very trIcky and sensitive...I've had a lot of these problems on my 99 but I've fixed them all through this forum...any other question feel free n ask n I'll do my best to answer
  • Definitely need to check the fuses in the kick panel under the dash on driver side if you are having electrical problems when it's rainng something is getting wet...same problem I had...if Itis is the case use an air compressor to blow the water out of the fuse box underneath the dash replace any bad fuses and check the seal around the windshield...I bought some clear silicone sealant put around the windshield n problem solved...this was after replacing many fuses and my starter so dont wait it can cause big problems
  • j_p_j_p_ Posts: 1
    I purchased a 2001 Navigator about a year ago from a used car dealer. Over this past summer I started having issues with it starting. After trying different things like the starter solenoid on firewall, new battery ect. ect. the problem still exists, though I have narrowed things down a bit. To get it to start I have to tap the side of the brake pedal a bit with my foot while having the key turned all the way forward. Usually after a couple taps, sometimes after a lot, the Navigator starts up. I can of course start it from the solenoid on the firewall with a screwdriver instantly but it is a pain popping the hood, grabbing screwdriver and touching the solenoid posts which bypasses most everything and goes straight to starter.

    My gf currently drives it and she can't kick the brake pedal very hard with her foot so now I have a rubber mallet in the middle console for her to hit the brake pedal with. This is becoming a pain and I would love to finally fix the problem, has anyone come across this issue and/or know the permanent fix for it?

    Thank you in advance for the help.
  • My radio is on but no key in the ignition. We had some snow and water was inside the car under the fuse box. I had a service man come out and dry under the dash and check the fuses, everything looks fine but there is a sizzle sounds and the radio and some dash lights stays on. Any suggestions?
  • dondonrh1dondonrh1 Posts: 1
    Recently had water leak caused by drain plugged from sunroof! Flooded front completely . All kinds of weird problems after that. Now after a week of drying out everything works ecept for A/C and air suspension! Checked all fuses I could find. Need help!
  • 2003 Lincoln Navigator:
    The battery drains overnight. I measure 340mA current draw with ammeter in series with battery cable, everything off, doors shut.
    About 2/3 of this current draw is from Fuse # 102: "Ignition Switch Power".
    The other approximately 100mA is from the Instrument Cluster, its own self.
    So...
    1) Are these current draws normal or abnormal?
    2) Are these current draws large enough to drain down my battery?
    3) Why is my battery draining down?
  • i have the same problem if i find out the problem i will let you now
1235»
Sign In or Register to comment.