Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Acura Integra Engine Questions

2456

Comments

  • zainjzainj Posts: 2
    Thanks bro
  • its your fuel injectoin relay under driver side dash
  • dlngpadlngpa Posts: 2
    I have a recently acquired '91 Integra (B18A1)with 5 speed transmission. I'd like to slow down the inital idle speed at cold startup. It seems to run at at 1,800 rpm for a couple of minutes each time I cold start it. Incidentally, I live on the central coast of CA so "cold" start means first start of the day even though the outside temperature is usually 55 degrees or so. The fuel delivery system probably has 286K miles on it as that's the odometer reading, altho the engine/transmission were replaced just prior to my purchase. The only manual adjustment I can locate is the brass idle screw at top of the throttle body and that doesn't seem to change anything much. I removed the air intake tube at the throttle body and sprayed the throttle plate with carb cleaner, that seemed to speed things up even more! Any input would be appreciated!
  • dlngpadlngpa Posts: 2
    After checking out the Haynes Manual a little further, I find reference to disconnecting the electrical connector at the Idle Air Valve before adjusting the idle air screw. Now I need to find out the proper way to disconnect that connector without breaking it in the process. I suspect it probably is done in a straight down fashion from the connector, but wonder if there isn't an unlatching process first. Any suggestions available?!
  • Hello all,

    I have always liked my friends GSR and a guy I work with has one he is selling. A 2000 GS-R for 5500. The only issue I have is that the car has 138k miles on it. I know the car is worth the money, but I am kind of leary about the miles. Can anyone help me with how long the VTEC engines last mileage-wise and what expenses I might take on given the cars age and miles??? Thanks in advance for any advice you all can give.
  • Hello, I put a generic fuel additive into my 88 acura integra yesterday and filled it up and drove about 1 mile, then parked for 24 hours. Today drove about 5 miles and it died at a stop light. Normally verrrry reliable and I attribute it to the additive..?? Any one else with experience with this? Ideas on where to start?

    Thanks for your time.
  • depending on what kind of additive you put into your car and whether or not you put it in before you filled up or after. If you put it in before you could be running on straight additive hence why your engine would just turn off with not enough combustion. if you added octane booster or something of the sort then you could have over heated your motor and burnt or welded your valves shut. best thing to do is disconect your fuel line at the intake and purge the system. then fill up with some regular gas and dont try additive again.
  • jt12jt12 Posts: 1
    If your rpms are going up slow till 3000 one of your pistons is not working: try basic spark plugs check it may just be a non firing piston. Happened to me on the freeway with my turboed sohc ek(piece of junk) well they came loose and the plugs were burnt so try that and goodluck because if not it may be something far more serious.
  • rabit1rabit1 Posts: 1
    98 gsr no spark good ignition module good coil got power to dizzy what do you think it could be a bad ignition or cam sensor thanks larry stone :lemon:
  • Well I know they are not the same type of cars but my friend Chewy (not his real name) has a 89 Honda Prelude Si and when he first got it, it had the same problem we cleaned the distributor, replaced the spark plugs, replaced the lines from the distributor to the spark plugs but it still wouldn't kick over because it wasn't getting any spark from the plugs, it was awhile ago but it was the coil in the distributor that was burnt out so if you replace it that should work no promises though ok
  • every now and then the fuel pump on my 90 integra doesnt prime when i turn on the ignition. i've replaced the pump, spark leads, plugs and all filters. wondering if it could be the main fuel relay or an old immobiliser.im stumped, any help would be much appreciated.
  • Click on the link on message #15 and then click on "overview". This will help you diagnose the main relay.
    Regards
    Corkscrew
  • does your integra not start sometimes when its hot or warm inside the car if so its the main relay,or its the coil they both dont cost much
  • i own a 89 integra 5 speed with a hole in the side of the block. i'm looking at a 95 integra(auto) b18 engine to replace it with. i work for a import(vw )shop & ive done many engine changes/swaps ect . over 20 exp. i just want to know from the guys who do acura's all the time.whats the best bang for the buck engine you would replace the old lump with. & what im getting into as far as engine mounts,sensors,wiring harness,computer ect. what all am i gonna need to take from the donor car. & will the flywheel off the 1.6 fit the b18 ? or should i just put the stock engine back in it & call it good. any advise will greatly appreciated. thank you.
  • I have a '90 Integra hatchback that can not sustain a consistent idle. It revs from 25000-35000 and back down constantly. I have adjusted the idle screw many times and replaced the coolant hose that was leaking when i purchased the car...any suggestions anyone??
  • I hear a popping noise when i drive but once i reach above 25 mph it turns into a grinding noise but i don't know what it is i was wondering if anyone could help me out i have a 95 teggie se could anyone help me figure out what the hell that noise is because i can't figure it out
  • I have had this problem in my 1991 GS and now a 1990 LS. I do get the "check engine" light on at time, usually on a warm day after the car has been running for awhile as well as cold days when the engine is warmed up. :confuse:

    I have not tried changing the relay, but I have found that the butterfly valve that is on the end of the throttle cable is the area of problem, atleast it seems that way for mine. It always restarts after tweaking this valve. My mech cleaned the mechanism and that solve it for a few days, but then the issue came back again.

    I have found that moving the throttle valve cable or depressing the valve in front will sometime solve the issue. I have pictures and can explain better if one is interested.

    I have never had the problem when first starting up from over night or after sitting more than 30 mins. Just once warmed or after stop and starts. Always though at the most in inconvenient times!!!

    I love the 1990-1992 Integras, looking to get another in the near future. May have found one with one 56k miles. I get excellent gas mileage and low cost for insurance! I just wish Acura would go back to the liftback version!

    I can explain in more detail and send pics. Leave a message and will contact via email with pics :)
  • I own a 96 Integra GSR and i had the same exact problem with mine but it turned out only to be my ecu fuse. Maybe you should check that out first before assuming its a bigger problem like i did and wasted the money to take it to some one.
  • Ok i have a integra and i bought it with a JR supercharger already on it. When i test drove it, the car did amazing. But after like 2 months the bottom alternator bolt came out and now none of the holes line up right. I called Revline (the place that put in the supercharger), and they said that it never fit to begin with and the guy just said to make it work. Well now i cant get it to work and have my alternator line up right with all the other pulleys. Im guessing it may be the wrong bracket but they said it was the one that came with the integra supercahrger. So i was wondering if it could be the wrong alternator or my bracket is bent. But also there is so much torque and power going to my alternator it is sheering off bolt i shove through the holes to make the alternator stay so i can at least drive it around town without the belt falling off. Any one have any idea what the problem could be? thanks a lot for the help.
  • I have asked several owners and mechanics how long the engines in particular and the cars in general last and was told about 200,000 miles. At present I have a 98 Integra LS (not a VTEC engine) that within the next few weeks will have 300K miles; therefore if my experience is any indication, you should be able to drive an additional 50-75K miles on the one you are considering

    As for the expenses that may occur (and this is not all-inclusive) those that relate to the engine and related components include the radiator (had to replace mine 2x), the timing belt (normal upkeep), and the emission control devices. Other expenses may include the wheel bearings ( I will need those shortly), power window mechanisms and the A/C system.
Sign In or Register to comment.