Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Sedona Electrical Problems

135

Comments

  • I have owned my 06 sedona for 1 year and have had to replace the battery once and the headlights at least 4 times! One goes out right after the other. It is very annoying and a waste of money. Did you ever find anything out rcorcoran?
  • l1029l1029 Posts: 1
    We also have had problems with our lights on our 2006 Sedona. It has only been a problem on the left front. We have replaced the headlight 2 times and the turning light 3 times! Right now the turning signal works when it wants too...I keep telling the dealer to check the electrical but they don't...we have had another minivan for 10 years and have never had to replace a light on it. I'd be interested if anyone else has had these problems.
  • jirkajirka Posts: 15
    The problem was a faulty battery. Some cells were bad, so they sometimes worked perfectly and sometimes not at all. The hardest problem was to replicate it in front of a dealer. If I knew it was the battery, I would just buy a new one, forget about warranty, and save myself all the trips to the dealer.
  • bmottbmott Posts: 1
    Hi David...I have the exact same problem. Started around 80K miles. Same symptoms. No problem since Thanksgiving and the problem started again last Wednesday when I was traveliing. Got a hotel for the night and it started the next morning fine. Got it to a KIA Dealer. Could not demonstrate the problem. Left it with them and they concluded I needed a new battery....$137 and 100 miles later, had the same problem. Left it overnight and it started up again this morning...Have made several stops and so far it still starts up. Mine is also an 06.

    Were you ever able to determine what the cause was...What the fix is? All I can think of is to get the ingition assembly where you put the key in replaced. I don;t have any faith in the KIA dealership but based on your posting and the postings on headlight replacements, they should know of these problems.

    Let me know what you know...I'd appreciate it...

    Thanks, Bob
  • Hello,

    I have a 2004 Kia Sedona. It has 65K miles on it. I've had this lingering problem with it that completely happens at random instances.

    My van exhibits electrical short(s) type of behavior. Prior to turning on the van, once you have the door open, you typically see the lights in the Van on, and once you put the key in the ignition, you start hearing the beep/tone sound. When the Van is having the problem, no lights will be on, nor the tone sound... as soon as I try to turn it over, the sometimes hear a brief click and then dead silence.

    I pulled out the battery, alternator, starter and they all tested fine. The battery connections are fastened securely. The weird thing is, I bought one of those computer diagnostic tools to see if any DTC's would be triggered from the problem, but it didn't see anything. Although quite odd, but the Computer Diagnostic tool was able to get the van running!!!

    Not every time, but some times, when the van is not working or having this problem, I hooked up this diagnostic tool and it ran a scan. Once the scan has started, it redistributed the power to the entire van somehow and it would turn on. Computer reset of some sort???

    The problem 1st occurred about 6 months ago. It was down a week until the the diagnostic computer got it running... it went down again about a week later, and I did the same thing and it fired right back up. It ran great for months until now. Same problem, however, I have not been able to replicate the solution.

    Any advise would be greatly appreciated.

    Thanks in advance.
  • jirkajirka Posts: 15
    Can't it be the same problem as I had (see post #63)? Sometimes the battery ran perfectly, sometimes I had the same behaviour as you say. When the battery worked all battery measurements were ">link titlefine. Personally, I would first spend those $50 and change the battery and see if it helps.
  • I have replaced headlights in my Kia Sedona 6 times in 3 years. Not to mention brake lights, turn lights and license plate lights. Does anyone know what the problem is? The dealer is refusing to do anything about it and at 50 bucks a headlight they are making a killing. Any suggestions. It is an 2006 Kia Sedona with 60xxxx miles.
  • Same car, same problem. This really should be a warranty issue since it constantly happens.
    I think I read somewhere that Sorentos have a similar issue and there is a new headlight harness with a resistor that allows less power to the headlights, dimming them but making them last longer.
    I've gotten really good at swapping out bulbs, a 15 minute job. I buy the cheap ones now at around 15 bucks each.
  • I'm having the same problem. Lots of replaced headlights, turn signals, and license plate bulbs. I've also started having problems with the wiring harness for my trailer hitch. The fuses have recently started to blow, which is a real pain. Mine's a 2006. Anyone else have trailer electrical problems??
  • kiasedona1kiasedona1 Posts: 1
    I bought a 2004 kia Sedona a few months ago and had it shipped to the Bahamas. The first week I used the vehicle I experienced what appeared to be an electrical problem. I turn the ignition the car will not say anything.....engine does not rool over or anything. The shift lever is in park. The dashboard light is dim and the power windows operate rather sluggishly. I press the brake pedal and the dash lights up...the engine starts. I have been using the vehicle for about 5 months and this problem has occurred at least six times. Also, I am experiencing a problem where on occasions I tried to stsrt the vehicle and get a clicking sound as if the battery is weak. I fiddle with the ignition switch trying to get it to start and eventually after 15 to 30 minutes it stsrts. I bought a brand new battery and these issues are still present. I think I got stiffed by the car dealer...... that car had that problem when I bought it. The car was bought from Metro Ford located on 7 Avenue Miami Florida.

    I would certainly appreciate any suggestion you might have with regard to getting this issue rectified. I have taken the vehicle to several auto electrical shops and have explained the problem to them and they all seem clueless at to what the problem might be. I am reluctant to have someone mess with the vehicle who don't know what they are doing.

    Please email me at daddy_boyboy@yahoo.com

    Regards,
    Fred
  • 11b33t11b33t Posts: 51
    Are you leaving the headlights in the 'auto' position (sensor turns on when dark / off in daytime) all the time? If you do, it could be power surging to the lights whenever you start the car...
  • preventladypreventlady Posts: 1
    edited June 2010
    We too are having electrical issues with our 06 Kia. Right front turn signal blowing out as well as the headlight. Replaced the headlight and turn signal once about a year ago. Then it went out again within a couple of months. Husband took out the light bulb noticed that it wasn't blown and put it back in and it worked fine for a couple of weeks, then went out again. At the same time the DVD player fuse blew. Called the local dealer and spent about 45 minutes on the phone with them since the book doesn't tell where the DVD player fuse is located... they couldn't find it either. My husband eventually found it by trial and error.

    We've also had problems with the overhead directional compass and aver MPG readings. Compass would say S no matter what direction we were headed and aver. MPG's would reset each time we turned the vehicle off. Dealer said the "recallibrated the system" to fix it. But this also took two trips because at first they said "no this is they way Kia's are designed." (Pence Kia, Richmond, V)

    Then the turn signal went out again during the same week. So, we took it in to the dealer. They said... replace the bulb. We said... it's not the bulb. They said... humm the bulb seems to be working fine now, we can't find the issue. Following week, turn signal not working again.. dealer finally agrees to fix the encasement of the bulb thinking this will fix it. I'm telling them it is a bigger issue given the other fuses that blow - this is at 58,600 miles. (Pearson Kia, Richmond, VA)

    Well, now at 60,150 miles we notice that every time we put on the brakes the air conditioner fan goes to about 50% power and the headlights dim. Two days at the dealer and "we can't replicate the problem." We pick it up tonight, don't even leave the lot and problem continues, get the mechanic in the car with us for a test ride around their lot and low and behold, "oh, there's the problem." Well, now it's not covered under warranty, to which I remind them that they told me if there were more problems with the "electrical system" and it wasn't far out of warranty they said they would fix it since they couldn't find the underlying problem at 58,600 miles. (Pearson Kia, Richmond, VA)

    Also, dead battery issue. Replaced the battery once last year, as we thought we left the interior lights on by accident (our old van had an auto shut off). Last weekend the battery went out three separate times, but strange enough the lights and radio worked. After driving it for an hour the battery didn't have any more problems.

    I'm hoping somebody gets to the bottom of this with Kia, as it is clearly a trend and a problem with the vehicle.
  • I changed a driver's side low beam bulb on my 2002 Sedona and now the van won't idle. When I take the bulb out and leave the bulb housing open, there's no problem; yet when I close the bulb housing, the problem returns. Does anyone have any idea what might be wrong?
  • sammy52sammy52 Posts: 2
    I want to ask you do you found the fuse for the DVD.
  • sammy52sammy52 Posts: 2
    where do you found the dvd fuse?
  • My dvd player works sometimes and other times you have to pull the screen backwards and forwards. I think that it is a short. I haven't looked for a fuse.
  • I unfortunately own an '07 Sedona. I have had my left front turn signal bulb replaced twice since April. When it was at the dealer last week I told them it needed to be replaced again at no cost b/c they had just replaced it in April. They could not duplicate the problem (after hours of keeping my van for this one particular problem). So when I went to pick up my van I asked again if they were able to find the problem. They said no. While reinstalling my girls' car seats, I started the van so I could cool it down before we left. I turned on the left turn signal and let it run until it started malfunctioning again (5-10 minutes at the most). It would stop working and then begin working again, back and forth. I went back inside and told the Service Employee. I told him about it working and then not working. (He observed this.) I asked him to PLEASE check the fuse and the electrical system for it to work on and off like that. His response was, "it's not electrical. Bulbs will work on and off like that when they're about to burn out completely. There's not anything electrical to check about the bulb and we can't check it electronically." Needless to say the bulb was changed and the last time I drove it, it was still working fine. But I find it to be a bunch of "bull" that there isn't something electrical going on and that they cannot detect it by hooking it up to a computer in their service department.
  • Yesterday my tachometer stopped working and the check engine lite came on.
    Does anyone know if this is a electrical problem or nor
  • I just replaced my left turn signal for the 2nd time in 3 months. I have replaced this year alone both turn signals twice. My 2006 has also had to have both fog lights replaced and both headlights. I don't understand it. Once in awhile my airbag light comes on but then it goes out. I love my van but sheez these light bulbs and electrical issues are nuts.
  • i have a 2003 kia sedona w 100,000 plus miles. lately it starts when it wants to. If i open the doors and place the key in the ignition it will light everything as suppose to, then on occasions if turn the ignition to start it will go completely dead and will stay like that for a while then after playing with the parking brake and the shift gear it will come back on on start like nothing ever happenned any suggestions
  • I'm beginning to hate this van, and for many of the reasons already posted in this forum.

    We bought it used but it was still under original warranty. The turn signal went out just before 60,000 miles. We had to pay for the bulb and the labor, but it worked after that. Earlier in the fall, the front dash power point and cigarette lighter stopped working, so I had the dealer look into that as well. They fixed it and told me that I had to watch the plugs for my kids' DS to be sure they only went into the power point, and not the lighter. We do not smoke and we have not used the power point since it was fixed. It is no longer working again. A week after having the turn signal replaced, a headlamp also went. My husband replaced that and saved us the labor bill. About a month ago, the kids and I were driving along and the radio station changed on its own. I thought it was odd, but changed it back, and it did it a couple more times. About three weeks ago, the same turn signal stopped functioning again. I called the dealer yesterday and set up an appointment for tomorrow to look into the signal problem. This morning the van won't start at all-just ticks-like an alternator is bad. There is definitely something wrong with this vehicle and its electrical system. The dealer says they can't promise the repairs will be covered, but I will fight for my rights as a consumer because something is truly wrong with this vehicle. I'm beginning to question its safety-what if something shorts out and causes a fire...I'll keep y'all posted. :sick:
  • Hi, did you ever find a resolution to this problem? We have a 2006 Sedona with just under 80,000 miles and is just had this problem with no start. I put the key in and the lights came on as usual, then turned the key and nothing. Lights went out, did not come back on. Battery still has power, the accessory plug I use for the GPS still powers the garmin. No exterior lights, power sliding doors don't work, power tailgate does not work. SO, checked all fuses, all good. Kia service depts are currently closed. Timing is everything. I am going to go and move the parking brake and gear shift and kick the tires. Maybe light a candle and make offerings to the Great Spirit. :mad: :confuse:
  • Bob,

    Did you and David ever figure this out? I have a 2006 Kia Sedona EX (75,000 mi) that does the same thing. Turn the key and all indicator lights come on but engine does not turn over. Have to keep turning key over and over until it eventually starts. Sometimes have to wait 10-15 min. and then will start. Happens 4-5 times a month just out of the blue. Dealer had me replace battery--same problem. Then they replaced IPM (instrument panel module) twice--same problem. They can never replicate the problem in the shop because it is so intermittent. Dealer says there is little they can do unless they can replicate with diagnostic computer hooked up (what are the odds??). They are now corresponding (by email) with Kia Techline to see if maybe it is the ignition switch but are saying it is unlikely. Please let me know if you have any advice.
    Thanks,
    Mike
  • We have had this 2006 Sedona for a few years now and have had to replace the headlights and turn signals 4 times in the last 5 months. I looked at a burned out bulb and noticed what looked like scorch marks on the connector. I brought it to a mechanic friend of mine who I trust and he let me know that if the connections are not tight then the bulb can burn out and leave those marks. The lights work each time I replace the bulb but only for a few weeks. Anyone else getting this problem too?
  • nakamoto2nakamoto2 Posts: 1
    edited May 2011
    Did you ever find a solution to this? My 2006 Kia Sedona is doing this as well as numerous other things.
  • psaddpsadd Posts: 1
    I have a 2004 Sedona 2.9 diesel LE. Every time the battery is removed the ECU-ETACS fails and cannot be revived. I'm about to go to my 8th. Kia's suggestion is change the ETACS but there's clearly an underlying problem with the car. Has anyone had this problem and found the root cause? Auto-electrician quoting £500 just to diagnose the problem and, as I've seen many Sedonas on other fora with the same problem, i feel sure someone, somewhere must have an idea what causes this.
  • lameridethlamerideth Posts: 3
    I did not find a solution, as a matter of fact, I sued Kia using a federal lemon law and got a settlement. It wasnt much, but still helped with the expense of changing lights all the time. Unfortunately(?), my Kia was totalled. AND the air bags failed.
  • have a 2002 sedona the alt fried now door lock button doesnt work and after couple days sitting idle battery is drained
  • jackj59jackj59 Posts: 5
    Ditto on the Turn Signals. And a couple of times - like right now - I take the assembly out and it works! Put it back in... yeah, you get the picture. I also bent the metal tongue that contacts the bulb out, and that did seem to help for awhile. Actually, I think that was the other bulb, so maybe haven't done it yet on the right. So, possibly that's the fix. Definitely worth a try. And since they still work intermittently, it seems quite logical (which is how I came up with the idea the last time). I'll post back if it doesn't fix it.
    Also, I'm far from an expert, but I've only heard about not touching the bulb with your hands if it's a halogen bulb. Is it an issue with non-halogen, too?
  • darren632darren632 Posts: 2
    edited July 2011
    i have a kia sedona 2003 i have just had the engine rebuild as it stoped running and will not start again and now the engine been rebuilt its still not starting. it trnes one time and thats it, its like its killed the batters off. can anyone help me out by this.

    thank you darren :sick: :confuse:
Sign In or Register to comment.