Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Concorde Electrical Issues

Need help soon!!!! I am having an eletrical problem or a very pissed off ghost has decided to haunt my car and I need to figure it out one way or another. Does anyone know what could be the problem with my 2000 Concorde LXI?

It started with the lights inside the car blinking on and off, next it went to the dash lights blinking on and off (i.e. the air bag, oil lights, etc...) after that my stereo would switch from the CD player to the radio in mid-song, and later my air conditioner would come on, even though the compressor is broken. I have taken it to two electrical mechanics and neither has identified the problem.

I have spent a small fortune on this car already (i.e. fixing the rear windows that still wont come down, fixing the rear brake lights that would not go off and several other general maintenance repairs) and I just would like to know what the problem is (short of selling the car and buying a new one that I cannot afford), so that I can have it repaired once and for all.
«1

Comments

  • Karen_CMKaren_CM Posts: 5,024
    If another Concorde owner with the same problem shows up, you might want to post over in the generic Electronic Gremlins topic in Maintenance & Repair.

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

  • I am having the same exact issues with my LHS! Since February I've spent $2,100 getting extensive work done under the hood and the car is still giving me problems. The engine was replaced a year ago. In Feb. there was a fire under the hood. Got new battery and wiring. It stopped in March and wouldn't turn over, had it towed, got some other crap replaced, and in June had the alternator and a new battery installed...told it has to be the electrical/wiring. The head lights are very dim, can't be seen. The dashboard lights are nonexistant and I can't get rid of the check engine light. I want no NEED to know if there is an inexpensive way to get this taken care of without having to get a new car, it just can't be done right now.
  • bliesveldbliesveld Posts: 1
    fire under the hood

    You may want to check the recalls for the car, my 1997 Concorde had a recall for leaky fuel rails... I went to check the oil one day and I had gas all over the inside of the engine... If I hadn't found it there would have been a huge fire.

    This might have been what happened to you.
  • WOW - I've got the exact issue you describe on my 2000 Concorde LX! Interior lights blinking on and off randomly to the extent that the battery died on Monday, boosted car and it has worked(?) OK since. Not sure if you're still following this thread but have you had any success getting this problem fixed?
  • mondo3mondo3 Posts: 2
    Hi I have a 98 concorde, after the 2.7 threw up I opted for a 3.5, was lucky to find a t-boned 300 donor,, that was 30,000 miles ago, car has run and still runs like a raped ape, but a month or so ago, my check engine light came on.. it was 1698 which is bad ground or no communication tween ecm and tcm, car runs and shifts fine.. My tach, speedo and temp guage sometimes work and sometimes not.. it has nothing to do with bumps.. I can be sitting idling in driveway, tach and temp will be working, then drop to zero, after a few minutes they will come back, while driving sometimes the speedo and tach will seem to get stuck,, and then increase to correct speed,, my cruise works fine when the guages are working, and it does not quit when the guages do.. But I cannot set cruise if the guages are off.. Also when the guages aren't working, my gas guage is off..Anybody have any clues!!!???
  • ellenballellenball Posts: 2
    No, I haven't had any success to date. The lights have stopped blinking for now, but now my cruise control light comes on at random. I am taking my car to the dealership this week and discussing the problem with them. I hope I can get a solution soon. I will keep you posted.
  • Thanks for the update. I took mine to a repair shop and they hooked it up to their diagnostic system but of coarse when I actually want the problem to occur it won't and therefore the system did not provide any direction on what the problem could be. So basically I'm no further ahead.
  • mondo3mondo3 Posts: 2
    Hi, I posted a message about our 98 concorde with electrical gremlins.. My solution came when one day the car would not start.. It turns out that one of the 2 bolts that afix the 2 red wires to the positive terminal was stripped, it would snug, but was not tight enough for a good connection,, I also had flashing lights, trunk light would not work, intermittent guages, shift indicator light would not work.. I had this at a repair shop only for them to tell me that the computer was fried.. Maybe this is not your problem,, but it would be a very cheap fix.. PS pull up the airbox,, it is a million times easier than pulling off the wheel and inner fender,, good luck.
  • Hello, I had a 1990 chrysler new yorker 5th ave several years ago with the exact problem. It turned out to be the ignition switch. I had to laugh when I read about the ghosts because that is exactly what it seemed like!

    Also, it wound up having to have a new motor put into it & luckily I had purchased an extended warranty so it was covered. I now have a 1998 chrysler concorde lxi that has 56,000 miles & the body is in showroom condition & it too needs a new motor. (of course the warranty expired @ 50K miles)I was told by the service tech that a new motor costs $5K which is more than the car is worth since it is 9 years old. Chrysler was no help when I contacted them. I googled chryser complaints & there were several web sites with customer complaints with the same problems on concordes & 300C's, some still new & under warranty & chrysler also refused to honor those warranties saying it was the customers fault. Go to www.mychryslersucks.com as it is the one with the most complaints. I know I will never own another chrysler!!
    Thanks for letting me vent
  • i will be driving and with lights,radio,heater or air on wipers and all at once i loose transmission gears so i pull over shut car off and restart and car works great what could be the promblem does not do it all the time
  • yesterday i finally figured out how to change my brake pads on a 97 concorde lx..and since then the parking brake like near my speedometer turns off and then on for a while and then just randomly turns off....could i have done something to the brakes? they work fine to me...bled them and everything....

    one thing it could possibly be is that the resevoir for the brake fluid isnt all the way filled up...but when i take the cap off it still has some in it. would i need to fill it up to the max line possibly?

    also does the same thing with my brights near the speedometer...ever since i changed the bulb the light stays on all the time (which i did that maybe 3-4 months ago)
  • ok....well...a couple of problems.. when i changed my front brake pads on my 97 concorde, all went semi smooth (minus the 4 hours it took me to figure out how to do it), all except for the screws and bolts on my car. for instance the two screws that hold the caliper to the rotor are severely rusted (pretty much all of them on the car are) and i really need to change my back pads (diskbrakes) but one of the screws that i mention will not come off for the life of me. also it is basically stripped almost.

    so ya basically my question is that ive tried wd40 and that didnt work..not even the right size socket or regular wrench could do the trick, so what should i do if i didnt want to take it to the shop to have them do it? (keep in mind that im limited on tools, so if i need to get someone with a compressor socket, lemme know)
    thanks
  • Hey everyone! I have a 2000 chrysler concorde and recently the battery light has come on... Swaped out the altenator and checked the battery and it still registers a code. I wanted to know is there a fused link anywhere that would keep the car from keeping a charge? Please help me with this if you have any information!
  • I have had and on going problem of my Concorde not starting in the cold. The engine cranks but does not kick over, but when the weather warms up it starts. I had the cam sensor and the crank sensor replaced 6 months ago. It ran fine until a month ago, took it to the dealer and it started for them so they couldn't tell me what happened.
  • r2d8r2d8 Posts: 2
    I have a 1998 Chrysler Concorde with a little over 100,000 original miles on the engine. A couple of months ago, while driving, the gas gauge needle dropped down causing the ding sound that the tank is empty but the tank is not empty. I filled the tank up full, the needle did not drop again until the tank got down to 3/4 tank, then it continued drop off and on until the needle showed it was below 1/2 tank. I took it to the garage, the mechanic stated it did not do this strange thing for him but he cleaned the connectors in the wiring under the front driver's seat. It was a couple of days after that when that it started dropping again. What is this? what needs to be fixed? is something to do with the float? float sensor? Everyone is scratching their heads on this one.
  • I replaced my rack & pinion & in the process I broke the clockspring. I replaced the clockspring & now the air bag light is on. My cruise control works & all lights. Is there a way get rid of the air bag light without using a scanner?
  • I had the same problem with the interior lights flashing, then I couldn't turn them off, so I took out all the bulbs so my battery wouldn't be drained. Yesterday I was driving and all of a sudden lost power, including my steering. I coasted to the side of the road. My headlights and dashboard still worked. (I do have plenty of gas in tank.) I waited a minute or so, then restarted the car. I drove it home but now I don't know what to do. Why would the car lose power while driving? This is the worst piece of crap car I have ever owned! :lemon: :mad:
  • I lost air bags, power windows and heater control. I think it may be related to the ignition switch? the key on engine running fuse works, but no power in the fuse box for the above mentioned components. Any ideas?
  • You are certainly not the only one. Chrysler Concorde wiring is terrible. It breaks down after 8-10 years and then cold and moisture effects it. I have a 1994 Concorde and it only will not start when the temp drops below 50. I have seen a few other posts stating this same problem. When I turn the key to the on position the fule needle does not rise and I notice that is because the fuel pump is not making a "whirring" sound and turning on. It is a problem within the wires somewhere between the power source and the fuel pump under the trunk lining. Strange connection between these two. I am in Florida and it has been cold so now I wait for it to warm up enough so I can go to work. Yesterday it was about 10am. CRAZY! Did you find out an answer to this similiar issue? I have not seen anything posted. Let me know and I will let you know. Thanks.
  • I have a 1994 Concorde and it only will not start when the temp drops below 50. I have seen a few other posts stating this same problem. When I turn the key to the on position the fule needle does not rise and I notice that is because the fuel pump is not making a "whirring" sound and turning on. It is a problem within the wires somewhere between the power source and the fuel pump under the trunk lining. Strange connection between these two. As soon as it is around 45-50 degrees the fuel pump will turn on and the car works fine. Any ideas where in the wiring this is being caused??? Thanks.
  • bluelisabluelisa Posts: 1
    Help, My 2001 chrysler concorde gas gauge flashes empty to full, empty to full as I am driving. Sent it to the shop, and they could not reproduce it, Then the car started to jerk, it cost me 500$ for some kind of "timing device" and the car still flashes empty full while I am driving with a full tank... HELP can't afford more repairs, but want to know, is this safe? Can I fix this myself with some sort of fuse? Desperately seeking answers
  • long story short, no fuel pressure, found half of fuses without voltage until I wiggle the steering wheel. Then the gages, blower motor, fuel pump start working until the steering wheel (column) is moved again and looses voltage. what could be causing this?
  • jacek3jacek3 Posts: 2
    I have a second hand 96 Concorde LXi - bought 3.5 years ago from retired couple at 46 000 km, right now it has 78 000 km - mechanically sound but electrically rather a lemon.

    To make the story not too long - right now the overhead console temperature display behaves not very well. Most of the time it takes about 10 min. of driving before it "catches up" to the outside temperature. But some time it's even more weird - today in the underground garage it was showing 17 C, almost immediately after leaving garage jumped to 20 C though I felt that it still was NOT right (it felt more like around 25 C). Than after about another 10 min. of driving it jumped to 24 C (which is about right). The Automatic Temperature Control was OFF all the time.

    I have observed this strange behavior for about 6 past months. What worries me most is that ATS sensor also probably "talks" to the main computer (via Body Control Module, BCM) that controls A/C and once A/C gets turned on the things may really get out of hand.

    Any clues what causes the problem ? Is it the ATM or BCM ? I have replaced the main computer (Power Control Module) about 3 years ago.
  • jacek3jacek3 Posts: 2
    Just to continue on my previous message - the Automatic Temperature Control unit does NOT show any error codes (after setting temperature to 75 F and pushing and holding pressed 3 control buttons till the display flashes)
  • descottdescott Posts: 1
    Hi I am having the same exact problem. It started two day ago. Did you find
    our what is causing the problem? What did you do to fix it?
  • I am having gremlins as well on my 1998 concorde. Three months ago my lights would not go off exterior and interior, ran the battery down. Recharged it..then my door locks pop up and down the entire time motor is running. Now battery light comes on and dings. I have no idea whats up. I am changing battery today. Any thoughts?
  • r2d8r2d8 Posts: 2
    I finally traded my 1998 Chrysler Concorde in on another vehicle. All the gauges began to mal function, I had no reading on temp, speedometer, odometer, gas, or RPM. I tried to get the problem fixed but the problem could not be found without putting the car in the shop for several days so the tech could try to locate the problem, which, as you know, could amount to several hundreds of dollars, and I was told there was no guarantee they could find the problem.
    In the odometer window the code noBus was visible. I was told all that meant was there was a loose connection between the two computers. Grimlins? you bet because when the gauges were working the check engine light would stay on, when they were not working, all the dash lights would be on as well.
    I dumped that grimlin infested car for good.
  • Well I had my battery changed..door locks stopped popping FOR NOW. but in the past they periodically stopped for a few days only to return later.. Wish me luck.
  • I am having the sane problem as a couple others...I have a 2002 Concorde & the airbag light comes on sometimes, when it does the turn signals don't work, the windows won't roll up or down & the heater blower won't run. I haven't read anyone that actually posted a fix for this. I can move or wiggle the key & it stops for a while, but returns unexpectidly. I replaced the ignition tumbler & that didn't fix it!

    Anyone ever fix this problem?????

    Please someone HELP?
    This is driving me nuts!

    thanx - Bob
  • palhal1palhal1 Posts: 2
    I have a '99 Concorde LXi I bought new. It now has only 54,000 miles on it. About a month ago the engine stalled. Restarted and stalled again. Towed to local garage. Diagnosed as Crankshaft Positoning Sensor and replaced. 5 days later it stalled again. Local garage couldn't solve problem. Hat it towed to a dealer. It has been there for 2 weeks. They say a short is causing the ASD Relay to trip which can cause the engine to stall. They opened the wiring harness but said the short was not pulling enough ohms to cause the relay to trip. A couple of days age they mentioned a 'Intake Plenum', whatever that is. I am pulling my hair.
«1
Sign In or Register to comment.