Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suzuki XL-7 Electrical Problems

2»

Comments

  • steve445steve445 Posts: 1
    I have a 2007 xl7. 6 months after purchasing it, the dealership closed down. The closeset one is over 1 hour away. It is not even a dealership, just the service department that is not open when you go. We are have trouble with our brake lights now. They will not come on when brake is applied. The lights come on when setting security system and the top light works. But no luck on the brake lights. Has anyone out there had the same issue and how was it fixed. Thanks.
  • I have a 2007 XL7 and I have had this problem. Car kept going dead and would jump it off and go get the battery tested, always the same results; Battery tested fine/working and the Alternator was fine/working. Finally, before taking a long road trip paid almost $200 dollars for the battery and installation at Pep Boys(which was the cheapest carrier of the battery) and car has not yet went dead. I have however noticed the same thing with the voltage readings while driving ranging from the low 12 volts to 14.2 volts. I am confused with that. I have also had the same problem with the A/C controls not working. One time the a/c was cold went to turn up the temp and wouldn't work, tried turning the blower from auto to a lower blower speed and wouldn't work and then finally tried changing where the air would blow till I could pull over and restart the car and it wouldn't work. Just ended up suffering thru. Then on another occasion got in the car turned it on and the A/C started blowing out Max Heat from the vents and everything worked but the temp selector, I just don't know what to do. I have never had a problem with my radio yet. I am now having problems with my Service Air Bad light coming on, My Service traction control light and Service stability control light coming on this have triggered my ABS light to come on. Not sure if the ABS light is something separate also messed up or if its tied to one of the other lights coming on. All these lights coming on have occurred within a two day period(today and yesterday). I have noticed that the lights come on when cranking the car for the first time of the day, and after sitting for a while, but when I went driving for a good distance and get out somewhere and then return and crank the car that these lights are no longer on. I am over this car. The air bag problem has been since buying the car, and now with these new problems I dont know what to do anymore. This has been the most expensive car to maintain between the ridiculously/continuously worsening fuel economy and premature repairs for a car of its age/mileage. Can anyone shed a little light on my problem and send it my way??
  • I have a 2007 XL7 and I have this problem. Car kept going dead and would jump it off and go get the battery tested, always the same results; Battery tested fine/working and the Alternator was fine/working. Finally, before taking a long road trip paid almost $200 dollars for the battery and installation at Pep Boys(which was the cheapest carrier of the battery) and car has not yet went dead. I have however noticed the same thing with the voltage readings while driving ranging from the low 12 volts to 14.2 volts. I am confused with that. I have also had the same problem with the A/C controls not working. One time the a/c was cold went to turn up the temp and wouldn't work, tried turning the blower from auto to a lower blower speed and wouldn't work and then finally tried changing where the air would blow till I could pull over and restart the car and it wouldn't work. Just ended up suffering thru. Then on another occasion got in the car turned it on and the A/C started blowing out Max Heat from the vents and everything worked but the temp selector, I just don't know what to do. I have never had a problem with my radio yet. I am now having problems with my Service Air Bad light coming on, My Service traction control light and Service stability control light coming on this have triggered my ABS light to come on. Not sure if the ABS light is something seperate also messed up or if its tied to one of the other lights coming on. All these lights coming on have occured within a two day period(today and yesterday). I have noticed that the lights come on when cranking the car for the first time of the day, and after sitting for a while, but when I went driving for a good distance and get out somewhere and then return and crank the car that these lights are no longer on. I am over this car. The air bag problem has been since buying the car, and now with these new problems I dont know what to do anymore. This has been the most expensive car to maintain between the ridiculously/continuously worsening fuel economy and premature repairs for a car of its age/mileage. Can anyone shed a little light on my problem and send it my way??
  • : I own a 2008 Suzuki XL7 Premium AWD. I bought it new. The tighten gas cap light came on repeatedly starting at 40,000 miles. I took it to the dealer and he "just tightened the cap" and told me that if it did it again, I would have to purchase another gas cap. The notification appeared frequently after that, so I purchased another cap (from Schuck's) and they reset the memory for me. That lasted all of 1 day, so I called the dealer. He is some 50 miles away and told me to bring the car back in. I made an appointment and they told me they would have to keep the car causing me to rent another vehicle to get back home. After the second day, I called. They told me there must be a vacuum leak somewhere...but, had not found the actual source. On the fourth day, I went to pick up my car and they said it was "fixed". Two days later the same thing happened. Now, I just drive the car with the engine light on and am thinking about trading the car in. The dealer tells me that there are several waranty issues and it might or might not be a covered item to fix. I am certainly perplexed. Does anyone have any ideas? I really hate to purchase another car at this time. I have 45,000 miles on my XL7 and other than that no real problems at all. Got 23 mph on my last road trip, so that is acceptable, but I'm quite worried about that engine light staying on and the "tighten gas cap" warning that comes and goes while I'm driving......
  • 2bconcerned2bconcerned Posts: 2
    edited January 2013
    Daughter has the 2007 XL-7 and has now put the third battery in within the past 5 years. She bought the vehicle new. Has had everything tested, alternator, starter, etc., and nothing found. Any answers would be appreciated as it is still under warranty. Thanks
  • I realize this is late, but I seem to be having more frequent issues with my XL-7 that I have had since new in 2007. I find that if I have an issue with the heating system, I pull the fuse for that system, wait 20 seconds, then replace the fuse, and everything works fine again. I have done this for the following systems in this car. The radio, the hvac system, stability control, the ABS system, and the airbag system. This fix usually lasts about a year, and they all seem to happen right about the same time. Usually when one fails, it kills my battery, then I jump the car, look at what errors I have like stability control, or airbags, pull that fuse, replace it after 20 seconds, and the car runs normally for another several months.... till the battery dies again for no reason. then it is another system that needs to be reset usually. It is no fun at all. Now that I have finished paying it off, it is time for a different model, probably older, as I hate :mad: all this new computerized stuff, it is the issue.
  • pms2pms2 Posts: 1
    Just replace the light bulb.This is an easy fix.
2»
Sign In or Register to comment.