Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Frontier Transmission Questions

2»

Comments

  • thomfthomf Posts: 2
    I have a 99 Frontier, 4x4 king cab, V6, 5 speed. In March I had the clutch replaced. Over the last month and a half the gear shift has started popping out of gear when I am sitting at an idle. It does not do this when I am driving. My shop says it might be the synchro gear but would have to drop the tranny to check it out. Oh boy. Is it possible for something else (less expensive) to be worn or out of adjustment, like something in the shifter assembly or something? Thanks
  • asaasa Posts: 359
    I have a (non-Nissan) book that shows these usual culprits - Worn Shift Fork, Broken Spring, Synchros.
  • Hi all.
    I have an 03 supercharged 4wd frontier with an auto tranny and just shy of 100k miles. As of late, it seems that whenever I am driving through town at a fairly even speed of 35-40mph, when I press or let up on the gas pedal, the tranny shifts up or down harder than usual. I don't notice it at any other speed ranges, and it doesn't throw me to the floor or anything,.. just enough that I notice. I did notice that my tranny may have a small leak underneath, but I check my fluids constantly and it's clear and pink and I've never had to add any.
    I don't have a reliable mechanic here in this small town, so when I take it to the big city to have it worked on, I'd like to have an idea of what I'm talking about. I've had enough experiences with repair shops to know that they will often take advantage of me since I'm a girl.
    If anyone has any feedback, I'd sure appreciate it.
    thanks
  • thomfthomf Posts: 2
    Thanks very much for your reply. I will check those out.
  • bcjaxbcjax Posts: 1
    I have a 2003 Frontier with about 90,000 miles on it. I have recently notice that when I push in on the clutch I am getting sort of a humming noise. When I release the clutch the sound goes away. The transmission seems to be running fine, I am having no problem with shifting. Also, it moslty happens in the morning after it has been sitting over night. Any thoughts?
  • Hi,

    New to the forum and have a question. I have a 2007 Frontier 4x4 Auto King Cab and last winter experienced a blood chilling whine coming from who know's where. It was so pierecing that we had to stop the truck as I thought a bearing had locked up or something. This noise has only happened twice and both on cold days -25 C to -30 C. The first time it happened I had been driving for a hour already. The noise would get louder slightly the faster I drove but would completely go away below 70 k/hr or ~45 mph. I took it into the dealership and they said they could not reproduce the noise and then said they found some obscure bullitin and something. I do not have the invoice on hand to let you know what they replaced, but I was sceptacle anyways. It happened again a few weeks later on a cold day but I was only a 1/4 mile from my destination (work). I pulled in and it has not repeated itself. Winter is fast approaching and I am getting concerned again. Any ideas out there would be appreciated. We have a old time mechanic at work and he has a idea that a pump is being starved at cold temps.

    Thxs
  • I had the exact same experience in my '05 Frontier KC 4X4 auto coming home from an out of town visit on Christmas Eve. It was -22 deg C (-8 F) and I'd been driving about an hour. Suddenly a loud, intense whine started as I was driving along, it almost sounded like the stereo was feeding back. I shut all the electronics off, and it seemed like it was coming from below the shifter on the centre console. It would get louder as I accelerated and quit altogether below 80 km/h (45 mph). Every time I sped up, it came back, scared the bejesus out of my wife. No variation in pitch as I adjusted throttle, it would just get louder or die away. Stopped and checked under and around the truck, everything seemed fine. Made it home, but whined the rest of the trip. Checked fluids today, and trans is full @ cold temp and looks fine. Also went for a drive today and no whine at any speed. Outside temp a bit warmer @ -12 C (10 F)

    If you have any followups to your pump starvation theory, let me know... it is unsettling to say the least.
  • huff70huff70 Posts: 1
    i bought a supposed 2000 frontier transmission from a salvage yard but im pretty sure it came out of a pathfinder. does anyone know if this will bolt up and work in my truck( 2000 frontier, 6 cyl, 2wd, 4door)? please let me know asap cause if not im gonna go back to that salvage yard with a gun and get my money back..
  • whats up dude, i bought my 09 frontier last year early january and since ive had that same problem. i hate this transmission so much, ive tried to explain to friends and family and even the dealership and no one knew what the hell i was talking about. i even sent an email to nissan about this and they never answered back, bastards. well at least im not the only one with this problem, i guess we are screwed with this situation.let me know if there is away to fix this before i go crazy. laters, take care.
  • I didn't drive my truck for a few months, will try to check with local nissan dealer about ECU software upgrade, I suspect it's a software issue.

    -albertr
  • What model is your Frontier? Mine is Pro-X 4x4 with towing package and larger tires - 265/R16. Maybe large tires attribute to less than usual torque at low RPM? The other thing is my engine is not broken in yet, has just about 2K miles on it.

    Still, I think shifting ratios needs to be re-programmed for more aggressive down-shifting. I'm gonna call Nissan and talk to their customer care department.

    -albertr
  • zniffinzzniffinz Posts: 1
    I've got the same thing in my 03 Frontier. Did you ever find out the cause? At first I thought release bearing, but it really sounds more like vibration in the tranny. Also, sometimes I do not hear it with clutch depressed but as soon as I put shifter in 1st position it starts. Always disappears when clutch is released.
  • hinsonk2hinsonk2 Posts: 1
    I have an 04' crew cab xe frontier and its an automatic but i think they transmission just shot. and one have any ideas why it wont rev past 3000 rpms? if you try and give it more gas it just winds out like its in neutral
  • donselldonsell Posts: 27
    i'm reading in this forum about people with 05 and 06 Frontiers running into problems with the radiator leaking into the transmission causing an obvious problem.

    Has this been corrected in new vehicles?
  • I also have a similar issue with my '03 Desert Runner. It has a manual transmission and has always whined in the cold. I replaced the transmission fluid after I hit 100K miles a few months ago and the issue has not gone away.

    Have you had any issues getting into fourth gear without a grind? The dealer said it was a synchronizer issue that would cost me a new transmission ($3500). For a truck that hasn't given me any other problems, this sounded a bit extreme.
  • I have a similar problem, it only does it once after starting from cold engine, close to the first time it shifts, there is a metal to metal clank, again the dealer says this is normal for my truck, its [non-permissible content removed], they just don't know what is causing it.
  • robertrolandrobertroland Posts: 2
    edited February 2013
    I have a new 2012 Frontier 4x4 SL automatic now 5,000 miles. I noticed right away that when Ai would accelerate and/or trying to pass it will not up shift and the RPM's depending on my speed have gone up to 6,000 before coming out and only when it is ready. So after 4 months of getting the run around finally got Nissan Corp and they seemed to care..wrong. Our Nissan dealer went BK right after we bought it so had to drive 5 hours to the nearest dealer. Before test driving it we were told its the nature of the beast. So i took the tech for a spin, at 55 I stepped on it to pass another vehicle and it stuck at 6000 rpms at 90mph and still had not upshifted. So i let up on the gas and the tech said that is why it won;t shift you have to keep it down until the computer gets to the right speed?? Well at 100 it finally shifted the tach on the red line. Now this will also happen at lower speeds the tach sticks and the engine races until it decides to shift.

    So I ask to drive another 2012 and it does the same thing. I drive back another 5 hours home call Nissan they do not as usual get right back with me, of course because they talk to the dealer first, and I get a once very nice person who has transformed herself into a cold now uninterested person who says.. this is what the specs are and we will note it.

    We are heart sick, traded in our beautiful never a problem Murano as the warranty was up for a truck as we are now on a ranch and have 6 years to drive a car that will not shift. We live in logging country and have to pass and it will not upshift to go faster when passing and a scary thing when a semi with logs is coming at you while trying to pass. Not to say what its doing to our engine and transmission.

    If anyone has any suggestions on what we can do to get this truck to shift please reply. i am 73 and have driven almost every car and truck out there and never had one that will not upshift most by just letting up on the gas.. drove a rental Ford Focus and no problem at all ...

    Nissan said also until there are more complaints or failures they can do nothing. A death maybe or two and even them my faith in Nissan is gone. THANK YOU in advance for any help you can give us...

    And just to note , I asked for this in writing and was told since it was a corporate thing they had to do some more stuff and they would mail it to me, have not got it yet.
  • You are so right there is no power you have to hit a lower gear to go faster and how does that save you gas? Not only is this happening on my new 2013 I cannoit upshift at 60 mph until the RPMs hit 5,000 got to 90mph 6000 rpms with the Nissan mechanic and it would not shift and he said I had to keep accelerating until it does??? We have to pass with logging trucks and fear we are going to die trying to do so as it will not go faster and the rpms are racing at the red line. Nissan corp said there is nothing wrong and closed our case.

    This is a huge problem. And people need to start posting here and contacting Nissan corp as the dealers are not going to admit it either.
  • hey fellow frontier owner u are NOT ALONE !!!! i also have a 2012 i bought literally off the delivery truck with only 5 miles on it. i also just noticed the shifting problem when i last went up my mountian house. i have around 9000 on my dash and at first thought maybe i was alone on this strange problem. i was told at the dealer that it was because i installed an aftermarket muffer and intake box that that was the cause but being an engine biulder for years and owning and modifying well over 100+ car just of my own i knew that was bs. how are u makeing out with nissan corp? my truck only does the shift problem above 50 it seems. u can email me back directly if you like im courious about this issue.
  • not sure how to email you but nothing has changed. They refuse to address the problem say there is no problem. Until someone is killed it will stay that way. They were nice at corp until the Nissan dealer said there was not problem after sending me 300 miles away as ours went BK,

    Now there is another problem. When backing up and putting back in drive it does not want to engage 10 percent of the time. The tranny on this truck is defective just a matter of time before it really fails for good. Nissan is not immune all car companies are bottom feeders. Thanks for writing as more and more people need to be aware and hope this keeps getting out there. Sorry for you issue.. be careful. Bob
2»
Sign In or Register to comment.