Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Safari/Astro Noises, Rattles, and Squeaks

bodreybodrey Posts: 7
edited March 15 in GMC
Just bought a '92 Safari and there's a noticeable "clunk" sound/vibration. It doesn't happen constantly; once I'm up to cruising speed it seems to go away and the van drives fine. However, I notice it especially when I'm pulling away from a stop (right after I take my foot off the brake). It sounds/feels driveline-related. I read in another thread that it might be caused by the transmission but I wanted to get some other opinions first. Is it something that Safaris are known for (design problem) or that I need to worry about? Is it going to damage other components by driving it this way?

Comments

  • I had the same problem with a '95 Astro. Would clunk after stopping - no clunk while driving. Mine turned out to be brake related. It was a combination of rusted brake drums, a build-up of brake dust and weak springs on the brake shoes.
  • Well, it could be brake-related because I had them looked at during the safety. When I first brought it home there was a lot of vibration in the steering wheel when I applied the brakes. The mechanic said it was due to a build-up of rust on the drums. I guess it hadn't been driven in a while. Maybe the springs are weak too. As long as it's nothing major I don't care. I've spent enough money just getting it on the road as it is...
  • I suspect the noise you hear is anytime after starting the engine and after stopping the vehicle.
    Try removing the drive shaft and applying grease to the tranny spline and shaft yoke. You will likely find that clunk goes away. At least for a year or two!

    Have fun.

    Tony
  • 95z2895z28 Posts: 1
    I have been trying to pinpoint a heavy vibration / shudder issue in my 1994 Astro.

    I can only describe what happens as equal to running across pavement cuts that warn of a upcoming stop sign. It only affects the passenger side and literally shakes the entire drive train.

    This only happens when you are applying gas, most apparent on any type of uphill grade. When the gas pedal is released it stops.

    Any thoughts on this ?

    Thanks in advance
    95z28
  • tripower1tripower1 Posts: 25
    I've got a 96 Safari and love it. The passed six months has been hard on her and she needed a lot of work. I had a rumbling sound comming from the rear and when I stake off from a stop I'd get a clunk from the rear, this wouldn't happen all the time only after a hard stop. I took it to Mceleven dealership and they couldn't find any thing wrong, taking it to this dealer was a mistake. I replaced the rear leafs because they were out of spec's, that wasn't it. I drove it from SC to MI for a family visit and had my brother drive it, who's a transmission pro, he said my differential side bearings were shot and if it didn't get fixed asap I'd be replace the complete rearend. He did the work for me and charged me just for parts, 110 buck and he replace a bad axle seal, now the rear is as quiet as a baby sleeping. I just replaced the rear brakes and hope that salves my clunk sound. During the brake repair found that same seal was leaking again. Axle looks good, any ideas why the seal would still be leaking?
  • tripower1tripower1 Posts: 25
    Lisen to your rear end when your driving at a steady speed, do you here any noise coming from it like a rumble or grinding sound, give it gas and let off the gas and see if the sound changes, if so have a good trans shop inspect the differential,axle and pinion bearings. If that's not if check your brakes, could be a broken brake shoe pin.
    Keep us informed of what you find out.
  • wildrescuewildrescue Posts: 3
    I have a 1993 GMC Safari with 216000 miles but she runs strong. Today she started with an ear piercing whistle. We took off the serpentine belt to eliminate all front engine componants. We also checked all vacuume lines we could find. We then removed one injector at a time. The whistle is still there. Sometimes with engine fluxuation there is change in pitch of scream/whistle and every once in a while it stops all together but returns soon.
    Any idea's of where to turn to next? It is very loud and I am concerned that it will strand me some place. Has anyone had this? All help welcomed
  • bodreybodrey Posts: 7
    I just had my mechanic look into the problem. He has owned two Safaris so he knows his way around these vans pretty good. He said the clunking is definitely coming from the rear end. Apparently, there is a design flaw in the pre-95 Astro/Safari differential housings that causes them to wear which causes the gear assembly inside to shift/play up and down. He says his Safari does the same thing and that until it starts whining/grinding I shouldn't be overly concerned about it. I trust his judgement so for now I'm going to let sleeping dogs lie.
  • jane7042jane7042 Posts: 1
    I have the same problem. I have a 2002 AWD Safari with 65000 miles on it. Previously owned a AWD Astro. On the Safari I have a very sharp whistle coming from the drivers side starting at about 35 mph. I also had it on the Astro but it just went away. However on the Safari it persist. When I open the window it is louder. I moved the mirror housing in and it quit, put it back and it started again. I then put my hand over the gaps in the housing and it stopped. I then put some black duct tape over the gaps on the back side of the mirror housing to stop the wind from going in and causing the whistle. Now it is not as loud but still persist and I can not find out where it is coming from. It does not do it consistently but has a very high pitch and is very irritating. It seems to happen more when I am driving into a head wind.
    Can anyone help.
  • wildrescuewildrescue Posts: 3
    The whistle/scream happens even when the van is parked. It seems to go away when the engine is under power. When I step on the gas it goes away, but when I take my foot off the gas it returns. Still have no idea what this is. It isn't the wind because if it was it wouldn't do it sitting in the garage just running.
    No performance problems, it is running great just sound annoying. When the dog house is off the noise is deafening so as long as the radio can be turned up and up I guess until I find it we will be ok.
    Still if anyone has any other idea's that would be great.
    Thanks
This discussion has been closed.