Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Jimmy Transmission Problems

1998 Jimmy After truck warms up shifts hard between 1st and 2nd gears. any ideas
«134

Comments

  • I recently pulled the tranny, had it repaired, and put it back in. The ABS light stays on,the engine light stay on, the speedo doesn't work, and it doesn't shift into 3rd, only 1st and 2nd. At first it would only stay in 1st, i topped up to oil and then it went into 2nd. Does the computer have to be reset in any way? If anyone has any ideas I would really appreciate it. Thanks
  • hi this is brian i have a 2000 gmc jimmy i had the same problem come to find out i had to replace the speed control sensor its located on the back of the trans u will see a wire that plugs in and the sensor screws out u change that and u will find out the abs light will go out and the serves light will also go out and speed o will start to work again hope i helped u out just to let u know they go all the time theres 3 of them on my truck so hope i helped u out later brian
  • Don't know if you got it fixed yet or not but i wanted to confirm another answer that was posted. I have a 01 Jimmy and I recently had my speedo go out, ABS light stay on, check engine light, parking brake light flashing and couldn't shift beyond second gear. I limped it to a repair shop and the computer code was the speed sensor. $143 later and the mechanic had it up and running again.
  • Yea I got it fixed now, thanks for replying. There was one plug that wasn't fully contacting and then they replaced a small plastic piece that bolts to the side of the tranny on the left lower side. I don't remember what it was exactly, some type of linkage was attached to it. There were 2 electrical plugs built in and one of them was broken.
  • Hello all, my name is Justin and i am from Michigan. I have a 97 4wd Jimmy. This started about almost a month ago. It was at first an every once and a while thing at the start but it seems as if it is pretty constant now. When the car is place in the Over Drive position, it does not seem to start in the 1st gear position. Possibly 3rd gear is where it starts. If you put the car in 1st gear, it runs in first gear and so on for the other gears. I just don't know what the problem is and i am hoping to get something done by myself without having to pay some guy hundreds of dollars...I do not think that it is mechanical because there has been no slippage or jerking while shifting. This seems to have started all of a sudden over the past month. Also, it seems like when you park the car, it thinks that it is in some sort of gear. I say this because I cannot get the key out of the ignition. I have had the ignition replaced about 2 years ago because I could not turn the key. I know that the car is in Park because I have tried to push it while off and have been unsuccessful, so I am pretty sure it is Park.....I could really use you folks wisdom...please do help.
  • dbldsdblds Posts: 1
    Hi My 94 Jimmy suddenly started dropping into neutral after running for a couple minutes. When engine is first started, it will go into drive and reverse but drops into neutral within a minute or so. Shut off engine and restart it, it again goes into gear then neutral. Anyone know what's causing this? It was running great with no transmission problems. Appreicate any help!
  • hi this is brian i have a 2000 gmc jimmy 4wd i would like to know if anyone may now how long it takes to change a tranny on my 2000 gmc jimmy 4wd i was told 9 hr it just seems really hi because i have change trans before and it was never that long if anyone knows please let me know email is foxracein_17@yahoo.com thanks brian
  • Like so many other people on this board, I am having transmission problems with my Jimmy.

    I have searched high and low to find the culprit to what is going on...

    Mine is a 1997 Jimmy 4x4. When it is cold outside, the transmission shift hard from 1-2 and takes quite awhile (as well as a low speed) to shift from 2-3-4.

    The RPM needle shakes violently back and forth thus preventing the vehicle to obtain speed.

    The vehicle WILL shift eventually, but this make going up a slight hill very slow and time consuming.

    However, when the vehicle is warm or the weather is even warm outside, the transmission shifts great and doesn't seem to hesitate at all.

    Could this be something as easy at the TPS, Ignition related, or perhaps bad plugs?

    Help me out here as I am growing tired with this vehicle.

    Thanks.
  • IF SOMEONE CAN HELP IT WOULD BE GREAT. MY JIMMY WILL GO INTO GEAR WHEN I FIRST START IT UP, BUT WHEN IT WARMS UP I GOT NOTHING. SO COULD IT BE THE TRANSFER CASE OR THE TRANS. ANY HELP WOULD BE THANKFUL.
  • fordfan_17fordfan_17 Posts: 175
    need just a little more info on your jimmy year is important and fluid condition. normally transfer case will not cause this problem as the t-case is basically a mechanical link converting power to the front driveline consisting of a chain and 2 sprockets and 2 shift forks 1 for 4 wheel drive and the other for high range low range and if your vehicle moves at all you can basically eliminate the t-case as being the problem
  • My95 jimmy auotmatic shift from 1st to 3rd gear skipping second .It does the same thing on down shift . It wont work manualy either ,what would be causing this to happen ? The transmisson was working ,it happen all at once.
  • hellcattthellcattt Posts: 3
    OK guys - bear with me, Im a girl, but not a mechanic and Ive got mechanical issues and need some great advice! Got a 2000 GMC Jimmy 4x4 automatic. Transmission felt like it was slipping or surging. My old mechanic checked it out and said it wasnt slipping, but he thought it wasnt shifting when it was supposed to. He said it was waiting too long to shift gears and would jump in and out of overdrive several times before locking in. He sent me to a transmission specialist who checked it with a computer and the code P1870 popped up. He said it was the torque converter and would charge $700 to replace it. Went to a new mechanic who said to try flushing out the transmission first (146,000 miles and was probably way past due). We tried that - didnt flush out the converter though - they said very little metal in the fluid, it worked great for 2 weeks. They also put some sealant in there that is supposed to seal any leaks. Two weeks later, the same surging occurred and it started shifting harder some, but it doesnt do it all the time. Some times it drive great, no problems. We tried pulling a pontoon boat with it and it doesnt surge then, but it did overheat - no coolant left in it but its disappearing with no apparent leaks. Not sure if the problems are related. Now the check engine light is on. I was planning on replacing the torque converter since that was what was told to me what was wrong with it, but after reading some of these posts on how something small and simple can cause major symptoms, Im hoping I wont have to drop that much money into fixing it, as Im on a budget now and was hoping someone could give me a better idea of what else to look for that may fix it before I spend all that money and my problem still may not be solved. Any help is appreciated : ) Thanks guys :) Cattt >^..^< :confuse:
  • Hi. I have a 1990 S15 4x4 Jimmy with a manual 5 speed transmission that went out. If I rock the car in 1st it makes cranky noises like some scraping a bar across gears.

    I love this truck! Mechanic says not worth fixing at 187k. I agree ($890) but, If i can find good used or rebuild for under 300 I'm going for it!

    What tranny or rebuild kit do I need? Will a 4 speed work? Are there any special tools I need for a rebuild?
  • mdega287mdega287 Posts: 1
    I got a 96 Jimmy 4.3L 4wD Auto, everytime I go on the highway after a good 45 mins my check engine light pops up,but everything checks out and when I stop my truck at a light or something and start to go my first gear roughly goes into second and jolts my truck then after I get rollin it runs smoothly but its just that first gear that sounds bad, but my Check engine light remains on for the whole trip and stays on for about a week then turns it self off. Can anyone tell me whats going on?
  • bwill1961bwill1961 Posts: 1
    there are lots of issues with these transmissions my 2000 jimmy trans failed about 140000 mi which coded p1870 trans slippage.. torque converter usely take care of the trouble but sometimes in the valve body you can have sticking piston.you can fix this without taking tranny out. by the time you pay for the parts and labor and might not fix trouble.. you can go on ebay an buy a rebuilt tranny for about 500 to 600 + shipping. that what i did my jimmy run great pulls hard shifts great. cost me around 800 dollars. but i am a mechanic done the work my self . it would cost around 2100 at a trans repair shop. hope this helps..
  • edge42edge42 Posts: 1
    I have a 99 GMC Jimmy that will just barely take off in drive (whining noise) but it will go just fine if you start out in 1st, shift manually to second then to drive. I changed the filter and fluid. The fluid wasn&#146;t burnt and very little debris in the pan. Still have the same problem! What&#146;s the most likely fix?
  • Got tired of no one being able to tell me for sure what was wrong with it before I dropped several hundred dollars into and the whole undercarriage was rusting away so I gave up on it and traded it in on a Toyota truck :)
    Thanks to everyone who tried to help :)
  • My Jimmy is hesitating when first taking off, only when engine is cold. And occasionally when cruise is on, the rpm's will surge up alittle. I have changed plugs and wires, put new fuel filter on, replaced egr valve, added some BG44K, and am waiting on a new cap and rotor in the mail. I am out of ideas of what is wrong. Any suggestions? Is it the tranny?
  • Well I put on my new cap and rotor and that didn't do squat. I took it in for a diag. test this morning and the "mechanic" said he didn't know since there was no check engine light on, so he couldn't check the codes. My next steps are to change coil, temperature sending unit, and change trans. filter. Please reply if you have any ideas.
  • ray63ray63 Posts: 1
    I have a 2000 GMC Jimmy. It started out with my Gas Temp RMP and Speedo guages not workin while driving. They would quit workin for like 10 secs then back to normal. Then it went to not workin and not being able to get my key out of the Ignition. When i cant get my key out of the ignition i would have to disconect the battery. When i would start my truck with the key stuck when i put it in to drive it would shift hard into 2nd gear. While driving it will only shift into 2nd gear and 3rd no overdrive. and usually after driving around 2 miles all the guages will start to work but it still wont shift properly. any help on this would be most welcome
«134
Sign In or Register to comment.