Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Envoy Electrical Problems

1235

Comments

  • Rooster22,

    I understand why you are frustrated. I see in your post that you are experiencing some concerns with your gauges - have you been in to a GM dealership for a diagnosis as of yet? Or have you already worked with Customer Assistance? We would be happy to follow up with you on this - please send us an email with more information on your situation.

    Best,
    Sarah
    GM Customer Service
  • After convincing the dealer to just keep my car until it acts up, I finally recieved a call 2 weeks later. The service manager stated that my car finally"broke!" What he meant was that it finally would not start. My 2003 Envoy has 82000 miles, I bought it brand new for $35000 cash, and it has been the biggest lemon since day 1. He asked why I had not been to the dealership in over 3 years and I told him I could not afford the labor. I have showed them every piece of paperwork with all the many repairs including 5 starters, 3 batteries, 2 ignition switches, fuel tank, tierods, shocks, etc! Crazy enough, they now tell me that the only thing testing bad is the starter! Really!!!!! 6 starters in a car with 82000 miles? My husband is looking for the schematics, as he knows that there is something in the wiring causing this car to act up. Any suggestions or similar problems? We did try contacting GMC.....what a joke! They wanted $729. for a new starter... needless to say, the car is back sitting in the driveway. I'm afraid to get stuck somewhere.
  • OK....so now I have spent $1745.87 on "repairs".....still have the starting problem...never has been resolved for more than a few days.
    can take up to 55 key turns before starter engages and engine starts......use to be related to outside temperture now it just does it whenever.....Now need to find out what electriacal circuit is common to the Air Bag and Seat Belt warning indicators on the insturment panel. This started two weeks ago. The air bag warning light and seat belt warning light stay on after starting vehicle. Fastening the seat belt has no effect on the warning light, just stays on fastened or not. Air bag has been checked and it is OK.
    I do believe this will be my last General Motors vehicle of ANYKIND......Customer Support has been NO help.
  • Well Jen, I hate to tell you this, but I have the biggest lemon in GMC history, I bought my new in 02, I have had the tranny replaced, the 4 wheel drive, tie rods, upper and lower, radio, mirrors,door locks, wheel bearing, air conditioner, rear hatch window and catalytic converter and last but not least is a water leak, everything was fixed because it was all under warranty but the water leak which I still have to this day. I am done with GM, never again will I buy another one, this auto has seen the shop more than any auto that I have own, I once told the dealer that the reason that I bought a new car is to stay away from repair shops and I was there so much that I should have my mail deliver there, any way I can't help you out with your problem but I would tell you to go on line and buy the starter, GM wants to much for them and if you look around you can get it for a third of the price, also I also had bad relation with GMC service about this auto, also with the dealer that I have been to, so now I do my own repairs. Try jcwhitney.com or partstrain or rockauto and there are more out there
  • My power seats, driver and passenger, no longer move in any direction. The heated seat feature works. I have changed the large aluminum 30 amp fuse/breaker, but to no avail.

    Any ideas?
  • :(
    I have a similar issue! sometimes the car's electrical shut down while driving...then right before i put to the side...it lights back up.

    The car will run perfectly fine, then when i go to lock it with the remote...the car wont lock...then when i go to start the car...it will start then bog...I am pretty sure it has something to do with the security system. If i do the 10 minute reset to my passlock key the car will start up again. What you do is put the key in...turn it two clicks...wait 10 minutes, the radio will turn on...and the car will start up...its such a waste of time...

    I took it to the mechanic last weekend told them the problem...they did a scan of the car for $150 to tell me NOTHING was wrong with it. bullsh!t. I am thinking of maybe getting remote start?

    What other ways can this be solved??

    //2003 Envoy
  • Was your mechanic with one of our dealerships? We're available to follow up on this appointment if you like! Please send us an email with more information (please include name, last 8 of your VIN and current mileage, and the name of your dealership).
    Regards,
    Sarah
    GM Customer Service
  • Hi I have an 07 Envoy Denali and I have a problem with my engine light being on. Took it to get a diagnostic check and the Throttle position sensor needs to be replaced. I have replaced my altenator and battery in 2010. Now my bags that lifts the truck struggle and does not work on a daily basis, my lights may not come on and the oil gauge light is on (and also dropped down to zero). Two years ago i replace the motor that controls the window that cost me around $500 bucks. If all these problems are common why haven't they did a recall on them. I mean is this why they don't make them anymore. I am strugglng what can I do, Its not in warranty and it seems like the motherboard going bad. What are my options?
    Please let me know...
  • j_engj_eng Posts: 9
    It is actually the windows power module that goes bad and must be reprogrammed. Unlike the old cars that simply had a switch and a motor protected by a fuse. My 2007 GMC Envoy's module melted since the 5 volt logic line doesn't go through a fuse. Most of the cost was covered by my extended warrantee $1,500 that I had purchased when I bought the vehicle. My issue is primarily with the design where the fuses didn't blow and where a simple failure of car window module can leave you stranded because it shuts off all the computers in the car!
    If I was in the remote area to ski/hunt/fish or between cities, this kind of total failure could have killed us.

    Also the GM's insurance coverage to provide the rental car is only after three days of repair so no rental coverage after the car was towed to get home or get back to the dealer or be able to get to work. If they have the car but are not working on it the days they have it don't count!

    The car smelt burnt rubber for a month and they will not get my auto-start working because it was not a GM install, even though it was in the car and working until the fire!!! They want to sell me another one and pay for the install.

    John G GMC Envoy 2007 72K miles,
  • j_engj_eng Posts: 9
    For those of you where the window stopped working but you were able to drive, You were lucky! My window module melted and shut off the whole car. I had to get towed. Most of the cost was covered by my extended warrantee $1,500 that I had purchased when I bought the vehicle. My issue is primarily with the design where the fuses didn't blow and where a simple failure of car window module can leave you stranded because it shuts off all the computers in the car!

    If I was in the remote area to ski/hunt/fish or between cities, this kind of total failure could have killed us.

    Also the GM's insurance coverage to provide the rental car is only after three days of repair so no rental coverage after the car was towed to get home or get back to the dealer or be able to get to work. If they have the car but are not working on it the days they have it don't count!

    The car smelt burnt rubber for a month and they will not get my auto-start working because it was not a GM install, even though it was in the car and working until the fire!!! They want to sell me another one and pay for the install.

    John G GMC Envoy 2007 72K miles,
  • I'm glad to hear that your extended warranty helped with the costs of this. It sounds as though the repair has been completed apart from your auto-start; how has everything been since then?

    Sarah
    GM Customer Service
  • knutterknutter Posts: 1
    I have a 04 envoy that is still going 60 miles in the stoped at the house,it has happend 3 or 4 times within the time that I have owned the truck. I replaced the gas tank in 08 ,a couple of lights and regular other normal things.Bought it in 07 with 41,700 and now has 65,550 if I had more driving time ???. In Oct. 11 I called coustmer service and they tell me to get test Feb. 12 took another trip and lo and behold cluster went wild stuck fuel gage sometime. I talked to a lady and said get a 100$ test so I did service man said that is was the cluster and GMc would not help out . I called again to another guy and said I wanted to talk with his boss.He said that he was regional manager SE.No help and wasn't resolved 65,550 Quality ????????Service man said they would send cluster back to have set at gm so who knows what cluster would be in the truck,another one from gmc and goes bad again???? You can go to many forams and the same thing. I do have all names, numbers and times. Video comming...Watch out Volt buyers
  • precoseprecose Posts: 1
    My wife and I bought this car in August and have had nothing but problems with this car since we got and every time we take it in they can't help us because the problems are intermittent. First off the headlights turn off in the middle of the night and even turning the car on and off doesn't work you just have to pull over and wait for them to decide to turn back on. CD Player overheats and turns off and also sometimes randomly ejects all CD's while your driving and not even touching it. The back speakers get a high pitch squeal in them and have to be turned off all the time because it's so annoying. The headlight washer fluid sprays randomly even with the car not on. I found this out when I was adding oil because it burns nearly all the oil in about 3,000 miles and has been taken to two different shops and they said that there aren't any leaks. My Stabilitrak service light comes on whenever it wants but as soon as you cycle the key the light goes away. The compressor for the air suspension sometimes will turn on with the car off and stays on overnight/hrs. This has led to me consistently having to jump the car nearly everyday unless I pull the 30 amp fuse under the hood every night. The Alternator, voltage regulator, and battery tested good. I think the last problem that I have with this vehicle is that sometimes when you're using the windshield wipers they'll just go on hyper speed and back to your set speed and up and down. The vehicles diagnostic port is also burnt and not even GM can hook a tester up to the port.

    I'm really at a loss on what this can be and have no help on what could be causing it. The car looks good and rides good but is the biggest electrical POS I've ever seen. Any help or ideas would be great I'm getting tired of handing over a couple hundred for them t
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    precose,
    I know that it must be frustrating to have so many concerns that are difficult to resolve, and I'm sorry that this has been your experience with your Envoy. If we can follow up with your dealership on any diagnostic appointments you have had, please send an email to socialmedia@gm.com with the following information:
    your name/Edmunds username
    phone and address
    last 8 of your VIN and current mileage
    the name of your involved dealership

    All the best,
    Sarah
    GM Customer Service
  • j_engj_eng Posts: 9
    Everything except the autostart has been fine ever since but their should be a recall to get a fuse installed to prevent the module from drawing so much current that it can melt and a window module failure should never shut off the the engine by effecting the logic line to the main computer. It should send a diagnostic meassage to the dask that a window module has failed. :(
  • j_engj_eng Posts: 9
    All electrical systems have been fine except the autostart.
    There should be a recall to get a fuse installed to prevent the module from drawing so much current that it can melt and a window module! A minro module failure should never shut off the the engine by effecting the logic line to the main computer. It should send a diagnostic message to the dashboard that a window module has failed.
    JGeng :(
  • j_engj_eng Posts: 9
    Sounds like you bought one of the thousands of cars that were caught in the many floods down south. The corrosion is taking its toll in the wiring, fuse box under the dash or relay box located in the engine compartment, and connectors.

    - Check the car fax and if not on car fax try to contact the previous owners listed on the title and hope it isn't being passed around from dealer to dealer.
    These cars are well made but any car that was flooded are a big risk. The VIN number should show up on an insurance claim if the owner or dealer is trying to hide this fact.
  • golferxgolferx Posts: 4
    I've looked thru the many problems posted about Envoys but not seen my problem. While driving it, it just looses power and stops. The only light that comes on the instrument panel is one that says "Low oil pressure". If I let it set for 5-15 mins. it will start again but may stop again several times before I get home, or it may not stop again for months. I've had it towed at least 4 times but the dealership can never find anything wrong. The first time it happened the dealership said it had gas inside the fuel module so they replaced it, but it has stopped on me 3-4 times since they worked on it. It stopped on me two times today on my way home, and it seems to only happen when the temp outside is really hot. like today is 100 degrees. Don't know why that would have anything to do with it, but it is always an unusually hot day. Hopefully someone out there can give me some direction as to what to do besides drive it into the river.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    golferx,
    When did your dealership do the fuel module work? We're happy to check into this further if you would send more details (including your name/Edmunds username, the last 8 of your VIN and current mileage, and the name of your involved dealership) to socialmedia@gm.com

    Regards,
    Sarah
    GM Customer Service
  • golferxgolferx Posts: 4
    Have you had any luck finding the cause of the shut down. Mine is doing the same thing, and the dealership doesn't have a clue.
  • golferxgolferx Posts: 4
    Name is John, golferx is username in Edmunds. Vin #46180822, has 139794 miles, and Arbogast is the dealership in Troy OH. Hope you can help, but from the looks of the other postings, I'm not very hopeful. I called to get the date of the work done, and they actually replaced a fuel pressure regulator, not a fuel module on Sept 2011. I've had the same issue of it stopping on me while driving at least 5 times since then.
  • magenta66magenta66 Posts: 1
    I own a 2002 Envoy XL with 77,000 miles on it. The "Service Engine Soon" light keeps coming on and diagnostics tells me it's throwing the same fan code over and over and over. I've replaced the clutch fan assembly three times in the past year. I'm thinking an electrical issue is really the problem here, given the history of this make and model. Any thoughts? A sensor of some sort?
  • I was wondering if you had anymore help with this issue. I had a problem with my GMC. It caught a fire!!!!
  • I was starting to have the same problems as rooster22. We purchased a used GMC Jan 2012. Just recently we started having an issue with the air conditioner, everytime we turned it on it would say oil pressure low, check gases, the car instantly shut off, and also the service engine soon light would come on and we had it serviced in April 2012.The display in the gauge cluster immediately shut off the vehicle due to a loss in oil pressure. I checked to oil it was full. On the way home the oil pressure gauge steadily dropped from 40 to 20. Before we could get it looked at, up until Wednesday 8/1/2012 the window stopped working on the passenger side. I managed to get it up just a little on Thursday and in the wee hours of Friday morning the car caught on fire on the passenger side. I saw that the window wiring has problems from the other posts. Luckily the fire dept was able to put it out before the fire got to the house and no one was in it. We liked to have had a major loss and fire damage. Will GMC help with this situation? I am out of a car and I lost property within the fire. I am going to have to pay the insurance deductible and other costs. I am also going to have to try to get a new vehicle. I have a lot at stake here and my situation is a bit of sensitive.
  • If you haven't already contacted the GMC Customer Assistance Center, please send the following information to socialmedia@gm.com so we can look into your situation further: your name and Edmunds username, phone and address, the last 8 of your VIN and mileage, and the name of your preferred dealership.
    Sarah, GM Customer Service
  • golferxgolferx Posts: 4
    Solution, I bought a new car.
  • steverstever Viva Las CrucesPosts: 40,562
    GM or ?

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • My 2004 gmc envoy 4.2 inline 6 run really rough at cold start up. When I put it reverse gear it quits shaking.When I put it back in drive it starts shaking again.When it warms up and the engine is at operating tempeture it smooths out some but not all the way.by the way the ac is running when I have the problem. when the engine is warm and the ac is off theirs no problem.I hope you get what i am saying.
  • I have a burned out license plate bulb on my 2002. I've removed the 2 screws and plastic cover that protects it and can see the bare bulb. It is a no. 168, which has just a glass wedge base. It "should" just push/pull with no twisting I presume. It's a tight space, and there's not room for my fingers. I have been unable to pull the old bulb out, but have been afraid to force it since it might break in my fingers. I suppose I can try again with a glove.

    Have any of you replaced this bulb, and have you had a difficult getting out the old bulb. Any tips? Should I try gripping it lightly with some pliers? Thanks.
  • pepito51pepito51 Posts: 16
    edited October 2012
    OK, I managed to solve the problem in removing the license plate bulb. It's very hard to pull out with big fingers and a tight space. It's hard to get a grip on the bulb. One thing that can help is a thin piece of gripping material--such as the thin rubber pads that people use to remove a jar lid, or a thin piece of cloth. I still had to rock it rather vigorously, but got it out. The new one does not seem to be in as tight.
Sign In or Register to comment.