Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Changed Air Filter - Car Won't Move

I changed the air filter in my 2001 RX300 (as well as the cabin filter). The car starts and runs fine but it won't move backward or forward. Could I have knocked something loose when I lifted the cover for the housing that holds the air filter?

Comments

  • la4meadla4mead Posts: 347
    If the problem started directly after replacing the engine air filter, my first thought is check for a forgotten unplugged connector and/or ventilation hose. My second thought is perhaps the airbox or somewhere downstream an intake hose isn't seated properly. Easy things to try, but I hope I'm not steering you wrong.

    Or happen anytime later? The symptom you describe sounds like what others have experienced with either a MAF sensor or throttle control valve fault. You can search the RX300 threads. Check if either one of those needs to be cleaned/replaced. I haven't had problems with the MAF or valve, but it sounds like familiar previous discussions each with an easy fix, but the MAF sensors aren't really cheap.

    I'm just wondering how dirty the old filter was... Is it possible there was a lot of dirt and some got into the intake hose?
  • wwestwwest Posts: 10,706
    I would be more suspicious of having knocked a connector loose behind the glove box in the process of changing that filter.
  • jawjakjawjak Posts: 1
    Thanks for the info on the MAF sensor, I had a similar issue, and with a little readjustment it's working great now! :shades:
  • la4meadla4mead Posts: 347
    edited May 2013
    Jawjak, I'm glad yours is working now. Coincidentally, I just cleaned mine again today as part of normal service. I'll try to get to the IACV and a good throttle body cleaning tomorrow before I change the motor oil and tranny fluid exchange as part of general maint. before the weather gets real warm again.

    You can find more great info from other knowledgeable DIY'ers at:
    link title
  • harryhess1harryhess1 Posts: 35
    In my maint. book on the 10.15.20,25 checks, it says nothing about changing the engine air filter. I called the service dept and was told that at 15k they remove it and clean it and then at 30k check the change it. I can see nothing in the maintance book that mentioned this. I now have 20k on my 2011 rx 350, does it need to be changed? Thanks Harry
Sign In or Register to comment.