Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Cherokee Electrical Problems

ancobacaancobaca Posts: 3
edited 7:26PM in Jeep
Ok I have a dilema. My wifes jeep is a 95 jeep orvis. One night when we turned on the overhead light for the rear seat the radio shut off, and the little panel which shows picture of the vehicle would blink. The clock has always gone out on occasion for no apparent reason. Anyhow as soon as you open the door there is a ticking sound coming from passenger side dash. As soon as door is shut ticking stops. The radio is still out, and the heater wont kick on unless the door is shut. If you open the door the heater shuts off. I checked a few minutes ago and found the ticking to come from a relay that was under the glove compartment. I took out a few screws from glove compartment and saw a block with what looks like some relays. On the relay is 56006709 under that is 50732 and then a # under that that is pressed in probally for production #. When I take the relay out the ticking stops but then so does my lights up above. So I am wondering what this relay is and could that relay cause all this problems if it was blown. I have googled it all over and did find a couple things but it doesn't specifically say what it is. It has 5 prongs with the numbers next to each one as 30 85 87a 86 28...any help would be appreciated. My wife is driving me nuts, because "I turned the light on like she asked and caused this whole mess, its all MY fault" lol

Comments

  • lhoudinlhoudin Posts: 1
    I have a very similar problem right now in my 1998 Cherokee.

    In my case, it involves the fan continuing to run after I've parked and shut off the engine. I have to pop the hood, walk around and literally smack the plastic fuse box under the hood.

    The culprit in my case is the same type of relay you mentioned. I'm staring at one right now, numbered 56006709 50732. Sometimes relays fail open, sometimes they fail closed. In this case, my fan relay sticks closed sometimes.

    Time to replace it with a new relay. I'm not sure how difficult that will be, to find an identical part, but will be calling around to local auto parts stores.
  • Ancobaca,

    I have exactly the same problem as you described in your April post but with a 1994 Jeep Larado Grand Cherok. Did you get to the bottom of this? I have ordered a replacement relay, but I will be surpirised if the relay is the problem. jhtjr
  • For a couple of weeks my check engine light would come on then go off. Two days ago all my instrument panel gauges including the speedometer began jumping around and falling to zero. It did this several times then turned to normal. My turn signals would not work and my headlights were dim. I parked it and the engine began cutting out. I shut it down and it would not start. Apparent low battery. I took battery home and charged it. After installing battery I drove it home. All was normal except the voltage meter was low and Check Engine light was on. I removed the alternator and had it tested. It checked normal. Battery seems OK. What should I check now? Please all the ideas I can get.
  • Did you ever find out what was causing your electrical problems? I have a 2005 Jeep Grand Cherokee Laredo which is doing something similar. The check engine light goes on and off. Sometimes all of the gauges stop working after I hear a series of noises. But the worst part is that the lights go out. If I stop the car, and turn off the engine and then restart it, the lights usually come back on. Tonight they wouldn't come back on. I found out that if I pulled the dimmer/high light control toward the steering wheel and held it there, the lights stayed on dimly. I turned on the flashers and drove carefully home. I have had it in the shop three times and they say that they need this to be going on to run their diagnostics. Unfortunately, so far, it has only happened on weekends and evenings when they are not in the shop. I am getting desperate. I need my vehicle but I am afraid to drive it at night. Any suggestions?
  • My problem ended up being the battery after all. Since I had the alternator checked and found it OK I decided to pull the battery and have it checked. It turned out being very weak. The low voltage must have disabled the alternator from working correctly. Don't know for sure what to tell you about your problem. Definitely sounds electrical somewhere.
  • I have the same problem, did you find a saluation, I would love to know.
  • I have a 1995 jeep cherokee, 5 speed, 197,000 miles, I recently replaced the waterpump and radiator, and battery, while driving, the odometer, speedometer and fuel gausge stopped working. The next morning when starting the vehicle, none of the indicator lights ( oil, battery, temp, seatbelt, etc.) would not come on. any advise or suggestions would be helpful.

    Read more: http://www.justanswer.com/tags/jeep/wrangler?r=ppc|ga|1|Cars+%2D+2|Jeep+Wrangler- &JPKW=jeep%20wrangler%20brakes&JPDC=C&JPST=www.automotivehelper.com&JPAD=3184928- 193&JPAF=txt&JPCD=20091207&JPRC=1&gclid=CPTox5zAmKECFQ8UswodUkuEOw#ixzz0llSOkFK2-
  • I have a very similar problem in a 95 Jeep Grand Cherokee, 195K miles. Clicking from relay 56006709 50732 when door is open and radio, heater, AC computer problems. I pulled the rely and two of the prongs were scorched- I replaced relay but the problem was not fixed.
  • Ancobaca and jhtjr,

    Any resolution to your problems? I have 95 Jeep with similar problems- same clicking with door open, heater stuck on. I tried replacing 56006709 under the glove box but this didn't help. I can drive the car with the relay pulled- but radio, computer, HVAC don't work.

    thanks all for any info
  • pededardpededard Posts: 1
    I had the problem with the instruments going to zero while driving and would have to hit the face of the instrument panel with my fist to fix it temporarily. I partially removed the instrument cluster (could not remove it completely because I could not figure out how to remove the headlight switch knob). I found that the four or five phillips head screws that hold the panel together were all somewhat loose. I tightened all of them and replaced the cluster and have not had the problem since. Apparently they complete the ground circuits to the panel.
  • mark512mark512 Posts: 1
    Check fuse #8! (I'm pretty sure it was #8--it was definitely a 15 amp fuse.)

    I had a very similar problem with a 95 Grand Cherokee. It all started when turning off an overhead light. A relay near the passenger's feet was clicking rapidly when a door was open; radio worked intermittently; an aftermarket CD changer didn't work; info display in front of gear shift didn't work; interior lights blinked dimly, even when they should have been off; power door locks didn't work. The car drove fine, but the electrical system was going crazy. It turned out that this was all caused by one blown fuse.

    Good luck!
  • predwardpredward Posts: 1
    Any resolution to your problems? I have 95 Jeep with similar problems- same clicking with door open, heater stuck on. I tried replacing 56006709 under the glove box but this didn't help. I can drive the car with the relay pulled- but radio, computer, HVAC don't work. HELP!!!
  • jhtjrjhtjr Posts: 2
    My problem persists, sounds very similar. I gave up on fixing it a year or so ago. I became convinced at that time that problem was not in the supply side of the electrical ckts, i.e., not the +12VDC side of things for which the fuses and relays play a role, but rather a bad ground connection somewhere. Only this could explain how so many things are messed up. Good luck!!
  • I bought a 1993 jeep cherokee country that doesnt run one day it wouldnt start it would crank over but wouldnt fire the man worked on it as a project with his son and it had weak spark when he got it so he replaced the sparkplugs, plug wires, distributer cap and coil and crank shaft postion sensor and it has strong spark and fuel but wont fire could it be spark timeing or are there any other sensors that could be messing with it starting.
  • mwalpmwalp Posts: 1
    '04 Grand Cherokee w/ 4.7 4wd - I have experience electrical issues that on the surface seem unrelated but are apparently tied together. Symptoms = windows on right side inop, elec door locks only work on drv side, speedometer is constant 10 mpg high at all speeds, interior lights inop. At one point the drv side windows went inop. I disconnected battery and drv function return but all other symptoms remained. i check PCI Bus and found the volt reading is varying between 0.5 and 2.5 volts which i'm told is normal. any ideas???
  • Check for loose grounds somewhere. I have had 3 problems with vehicles recently. I ended up cleaning ground connections on the battery or on the devices effected and have fixed 2 of 3 problems and seemed to help on the third one.
  • God bless you sir. I am forwarding this to the others if you dont mind.
  • Ok last night my daughter pressed the overhead light in the rear of the console , after this happened a constant clicking of What I assume is the s.a.m. (system alarm module) relay. the radio does not work the interior lights flash the System information does not work.

    I get up this morning to tackle the problem I started first with the Overhead console and removed it. The Light Assembly's were loose because a couple mountings were broken ( fixed with super glue and a small piece of jb weld, yep Jb weld works on plastic great), The backs of the light housing has wires on it that are exposed at the connectors and when the light was pressed it shorted out on the roof metal ( Used CardBoard and tape to cover the connections before replacing).

    I found that the #8 fuse was blown (15A mini blade fuse) Replaced it with another 15a and the problem is fixed.

    Hope this helps everyone who has this problem
  • mikkimotomikkimoto Posts: 1
    smgordon1259 got it RIGHT. I did exactly what he did and it turned out great. Had to look up how to remove overhead console. There is 1 screw located near rear view mirror then slide whole console toward windshield to clear clips.

    I'm a chick & I fix my own [non-permissible content removed].
Sign In or Register to comment.