Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Colorado and GMC Canyon ABS Fault Issues

2456713

Comments

  • gmcustsvcgmcustsvc Posts: 4,083
    Hello apg20,
    I apologize that you are experiencing a concern on your vehicle. Have you had anyone diagnose your vehicle for the concern? Thank you,
    Mariah GM Customer Service
  • ECR223ECR223 Posts: 10
    Well at about 46,000 miles I was having the drivers window/lock/FOB problem, and that's when I found these forums... Now, at 56,000 miles, 2 days ago I hit the brakes, ABS kicks in(for no reason), and then "ABS FAULT" comes up... Much like my previous problem, it's good to see I'm not the only one... I haven't taken it to the deal yet, and probably won't for 2 more weeks at least(until I have time)... Can't wait to see how much this is going to cost!!! It's a real shame too, I love my truck... But I'm not going to want to keep it if it starts developing ALL of the problems listed in these forums!! :mad:
  • omaitaomaita Posts: 16
    Hi, now that I read the other posts, I don't feel alone. Here is the history.
    I bought my 4X4 Chevy Colorado 2006 in Oct'06 here in Gaithersburg MD (Criswell).
    It was cold and just after few months Nov-Dec the truck began with the problems.
    In cold weather the car just didn't move, it needed more than 10 minutes to get warm and be able to move, dealer just said something like the rotors were crystallized and it was normal, to be honest I didn't have time to go back to the dealer for the problem that today still persist.
    Then, I started to get problems to start the car every other week, and for the same problem I went back to the dealer about three times. First they said "We were unable to repeat the problem so we just reset the computer", then they said there was a loose cable, and at the end they just replace the igniter or starter. It was more than 1 year and I don't have THAT PROBLEM again.
    But as soon as that problem went out, it comes another one: THE BRAKES. Every time I push the brakes, the car showed something like a pulsation, so I went to the dealer and they said ok the "brakes are bad, something weird, because your car it has less than 20k miles, so we are gonna replaced all four for you at no cost".
    After they did that the problem went out for like 6 months and it came back again. Again, i didn't have time (IT'S ALL MY FAULT) and I didn't take care of that, but then started to show ABS FAULT and the pulsation was harder when that happened.
    My car has only 33K, but I bought it on Oct 2006 so I thought the warranty was expired, but checking all the papers given to me by the dealer when I bought the car (BECAUSE I'M TRYING TO SELL THE SCRAP ASAP) I found that there was an EXTENDED PREMIUM WARRANTY by Performace Fisrt that cost me $ 1,100, so I went to the dealer two days ago, dropped the car they called me yesterday morning to said "we could not duplicate the ABS FAULT, so we just tight the connectors; and regarding the noise every time I make a turn, front brake rotors needs to be cut or realigned and that will cost you around $ 345, but we do not guarantee that the noise will be gone", so I said, leave the noise that you do not guarantee will be gone and just fix the ABS FAULT, also I told him, about this forum and let him know that people here is talking about a bad sensor and loose bearing, and just said YEAH YEAH YEAH WE ALREADY CHECK THOSE THINGS.
    Honestly now, I don't trust those Chevy Techs that one of the times when I dropped the car gave me a check list detailing what was already checked, like lights, and as soon as I saw the car there was a turn light not working and they just said I'M SORRY WE'LL TAKE CARE OF THAT.
    Today I got the same problem with the ABS FAULT message. I took some pics of the message and I dropped the car. Hopefully, I am not gonna need to pay another $ 100 as deductible for the same problem they can't fix.
    Bad experience with Chevy, that's the reason one year ago I bought a new Nissan for my wife and I still have peace of mind with that car.
    I don't know if that extended warranty is transferable (even in the dealer nobody knows, and nobody give a paper where it says yes or not), but if I don't sell the scrap in the next month I will contact a lawyer for this nightmare.
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello Omaita,
    I apologize that you have had concerns with your vehicle. Did the dealership ever find the concern? Thank you,
    Mariah GM Customer Service
  • I stated on here a few months ago that my abs fault code was intermittent, but now it is happening almost every day. Here's what happens. In the morning I start the truck and the code clears. I drive to work, all is fine. I get done with work, go to leave and the first time I apply the brakes, the ABS activates. The brake pedal pulsates. (I'm on clear dry pavement) and the ABS fault pop's up in the DIC. I drive back home, park the truck for the night and everything is fine in the morning again.
    Seems to me that this is a safety issue, and GM needs to issue a recall. Especially considering that the Colorado has a history of electrical gremlins.
    Does anybody know of a phone number, or E-mail address to complain to GM about this problem. Maybe, if we all start making some noise about this, GM will fix these problems with a recall.
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello Tomtom231,
    I apologize that you are experiencing a concern. Have you had anyone diagnose your vehicle since the code is on all the time now? Can you email me your VIN and current mileage? You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • lvfranklvfrank Posts: 7
    Mariah,
    This is also happening to my truck. I have written in this thread before. I have had it to the mechanic, and they have replaced the sensors and both hubs. There is no ryhm or reason why it comes on. I agree that eventhough I have been told by the mechanic that my brakes will work, just the feel concerns me. If you want it my VIN Number is 1GCDT136958245113 and I have 75,000 on the truck. Had both hubs changed at 65,000 because they thought that would solve it. It seems that it is an electrical problem to me, especially with everyone that has discussed this issue on the thread. Don't expect anything out of this because I am becoming really dissatisfied with Chevy.
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello Ivfrank,
    Do you still have your warning lamp coming but, there is nothing wrong with the ABS correct? The only thing I could do is set up a case with an agent for you. I would need you to email me your contact information, dealership and best time to contact you. You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • omaitaomaita Posts: 16
    Hi, thanks for reply, at least somebody from GM shows interest in my concern.
    I dropped the truck on Thursday, then Criswell call me on Friday to let me know that they were able to duplicate the message ABS FAULT and, like EVERYBODY is saying in this forum, the problem it was a BAD SENSOR and BAD BEARING (even tough they prefer to call it "HUB").
    The first call it was to tell me that my Performance First extended warranty should cover only labor and sensor, but the Bearing (350.00) should be covered by ME.
    Then they call me again, to let me know that the Dealer will cover everything.
    I was unable to pick up my truck until Tuesday because they found another Code in the testing drive, so they changed sensors and bearings in both wheels.
    Has been two days, and there is still no problems with the ABS FAULT.
    I still have the pulsation on the brake pedal that they said my PREMIUM Performance First doesn't cover.
    Anyway, thats something I live with until I sell it.
    Thanks again, last favor, how can I know what factory warranties my 2006 34K miles still have my truck and if the extended warranty is transferable???? Since I never received the Warranty Facts Book when I purchased the car.
  • I am having the same issue.. 2005 Colorado Z75 I5 - used to be intermittent ABS light that used to resolve itself every time I restarted the car.. now the ABS actually DOES kick in and pulse when going slow (~5mph) and the light is almost always illuminated.. I am just under 100k miles, brakes and rotors changed last year. nothing since.

    I dread going to the local dealers.. they gave me a hard time when I first bought the truck by telling me it was MD state inspected, only to find out it was metal on metal for my front brakes and needed new rear tires.. anything recommended by the posters here? can I pull ABS codes without going to a dealer to try to limit cost?
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello Joe22306,
    There maybe some places that do read codes in your area but, I cannot recommend anyone. Because you are still experiencing the concern I could have an agent look at your situation further. However, they do require that you take it into a dealership to have it diagnosed. If you want to do that please email me your VIN, current mileage, contact information, dealership and best time to contact you. You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • Just a Followup.

    I got a call back from the dealer telling me that they cleared the codes, and I needed brakes one.. ~$1100.. I explained that ABS kicks in randomly when the truck is 'cold' so they said they would call me back in a few hours after letting the truck cool off. The Chevy Dealer now says that the hub bearings are failing on both sides and recommend I replace the hubs / brakes / rotors / sensors.. over $2500 for the job. seems a bit excessive.

    they also said it could be an issue with low voltage, but didnt go too much into detail. yes, this started around when my factory battery died on me a few weeks ago come to think of it. but I dont see the connection.
  • I have the same problem as everyone else. I have a 2005 Colorado Z-85, 4x4. Two weeks ago my ABS system would kick in when stopping at slow or high rates of speed. It does this 3-5 times, then the light comes on my dash board and ABS disengages.

    I took it to the dealership this morning. I got a call an hour ago saying the diagnostics read that both front left and right abs sensors have errors and need to be replaced. This also requires both hub assemblies to be replaced. I asked the service technicician if it makes sense that a vehicle with 72,000 miles on it would have both front ABS sensors go bad within two weeks of one another. He said it does not make sense but it is what the computer says.

    I am not paying $1,175 to have something fixed that does not make sense. I think it is pretty obvious Chevrolet has a problem here.
  • hgb3hgb3 Posts: 1
    I have a 2005 Canyon 4x4 with less than 25,000 miles. Never off-road, never abused with the same abs problem, comes and goes. This is without a doubt a GMC issue. GMC needs to step up and make this right.
  • realalerealale Posts: 1
    bpetuch
    My 2006 Colorado started the same way last year. There was about 30000 miles on the truck and I had owned it nearly three years. i finally got around to having it repaired last week.The diagnosis was faulty left wheel sensor. Labor and parts would be about $227 but as they got into it they found the back side of the bearing had rusted and forced the exciter ring to ride along the sensor and damage the sensor.
    That added another $350 to the bill. The mechanic said the other side was rusting and would most likely do the same. I was told this was a design Chevy has changed.
    Hope your extended warranty is better than mine. This should be a recall repair.
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello Joe22306,
    Thank you for the update. I am glad that the dealership figured out the cause of your concerns. I know $2500 can be a lot of money, and I looked through the case notes and it looks like you are going elsewhere for the repairs. If you have any further questions please let me know. Thank you,
    Mariah GM Customer Service
  • rpwillisrpwillis Posts: 1
    edited September 2010
    My 2005 Colorado is having a problem with the ABS Fault light coming on and the pedal gets hard and brakes barely function. This appears to be a well known problem to GM. I guess they will take care of it when I go through the a** end of another car.
  • I have the exact same issue, but I'm stationed in England and Chevy dealerships won't touch and don't know what a truck is! I am not popping any codes, but England roads are wet and get very slick and I am scared of the brakes giving out and I can't stop!! GM might do a recall when I send them the bill lol
  • I am very concerned since my truck started having ABS faults about two weeks ago. I haven't been able to find anyone that can help with this issue. We have taken the truck to three different shops with no fix yet. The brakes have been replaced, the sensors have been replaced and still there is no correction for this problem. After reading multiple posts about this same type of error, I have posted a formal complaint on http://www-odi.nhtsa.dot.gov/ivoq/index.cfm . All of you that have this same problem, please go out and do the same thing as well. Maybe we can get GM to wake up if we all post to the NHTSA and get them checking into it. Maybe if they get 50+ complaints in a couple of days, they will truly help us out.
    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    .

    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    .

    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    .

    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    .

    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    .

    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    .

    Thanks
  • Have you had any luck with getting the error to go away? I am getting so frustrated with my truck! Please reply if you have or haven't had any luck and what you did if you were able to get it fixed. I have reported this problem to the ">link titlehttp://www-odi.nhtsa.dot.gov/ivoq/index.cfm"
    .

    Thanks
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello Bethanya,
    I apologize that you are experiencing a concern with your vehicle. Did you take the vehicle to independent shops or GM dealerships? Do they clear the code and it keeps coming back or are you feeling problems with the brakes still? Thank you,
    Mariah GM Customer Service
  • I just fixed my ABS fault problems the easy way. I traded my Colorado in on a 2010 Ford Explorer Sport Trac. The Spot Trac seems so much more refined than the Colorado. And NO fault codes. lol. Good luck everybody, I'm still going to follow this thread, because I'm curious if GM is going to come through for everybody and issue a recall like they should.
  • john_sjohn_s Posts: 1
    edited September 2010
    It is rediculous no help I have also reported the concern to http://www-odi.nhtsa.dot.gov/ivoq/index.cfm
    The bulbs also burn out quickly what a piece of crap
  • gmcustsvcgmcustsvc Posts: 4,083
    Hello John_S,
    Can you tell me a little more about what is going on with your vehicle? Also, have you had the vehicle diagnosed for the concerns? How long has the issues been present in the vehicle? Thank you,
    Mariah GM Customer Service
Sign In or Register to comment.