Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Volkswagen CC Maintenance and Repair

leo72leo72 Posts: 2
I was driving yesterday for the first time with A/C on and windows closed and noticed instrument panel shadow in driver's side window. It was blocking the view in the mirror, not to mention it was very annoying. Anyone else has experienced the same problem? Is it a car design or a defective glass? Thanks in advance
«1

Comments

  • My wife's Passat has been giving her the following issues. It has happened twice on the highway. Any thoughts? Thank you in advance:

    Driving down the road and all of a sudden the EPS light and warning triangle w/ arrow circle around it (anti slip regulation) light came on and the car had loss of power.
  • My car was driven 30K miles and the 2 year old battery provided with the car by David Maus VW of Orlando, just crapped out dead, capute gone, worthless. I only had the damn car in David Maus's VW for its 30K mile service 30 days ago....then this!

    Makes me wonder is it VW, David Maus, or just a [non-permissible content removed] battery that VW installs on the cheap meant to crap out after 24 months so you have to purchase a new one so soon? Anyone else out there with this battery issue yet?

    Letl me know.
  • Can anybody tell me how to reset the service now message in the dashboard display?
    The car has had is maintenance but the garage that did the service doesn't know how to reset this message, plus the owners manual is not helpful.

    Thanks.
  • i just got a 02 passat 4 motion a couple days ago and ive noticed some things with the car....

    1. the heat doesnt work---all the fixings for the heat to work is running fine but there is just not hot air coming out the fans blow hard and everything but no heat...the heated seats work perfectly but no hot air im seeing that it could be a couple things like a clogged hose or faulty heater core but im not sure because everything else works fine...

    2. the radio goes out as volume goes up----ive noticed that on certain volume levels the volume on the monsoon radio would cause it to go out, now the radio would still be lit up but id have to turn it off then back then turn the volume down for it to work now if i didnt turn the volume down wit would play for a couple seconds then cut off again like it was blowing a fuse or something or busting the sound decible level causing it to go into some type of fail safe or something....

    3.none of the streering wheel functions work nor does the horn----now i dont typically use the horn so i didnt notice it at first but i was excited that i had steering whell functions and i noticed those off the bat the cruise control light comes on but doesnt set nor will the volume change if you select a different one one the wheel...now they all light up when you turn on the headlights at not but still dont function...also turning the wheel does nothing as well, now with the horn i press it to no result but when i lock the door with my actual key you can hear a little horn toot which confuses me why the horn wont work

    now with all this being said everything else work completely fine...everything lights up no fuses are blown windows work sunroof all the locks everything else electrical works fine to my knowledge so any help in how to fix them would be greatly appreciated.....
  • mskitkamskitka Posts: 20
    VW CC: I cannot believe that Edmunds didn't comment on the throttle lag with this car. The acceleration is so bad that it is unpredictable and unsafe. I even read about a woman who almost got in an accident with it because the car wouldn't accelerate fast enough, so she almost got hit while turning. If it was not for the unseamless turbo, I would have leased this car. While driving up a highway ramp during my test drive, I had the pedal to the floor and nothing was happening. Then whoosh! I'm sure it's not a factor in a manual, but they need to improve the lag.
  • My CC has a LAG in acceleration from the start too. Makes you wonder what's ups with Audi/VW when they designed this engine.
  • mskitkamskitka Posts: 20
    I'm very surprised. In the past, Audi/VW has always had the tightest (in a good way) suspension, quick acceleration and a nice drive. I don't know why they would mess with something that isn't broken. I've had a '98 A4 that I loved! It was the most perfect car with the least amount of problems I have owned to this day (wish I bought out that lease!). My '05 Saab 9-3 had turbo and it was a lot more seamless then the VW CC. The 9-3 had turbo lag when you went to brake. This is a problem with acceleration. Someone mentioned it is a problem with the auto transmission upshifting too soon and the ECU. The car is opening the exhaust for too long before acceleration kicks in. VW seriously needs to recall and time it better and also reset the ECU.

    I wish there was way we could get this to the Edmunds.com editors. They should really include that in their review and they haven't, can't believe it as it was an issue in the 2 CC's I test drove.
  • I am looking at a 2009 that was returned for water in the doors. I know this has been a problem in the past. I really like the car and the new owner said VW put new seals in the windows, undercoated the doors and added 12 months to the warranty. I wondered if anyone else had this done and if it has solved the problem. Worried about the water in the door short term but if water is in the car and long term problems with electronics in the door.
  • slkrslkr Posts: 1
    :surprise: the CC was the car of my dreams after a big effort and thousands of dollars I was able to get mine, it was just like a dream came true it was perfect until two years after and with only 21,300 miles TRANSMISSION fail ......

    just out the blue car will not go in reverse or forward I freak out because I was in the middle of the street with traffic coming towards me I shifted back to drive and reverse several times with no results until I came out of the car and pushed off to the side ..... :blush: besides the shame of push my brand new car it was very scary being in the middle of a busy street with no transmission. After I turn off engine and wait a few minutes I started car and surprisingly car responded normal.
    I took car back to dealer and they said it was something call the MECH TRONIC SENSOR who knows what that thing is but anyway they told me they will replaced at no cost and they make arrangements to get me in a enterprise rental unit,
    I was told that it will be ready in about a week, well long history short it took 4 weeks for the part to arrive plus an extra week for labor....
    finally I get the car back just for one more week after seven days SAME thing happen again this time in a expressway called roadside assistance they towed car back to dealer they had it for 3 more weeks I got the car back on January 19th with brand spanking NEW TRANS I was told they replace the whole trans with a new one........

    car was in perfect condition until last Sunday Feb 11 that it happen again :( ... I turn it off start it again and car is working now apparently normal......... if that happen again I'm going with the lemon law does anybody has any advise or had the same problem ??
    PLEASE ADVISE
  • I am having the same issues with my car. I took my car into the dealer for the recall repair and a week later my battery died. At the time, I had about 36K miles and the dealership said I need a new battery. After they charged me over $170 for the new battery and installation, I am having the same trouble less than 3 months with the new battery. This is my first VW and I think it will be the last. Not happy with the service and battery issues. I have had 4 Nissans over the past 15 yrs and I have never ever had issues with a battery. Back to Nissans I guess.
  • 0311vn0311vn Posts: 48
    Is the air cleaner a reusable-type that can be washed out, as one person told me, or is it a replaceable-type? My CC Sport has 34K on it and I have not had the air filter serviced, unless the dealer did it during a 10,000 mile service. My manual is in storage and not available for me to access for service info.
  • 0311vn0311vn Posts: 48
    I opened up the air cleaner housing today and noticed that it is a standard replaceable paper element-type filter. It is not a reusable "washable" filter as an employee at an auto parts store thought it might be.
  • 0311vn0311vn Posts: 48
    My 2010 CC Sport has 33000 miles on it. I do not drive cars aggressively, but was wondering what is average mileage before original brakes on a CC Sport will need to be serviced. I am not having any vibration from the rotors and or any squeaking noise from the brakes pads as of now.
  • I have only 22.5K on my VW CC 2010, it has been 2.5 since I got my car, and now I have to replace the battery, since the warranty on the battery covers only up to 2 years or 24K, when everything else in the car is under warranty for 3 years or 36K, I wonder why that is? Is the battery is not suppose to last longer than the warranty coverage?
  • I have come close to death 3 times now because of the lag.
  • Could you please tell me where the air filter is located at on the 2012 CC? I have a terrible odor coming out of the air conditioner when its first turned on. it smells so bad that I have to roll down the windows for at least a minute until its gone. I'm thinking the filter might need to be changed.
  • Several times since purchasing the car last year I have experienced what I consider a significant issue with my CC V6 Executive. When pulling out from a hard stop into a traffic intersection or making a turn crossing traffic - push down the gas pedal and absolutely nothing happens. Can push pedal to the floor but with no response, no increase in RPM, no indication that pedal has been applied. I have read about false neutral and pedal hesitation problems, this is something different and could cause a traffic accident. On one occasion I rolled into the traffic lane with oncoming vehicles and barley crossed without incident after pressing the pedal down several times in a panic. I cannot say under what conditions hot, cold, long or short drive, hill or flat surface, or what operational pattern is prone to the failure- it just occurs maybe once a month under daily normal driving conditions.

    I have taken to the dealer and reported the problem; after a day in the shop they say they "cannot duplicate problem" and no fault codes present. I understand intermittent problems are very difficult to diagnose and seek any similar experience or advice on how to facilitate dealer repairs. :confuse:
  • forever1forever1 Posts: 1
    I loved my new CC car however; Friday afternoon i was driving home i was driving in traffic then suddenly when i pressed the gas pedal no response. I pushed it several times and nothing happened i assumed it turned off however the radio was still on and the battery icon appeared. I put the car in Park then i restarted it. I took it to the dealership Saturday, morning and reported the issue. :(
  • tinap1tinap1 Posts: 1
    This is still an issue in the 2013 CC !! I wish I had done more research before leasing the car... I would not have picked this car. As said in an earlier post the lag is unpredictable and very unsafe!! Can't wait until my lease is up... I will not be getting a VW!
  • dansa2dansa2 Posts: 26
    Radio volume decrease then cuts off. Drive a while comes back on. At times cannot get radio icon to show on screen.
«1
Sign In or Register to comment.