Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Avenger

1246

Comments

  • jezzijezzi Posts: 1
    I've always really liked avengers, and after my stratus died I was going to buy one. So I did my homework & they apear to be pieces of junk. Please tell me they aren't! Does anyone have anything good to say about them? Because the only "good" things I've heard came from the people trying to get rid of them.
  • i drive a 1995 dodge avenger ES im glad to say i got one of the good ones.i have been the only owner of this car and i got it up to 226,000 miles on it , and its never had any mechanical problems , except for the things you need to replace when a car starts getting old ( water pump, alternator, spark plugs/wires, seals, belts ext ). its been the best car i have ever had, and still do date i put about 100 miles every 2 days. but luck doesnt last forever, yestarday my ANTI-LOCK light came on, the car still drives the same, but when i turn the car off, i hear a vibrating noise coming from under the hood by drivers side wheel , its fairly loud, and i think its the hydraulic module, i have to disconnect the negative battery cable to get it to shut off, but it comes right back on when its re-connected. does anyone have any advice on what i might be able to do ? its thanksgiving and no auto shop is open .
  • i have a 1995 ES with 226,000 miles on it, its been the best car i have ever owned.
  • hey your problem is the wheel bearing its a sealed unit the abs sensor is inside of the bearing so your bearing must have gone out and took the sensor out with it. its a common problem on avengers normally its the rear ones but ya just have the bearing replaced and that should solve your poblems
  • kagerkager Posts: 1
    I don't care what anyone says about the Avenger... mine is now 6 years old now and has 125,000 miles on it. I have yet to put any money into it (I've been the original owner) and have put a lot of miles on it for a 6 year old car... this has been the best vehicle I've ever owned - and I hope to have it another 2-3 years! It's just a good dependable car! No complaints here!
  • Is your O2 sensor bad, or camshaft position sensor bad, It could be numerous things though you need to know exactly why the light is on.
  • i have a 99 avenger ES i jus got it wit 72 000kms on it, i was having a problem with the stario but aperantly it was a fuze problem how ever i hurd some talk about maybe i should take a look @ my condenser that might b short circuting the wiring. Another thing is that it is leaking coolant however the leakin is slow, it leaks a full load in about 2 weeks... i hurd it could b a gasket problem but im not sure, any idea as it wat this problem could be???
  • caleb3caleb3 Posts: 1
    i just got a 95 avenger and i need to know what type of engine it needs?
    need answer fast thanks
  • I have this very problem and a service can be performed to restore them back to crystal clear. I found it by going to yahoo search and entering headlight restoration. Here's what I got http://www.mdwholesale.com/. You will find everything that you need here.

    Let me know how it works!

    Billy
  • caleb3 it depends on if you have a es if so the you have a 24valve v6 which is call a 6g73<--thats the motor type its a 2.5 liter motor. also along with that your transmission type is A604 / 41TE this is a stock 4 speed auto for and es. if you have a 4 cylinder the it is called a 4g63 which if you wanted to you can go and get a 4g63 turbo motor out o a mitsubishi eclipse or out of and eagle talon or ranging in years from 92-99 and any one of those motors will bolt right up in there but you will need to change your motor mounts out
  • The 4 cylinder motor is NOT the 4g63 motor, and the 4g63 is NOT a swap as easy as replace the mounts and you'll be fine. The 4 cylinder motor is the 420a motor, same as in the dodge neon, except in the neon version of the 420a motor the head is flipped around. the intake is in the front while the exhaust is in the back. In the avenger version of the 420 a motor the intake is on the back and the exhaust in the front. I have a 1998 Dodge avenger with the 4 cylinder motor that I turbocharged and I love it. I have had very little problems since I bought it 2 years ago. I know alot about the avenger and can help with problems that people are having. Feel free to contact me if anyone has any questions. For all those reading this check out www.aseclub.net it is the avenger/sebring club and they have many modified cars, as well as many stock cars they have all had the same problems you have experienced. Check out the forums, and please search for a problem before you post a new problem. It is free to join.
  • My check engine light has been on for a very long time. I was told my O2 sensor was the cause. I'm having someone fix it now, but ran into a problem. I need the part numbers for the 3 02 sensors (1 in the front and 2 in the rear). I am told from the dealership that there are only 2 sensors, but my mechanic is looking at 3. Can anyone help? I need the 02 sensor parts or part numbers so I can purchase them.

    Thanks
  • maxflimaxfli Posts: 1
    I have the exact same problem. Have you been able to fix it?
  • gregg7gregg7 Posts: 1
    The only to tell is to remove the cap and take off the rotor. The rotors visually look the same it's the three flats on the rotor and the shaft that make it Large or small cams.
  • dmoney95dmoney95 Posts: 1
    at stoplights my 95 avengers idles really rough, to the point where the whole car is shaking then when I go to drive off, the car barely drives and I hear a knocking noise from the engine. If I downshift into L the car flies off. What is wrong with my car? :confuse:
  • I have a 97 dodge avenger with a four cylinder, five speed. I recently blew the 2.0 and am inserch of a new motor. i was wondering if the 2.5 liter v6 would fit into my application. the reason is they are a lot easier to find then the 2.0's. Any other motor applications that would work would be helpful.

    Thanks,
    Seth
  • davertdavert Posts: 23
    There have been at least two Avengers aside from the TV show - the Hillman Avenger, and the Mitsubishi coupe with Dodge labels. The current Stratus is moving ot a Mitsubishi platofrm (as in dimensions and such) with Chrysler engineering. It's due very soon, and htere's a whole bunch of info at
    http://www.allpar.com/cars/dodge/avenger.html
    along with spy photos and such.

    FWIW, no quality predictions should be made by anyone on this model since it is completely, totally new except for the V6 engine and perhaps the automatic. There will even be a six-speed automatic which is completely new. It's not made by Mitsu and it's not designed by Mitsu - it's a cross breed. Heaven only knows what that will mean especially with the Mercedes bigots in charge.
  • balonis23balonis23 Posts: 2
    i have a 97 avenger..and i got it with around 33 thousand miles for only 1500...its a 5 speed 2.0 and it runs great...theres nothing wrong with it at all so far...i had it for about 4 months now and i had a water pump problem which it overheated .and a mechanic changed all the hosesfor me because he said they were roting..and i think my rotors are starting to warp....but now everythings still going good with it ..and i havent had any other problems with it...to me this was a killer deal when i got it :D....but does anyone know how to remove the clear part of the headlight to clean..because dodges are known for having bad headlights..and i dont know how to remove the seal..so if someone knows how to just let me know...

    thanks,
    dave
  • balonis23balonis23 Posts: 2
    yeah i have a 97 avenger..and i have it for about 5 months..and it runs great..a lil 2.0 5 speed..and the check engine light came on recently and its been on..but theres nothing wrong with my car ...but i was told it could just be a sensor
  • jim83421jim83421 Posts: 6
    i am working on a 96 avenger 2.5 they already changed out the plugs wires cap rotor and sensor before bringing it to me it has a miss on cyl 3 good fuel pressure voltage to injector and to plugs it fires when out of engine but not when in compression is very good 150 -155 on this head has any one found this problem
  • I have a 96 Avenger es V6 and i just bought it about 2 months ago and the headlights are so bad that you can verily see through them! i got some stuff at O'Rielly's auto parts, it is some polish stuff that comes in a blue bottle, and you just wipe it on and buff it off and it cleans the out side off really good, but i ended up just payin the $500 and buyin all new headlights cause everyone kept telling me that your not supposed to take the clear cover off, i thought it was pretty stupid, but whatever! Sorry if that wasnt of any help to ya!
    Caleb E.
  • c0k3h3adc0k3h3ad Posts: 1
    i have a dodge avenger and the headlights fogged up too. the problem is not in the lens like most people think. its on the outside. a way to cure this is to sand it using a slightly higher grit of sandpaper each time until the "fog" is gone, or you can buy some cleaner used to remove the fog.
  • 3girlmom3girlmom Posts: 1
    I bought my 96 Avenger back in Oct.05. I have experienced a small leak with Transmission fluid. But for now, I just make sure to keep my fluids topped off. Mine is black. Since purchasing mine, I've seen 6 other black ones. 4 out 6 all have the same problems I see on my front of the hood and that is the paint fading (the clear coat looks like a cracked egg shell). I was wondering if anyone knew of a recall on the paint jobs on the black ones. I have 96 Avenger ES 24 valve. By the way...the car is awesome!! It's sporty and still has a unique look from some of the cars today. It still keeps heads turning!!! ;)
  • Hi I own a 1996 Avenger ES 2.5L V6 with 275000 Kilometers on it (about 171000 Miles). Car has been great and I plan on keeping it for a while longer, but have a few questions that maybe someone can help me with. 1) The oil pressure gauge ALWAYS reads on the lowest mark...is the gauge dead or do I have no oil pressure? Also 2) Recently I have noticed a clacking/clicking sound coming from the engine in the first few minutes of use, then it goes away. What is this? Is it a problem? Finally 3) On a few different occasions after the battery has been disconnected for a period of time, (and then re-connected) my Avenger gives me many problems such as will not start, if it does start it stalls shortly thereafter or when put in gear, etc. I find if I nurse it into gear and take it for a spin for about 20 minutes, it cures itself? What can this be? If anyone has some suggestions, please let me know!

    Thanks!
  • The engin swap is pretty easy to do, its just costly. All the mounts and everything will line up with no problems. When doing the swap you will need the motor, all wire harnises, ecu, tranny, and the drive shafts. Only reason why you will need the tranny and drive shafts is because its the same engin as what you have except everything is switched. instead of the tranny being on one side its on the opposite side.
  • Ive read through all the little discusion on this page about the avenger and I disagree with both guys. I think the avenger is a good car to own. Mycousin had hers for 5 years and didnt want to get rid of it but had no choice sense she needed a 4 door. She never had any mechanical problems with it and she had the automatic one. Now I have had Avenger for bout 6 months now and Im loving it. Only mechanical work Ive done to mine is what I wanted to do to it, nothing has broken. Yes I did do the timeing belt, but when ever I get a new car I do the timeing belt. My cousine had a 97 Avenger with 90k miles on it with no problems and I have a 96 Avenger manual with 136k miles on it. Now 2500 for the car I think is a little much, I would only pay 1800 to 2000 for the car.
  • i have a 97 dodge avenger with a blown motor and i was wondering if i can throw a engine from a 97 neon dohc in it? thanks please email me back at bmarcuz@aol.com
  • I have a 97 Dodge Avenger ES 2.5L. My car was running perfectly until yesterday when I rained. I was riding on this backstreet at night in the rain, when there was a puddle of water sitting that I didn't see. I drove right into it and water went everywhere. A few minutes later I see that my engine light is on. I thought maybe this morning it would be off but it's still on. Does anyone have any idea what I could have done to my car, and if it has anything to do with me getting something wet underneath my car??? please help...
  • I have heard that the air intake on the Avenger is very low, a "bottom breather" if you will, and in some circumstances like you mentioned with the puddle, water can get inside the intake.

    I dont really know what this does to the engine, but that sounds to me like what happened.
  • Karen_CMKaren_CM Posts: 5,019
    A reporter seeks longtime loyal Dodge-Chrysler-Jeep buyers who want the company to build a subcompact model or two. Please reply to jfallon@edmunds.com no later than Friday, October 20, 2006 with a few relevant comments and your daytime contact info.

    Community Manager If you have any questions or concerns about the Forums, send me an email, karen@edmunds.com, or click on my screen name to send a personal message.

Sign In or Register to comment.