Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Oldsmobile Intrigue Heating and Cooling

123457

Comments

  • pete14pete14 Posts: 11
    Try flooding the switch with WD-40 and moving it through the positions a couple of times. This has worked for me over the past year.
  • Great to hear! I will give it a shot and see what happens.
  • hey the ignition switch may be the problem.. if you need a switch or even the ac control module contact me 336 260 9027 if you need used parts.. i totaled mine but those parts are great and the switch is only about a month old... btw i am a mechanic ..
  • Victory!

    It actually was the ignition switch that fixed most of the small electrical problems I was having.

    I have to wait for the weather to get a little warmer to check if the A/C works. Weird thing is I turned on the A/C and didnt hear the compressor kick on so I may be just be out of freon... or its just still too cold outside for me to tell a difference.

    ctdunnagan- I appreciate the info, and I may contact you if i need anything to see what parts you have.
  • Well i have the same exact problem as #29. my ac only blows hot air and the a/c dash light blinks and doesn't stay on. now a while back i refilled with freon and it cooled like a new car for an hour or so. i just wanna know if i did all that could it still be the compressor, clutch or maybe just the diode? also where can i get the diode if needed?
  • tiffer420tiffer420 Posts: 7
    Does the AC Bypass Pulley not exist for the 99 Olds Intrigue 3.5? My AC Compressor is siezed so I was going too throw in the bypass pulley but I can't find it for a 3.5 ANYWHERE. Can find the 3.8 but not mine.....without it I'm pretty well screwed....
  • rm64rm64 Posts: 1
    How much is an ignition switch run?
  • My air conditioner and heater blows out all the vents at one time .. the mode button shows to be changing but it doesn't .. how can I fix this?
  • I have a 99 Intrigue GL with Climate Control and after spending $400 on mode actuators, fan resistor switches, and an electric vacuum unt, it was the damn ignition switch. That beyond my ability or fear factor to replace myself.
    Now A/C and cruise control are back to normal.
    Same story, shop initially said ignition switch could not cause these issues-well they had to take that back but at a $500 bill to diagnose and changeout.
  • dcanfielddcanfield Posts: 2
    edited October 2011
    i recently replaced the ignition box in my intrigue and the heat / ac / heated seats do not work at all could it be the heater switch
  • I hope this helps some one out because I spent a lot of time to solve my problems. 1999 Oldmobile Intrigue GL 3.8L. It started out with the lights going out on the climate control. Sometimes they would come back on. It just depended on the day. Sometimes the fan worked and sometime it didn't. I checked fuses but found nothing that did not look correct. I took it to a repair guy and he told me that the climate control unit was broken. New from GM was $860+. I bought a used one on E-Bay for under $100 but it did exactly the same as the one I had in the car. Also over the past couple of months the cruise quit working. The automatic headlights quit coming on. One electrical issue after the next. I started reading the Edmunds forum and I noticed a few other people found a faulty ignition switch. The local parts stores had the ignition swith in stock for $90. I installed this myself and it fixed all my problems. I have cruise, lights, heat, etc. ALL OVER AN IGNITION SWITCH. Sorry for being long winded but I hope this saves someone some money and time.
  • I have the same problem but I replaced my ignition switch and it work for awhile, now it's works whenever it wants too. So what now, another ignition switch.
  • I replaced my ignition switch at the end of October. So far so good. I did buy new and not a used one from a scrap yard. Did you buy new?
    It is also possible for you to check by the fuses to make sure you still have 12 V to the fuses. That is what causes the problems is a voltage drop. Hope that helps. Good luck.
  • I did buy a new igintion switch. I will see about the voltage thing. How do you check it? It's cold and a heater would be nice.
  • I replaced my igintion switch and it fixed it for months and now it's back to not working. So, what should I do now?
  • car4ditcar4dit Posts: 1
    edited February 2012
    My 1999 Intrigue had the automatic headlights stop working a few weeks ago one evening, then a few days later I noticed no more cruise control, then the heater control unit would go dark and sometimes just stop working completely after traveling a few miles, but never staying on for more than 5 miles or so. I called the dealer maintenance shop, said they would charge $98 just to look at it! So I read the posts on this forum. I bought a new ignition switch for $87.99 and today my neighbor (a Honda mechanic) spent 2 hours replacing the switch (he charged me only $80). I've since taken 2 drives for > 10 miles after dark... the headlights come on all by themselves, the cruise control works again, and the heater stayed on, and even responded to the buttons I pushed. I am so thrilled! Thanks so much to those of you that posted your issues here for people like me to read and TOTALLY solve my problem. You guys are great! My mechanic neighbor was skeptical, but admits that it worked.
  • cab434cab434 Posts: 2
    Im gonna take your word for it car4dit I have oll the same problems 1998 Intrigue. I have spent more than a year with vent problems. Headlight problems. Cuise problems. I will post
    after I buy and install my new ignition.
  • gwensbgwensb Posts: 5
    I replaced my ignition switch, too. I still have the same problem. It only worked for 4 months then it went back to crazy again. Now one size is cold while the other is hot. I hot wire the ground wire and I get hot and cold. I don't see replacing the switch again.
  • I just need do know how to fix the.mode on the AC so that you can change which vent the air.or heat comes out of.HELP!!!
  • gwensbgwensb Posts: 5
    I don't know how to tell you that. My comes out cold on one side and hot on the other side. So I can't run my ac cause it blows hot air on the driver side but cold on passenger. I'm out $1000.00 already. My brother, that's a mechanic in Texas said he has never seen that problem before. That's why I have hot wire the ground. It's on but cold and hot. My quit coming on after I paid $1000.00 to fix it. I wish I knew. Sorry!
Sign In or Register to comment.