Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda MPV Climate Control

maypo1960maypo1960 Posts: 2
edited September 4 in Mazda
Hi all...
I have a 97 mpv that up til now has ran flawlessly aside from maint. items form time to time. :sick: Recently, i noticed a marked drop in temp from my heater....and it's getting COLD in Ohio. My temp gage reads in the normal range so i decided it may be time for a flush. Flushed the system , refilled and flushed a second time with straight water as instructed in my shop manual. Now I have NO heat. I have airflow, so I figure that the ducts aren't clogged. Removed the trim and checked that the air mode and temp blend controls are working. I noticed something in the manual that said there is always circulation to the heater (even if the termostat is closed) unless the a/c is set to max or the system is switched to off. Is there a coolant valve that is operated electrically that I'm not aware of? If so, does anyone know where it is? Any help would be greatly appreciated. :(

Comments

  • subearusubearu Posts: 3,613
    clogged heater core or bad thermostat (do get the OEM one) or water pump impleler is shot

    I would bet on the clogged heater core

    -Brian
  • reynold3reynold3 Posts: 1
    Just wanted to post some info, I have a 2000 Mazda MPV with ac problems. The van’s ac will run for 15-20 minutes until warmed up and then stop, creating a drivers hazard in the muggy summer months by fogging the windshield. I had the problem diagnosed as the ac clutch. This is a fairly simple fix that costs $120 for the part, but, (Nipon)Denso the manufacturer, takes advantage of customers by forcing them to buy the full ac compressor at $600 This is not only unfair but it promotes environment pollution when refrigerant is needlessly released upon repair. Denso states that there is a 90-day wait for an ac clutch. I found this to be inexcusable and contacted Mazda North America with my complaint.
    Mazda was very helpful and I hope that they will pressure Denso to keep parts on hand for vehicles that are at least under 10 years of age, or force them to release product design data and part numbers, so that another company can make up for Denso’s incompetence.
    Mazda referred me to Mazda Mart 800-221-5156 who was able to determine the correct ac compressor for my van at a reasonable price of $250. I would still like to only change the ac clutch which promotes a greener environment because even when you do it correctly a little always leaks...
    Hope this is some help and relief for the summer heat...
  • pj2008pj2008 Posts: 2
    How many rear AC vents are in the 2006 mpv, and were are they located for the second row seating? Also, how well do they work.
    Thank you very much.
  • jipsterjipster Posts: 5,345
    AC vents are located between second and third rows on ceiling. Fan speed can be controlled from front seat, or back seat area, if driver chooses. Works dang well in my opinion.
  • Maypo1960
    What was the solution? I have a 1998 MPV with the same problem. The rear heater unit works and the temperature of the water going in and out of the core is approximately the same. Plenty of airflow. I am suspecting a broken damper inside the duct. Hope to hear from you.
    Thanks
  • ira8ira8 Posts: 2
    About three months ago I was travelling with my Mazda MPV 2003 at 60 MPH on the highway and the van just turn off. This just happen again last week. Pull over to side of the road and MPV will start up. Went to the local Mazda Dealer and their computer hook up can not find the problem. Can this be fuel filter problem? Can this be electrical problem?
  • Hello maypo1960. I read your Dec 31, 2006 posting about the heater problem in your Mazda MPV. I have a 1993 with the same problem - hot water going to and from the heater when I check under the hood, good fan strength, heat gauge is up but no hot air. Did you find out where your problem was ?
    Thank you
  • Semmpv:
    I noticed you had a similar problem to mine with your MPV heater. Did you find out what was wrong?
    Thanks
    Choquer
  • ken90ken90 Posts: 3
    We have a 2000 Mazda MPV, and can not get heat to the rear compartment. All we get is cold air. The owners manual does not explain how to get heat. Can hear and feel the blower moving air. any ideas?
  • subearusubearu Posts: 3,613
    You need to have the rear heat option in order to have rear heat. If you had heat before and now don't, then you have an issue.

    You can check underneath the van on the passenger (right) side below the sliding rear door. You'll see aluminum tubing for A/C going to the rear wheel well and if you have rear heat you'll have black steel tubing. They may be wrapped in foam along the way and will have 2 tubes each.

    -Brian
  • ken90ken90 Posts: 3
    Brian.
    Ok , I will check for the tubing. There is an overhead selector for fan speeds 0 thru 3 (I think) same as on the control at the front operators panel. So I presume the heater feature is there.
    What kind of problems can there be with the rear compartment heat?
  • subearusubearu Posts: 3,613
    If you have rear heat, the rear heat tubes can corrode in the wheel well and eventually leak. So, you might not have heat for that reason. You might even smell and see coolant leaking outside. Check your coolant level in the bottle up front, as you don't want to be w/o coolant in the engine.

    There is a Special Service Bulletin for that leak, that extended coverage to 7 years. Replacement tubing and removal of the plastic guard in the wheel well is the fix.

    Another possibility is that the flow switch up front behind the engine has the rear heat tubes getting no coolant. Possibly for the reason above, or perhaps because of previous work. Yet another possibility is that air is in the lines and needs to be "burped" out.

    -Brian
  • foxmikefoxmike Posts: 1
    I am having the same problem as in # 16 posted by subearu. I feel there is air in the lines.How do I "burp" the air out of the lines?
    Foxmike
  • I know exactly what your problem is....its called a AIC valve also known as a Automatic Idle Control Valve and they can be bought from most any parts store...price range 75 to 200 bucks and you can change it out yourself as it sits right on the top of the engine compartment.... its small and it has one elec cord to it I think.....this will fix your car from stall but you will need to get someone with a diag computer to reprogram your computer for max performance.....it is not immediatly nessesary to do the programming for the replacment to fix the problem but it is something you will want to get done.
  • cobeycobey Posts: 1
    Not sure if this will help you folks, but this is an ongoing issue with our MPV. Pretty much every time it goes into the shop, it comes back with no heat. The solution for us is the water valve. See this link

    http://www.mpvclub.com/tsb.php?id=152

    For whatever reason, the tech always like to fool with this valve...
  • What are the vents under the driver seat and the passenger seat for? Heat or A/C?
  • subearusubearu Posts: 3,613
    those vents should get some flow whenever you have the front selector on one of the floor settings, which would usually be heat, but could be A/C

    -Brian
  • It blows cold, anytime I want heat on my feet being the driver. The passenger behind, complains about the cold. I am going to change the cabin filters as well, since the air flow is weak.
  • subearusubearu Posts: 3,613
    There is a TSB about the blend door, that would sound like yours needs that work done.

    -Brian
  • How/ where would I find such a TSB, which is "technical service bulletin" right?
  • subearusubearu Posts: 3,613
    MPVClub shows it as number 07-001/04R, which you can look there or elsewhere on the 'net. Another possibility is number 07-004/04, especially if you work done on the vehicle just before you noticed it happening.

    -Brian
  • I had a tune-up done about 2 yrs. ago and we were on the way home i think and the fan sounded like it died about half power. We asked them about it but they didn't know anything and were going to charge us to dig into it. We just lived with it, but it was hot and we didn't notice the heat issues with the floor vents until it was too late. I'm going to change the cabin filter and also look for the valve. Thanks for the advice.
  • We have a 2000 mpv and the heat recently stopped working. Stills blows cold air no smell no foggy windows but there is a loud fan noise under the hood like when you are running ac. Any ideas?
  • Hi,

    I'm currently having what sounds like the exact same problem with my 2000 MPV. Were you able to figure out more information on this?

    Thanks in advance,
    Darryl
  • It was the waterpump
This discussion has been closed.