Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Kia Rio Electrical issues

2»

Comments

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,549
    I think they'll take you seriously, especially if you mention safety concerns. I also think it's electrical in nature--perhaps a malfunctioning brake light switch. This start/stop feature is integrated into a number of the car's systems (temp sensor, battery condition, engine RPMs, etc) so it could be a bit tricky to track down an intermittent problem. You may have to be patient with the dealer and/or the system might have to fail completely before it can be remedied.

    MODERATOR

  • Well i purchased my Kia Rio brand new in 2009 and my car stereo has no audio on top of that my overdrive button is malfuctioning..and one day last week i was driving at night and EVERYTHING but the car cut off! I still have payments .. at this point I am doing oilchanges and thats about it..not putting money on parts. I give it two more years tops!
  • vidarvidar Posts: 16
    The car is heading for the dealership for warranty work due to the UVO system and display being intermittent. My daughter will be taking it, as the car is not local. As she has not dealt with dealerships before concerning warranty maintenance, I want to arm her with info about any known problems with this system beforehand so that the service department will not treat her wrong.

    She told me the UVO system ocasionally resets when the car is shut down and restarted. Have not disconnected the battery as of yet, as I have been told by one dealership that there is a dealership reboot required for the cars electronics when the battery has been disconnected. I have not verified if this is correct or not.
  • skeptic101skeptic101 Posts: 29
    There has been some discussion on another Edmunds forum about the DRLs (Daytime Running Lights) on the 2012 & 2013 Rio5 SX. Do any owners here have an SX with DRLs? If so, do the DRLs use the LEDs below the headlights or reduced power of the high beam lights? Thanks!
  • I have a 2007 Rio with the battery drain problem. It has been going on for years until I noticed it only happens in the summer. If the A/C is left on when the engine is turned off, it appears some kind of relay is left on which drains the battery, rather quickly. Perhaps the AC clutch?

    A jump will always get the car started and everything is fine until the AC is accidentally left on again. Clearly some kind of design problem. I have seen other complaints about this online, but good luck trying to get Kia to acknowledge or fix the underlying cause.
  • vvirkvvirk Posts: 1
    Hey,

    First time I'm posting here, hopefully someone can help....

    My 15A "Room" fuse under the hood keeps blowing, there is obviously a short somewhere but I can't find it, neither can the Kia mechanic.

    I disconnected my stereo, clock, dome lights, trunk light and AC and the short is still there, even while the car is turned off and the key is removed (all the doors are closed as well)

    Anyone else have this issue? Is there anything else that is connected to this fuse that could be causing the issue?

    Thanks....
  • I have a 2007 kia rio and it has started the battery drain problem. I make sure every time I turn it off that everything is off...a/c, radio, lites...etc...yet it will decide not to start without any warning....I end up having to get a boost and never know when it will happen again. I have been told it was not the battery, alternator or starter. I have gone thru three new batteries since I bought this car. this intermittent start problem just started a few months ago. any one had success in getting this fixed?
  • pmdonaldpmdonald Posts: 1

    I have a 2008 Kia Rio5 and was having problems with the battery occasionally and seemingly randomly being dead. Apparently, if you unlock your car, open a door to take something out and lock it again without starting it, it will send power to the accessories which will drain the battery. In retrospect, that makes sense of most of the problems. I had. Hope this helps!

  • PF_FlyerPF_Flyer Pennsylvania Furnace, PAPosts: 5,859

    @saugerknaut said: THE FIX FOR KIA RIO BATTERY AND STARTING ISSUES!!:

    Welcome to the forums and big thanks for posting info that I'm certain will benefit everyone.

    MODERATOR
    Need help navigating? pf_flyer@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • 04kiario04kiario Posts: 4

    @aubreyd said: My Daughter just purchased a 2001 Kia Rio.It is running a little rough so we took it in to have the codes read.According to the shop the P code is"cpkl" which apparently is the fuel injectors.When I pulled the middle 2 connections from the injectors it didn't make a difference on the way it run.I have tried injector cleaner but no help.Could it possibly be a bad injectors or a fault signal to the injectors.Could someone please help.

    Try checking your upstream HO2 sensor or (oxygen sensor). I was having this issue with my 04 kia rio and was thinking it was injectors, until I stumbled over a manual I got for it at mitchellsDIY.com. And it stated that the upstream oxygen sensor tells your ecm info to send signals to your injectors. It's worth a shot because they are really easy to replace and may fix your problem.

  • 04kiario04kiario Posts: 4

    @john6161 said: Greetings

    My daughter’s 2001 Kia Rio has intermittent starting problems. It may start 10 times in a row however on the 11th try NOTHING. Will not turn over or anything else. The battery is strong but apparently each time it has not started she had it boosted and it started. Makes no sense to me as battery is good.

    I have it in my driveway, started a few times no problem but now will not start, as I said will not even turn over, sounds like an ignition problem to me but I am a novice. Any advice would be appreciated.

    Try checking ECM(cars computer), or possibly ignition coils? Did you try checking your alternator? because they will drain even a new battery if given enough time to. Since the alternator is your charging system for your battery. that could be the case.

  • 04kiario04kiario Posts: 4

    @cynthia said: I bought a used 2006 rio about 3 months ago. It has less than 50000 miles.The battery has drained on me 2 times. The first time I was at home so it wasn't a big deal. I have 24hour roadside assistance with my insurance so someone came to jump it and I drove it to the dealer. They said the battery was drained and they recharged it. I didn't know what had caused it to drain. I thought maybe door wasn't closed all the way and the interior lights were on or something so I set all of them to off so they don't come on when you open the door. It's been 2 months and I was leaving walmart and the engine died when I was trying to leave. I turned it off and restarted it. I was halfway backed into the aisle and it died again. I tried to restart and it wouldn't start.

    Same problems, except my battery was totaly ruined. Today I have 5th battery in my car within one (1) year.

    I really liked KIA. But after this experience, I'm not sure about their cars at all.

    Have you had your alternator checked?

  • 04kiario04kiario Posts: 4

    @sufan1 said: I am having the same problem as #14. Did you ever find out why. I need to get my car inspected and it won't pass with this problem

    upstream heated oxygen sensor

2»
Sign In or Register to comment.