Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac STS/STS-V Maintenance & Repair

13»

Comments

  • leadfoot17leadfoot17 Posts: 1
    What can cause the temp and fuel gages not to come on when starting the car? They come one sometimes then they go off again also there is a check engine light on, I heard this is an uncommon problem, can it be repaired without alot of on going expenses?
  • dgrunskydgrunsky Posts: 1
    I have a 2000 STS and have a similar problem. Traveling 75+ steady speed on a hot day, it will suddenly run hot and give "turn off A/C" indication. Also, the fuel gauage becomes erractic. After slowing down and turning off the A/C, the engine cools down. If I stay below 65, it does not heat up. Any suggestions?
    dgrunsky
  • bsteve2bsteve2 Posts: 1
    Not only has our 2005 STS, originally owner, had excessive problems, which it has, but repeated problems after repair has resulted in the cup running over. In summary the car and/or the service we get at Moritz Cadillac, Arlington Texas is worthless. To name a few; our entire electronic dash board went out (totally back) several times when trying to connect with our Bluetooth phone, once it happened by Moritz’s service agent at the dealership, when trying to show us the proper way to connect. Needless to say, we will not try to do it. Never had a vehicle I can’t use with its own features. Then there is the automatic steering wheel extension. We are now on our third. Today we brought the car in for a repeat tire monitor service message. Moritz dealership said the repair would take no more than a few hours, wife got there at 9 AM and left 3 PM, some of the delay was due to the services techs lunch break. The straw that broke the camel’s back, that within 20 minutes of leaving the dealership, the “service tire monitor” message came up for the same wheel.
    These are facts; unfortunately we are stuck with the car. Sad thing is if the car got stolen, it probably would not work and the thief would not be able to move it or bring it back. In all seriousness, Moritz is responsible for incompetency. Never had I had a so called luxury car that would be better suited as a boat anchor and possibly useful to plug BP’s leak in the Gulf.
    I am sure Moritz will try to go after me for liable; however, I have every service receipt to back it up. Less the one they would not give me, when for another reason the problem reappear immediately as we left and just went into reverse into the service area.
  • jjbuckleyjjbuckley Posts: 1
    Hi all, hope someone can help with my saga.

    94 STS 134K miles was running great except for bad heater blower motor.

    Went off for long weekend, came back and started the STS to go to store, car ran horrible, a bad stumble/hesitation on acceration and rough idle. No codes set.

    Came home and decided to pull battery cables and clean and check for proper grounds.
    Started car got error codes and in the DIC it said "traction disabled" Stop engine, low oil pressure. Checked codes and got IO34 loss of PCm data, IO52 keep alive memory, TO72. went in to OBD to clear codes and of course I have a "No PCM data" all paramaters are there, ABS, SIR, ACP, TCS, RSS, went in to each one to the clear codes and did that now I just have the IO 34 code and dashes in the MPG and Range Displays. No info in the DIC from any PCM parameter ie: Temp, MPg...

    The car will start and run, but only in the default mode of 2nd gear only, bangs very hard when you put it in gear.

    I checked the main grounds on each side of the radiator, replaced the battery cables still have the problem.

    I checked the voltage at pin M of the ALDA connector to ground, got 3.79v to 4.29v it varies constantly. I did this to see if the data line was locking up.

    Decided to swap out PCU with a friends, his STS was rear ended but the front end is ok, still have the same problems, but I got a ACP code and dashes in the Temp display with his PCU, car would start but still has the problems, swapped back to my PCU.

    I then swapped the IPC out still have the same problems, I put mine back in.

    I am at a stand still I do not know where to go next, any ideas would be great.
  • elburnelburn Posts: 4
    I have come across a Cadillac Seville STS. It is a 1998,34,000 miles. Selling for $5800. What do you think? Is this a good deal?
  • 98 STS 108000 miles. Recent headgaskets and inserts done at dealer. Car run and drives.
    Car needs some work. Interior and exterior in good shape. anyone need a good parts car or fixer upper. Asking 2000.00
  • My 2003 caddilac sts will not start i drove home from work today and the car was fine when i parked it i went to start the car a hour later and when i turned the key it stared clicking the lights went dim and then nothing i tried to jump the battery and nothing. is ther a fuse that might be blown please help.
  • Hello everyone. I have a 2005 STS with 30,000 miles. The only problem I've ever had with the car is replacing the battery. I am having a problem with the A/C discharging water into the passenger floorboard. I can usually hear water "gurgling" somewhere in the dashboard just before the water flows. I have read that the discharge hose is probably clogged. Where can I locate this and what is the best way to unclog the hose? I have read about using compressed air and wire coat hangers. Please advise!!
  • gmcustsvcgmcustsvc Posts: 4,130
    homewoodman,

    Please keep us posted when the issue has been taken care of. If you have any questions or concerns please feel free to contact us directly.

    Thank you,
    Caron, GM Customer Service
  • janette12janette12 Posts: 2
    We have a 2005 Cadillac STS 3.6L V6 with 86,000 miles on it. The timing chain tensioner failed causing the timing chain to break and now we have been told the engine needs to be replaced. We just bought this car in March so really have no choice but to fix it. Our mechanic says this seems to be common but we can't find any TSB's regarding this. Anyone have any suggestions?
  • gmcustsvcgmcustsvc Posts: 4,130
    janette12,

    I apologize for the problems you are experiencing with your vehicle. Could you please email me your VIN? I would like to look further into your situation.

    You can get my email by clicking on gmcustsvc.

    Thank you,
    Caron, GM Customer Service
  • jpfjpf Posts: 496
    Check out forums for other GM cars with 3.6L engine, e.g.'s GMC Acadia; Cadillac CTS; Chevrolet Traverse; etc. All of them have separate discussions about this engine's problems. Good luck.
  • Did the dealer solve the problem for you? If so what was the problem?
  • emfmsremfmsr Posts: 1

    my 2008 sts is using 2 to 3 quarts every 6,000 miles. started last year. i have 105,000 miles on the sts

13»
Sign In or Register to comment.