Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Buick Century Electrical/Lights

124

Comments

  • cshousleycshousley Posts: 3
    I have the same problem. What did you do?
  • mushkamushka Posts: 1
    Where can I find a replacement cluster for 2001 Buick Century
  • cshousleycshousley Posts: 3
    I cannot vouch for this company as I have not used them; however, I did find this company that repairs an instrument panel.

    http://www.mrwhizard.com/index.cfm
  • Kirstie_HKirstie_H Posts: 10,913
    You can also check www.car-part.com. They have a pretty good list of parts from salvage yards all over the country. If you don't feel comfortable ordering, you can always use the site to help find a salvage yard near you, then you can work with them on getting the replacement part.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • i have been reading past discussions and mine is different. my dashlights are out meaning my odometer and my gear shift for my 2001 buick century custom now my lights are out but my tail lights still work what do i do?
  • If it is just the odometer and gear shift lights that are out, go to Youtube and do a search for Buick Century dash lights... Eventually you will find info and video about the four resistors that need to be replaced. Worked for me. Cost less than 2 bucks from Radio Shack. Of course I took out the dash, get instructions... I had a friend who was more experienced at sodering to soder on the new resistors. Saved me a bundle.
  • I got a 2004 buick century with the same problem of the headlites going off,then hitting the hi beams makes them come back,,any solutions ?? Zapp
  • I have a 2003 Buick century, which for the past couple weeks has been driving me crazy with blown bulbs. First was the back up lights, replaced those, then tail lights, replaced those (one by one), then brake light. I eventually replaced every bulb in the rear light cluster. Now instrument panel and all tail lights out, found the bad 15 amp fuse replaced it and still no lights. When everything started I did notice a hairline crack in the tail lens which was allowing water to get into the tail lens and corrode the bulb housings. I sealed the crack and checked for any damaged wiring however other than a little corrosion which i cleaned, nothing. Please help I'm pulling my hair out. I'm pretty sure its a short in the wiring however electrical wiring diagrams are like french to me. PLEASE PLEASE tell me any advise on where you think I should start looking for the short. Thanks
  • This problem just happened in my vehicle too. I was wondering if you would happen to know the part number or what the part is called?
  • did anyone find out what the problem is...same thing is going on with my daughter's car
  • Did you find out what it is and could you share it? Same thing is going on with mine.
  • Hi,

    I tried that on my 1998 Buick Century and and nothing happened. Could you be more specific such as when to insert the ignition key, and what position to set it to?

    Thanks,

    Michael F
  • boo321boo321 Posts: 1
    edited December 2011
    After changing tail light and turn signal bulbs, my 2002 cedntury started up but the stalled. I tried to start it again and now it won't even turn over. The security light does not stay on, but my brake light and fuel light stay on and i know I have fuel in it, but along with the light staying on it also stays on E. Any help would be great
  • Hi, I have a 2005 Buick century. My lights behind the speedometer went out, not the lights for the P/R/D. I took my dashboard apart and replaced the lightbulbs thinking this would work, but when we tested the lights, they still didn't turn on? Can anyone pls help?!! Thank you!!
  • I had this problem with my 2001 Century. After checking everything I coud think of and replacing many fuses, I accidently found the cause of the problem.

    While opening my trunk with the lights on after just replacing a fuse, the fuse blew again, but in the darkness of the trunk I caught a glimpse of a electrical spark near the right side trunk hinge.

    I found the problem. The wiring harness retainer does not allow enough slack in the harness where it comes into the trunk lid from the body. The wiring eventually breaks from flexing at that point. The wires then short together knocking out taillights, and all dash and control panel lighting.

    I got many outrageous repair quotes and suggested solutions before stumbling on the simple answer to this problem.

    I hope this helps you even though your post was a while back. Maybe it will help others too.
  • Thanks oldiron86. We bought an 02 Century 5 weeks ago and 3 nights ago, I had no dash lights. After finding your message, we checked the tail lights and realized they were out, too. We unhooked some of the wires to try to find the bad wire by trial and error and after blowing 4 fuses, we think we have narrowed it down some. I now have dash lights and tail lights, but no back-ups or license plate lights. The wires had all already been taped up with electrician's tape, though. The dealership where we bought the car wants $90 for a diagnostic and then go from there. I am not excited about spending more money on this vehicle. I'm guessing I need to remove the electrical tape to see if I can figure out which wire is bad?
  • ok i gotta 1999 century im looking at cooling fans wont work tested all relays and they work one fan was burned out i replaced both and all fuses going to it. another issue is the ignition seems messed up turn on key to start and car starts right away minus the turning it that one click forward to start then it goes back to stay in the run position i turn it forward and back a few times sometimes it works again sometimes it does not. ok most of the times it does not put in new ignition switch and key worked for a while like 8 hours now back to square one. i am gonna try this trunk wiring ordeal to see if thats the culprit. however i had a 2001 lumina that the cooling fans quit working on as well caused my junk plastic intake gasket that those gm morons used to crack which i had to replace which i found the special tool and did so. and of course got the upgraded metal gasket. i am lost i have checked all fuses and relays. please help going to wire the cooling fans to a toggle switch for now.
  • the check eng light and the abs light and the trac light are on and sometimes goses off
    has anyone els had this problme and mybe could shine some light on this
    i try and pull codes and it comes up w nothing
    i was thinking mybe the ecm or body control moduel ?
    let me know oh the low tire light as well and i check the tire presser and nothing
  • after getting intake manifold gasket replaced, next day engine wont start w/o revving gas, 3 days later radio and windows don't work. replaced ignition switch. mine definately was bad. started right up first day , radio and windows work on On position but not while running?? engine will start sometimes w/o revv
    ing, but mostly have to rev to start. also stalls out when making turns. engine revs high on its own sometimes. My friend who is a wrench head is baffled. It is odd it ran purrfect before the gasket manifold was replaced? My wrench head was outta town so had it done elsewhere. mechanic accepts no responsibllity. any help would be appreciated.
  • I have a 2003 buick century the right side headlight wont work, i replaced the bulb and still wont work. I have power to the conector on the red wire. I put the new bulb in the left side and it worked there. I'm stumped now help?
    thank you any help wecome
  • my abs,serivce eng light and trac n low tire light on ........i have
    been looking online and havent seen anything that the cluster
    is the problme bc all i have seen is there bulbs not lighting up
    and they come on after starting the car and putting it in gear
    and sometimes not comeing on for a short while but then come
    on and i check for codes in the ecm and i reset the sereivce light
    and it dont reset the light and i check w the dealer and they said
    the cluster is usaly at falut and had one there w the same problme
    lol but they didnt check it out and he thut it was the cluster
  • do u have a gd ground ?
  • dex_cerdex_cer Posts: 1
    mine is 2002 buick, after 2 bulb replacement i found out that there was a short in wirings connecting to that bulb because it lights up after i bend the wiring or straighten the wiring, unfortunate for me i have to replace this since my headlight was completely glued. and it cost me 80 bucks for the whle set ibought online.
  • rasbertarasberta Posts: 1
    ok so what was the simple solution? i have the same problem on my 2002 Buick century.the brown/green and black wires are spliced because of the trunk..how can i fix this myself?
  • I just had the Body Control Module replaced on my 05 Buick Century due to the radio and dashboard lights turning on on their own. This would always happen about 2 minutes after the car was turned off and locked with the keyless remote.

    About a month after replacing the BCM, the headlights in the car turned off completely while driving a night when trying to turn off high beams. The next day the horn was going off intermittently with no one in or near the car. The car had been turned off for two hours when this started happening.

    Does anyone know what this might be happening??? Help!!
  • Hi Chuck,

    I have the same issue on my '03 Century, did you get a response to this?

    Thanks

    Martin
  • My 2001 Buick Century is having multiple electrical issues. The other issues is whenever I start the car the drivers side window goes down If I can get it up then when I turn the engine off the window goes down again. Most of the time the window won't go up w/o turning off and on the radio or some other electrical device like the wipers and will only go up a little at a time each time I turn something on or off.
    Also, I'm assuming that this electrical problem might be the cause of another issue - the car won't go into reverse sometimes. This issue started at the same time as the window issue above.
    Any help would be greatly appreciated.
  • 2000 Buick Century Gear indicator light out and odometer light out. I found a small company in Florida who fixes this for less than $150.00 a few years ago. You have to take your cluster out and send to him. I should have used the Florida guy but I fixed mine myself after I found a youtube video but it's not easy. There are 4 small resistors on the rear of the cluster circuit board which come from the factory with cold solder joints. They are small and don't have pigtails and are hard to solder. Mine worked but eventually failed again. If you find a cluster from the junkyard (that works) the mileage will be wrong of course. The cluster is really not that hard to remove. A dealer will hit you for over $500 for this fix.

  • 2000 Buick Century. Electric windows, overhead courtesy light, and radio quit working all at the same time. Can't find common fuse or relay. Checked individual fuses, all OK. Talk about weird. HELP! I did have to jump start the thing not long before this happened. This has nothing to do with the common window regulator problem. I've changed so many of those that I can do it blindfolded.

Sign In or Register to comment.