Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626 Troubles

1565759616284

Comments

  • janusjanus Posts: 2
    :lemon: i have mazda 626 94, i have sound of "not taken key from the ignition" ALL TIME,
    WHAT TO DO ?? WHAT WIRE DISCONNECT ??? TO STOP THIS SOUND ?? JANUS
  • thangpthangp Posts: 1
    Since you recently replaced the entire exhaust system and the problem has worsen. I strongly suggest you should check for loose or broken wires of all the O2 sensors.
  • oshawaoshawa Posts: 16
    I fixed my misfire problem. I first thought it was the injectors, wasn't. I have noticed a lot of you 4 cyl 626 owners have this problem so here is a little help.

    You will need a 10mm wrench, screwdriver + pattern, clip remover-pliers, and a can of Carb cleaner or Brake cleaner (brake is more powerful...use wisely.) open your hood and find the little "Ford" logo just passed the air filter box. Before you do anything--> disconnect the neg (-) battery terminal.

    The problem with mine was a dirty, dirty MAF

    1. Release the air filter box clamps (like you are looking inside at the air filter).

    2. Disconnect the MAF (Ford thingy) wires [hold the clip in underneath and pull from the connector)

    3. Disconnect the "other thing" that plugs into the air filter box [pull the two clips on the side away from the connector and pull connector out)

    4. Now, your air box and MAF are freer to move, so use a screwdriver to release the clamp on the top side of the MAF to remove both the MAF and the box as one piece (it makes it easier to take apart like this).

    5. Be very careful on this step! ... Use your 10mm wrench to remove the 4 bolts that hold the aluminum housing to the air box, keep the gasket.

    6. Now you have your MAF removed. As you may notice there is a metal screen, you may or may not remove this, it's up to you. I did. You will need the clip removers to remove it, as you can see.

    7.) Looking through the screen you will notice a little hole on the top side; it's probably black and covered in soot. Bingo, that's the problem.

    8.) Take your Carb cleaner or Brake cleaner, and spray inside the whole aluminum housing, just to clean it out. DO NOT TOUCH ANYTHING WITH A CLOTH OR Q-TIP, OR FINGERS DO NOT TOUCH IT, THESE ARE VERY SENSITIVE SENSORS. Spray inside the black hole... Spray ONLY...DO NOT TOUCH.... just a few squirts will do. You must not use anything other than an alcohol-based cleaner as this is an Electronic component area. When you are done spraying, the little hole should be sparkling clean, and you will notice inside there are shiny bright little wires (2 I believe).

    9. Let the cleaner evaporate for 30 mins (just to be safe)

    10. Re-assemble and install your part.

    If this works for you, congratulations, I know the feeling. :)
  • bwade1bwade1 Posts: 8
    I just replaced my expansion valve and receiver/dryer as per mechanics diagnosis, and everything worked great for about a week. I got in it friday and the a/c is blowing hot air again.
    I checked for leaks and can't seem to find any, and the compressor is definitely working so I'm stumped.
    Any ideas what could be wrong?

    Thanks.
  • p100p100 Posts: 1,116
    Here is what happened to my 99 ES V6 A/C:

    Around 30K miles it started blowing hot intermittently. After replacing the receiver/dryer and the expansion valve under warranty, it still did fail intermittently until it finally quit for good. Turns out my coolant overflow tank leaked slowly and hot coolant got into the A/C compressor clutch harness connector which sits directly under the coolant bottle. Replacing the leaky bottle and cleaning the connector fixed the problem.

    The system worked great until about 100K miles when it suddenly quit. This time it was only the A/C relay (about $ 25 from Mazda). I diagnosed and fixed the latter problem myself.

    Don't be so sure that your compressor is working. Make sure the compressor clutch is engaging. You can see that by watching the clutch rotate as an assembly (when A/C is off, the A/C clutch sits stationary, and only the pulley rotates.

    If your A/C compressor/clutch is working properly, and the system pressure is correct, then I would check the A/C expansion valve for blockage.
  • puffinboypuffinboy Posts: 2
    I have something rattling inside the compartment by the passenger side airbag. Does anybody know how to ge the cover off so I can take a look to see what is making the rattling noise?
  • bwade1bwade1 Posts: 8
    Thanks P! That gives me lots of things to check but the last thing I want to do is take it somewhere and pay someone to diagnose it, I'd rather do it myself.
    I do notice a slight loss of coolant sometimes, usually about 5-10 ounces a month, probably overflow loss so I'll check that first.
    Thanks for explaining how to check the compressor clutch.
    BTW, I noticed a sound coming from the evaporator/expansion valve area under the dash after I had it working again. At first, it was a slight "whoosh" or "hiss" sound every now and then, like gas flowing through a valve (logically) but after it started blowing hot again, the sound was more consistent. Any idea what it was? Or maybe related to my new prob.

    Thanks again for your thoughts, I'll check those out and get back to ya.

    B
  • bwade1bwade1 Posts: 8
    One more question if you would...

    How do I unclog the expansion valve if it is indeed clogged?
    Do I just run water through it, or poke it with a screwdriver?
    I don't want to mess it up.

    Thanks again.
    B
  • sudongsudong Posts: 2
    I am a new member with my 1999 Mazda 626 ES. It is a nice car but with one problem. The air condition doesn't work well. It is not as cool as other Mazda 626. I don't know what's wrong. Do you guys have the same question? One of my friend has a 1998 Mazda 626 LX, and his air condition works perfectly.

    Thanks for your help.
  • ruthmaruthma Posts: 1
    Hi. does anyone know if the problems with the Mazda transmission affects the manual transmission as well? I am looking at an older manual 626.

    Thanks

    ruth
  • Engine Light Flashes on / off VERY briefly during warm up period. During this time the Mazda bucks or acts as if it is being pushed by a trailer for just a moment. If it's parked and idling the RPM's will dip and idle is rough but when the engine light is on.

    After the engine warms up it just purrrs - Engine Light no longer comes on or even blinks. Could it be the O2 sensor or the EGR? :confuse:

    Thanks - Paul
  • bwade1bwade1 Posts: 8
    The first thing I'd check would be the refridgerant level. It's usually the most likely problem if you're a/c isn't blowing as cold as you'd like.
    Ideally the temperature in of the air coming out of the vent is about 40 deg. F, but if it's hot outside, then it should be about 35-40 degress cooler than the air temp.
    It's best to have a mechanic certified in a/c repairs to check the pressure and add more r-134a if necessary.
    If you want to do it yourself you can buy a kit at the auto parts store near you.
    If your system is blowing somewhat cool air still, don't add more than 1 small can of r-134a. The entire system only holds about 2 cans total, so if it's a little low, then less than 1 can will do.
  • oshawaoshawa Posts: 16
    I had this happen back in the winter.

    Check your air intake hose for splits/cracks.
  • oshawaoshawa Posts: 16
    Just peek underneath the car, check if boot('s) cracked. If it is the CV drive shaft, it is a SOB to replace.
  • hazehaze Posts: 1
    Hi,

    I just got the diagnosis engine code PO 421 (on a mazda 626 year 98).
    If I understand things correctly from your discussion
    - there is a 8year warrant from mazda
    - the PO 421 code means that I should replace the cat converter
    - doing nothing wouldnt hurt the car - just makes its impossible to pass the smog/emission check
    - I could buy a cat converter for 150+ usd or so and replace it myself

    thanks
    haze
  • sudongsudong Posts: 2
    Thanks for your help!!!
  • xerosxeros Posts: 2
    I got a 1990 Mazda 626 DX from a friend about a year ago. Original engine, auto trans., and Fuel injection. 197000 miles.
    Recently I was driving home and my CEL started flashing in some pattern. I pulled over and it looked like there was low oil. so I filled it up. Today the light came on again but without the flashing. It will only come on while I am doing city driving. My MPG is hanging around 10-13(if that helps at all). I was also wondering if I should spend the $85 to take it to the dealership to ONLY get the codes from OBD1.
  • smokin739smokin739 Posts: 1
    My starter broke away from the engine. How do I get the starter out? there are electrical wires and tons of SH$% in the way. Can anyone help me or point me in the right direction. Do I go from the top or the bottom?
  • alcanalcan Posts: 2,550
    Which engine?
  • p100p100 Posts: 1,116
    You obviously need to remove the valve to inspect it. This means you must remove the refrigerant from the system. One way to clean the valve without damaging it is with compressed air, or with a thin wire. I o not believe these are that expensive to replace either. I would not remove the valve for inspection and cleaning until I eliminated all other possible causes. BTW, at 115k miles, my coolant bottle developed a slow leak again, so I needed to replace it. This time the A/C connector did not get contaminated.
  • p100p100 Posts: 1,116
    No, 4 cylinder manual tranmsission cars are much more reliable than 4 cyl automatics. V6 models have pretty good Japanese built auto transaxle.
  • p100p100 Posts: 1,116
    Severe steering wheel shake could be cuased by a bad tire with a broken steel belt, or by a loose tie rod. Not so severe shaking by a tire badly out of balance.
  • jkiserjkiser Posts: 1
    Hello,
    Our 1988 Mazda 626 has been quite reliable but, recently we have ran into two problems:

    1. When I try to start it, nothing, indicator lights come on but no crank. So, I am forced to push start it every time. I have to look for hills to park on, what a pain. It got this way, but at first it would fluctuate, start, not start, start, start, not start...
    Then just a few days ago it just won't start without popping the clutch on a push.
    What could be wrong? Distributor? Starter? I replaced selanoid already, what do you suggest?

    2. Just a day ago I noticed my 626 having hard time accelerating. So when I try to get on highway it takes a slow entrance and soon I am up to speed but the engine doesn't have the same umph as usual. What could be going on here?

    I also was wondering what should be checked on a tune-up? I really need to have one done soon. I want to know what is best for my vehicle.

    I really appreciate any form of reply and I just can't express how impressed by all of the posters here. What a wonderful sense of cooperation.
  • Hi, I have a 626 DX 1994 4cyl 2.0 manual, here's my problem. Yesterday when i stopped at the red light (after driving on the high way for half an hour, engine running3k rpm) my battery light turned on, it went like this for the next 10 light or so and then it didn't reappear... I suspect the alternator, is there any other possibility? I changed the battery with a brand new one this winter. Also, when i accelarate too quickly (on sliperry surface ;-) ) the front tire loose grip and then the car start to jump!!! the problem is: me, front suspension, motor rack/stand or else????
  • yahyah Posts: 2
    hey, I haven't had a tuneup on my 626 2002 yet by I get my spark plugs changed so why is my check engine light on again and there telling me at auto zone tht it's another misfire on cylinder 3 and I changed it 2 mons ago w/ plugs& wires. Help anyone!!
  • yahyah Posts: 2
    help what is a good price for a tune up
  • mazda626atxmazda626atx Posts: 227
    I have heard from many here that Auto zone will pull the codes for free. I do not know if that applies to OBD1 models.What other symptoms aside from just the CEL? There are Mazda sites that show you how to draw the codes yourself ,My Mazda is a little confusing. Usually it is done by jumping the tens pin and the grnd pin in the Diagnostic Locator box that is next to the battery. You should be able to do a google for your year car and get the exact instructions from a mazda 626 site. Those sites have generation 1 which is prolly yours . Good Luck
    :) Also this forum may have gen 1 cars on its home page
    Good Luck
  • boltsbolts Posts: 3
    Hi, I have a 1994 Mazda 626 ES V6, automatic. Within the last month or so, my car has begun to stall while slowing down, progressivly becoming more frequent. All that needs to be done is to put the car in park, turn it off and re-start (starts no problem). More recently, in addition to that problem, while driving the car it jerks and the engine light comes on. The engine light is usually on, unless the car is turned off and started again (some times a few times). I brought it to Mazda to do a diagnostics and they said it was the distributor assembly. I brought it to a mechanic that just changed it for a new distributor. On the way home same problem occured and when stopped it's even worse now, it seems like it's going to die. Any suggestins? I think I may have waisted a lot of money. Please feel free to e-mail me any suggestions or thoughts. THANKS FOR ANY HELP
  • Hi, the gas pedal on my Mazda 626 (1996) is very hard first thing in the morning or if the car has been parked for some time. If i start the car and give it upto a minute the pedal will be fine. Or unless i give it a good kick when i'm in a hurry, but not always happy doing this.

    Is this by design or is there a fault? the car has done 102k miles, if this has anything to with it.

    Any help is greatly appreciated. Thanks.
  • kent5kent5 Posts: 3
    I'm considering to buy a 2000 Mazda 626 LX with an auto transmission. My friend, who helped me test driving it, felt "not smooth" when he stepped on the gas pedal. Especially when transmission shifts, he feels a little shake. I was wondering if anybody had the same experience. Is it a big problem? Thanks.
Sign In or Register to comment.