Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626 Troubles

1787980818284»

Comments

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,244
    Well with a flashing HOLD button (meaning there are trouble codes stored) and an airbag light on, this car sounds like it has more problems than you really want to deal with. This means the airbag will not work in an accident.

    MODERATOR --Need help with anything? Click on my name!

  • mazda626atxmazda626atx Posts: 227
    UPDATE

    Hi Guys,
    Its been a long trouble free time since my last post here. My wifes 94 626 LXA ATX Air Bag started lighting up last night. It flashes then stops then flashes again. Never stays on solidly.
    Car has 88K miles on it and is in Athens Greece.
    I cleared the codes with the battery disconnect step on brake pedal for 10 seconds trick.
    Brought it to a Mazda guy who tried to run diagnostics on it and it showed no codes.

    It was not flashing when I brought it and now its flashing like crazy He asked me if the I4 is a FS V or FS1 I did not know the answer. The 93 is a Ford EEC IV ignition so I dont think he will ever get any codes.

    Unless the airbags are different from the OBD 1 system the only way I ever got codes in 10 years is the OBD1 jumping wire, and reading check engine light pulses

    Any ideas ?
    Does anyone know what the 1993 626 LXA I 4 engine is . Here is Vin if that will help
    1YVGE22C2 R5204361

    He said when light flashes that means airbag will not open. I am afraid it will open when wife is driving it . Is he correct ?

    Thanks
  • dizzydeedizzydee Posts: 1
    I think the best thing to do is go get it hooked up to a code reader cause I would say it is either or more along the lines of crankshaft position sensor or any one of those sensors or you can also do some of it the old fashion way with the digi meter. but with the money you will fork out on this and that you could have bought yourself a code reader lol. good luck don't know if I helped but that is what I would do.
  • Hello, my mazda recently started reving high when i first hit the gas. it would go up to 3000 rpms when i was just trying to go 40mph and then it would jump down to 2500 and then 2000 and then stay there, i kept driving it then eventually the O/D off light started flashing and then eventually it stopped going into gear. I then got a new transmission and got my car back today and the car runs again but it is still doing the jump in rpm's, the light never came on. Whats the problem? Please help.
  • Had the same problem after i changed my transmission for about 4 months. I did like you, kept driving it on high speed and now it seems okay, I'm not feeling that anymore. I can't say for 100% that it's gone, but just don't have it for now.
  • I logged into this site to verify what my mechanic had told me about the rear end noise on my 99 Mazda 626 LX 6c..... Not only was his assumption matching, but I have learned that I am one of the luckier ones..... my 626 has over 174K miles. I have owned the vehicle almost two years and have only replaced relays that have failed.... And then only because I traveled to hotter weather than in Humboldt that made it noticeable. Wow..... I now need sway bar bushings to stop the noise in the rear.... But be aware, there are good ones out there. I have had all the usual preventative maintenance done, although not necessarily to manufacturer timelines. (I went a year between oil changes, but I don't drive much in Humboldt.) But my Mazda never fails me, and for that I am grateful. Thanks for helping me count my blessings!
  • Hi, one day just starts a strange sound on the main belt section and when driving RPM reaches 2,000 with all gears car starts to falter (choppy), it all ends turning into more than 3,000 rpm. also higher than 3000 RPM strange sound disappears . I already replace ignition leads and spark plugs, can be Something with a crankshaft that he intercept timing belt?
Sign In or Register to comment.