Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Intrepid

1105106107108110

Comments

  • james234james234 Posts: 7
    Hi Grant assuming the oil level is full, it sounds like the oil pressure sensor is bad so I would change the oil filter and see if it will still light up. If it still lights you may have a bad oil pump.
  • terri15terri15 Posts: 2
    1995 Dodge Intrepid. First the Dimmer switch went out, replaced it. lights on the dash panel (ABS, Gas Gauge, Air Bag, etc) dont always go off some of them work some of the time and some of them dont. Its what the car wants at the time. Even the motors in the windows quit working, had them replaced, now they wont work again. Now you can put the vehicle in Drive, Reverse, or any other place and its just like you did nothing to it, it wont move, only when it decides too. I really need help I have put mega bucks into fixing the car and the same stuff keeps happening all over again...I really love the car but just cant figure out what the problem could be.

    desperate for help
  • terri15terri15 Posts: 2
    my 95 intrepid is doing the same thing but is getting worse...did you ever find out what the problem was????
  • chelseychelsey Posts: 1
    I have a 02 Dodge intrepid. V6 3.5L - a couple of months ago - I was making a U turn & it died out, wouldn't start again. Mechanic said it was the timing? - Got that fixed, then the oil light started to come on.. to make a long story short, 3 diagnostic test's, 2 mechanics and $600.00 later, the oil light STILL comes on at idle/stop & below 2000rpm. Engine light is also on. It seems like the oil light goes on sooner, as the car warms up & is ran for a while. When I step on the gas - it sounds like a washing machine. Like the engine needs more power. One test said it was my gas cap, one mechanic said it wasn't my oil pressure, but no one can figure it out! Too much $$ to go to the dealer, no warranty. Thoughts? Please HELP! :sick:
  • grant74grant74 Posts: 2
    My 96 had the oil light problem when I turned or applied the brakes, the light would come on.....turned out to be the low oil sensor by the oil filter, cost about 14 dollars, replaced it myself...solved the problem. Good luck
  • coop85coop85 Posts: 1
    Are you sure that you do not have the infinity system? If you have tweeters in your door and in your dash then you do. But anyway if you are sure that your car has the factory amp, it is located on the passenger side kick panel, once you remove the panel and look up, you will see the amplifier. What sort of a noise was your car making when you tried to play music? Because mine sounded like a pair of headphones even when the system was turned all the way up.
  • I have a 2004 dodge intrepid thats having electrical issues. dash lights will fricker, headlights also if on then they will go off just for a second.radio will also go off and speakers will pop.Doesnt do it all the time just when it wants to. can anyone help?
  • andre1969andre1969 Posts: 22,070
    my 2000 Intrepid got totaled when someone pulled a hit-and-run on it in a restaurant parking lot. Hell of an anniversary to remember, but it sticks with me. Just thought I'd pop in, and see if there's any activity still going on here. Nice to see a few of you guys still have your Intrepids running.

    I miss mine. It was just a base model, with the 2.7, but it was a good car, and the only brand-new car I've ever bought. It had about 150,000 miles on it when it got totaled.

    Oh, as for the oil pressure light coming on, mine did that too. There's a TSB for it. In my case it was just some sensor that got too hot, and in some instances where it didn't get enough air flow, such as stopped at a traffic light, fully warmed up, it would flicker. Mine started doing it around 85-90,000 miles, I think.
  • bobe4bobe4 Posts: 12
    My sympathy to you for your loss. My 1999 Intrepid is still going strong with 178,000 miles. I bought it new in June 2000. In September of this year I drove it 4300 miles from the Denver area to LA and from Imperial Beach to Oregon along the California coast and back home. It averaged 26 mpg as registered on the meter in the overhead console. Driving time was something like 85 hours. The only thing I don't like about this car is that I love it so much I can't get rid of it. There is nothing in my price range to replace it.
  • I have read many posts about water leaks on the driver side front interior. Has anyone figured out where the leak is? Mine started this winter. I resealed the winshield to no results. It isnt leaking coolent, just water. I own a 2000 and have had it since brand new.
  • tkfitztkfitz Posts: 95
    Just in case you stop by again.....
    The old girl just got her 115000 mile oil change. I put new fuel tank straps on last Nov. Still runs well. Starting to have a few minor rust spots that will need attention this Spring. I will need to replace the stabilizer arm bushings frt and rear, and new front brakes. Also need to get in the dashboard and replace the light bulbs....also drivers side rear door locking actuator needs done...All can wait until warmer weather comes. I use the Intrepid for a daily commuter now that my wife got a newer car. Average just under 30 mpg. I run the old girl extra in the winter-does very well in the snow, the heat/defroster is a lot better than in my regular commuter.
    The roominess and auto trans also sorely missed when I drive my other car.
    Still wish Chrysler had replaced the car with another FWD....
  • bobe4bobe4 Posts: 12
    Have you ever replaced the map lights in the overhead console? I have one light out and am afraid of cracking the plastic housing. Don't see how to remove it to get at the bulbs. Mine is a '99 with 180k miles and going strong. I love it. Bob
  • hd1200sport99hd1200sport99 Posts: 1
    edited January 2011
    Hey all, I have an 04 SE that was a Florida car, love it to death, but want to do a little cosmetic work on it. I have been looking at new front bumper skins, as I am interested in getting the ES skin that has the fog lamps. There are multiple different companies that I have found that sell them at a fairly cheap price, but cant seem to find anything on fitment compatibility. Anyone have any knowledge to lend?
  • timtreetimtree Posts: 5
    edited February 2011
    This is a 1997 Intrepid with the 3.5 L engine.

    There is a grouding strap attached to the head under the driver side valve cover (see photo). The bottom half is rotted away and I can't see where it attached.

    Can someone tell me where this ground went? Thanks.

    Also, the reason I am under the car is there is a sporatic "clunk" (feels like it is under the floor/lower fire wall driver's side) when braking. This seems to happen regularly the first time you take the car out and brake moderately or hard. I also can sometimes make it happen when I back up quickly, or brake after backing up quickly.

    I've been under the car. Not much rust or rot on this car for a 1997 in NE. All the ball joints, steering linkages engine and transmission mounts seem to be in good shape and tight, as do the axles and CV joints (rotational play is miniscule or non-existent, no "clicking sound when driving or turning). Connecting rods and bushings for the steering rack-and-pinion were replaced recently (this clunk happened before and after), as was the passanger side strut. Driver's side strut seems fine (looks like it may have been replace recently).

    Any ideas on this clunking would also be apprieciated.

    Tim

    image
  • Sorry, they make it too difficult to post a picture. I've put dozens of photo URLs on other better forum sites, after half an hour I give up on this one.
  • Ok, i've changed spark plugs before but this engine is a bit different and before i go poking and prodding around i figure i should prolly ask someone with some info, any pictures would be helpful as well. The problem is that they are obviously deep in there and under the air intake what method/process should i use to change plugs and wires, getting a p0303 (cylinder 3 misfire) so wanted to start there as i have not done it in a long time and have avoided it due to the fact its different
  • On my 1999 2.7 liter there are six coil packs you can see, they are not below the air intake. Each coil sits directly on top of the spark plug. There are no spark plug wires. If I remember correctly there is a green or black wire going to the coil pack. Disconnect it. Next remove the two star screws on the coil pack and remove it the long rubber piece is the spark plug boot. After that it all becomes pretty obvious the spark plug is down in the shaft. If you have a misfire try replacing the plug fist but I bet you will end up replacing the coil pack.
  • bobe4bobe4 Posts: 12
    Has anyone replaced an auto-stick transmission in a 1999 3.2 Intrepid? I am about to do so with a Jasper rebuilt and wondering about other's experiences.
  • dodge intrepids the 2.7 v6 absolute trash they were built with all kinds of flaws in the engines
  • alleycat10alleycat10 Posts: 18
    I drove my 2001 Intrepid SE 129,000 miles with no serious problems with the 2.7l engine, outside of having to replace the water pump at about 95,000 miles. I traded it for a new Honda Odyssey as I needed more passenger and luggage space for long trips. It was the best car I'd ever owned. To prevent problems with engine sludging, I changed oil every 5000 miles using 5w20 full synthetic oil.
  • imbeccabooimbeccaboo Posts: 1
    did you ever figure out what was causing your air bag light to come on and the windows quit working? my car just started doing that ...
    thanks
  • jhhfpdjhhfpd Posts: 1
    Im having the same exact issue. Did you ever find a resolution?
  • I had this same problem on my 2000 2.7 dodge intrepid. It was the oil sending unit sensor I think that was defective. There was oil leaking inside of it and was causing this issue. Not sure if its the same thing on your 3.5 though...
  • tkfitz1tkfitz1 Posts: 18
    Just turned 140000, still running great. I use it every other day or so for my commute. Average just under 30 mpg. I will have to do rear brakes, front stabilizer arm links and bushings this spring. New tires before next winter. A couple little bubbles in the paint near the gas cap. A small list for a 12 year old car.
    I still wish we could have bought a new one.
  • alleycat10alleycat10 Posts: 18
    edited April 2012
    I bought a 2001 Intrepid SE with the 2.7 liter V6. The engine is poorly designed and needs close watching to make it last. The engine compartment stays mighty hot when the engine is warmed up, the engine flanked closely on both sides with catalytic converters that heat the engine compartment and the engine externally more than I have seen with any other car. Knowing that, I changed the oil in mine each 5000 miles using full synthetic 5w20 from new on, driving about 22,500 miles per year. At about 90,000 miles, the timing chain-driven water pump started leaking at the seal, so took it to a mechanic for replacement. He found signs of oil sludging present, even with frequent oil changes and mostly highway miles, so replaced the timing chain tensioner which depends on oil pressure for proper chain tension. This engine has three timing chains, one main one and one for each of the two camshafts. He told me that many a Chrysler 2.7 L engine has failed catastrophically at relatively low miles due to timing chain tensioner malfunction due to oil sludging.

    While he was at it, my mechanic also replaced the upper tie rod ends that had lost lubrication due to rubber boots surrounding them rotted by the high engine compartment temperatures, this at only four years of use. I ended up driving this car 129,000 miles and, because of the finicky engine design, will never own another Chrysler product. I had a 1999 Chrysler 300M ahead of this car, it being a big troublemaker due to transmission problems at 38,000 miles total.
  • My 2001 Intrepid did the same for years, quite infrequently. My mechanic looked but couldn't find a problem. He said to wait for a complete failure or a diagnostic code. I traded the car, having never pinpointed the problem
  • I have the same car and had the same trouble, it was the bearings. It cost me about $100 bucks at the local garage to have it fixed.
  • My Intrepid was running fine until the other day I pulled into the drive got out for something then went to leave again and nothing! I get no response when I turn the key. All the electronics come on lights, radio, relay switches, etc but no further response from the starter or motor. I did the key trick with the check engine light and got a code 21, as far as I can find that means as issue with the PCM. The PCM was replaced with a used one in 2003. Where is the PCM and can it be tested?
Sign In or Register to comment.