Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Sentra 2006 and earlier

18788909293100

Comments

  • I live on an island in the South Pacific. Parts are hard to come by. I own a 93 Nissan Sentra 1.6 XE and a 95 same engine and model. I believe my ECM is failing on the 95. Can I put the 93 ECM in for troubleshooting purposes? Also are any of the parts interchangeable?

    Thanks, MK
  • My keyless entry will not work either. Ck-ed the fuse and relay, fine. Battery to the horn it beeps. Any luck finding where or what switch it may be.

    tnx.

    madown.
  • Hey-Der, please let me know how you make out on this. did your keyless entry fail as well? I've ck-ed the fuse and relay, battery to the horn - it beeps. so yep. the horn is down. tnx.
  • Is my wife's car, recently the check engine light came up twice got it service it twice. I took it to have the code check out an 02 sensor bank 1 upstream intermitently not responding it's been reset hopefully it doesn't come back. She took it to be serviced the 1st time & it was a waste of money, a none knowing mechanic who does not have the proper tools did a tune-up that was already done 11 months ago in which I spent $900. Today at local shop all four shock or struts are being replaced. Replaced battery for the winter, transmission flushed & the recent tune-up that was not needed it almost $2,000. Still the sensor is not replaced waiting to see if problem persist. Last there is a sound when the car is moving like a clicking sound & personally I don't like the way it upshifts from 1st to 2nd gear dealer said it was fine when we bought a 14 months ago and today I took it aamco & they also said it was fine. takes to long to shift and when it does it makes a weird sound if this is the way this vehicle shifts it sucks my mother's 96 altima is very fast shifter and smooth compare to my wife's sentra.
  • I dont think you have got a good deal at all - I bought my 2001 Nissan sentra 2.0SE in March 2005 and I paid around 6000 - we had negotiated it for 5600 but there were some closing costs / TTL etc which came to 6100 - I think you paid too much. Alos it had only 65000 miles on it and a perfect drive.

    -Anoop
  • dmb41dmb41 Posts: 1
    Hello,

    I have a 2000 Nissan Sentra XE 75k miles. I have been noticing a problem the past couple of weeks. Whenever I start the car after it's been sitting for a couple hours (after work or in the morning heading to work) it seems to lose almost all power when I attempt to accelerate and then after a few seconds it "catches up" and the RPM's go way up and then it is fine. When it does catch up the car jerks violently and the engine seems to rev up and back down and back up etc for about 5 seconds before it starts funning normally. After that I don't notice any problems while driving. I drive up a huge hill on the way to work about 5 minutes after my house and don't notice any sort of performance problems while climbing that. It's only when the car first starts and is cold. Also, if I let the car warm up for a couple minutes I never have this problem. However, it seems like something that shouldn't be ignored and I would like to find out what the problem is. Any helpful hints or suggestions would be greatly appreciated.
  • I have an 87 sentra and it has a few annoying little problems. The car runs rich for one, i think its the fuel pressure regulator, because the fuel pump functions and the injector was recently replaced. the temp sensors are brand new and work flawlessly. Another problem that im having is when the car is at idle, and you turn the lights on or if the radiator fan kicks on, it will start to sputter and then eventually die, but if you turn them off, it will come back up to normal. the last problem i have is it gets hot and doesnt cool off until you move and it doesnt cool off very much. the radiator is brand new and so is the water pump. the system was flushed and is clean. the thermostat is new and operates and the drive belt for the pump is tight. what could i possibly be overlooking or doing wrong? :confuse:
  • fitzy5fitzy5 Posts: 1
    Hi folks, my girlfriend owns a 1999 Sentra, the heater blower motor only works on the high speed, #4. with winter fast approaching she will need all speeds. I checked the fuses and all are ok, far as I can tell this equipment is not included in the relays of the vehicle (I maybe wrong).
    From reading about this problem I figure it must be either the switch or the resistor at the blower fan unit. Anyone had this issue. If I can solve this for her life will be good. Thanks for you help.
  • lgoldinlgoldin Posts: 90
    I had this problem and it was burnt resistor. I have 2001 SE and the resistor located on the right corner where passengers legs are. It is bolted by 2 bolts and I took it off, put a blab of solder where the resistor has burnt and that was it. I am not sure were the resistor is located in the 99 Sentra, but you can make a search on Internet. You should be able to find it.
  • I bough a 1991 nissan sentra xe in 1996 and sold it in 2005 and also had a 1994 sentra and the 1991 sentra gave me so much, the car ran grean during my ownership with it.
    sentras are great cars, now i have a 2003 sentra ser spec v and it flies like a rocket.
    I hope nissan never discontinues this model, it is awesome, also my girlfriend drives a 2004 sentra 1.8 s...
  • Did you get your horn working?

    I too have a 2001 Sentra GXE. The horn has stopped working and the relay/fuse/and horn(when powered directly) are all working. It has to been in the wiring or contact in the steering wheel.

    I was just hoping you'd found the weak link in these cars and save me some major disassembly!
    Cheers,
    -Cori
  • It sounds to me like you might have a problem with the electric fan or fan thermostat. I bet its not running at the correct speed or you don't the correct voltage level at the terminals. have you checked the alternator for voltage and current output? You might have lost one side of the rectifier. Also look for a bad or missing ground wire.

    Good Luck
  • tom71tom71 Posts: 46
    I'm interested in hearing from people who own a new 05 or 06 Sentra 1.8S
    with automatic tranny.

    How do you like the car?
    Does the car have adaquete accelleration - especially on freeway on ramps?
    Is the stereo system high quality?
    Is the car quiet at freeway cruising speed?
  • I used to own 2000 Sentra GXE. My horn died when the car had 37,000 miles. I did some troubleshooting and found that is was due to bad cable from fuse box to horn. Couldn't fix it myself (winter, cold, snow, no access to a garage), so I took it to the dealer - I think I paid around $100-$150 to get it fixed. At 38,000 miles the RPM gauge died and the odometer as well, which flipped the CEL on. Dealer said, the console computer and the odometer need to be replaced. I paid $100 for the diagnostic and drove off with my wife to VW dealrship and traded it for Passat. I loved the Nissan, but when you loose your brake fluid for no reason (dealer said cannot find any leaks, and yet I was able to add little over 1 bottle of brake fluid to get the "check the brakes" light to turn off) and have to go to 4 or 5 recalls for 3 years of ownership, and then the electronics start dying for no reason I cannot rely on this car and let my wife drive it with a newborn. Just my $0.02
  • I have 02 Sentra GXE 1.8L. (34000 miles on it)
    This must have good gas mileage, but it runs only 20 miles per gallon.
    Previous owner has driven this car in Wisconsin for at least two years, and now I am driving in California.
    Transmission fluid, oil chage, new brake pads, air filter (K&N), cabin air filter and wheel alignment has been done since I got it. No way to replace fule filter for this car.

    I am going to replace spark plugs.
    It has 17 inch wheel, but I don't think it affects that much.
    Anybody knows what the problem is?
    How can I improve the MPG?
  • coffmlucoffmlu Posts: 20
    I have an 04 Sentra 2.5S and it's been nothing but problems since I bought it. I've had it towed twice because it wouldn't start, had the rotors resurfaced a couple times and eventually replaced, and now the AC won't turn off when I just want the vent on. It also makes a lot of noise when it's cooling down. The only good thing is that all of this was covered by the warranty. I'll be getting rid of it soon though since the warranty is almost up. No more Nissan for me, I'll try a Toyota or Honda next.
  • Hi, I also have an 04 Sentra 2.5s (all of 16k miles). Although I don't seem to have quite as many problems as you, I'm not pleased with my car either. My car has been serviced by the dealer 6 times already for a variety of reasons. One of my biggest problems is that my key fobs do not always work (sometimes the doors will unlock, sometimes not - even when I'm no more than 5 feet from the car!). My dealer tells me it's due to radio interference in certain areas in and around the NYC area. They've replaced the fobs, but I still have the same problems.

    The sounds you're hearing when the car cools down, is it a "crackling" sound (almost like a fried egg cooking in a hot pan)? If so, I have the same "problem" and I've encountered two other persons who experience the same thing. My dealer told me it's the "normal" sounds the heat shields make when the shields are cooling down.

    However, my car also makes the same crackling sound when the car is in operation. My dealer (White Plains Nissan in White Plains, NY) told me that the heat shields needed adjusting (which they adjusted at no charge) and warned me that when parking in lots with those concrete bars on the floor, to be extra careful and avoid having the front end of the car rub up against them. The front heat shield, so they tell me, is easily knocked out of place by these bars. Well, not sure if I've helped you any. I think the Sentras are poorly built and this is my last Nissan, too! Good luck to you and let me know how this all turns out for you.
  • coffmlucoffmlu Posts: 20
    Thanks, I'll have them check the heat shields. It makes the sound while I'm driving too. My dealership also told me it was normal and then they said it was because of the gas I was using (said I should be using higher grade gas)! So, apparently, they have no idea what's going on. I usually wait now and compile a list of items I need fixed before I go to the dealer or else I'd be there every month. I've got three things that need fixed right now, so I guess it's time for another visit.
  • 89 nissan sentra.

    Can anyone please help me find the problem:

    Car was running fine...my brother put the cap on wrong and it cracked the cap and now it wont start. I replaced cap and rotor and it almost starts but wont completely fire up and run.

    I dont have the manual and know a bit about cars. I used a haynes manuel...too broad...but I traced it to either a transistor connected to the coil or Im guessing it damaged the ignition modual inside the distributor. I dont have the manuel to test and check either one.

    Maybe someone can please help me or tell me how to test it.

    Ive got spark from the coil....and very weak spark to the plugs. Im sure the coil is working fine as tested and grounded...has hot spark.
    I dont know if the circuit that acts like the points could have went bad or if the ignition module inside the distributor is bad. I tested the plug to it...it has 5 volt reference signal and 12volt power...plug seems fine.

    This all happend after he went for a drive and it worked and ran great. He took off the cap and checked the rotor as it was loose and moved before (didnt have the hold down screw) but I found that the rotor had slipped and was off when firing..hence the poping and loss of power. So I repostioned the rotor where it should be but didnt have the screw yet to keep it in place.

    It ran great!.....so after driving it.....he pulled the cap off to check if the rotor had moved....he must have put the cap on the distributor back on wrong...he started it up and it cracked the cap and the rotor chewed up the inside terminals.

    After that, I replaced with new cap and rotor and rotor hold down screw.....NOW the car wants to start up but wont!

    Please any suggestions!
    Thanks in advance and sorry for the long discription of the problem.
    I wish I had the manuel to test.

    Thankyou!!
    Eric
  • I have a 1999 Sentra, and the headlight switch is broken. I cannot turn on the lights, because the whole switch broke off. All I have is the turn signal rod, with the light thing gone. I was wondering if I can use the control from a 1995 Sentra to replace it. Or if there is any other way to go to fix it. This is getting irritating, cause I can't go any place after it gets dark. Thanks in advance.
Sign In or Register to comment.