-July 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

1995 Grand Marquis quits after 30 mins

monkeybiz6903monkeybiz6903 Member Posts: 2
edited May 2014 in Mercury
My Mecury has started quiting on me after running for about 30 minutes or so. Got it to restart using starting fluid. Got it home let it run with a/c on. Then killed it let sit from 10 minutes. Started and killed it 3 or 4 times. It idle starts surge up and down. Black puffs of smoke out tail pipe. Let set overnight, after a few cranks it running like a sewing machine. What could be causing this? Im handicap, and wrecker bill is adding up. Thanks in advance

Comments

  • Options
    georgcgeorgc Member Posts: 2
    My Car: 2000 Mercury Grand Marquis, 81,000 miles. I have had the car for three years. About two months ago I noticed the following: The idle was faultering. Also, when using the turn signals, the digital temperature indicator light would dim and brighten with each flash of the signal. I had the alternator and battery tested. The battery was bad. I replaced the battery. The Idle has returned to normal. However, the temp. indicator light still fluctuates in brightness when the turn signals are on. The mechanic said it was because of normal drain of the amperage
    from the battery. Do I have a ground problem? Please help. :confuse:
  • Options
    pmitchellppmitchellp Member Posts: 19
    The trunk button and the gas lid opener stopped working. The rest of the door panel works fine. I checked the wires and they are ok. Do you have any input?
  • Options
    pmitchellppmitchellp Member Posts: 19
    I had a GMC van that had the same kind of problem with the turn signals acting funny like that. It turned out to be because of a corroded socket on the front turn signal.
This discussion has been closed.