Edmunds dealer partner, Bayway Leasing, is now offering transparent lease deals via these forums. Click here to see May lease deals!
Options

Silhouette Accessory Inflator

jollymaejollymae Member Posts: 1
edited May 2014 in Oldsmobile
I have a 2003 Silhouette and went to use the rear accessory inflator and got nothing...tried to read the manual to find out which fuse controlled it, no luck really with that, but checked a handful of fuses that all were good. Anyone have any advice on why this isn't working? We don't really use it much, but my concern is that if it is'nt working that the auto-adjustment is not occuring in the rear.
We've had NUMEROUS problems with this van, but we don't have the means to sell and start fresh, so we must suffer through this one until the loan is paid off.

Comments

  • Options
    josh43josh43 Member Posts: 1
    same car same issue... check the connector to the load level sensor... mine was rusted out... quick solder fix... shop did it for free.
  • Options
    bob550kbob550k Member Posts: 148
    I pulled the fuse on mine and put in two regular old fashion air shock valves. The system would only pump up and not release any air so the van would get higher and higher and higher.
    $50 fix installed.

    Not worth spending money on in my book. The self leveling ride was a great feature but it's dead now!

    LOL
  • Options
    bob550kbob550k Member Posts: 148
    I pulled the fuse on mine and put in two regular old fashion air shock valves. The system would only pump up and not release any air so the back of the van would go up and up and up...

    $50 fix installed.

    Not worth spending money on in my book. The self leveling ride was a great feature but it's dead now!

    LOL
This discussion has been closed.