Edmunds dealer partner, Bayway Leasing, is now offering transparent lease deals via these forums. Click here to see the latest vehicles!
Options

Grand Vitara Engine Problems

redryder2redryder2 Member Posts: 7
edited July 2014 in Suzuki
ok guys and ladies: have 195,000 miles on 4 door suzuki suv(see title) and love it. no tire problems, buy the yokahamas every 35-40,000 miles. work as courier, 20 mpg, replaced left rear wheel bearing at 170,000 miles. problem: at 180,000 miles check engine light came on, cruise control was disabled, engine ran rough fluctuating between 550-850 rpm, engine died at stop lite, suv was very hard to start before starting finally. took suv to dealer, they said $1,000 to clean passages of carbon, replace egr valve. 6 hrs to do job, took 2 1/2 hrs, asked for discount, SORRY. anyway, fine for 2 weeks, then same symtoms but after dealer said no codes, i drove off and later the check engine lite disappeared and i had cruise control and engine was ok. now, this happens every 2-3 weeks and goes away, then recurres. a friend at vw shop said it could be the "throttle body" unit against the firewall in the center of the engine compartment, but big bucks at the dealer to replace if problem. i know, i know nobody else has this many miles on the "new" 2006 (which was a great suv and deal, i paid $22,000 for it) but if you have had this problem on the xl-7 v6(same engine) please post final resolution, i'll do same.

Comments

  • Options
    bm000092bm000092 Member Posts: 70
    Engine light comes on and there is no code that has been stored ??
  • Options
    tidestertidester Member Posts: 10,059
    Suzuki Vitara Maintenance and Repair may be helpful.

    tidester, host
    SUVs and Smart Shopper
  • Options
    redryder2redryder2 Member Posts: 7
    thanx for reply: after my post i went to auto zone and they found 3 codes with their computer, but, when checked to their data base, no suzuki explanation of the codes showed up. just about every other common auto used these codes but, no suzuki. go figure.
  • Options
    redryder2redryder2 Member Posts: 7
    thanx for reply: been there, no luck for 2006 detailed problem. beginning to think until some other owner has same miles, they won't have same problem. still driving it and only irritant is no cruise control(disabled) and very hard to start(cranks 10-15 seconds). plan to take back to dealer who did original work and see what they say($2,000 maybe?). if no sympathy from them i'll try some other dealer(crook) and roll the dice there.
  • Options
    tidestertidester Member Posts: 10,059
    Let us know what happens. In the meantime, have a great Thanksgiving. :)

    tidester, host
    SUVs and Smart Shopper
  • Options
    bm000092bm000092 Member Posts: 70
    Did you get the 3 codes ? I have a list of them, may be I can find it for you ?
  • Options
    redryder2redryder2 Member Posts: 7
    thanx for reply: yes, the codes from auto zone were P0101, P0401 and P2282. P0101 was referenced mostly to MAF sensor, vacuum leak, etc. P0401 was mostly EGR. P2282 suggested a intake manifold air leak. Because the intake manifold was supposedly removed in order to clean the manifold passages(intake/exhaust i dunno) maybe it was still not fixed on reassembly. the symtoms i have now were present when i went to the dealer originally, he fixed only the wide rpm fluctuation(550-850 rpm) which allowed the suv to die at stoplites. hope your suzuki codes book has a reference to these specific codes for 2006 v6 xl-7 type engine.
  • Options
    redryder2redryder2 Member Posts: 7
    thanx
  • Options
    bm000092bm000092 Member Posts: 70
    Here is what I found.

    P0101: Mass air flow circuit range/performance (MAF sensor volume is more than specification or less than specification.) It may also indicate that the MAF sensor is defective.
    P0401: Exhaust gas recirculation flow detected as insufficient (Difference in intake manifold absolute pressure between opened EGR valve and closed EGR valve is less than specification).

    P2282: air leak between throttle body and intake valve.

    Unfortunately, there is about 10 pages of documentation in the Suzuki book on how to troubleshoot this, it would be too long to post. But yes this information is available easally to any Suzuki dealer.
  • Options
    redryder2redryder2 Member Posts: 7
    thanx a lot. i'm off to suzuki dealer with this info. will let everyone know what they say and what they do. if they fix problem i'll give them credit, if they say i dunno i'll post the name of the dealer and what they said.
  • Options
    redryder2redryder2 Member Posts: 7
    thanx again guys/girls for the insights. went to the dealer and he found the p0101 and p0401 codes. he said it might be a faulty new egr valve and he would talk to suzuki about replacing under warrenty(just paid to have it replaced $736.00). anyway, since i brought it in 3 months ago after 5,000 miles and they found no codes at that time and now it is 23,000 miles(warrenty on repair was 12,000 miles) and they now find codes, i'm sol. however, in testing the suv they electronically(they say) opened and closed the egr valve a number of times. bottom line, the engine lite is now off, so egr must, for now, be working. they did suggest one thing, which i have done, go to a gm dealer(if any still exist) and buy a bottle of their super duper gas plus cleaner($28.00 choke). this stuff is so concentrated it will clean chewing gum off your shoe sole(thats GOOD), but you only use it about every 5,000 miles or you don't have any fuel injectors. suv runs good for 198,000 miles and hope to get 350,000 miles.
  • Options
    holmzyholmzy Member Posts: 1
    Engine has around 80000 mls.Started it yesterday and it started normal then immediatly quit.gets fuel when cranking but will not run or even hit.Could this be the timing belt broken?
This discussion has been closed.