-July 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

Rear Brake lights not working after pulling trailer

gpatemangpateman Member Posts: 5
edited October 2014 in Chevrolet
Hi. Both my brake lights are not working on my 2006 Trailblazer. This seemed to happen after using a trailer with the light adaptor plug-in (to hook up the trailer lights to on my trailblazer). This time frame may be a coincidence though. I've check the fuses under the hood and under my passenger side back seat and can't seem to find blown fuses. Where do I look from here?

Comments

  • Options
    burdawgburdawg Member Posts: 1,524
    See if the brake light switch has failed.
  • Options
    gpatemangpateman Member Posts: 5
    Where and how do I do that?
  • Options
    gpatemangpateman Member Posts: 5
    So. Here's how it played out. The tail lights were both not working but the rear upper hatch light was (so I was guessing something more than the brake light switch).. my buddies got the electr tester out and we had power to BOTH tail lights when pressing the brake pedal :) We then said "holy crap, it could be the lightbulbs........switched them and it was"......Lesson learned is check the easiest (even though I thought there was no chance that they burnt out at the same time) solution first......
    thanks guys.
This discussion has been closed.