Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Chevrolet Malibu Maxx Problem Codes/TSBs



  • pgroegerpgroeger Posts: 3
    It ended up having to replace the ebcm thats located right in front of the windshield washer filler neck. Since then I haven't had that problem. At least not sofar!!!! Just keeping my fingers crossed. I got lucky in that it was still under warranty. That ecm was pretty expensive.
  • drondron Posts: 1
    Hey, went through this for some while... very sporatic at first until finally never opening. I replaced the actuator to only have the same results. Took that back and tried swapping the mini relay out with the one for fuel... Bingo. went to local dealer and purchased new relay and works like new. Worth a try.
  • 2tired2tired Posts: 2
    Is there an easy way to get at the mechanism that makes the rear sunshades retract? They are pulled all the way out and just hanging loose in the back, after trying to use them the first time.
  • paopao Posts: 1,867
    not sure about the 06.. but in the 04 you had to remove the headliner to access the mechanism......I have simply left mine retracted as they never stayed closed or latched.......assume you are out of warranty now??
  • 2tired2tired Posts: 2
    I bought it used just two weeks ago. The very first time I tried to use the shades they both stayed open and wouldn't retract. The dealer agreed to supply the part, if I looked after installation. It's such a cheap design I decided to just cut them off and leave the sunroof that way. The rest of the car is well designed though.
  • giovanni5giovanni5 Posts: 1
    My malibu hesitates to start @ times,what could it be?
  • drejdrej Posts: 119
    I have the same hessitation sputter problem at starting on my 05 Maxx w/ 85 K miles, what years is yours? Mine starts a bit better if its cold and if I try holding the key in start for 1 second versus a quick spin of the key forward? It eventually does start scarily. But seems to be getting worse. I hate to go to dealer as some here have with no success. Any Ideas all? D~
  • rustybugrustybug Posts: 2
    edited June 2010
    If your having trouble starting your Maxx, particular when the enigine is not cold (i.e. after grocery shopping) and the engine is still warm ... it will try and do that sputtering but not start thing. If you will hold the accelerator down part way (about 1/2) throttle before you try and start it, it starts easily ... but be quick to let off the accelerator after it starts so you don't immediately race the engine.

    My theory is that this changes the air flow available to start. It seems that at certain engine temps this happens, while not at others ??? I suspect it is TPS sensor related. Once you press the accelerator past a certain point, the signal calls for more air, thinking you want to REALLY acclerate. I suspect the programming on it is just a bit 'finicky' between the MAF and the TPS when it is at certain temps.

    My explanation as to why may not be accurate ... but it works like a champ. Been doing it on our '04 (183,xxx miles) since it was new (once we figured out the trick).
  • rustybugrustybug Posts: 2
    183,xxx miles ... so not a complaint, just how things wear I figure.

    My wife was driving interstate and 'poof' power steering messasge comes on radio, light on dash and no power steering. She limps it home.

    I go out and check on it. I get no dash light, nor radio message and it pulls away (left) from curb just fine. It seems a little stiff trying turn to right at the stop sign, but not too bad. Driving down the road, it seems a bit 'loose'. Then when I get up to a stop light and take my hands off the wheel ... the steering wheel starts going back and forth on its own. (I assume it was 'hunting'.)

    I stop in and talk with a service manager (not much help ... I can get you in a few days). I leave and come home ... smooth as silk, good as gold, like brand new all the way home. After hitting the web (gotta love it) I'm of the opinion that it is steering sensor related (also has been doing a little bit of that steering / accelerator thing).

    So ... my question is about the upgrade to a different column / different sensor / cleaning contacts / greasing / not greasing etc. I've found replacement sensor, and a nice video about straightforward sensor replacement, but not totally sure about steering column removal efforts. I can turn a wrench okay, just wondering what others might advise as do's / don'ts along the way.

    Also, given that it seems to have 'settled' back in place ... is it reasonable to just wait & see (thinking that a good jar or something may have put it askew temporarily ... I wasnt' there when it first occurred).

    Thanks all.
  • paopao Posts: 1,867
    the issue with the sensor and column replacement is this some sort of recalibration of the column that must be done....dont beleive you can do that at home in the garage.....beleive the dealer has to do it

    not sure there is a upgrade so to speak of the sensor or column..what I have read the sensors fail...or the contacts get dirt/grease on them causing them not to work....again...the only resolution I have seen on the forums is a steering column replacement to the tune of $600-800.....

    getting ready to roll over 165K here on my 04 Maxx LT...and seven years old...hoping to get two more years out of her.....
  • lotusjaylotusjay Posts: 17
    Same problem, and the answer from "dron" solved it for me. After removing the trim panel and examining the latch and solenoid I suspected it was the cause. But when clicking the remote I also heard another sound from a relay nearby. As dron noted, inside the fuse/relay box at the left side of the cargo area there are several relays. If you place your finger on each as you click the remote you can feel which one controls the latch. (If there is enough light and your glasses are on you can also read the label inside access door.) Replacing the relay ($17 including tax at the dealer) solved the problem at the latch and the hatch opens with one click. The time it takes to fix this is about 1 minute if you have the relay in hand. The GM part number on the relay was 19116057.
This discussion has been closed.