Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Jeep Grand Cherokee Maintenance and Repair



  • Hello too all:

    I have a 2005 Grand Cherokee Ltd. The tire pressure monitor light comes on & the dealer suspects one of the sensors is the problem. In my opinion this feature is nothing more than a pain in my back side. It appears as though the monitor circuit is fused, (10A), but what I don't know is if the fuse can be pulled w/o creating a tsunami of additional problems. Any help would be appreciated.
  • rwengrrwengr Posts: 177
    I have some limited experience with this topic. For a small component, I would be very surprised if that component had its own fuse. Owners manual should have fuse info, but only way to be sure is to examine a wiring diagram.

    The best solution is to disable the output of the sensor. My guess is the dealer wants $400 or more to fix it.

    Because it is related to safety you might have to do it yourself. A mechanic might not do it. I'm 99% sure dealer won't do it.

    First, get a Haynes manual and look for repair info or wiring diagrams.

    The output of the sensor is probably a digital (1 or 0) input to your Body Control Module (BCM). The BCM reads sensor and turns the light on or off.


    You need to measure voltage output at the sensor when warning light is On and Off. If the values switch between 0V (Gnd) and 12-14V (battery) continue.

    Otherwise stop. If sensor module uses data bus to communicate with BCM, you cannot disable it and fake out the BCM. You will have to replace the sensor module.

    If the light is on for 0V, you will have to pull the input high (battery) to fake out the BCM. It's very possible that disconnecting output of sensor to BCM will be sufficent.

    If you measure (battery) when light is on, you will have to find a way to ground the input to the BCM.

    In either case the sensor output is left disconnected.

    Use a clip lead to test your solution. If OK, implement a permanent solution. You will have to backprobe nearby connectors. You will need a voltmeter probe with a long thin point. After you find a good location, you will have to improvise a connection.

    Test drive alone (no family) where there is little or no traffic.
  • rwengrrwengr Posts: 177
    You might want to think about a new or remanufactured Jasper engine. Where I live we have shops that install them. I don't know if you can do it yourself. Of course, it would be more fun. I'm sure they have technical support.

    Unless you know sellers, what are the odds of finding a 94 engine with less than 100K miles ?
  • rbirmrbirm Posts: 1
    i have 98 jgc i get no fire from coil .i have changed coil ,tps sensor,map sensor,crank positin sensor,and main computer, still will not start...prior to this it would run but very rough and used the heck out of gas.i chaned everthing thats has come up on code reading...this s crazy
  • I installed new tranny cooler lines on my 1989 Jeep Cherokee Pioneer 4.0 liter. The new lines had slightly different pressure fitting ends than the old ones. There are 4 shiny metal tabs inside whereas the old had none and used a plastic collar and snapped onto a 2 tabbed larger collar. I attempted to install without the plastic but couldn't get a seal. I started the engine and tranny fluid seeped out of the pressure fitting. They don't seem to lock into place. What am I doing wrong and how do I fix it?
  • Maybe the computer. But, have you got a battery harness you are proud of? If not, you may just not be getting the complete ground it takes for the 'puter to read the sensors correctly. About $135 will get you an OEM harness that connects the batt, the starter and the alternator plus applicable factory grounds. Made a big difference in my '97 reliability and eliminated some mystery behaviors.
  • rwengrrwengr Posts: 177
    I assume you hear the starter motor tying to start it when you turn the key.

    I looked at my 97 shop manual. Maybe this info will help. The first thing they recommend is a test for spark at the coil.

    1) Disconnect igniton coil secondar from center tower of distributor cap. Hold cable terminal approximately 1/2 in. from good engine ground.

    2) Crank engine with starter and observe cable terminal for a steady arc. If steady arc does not occur, inspect the secondary coil cable. Also inspect distributor cap and rotor for cracks or burn marks. Repair as necessary. If steady arcing occurs, connect ignition coil calbe to distributor....(and then they discuss observing arc at ignition wires, etc.

    If you really like the car try to buy a shop manual.

    Some other thoughts.

    1) You must be able to measure fuel pressure
    2) Wiring/connectors between engine computer and ignition components?
    3) What about the automatic shutdown relay ?
    4) The Body Control Module (BCM) and engine computer must communicate to start. Replacing BCM requires reprogramming BCM or it won't start. Is there a similar issue when you replace the engine computer?

    If you fix it, let us know what it was.
  • My 2004 has become a nightmare to disengage part time 4wd (4 wheel hi). It is the select trac package with the 4.0 litter. Sometimes it takes a 1/2 mile or more of constantly pulsating the gas pedal to finally come out. I have tried backing up when this happens and sometimes it works and sometimes it does not. If you have to park and restart it will disengage with a fairly large bang. It does this especially on turns. I only shift with the vehicle moving with my foot off the gas, as I was told by the dealer that this is prefered.
    I am guessing this happens when the front axle is binding a little from being on dry pavement when the transfer case finally decides to disengage. When the vehicle was newer it did this once or twice, now it is constant. I have had the case and axle fluids changed at the proper maintenance schedule using factory fluids.
    It has 63k on it and is still in warranty. I am bringing it to the dealer this week and was hoping for any advise from other owners with similar problems so I know how to respond if the dealer tries to give me a song and dance. Any help would be greatly appreciated.
  • I have a 2000 grand cherokee laredo with 4l inline 6 cyl
    yesterday the oil pressure gage went to 0 and stayed there
    any ideas what my problem might be ?
  • loosenutloosenut Posts: 165
    does your-04 have a vacm module on the front axle? check and clean the works on that,as that's how my -90 pioneer worked,and was told that's a standard axle for the cherokee..not shure if grand has that diffrent of a system,but would be worth looking at..maybee a weak or broken release spring,or a bad vacum diaphram or what have you..but it's gotta be there,as that's where the front axle is turned on and off..good luck!
  • loosenutloosenut Posts: 165
    hopefully its either the oil pressure sensor in the block,or -less likely,the instrument cluster..might just be a wire came off,as the pressure switch wire is right next to the oil filter,and could've gotten unplugged..check around the filter for a unplugged wire..otherwise,you have no oil pressure,and have,or will soon blow up the motor..(just kidding--i hope!) "ratteling" noise outta the motor?,like it's still got pressure?..otherwise,worst case senario,put a "old school" mecanical pressure gauge in it.
  • Hi,

    I know this is an old post, but I have the same problem! Works ok in 4 Lo, but no traction/engagement at front wheels in full time 4 Hi with Quadra Trac II. Anyone know of the fix for this?? Thanks!
  • Thanks for the info. I will check with my local mechanic about the vac module.
    I want to make sure the dealer will warrentee as part of the drivetrain. I have talked to jeep service guy who owns the same truck. He said that sometimes his does not disengage right away so he stops and backs up and it comes right out. Mine does only sometimes no matter how far I back up.
  • dandgdandg Posts: 91
    I used to manage a transmission shop,in fact bought a 94 JGC for $1.00 when the owner decided she did not want to put the 2500 in a rebuilt transsmisson.Just sold it and bought a 04 JGCL with 31k on it and will probably buy the 7/70000 Powertrain if it looks better for Chy suvival.

    Now your trans, have they dropped the pan? Whats it look/smell like?If it has metal and smells burnt then pull the unit and have it rebuilt.
    Not sure how many miles but a 95 with anything over 70,000 is going to need a master rebuild kit and not just gaskets and seals.

    You may have misunderstood the "new" transmission quote,there is no one that I am aware of that sells a "new" or fact reman unit for that.A good rebuild is over 2K,factory rebuild or a Japser is a bit more.For 1300 that might be a used unit,what is warranty on it?
  • Check engine light on and very sluggish when accelerating. Having to push accelerator more than usual after stopping. Wouldn't you know on a weekend and my mechanic is closed. Fault sensor code (AutoZone) came up with P1763: Governor pressure sensor too high. Causes: 1)Internal transmission failure 2)Open or shorted circuit condition. Any ideas? Safe to drive? No misses or noises from the engine. Smooth gear transitioning. Start and idle with no signs/sounds of any problem. Biggest change is it takes more accelerator pressure than normal to get moving.
  • i have 99 JGC that i just replaced the head gasket on my self but when i start it, it will pin its self to red line i have shut it down before it reaches it every time but i can not figure out what is going on i have checked every connection and i had color coded them all before disconnecting and thing all seems to be good there, i have checked the throtle body to see if it is stuck open but its working fine and i cant get any codes out of it any ideas
  • TRY this----engine off---key in ignition--trans in neutral.
    Place foot on brake, hold it--at the same time turn key in this manner--on-off,on-off,on.
    Sometimes this will clear codes and problems.

    If this does not work---disconnect the negative batt cable and let it sit for ten min. Usually this will clear any codes and bring everything back to normal.

    The key trick clears my ck eingine light problems.
    Good luck
    Smokey Swann
  • how hard is it to change the exhaust manifold gasket on a 98 jgc?the gasket is only 10 bucks but i dont want to pour a ton of money in it at the shop again......I too have the love hate relationship.......thanks.......
  • your problem is not computer related you have a air line,hose left unattached that is bleeding air in after the throttle body look for a open port before starting again.
  • rselfrself Posts: 9
    if both engines are the inline 6 then the answer would be yes you might have to change the motor mounts but they should bolt up the same.
  • Still having red line fun? If you didn't find an air leak like one of the other guys suggested, you might investigate the crankshaft position sensor (CPS). When I was having some glitches with my CPS, on one reinstall, the engine did what you describe. Well, not to red line, but definitely ran away. After another remove, clean and replace, it worked fine. It's a [non-permissible content removed] to get at. Behind the right exhaust manifold on the block where the bell housing bolts on. Might be worth a look.

    Good luck --- Clip
  • My '89 was doing the same thing awhile back, I'd have to shut it down. Difference is that after a couple of times, It'd get it's act right. You have cruise control? Was thinking about it awhile, you checked the throttle plate, Have you checked the Idle air motor? Maybe doesn't even have one, I don't know. Pintle doesn't move thoroughly and smoothly, the machine won't idle correctly. DON"T move the pintle in or out manually, messes 'em up, supposedly. I'd disconnect ALL linkage/sprin gs, etc. from the throttle-body and try it again. Hold the throttle shut with your hand, or something. Let someone else start it though, so's you might visually check the the mechanics of it all. I don't know what would happened if you were to remove the Idle-air-control motor and, CAREFULLY, metered the "controlled" air flow into the idle-air circuit manually. ie Shove a finger or such into the port the idle motor come from, stop or slow the air flow from the port inside, the port, and see what happens. Leave the motor connected to the harness, set it carefully somewhere safe and observe it's operation while you are at it.
    Oh, the cruise control..... Had a friend long ago, ME, got some vacuum hoses twisted around, and when I thought the'y'd "ONLY connect to those ports one way", It wasn't right at all. Vacuum came up -- so did the rev's--so did the vacuum--so did the rev's, etc.
    Scarry stuff isn't it? Spine jumps right out of the skin, huh?
    At the time mine was acting-up, I'd considered making a plane out of it.
    Just wouldn't have been as much fun though.
    You be careful, patient and consider, carefully, what's going on, and you'll be just fine. Have fun.
  • paulepaule Posts: 382
    I'd also check your throttle cable again. It almost sounds like it's "hanging" wide open. I had a Dodge Avenger way back when that the dealer replaced the head gasket on. When they put it back together, they hooked the cruise control return spring up wrong. So, the first time I used the cruise control, guess what. Yep, wide open throttle. I had to kill the ignition but not lock the steering column and muscle the car over to the side of the road.
    You should have seen the look on the face of the service manager when I took the car back in for them to check it out and I told him what had happened!
  • I just replaced a CV axcle on the drivers side and now the jeep is shaking (steering wheel) whenever I drive over 50 mph and I am not sure why? I should also say that the gears in the hoghead are bad so I also took the front driveshaft out to try to alleviate the the grinding noise I would sometimes hear .Can anyone pass on some suggestions?
  • tuggajbtuggajb Posts: 646
    first of all i would also remove the axel shalfs as if the gears lock up you will realy go for a ride you will not enjoy also prob brake the front axel housing also

    the shake could be that you did not get the front hub in strait when you tightened the 3 bolts that hold it in make sure that you didnt get dirt behind it (between the mount serfus and the hub)
  • I very much appreciate the help , would you mind breaking that down a little bit more as far as what I need to do to fix this because I am learning as I go .
    Thanks ,
  • tuggajbtuggajb Posts: 646
    when you changed the front axel shalft you had to remove the front hub to get the shalf out as when if you run the jeep the gears turn in the punkin so if the bearings are going bad they can get stuck and freze up in the housing lock up tight and stop you when you leaste expect it even with the drive shalft out the axels still turn the gears when you move so if you are not going use 4 wheel drive take out the axel shalfs and drive shalf and go for it
    here is a url that you can use to see what you need to do,L001/UserAction,logout/getInTheZone.htm

  • Hi, At this point I have been reading many different choices on what to do, to get this problem fix. I am low on budget so, if someone could just be able to direct me the best way on saving money and maybe fixing my problem.

    My 2001 Jeep Grand Cherokee Limited comes with a dual electronic AC/Heater control. AC works excellent. No leaks. Radiator tank is always fine on level. When turning up the temperature to get the heater runningl; nothing happens. Air goes from cold to a regular blowing temp. When weather is kind of cold and car has been running for a while you are able to see some fumes coming thru the vents. They smell like antifreeze but I have never found any leak below the dash nor below the car. Would anyone guide me in the right direction in order to try cheap things first and than go from there.

    I've heard it could be the heater core, motor blowers..

    Anyone that could help me, really much appreciate it.

    Thanks alot.
  • I took the jeep back into the garage after the tranny rebuild and torque converter replace and the vehical was still shuddering and they gave it to another mechanic and started checking other things and found out that there was a faulty ERG valve with very erratic voltage and pulse width -- replaced ERG valve and as of now I'm not noticing the surging any more . It was acually the engine that was making the jeep shudder . Will update after a month or so . ;)
  • You need to replace your font differiential gear nest. This composes of a ring gear, spider gears and new ring gear bolts. The shims are already there on each side of the spider gears; don't mix them up, and put them back in the same order you found them from. If you take the front drive shaft off to make the vehicle into a 2 wheel drive, this is going to create ALOT of problems you don't want to deal with.
    When you replace the gear nest, the pinion gear (the one where the front driveshaft connects to should not be tampered with, for it does not need to be removed. If the pinion gear, is in fact, the one that is damaged, then replacing it will be more difficult than you think, because there is in fact what they call a "crush" sleeve. This sleeve sets the load/preload for the differential in order to set the lash/backlash for the gears to mesh properly.
    I hope this helps you, and good luck m8.
Sign In or Register to comment.