Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Lincoln Town Car Maintenance & Repair

17810121322

Comments

  • papaapapaa Posts: 20
    I recently took my drivers door panel off for the same reason. Once all screws have been located and removed you very carefully lift the bottom out about 5 inches and lift up with attention to the top of the panel. It might take some time but don't get frustrated or the panel will be the boss. The wiring harness is usually strapped with plastic ties but you will see how much wiring there is behind the panel . Be careful and good luck
  • papaapapaa Posts: 20
    If some one knows the best place to get air suspension parts I would appreciate the info. Thanks
  • nwraaanwraaa Posts: 174
    You can find parts like the air spring bags, suspension pumps, and height sensors on Ebay.

    What is the problem with your system?
  • retired8retired8 Posts: 15
    This is to all folks experiencing air suspension problems. I see more and more of these kind of write-ups lately. Take my serious advice as I also fought the air suspension problem for a couple of years. Read my original entry, #318, on this site. You will save lots of bucks and pain by going direct to springs. I still have not noticed any difference, except it works. I also still have not heard anything about my cruise control problem noted in #318. Thanks
  • The car bucks while driving down the road. It does not do it all the time. I tried taking it out of overdrive and did not buck but one time and not as hard. I have talked to others who have the same problem. Any suggestions? Other than this problem I love the car. Also, have they improved this problem in the new Lincolns?
  • I've done many of these. The problem is that the nylon bushings that get replaced will also break down again very shortly.
    It's best to replace them with something else like aluminum or steel.
    The original bushings are meant to have some "give" to them, so as to prevent injury if someone were to get their fingers trapped in betwwen the window and the frame. But the design is faulty and the bushings disintegrate from wear and heat.
    I've also heard of some people using s/s nuts that are the same diameter and height of the original bushings.
    I just use an aluminum rod of the same diameter to cut the new bushings.
  • While there are aftermkt suppliers for the rear airbags, I've found that they unfortunately do NOT ride as soft as OEM airbags from Ford's parts counter.
  • The air system on the TC is not that complicated to warrant a conversion to coil springs.
    Coil springs are also a maintenance item, they will also wear out.
    Glad you're happy with your setup tho.
  • I have a problem with the intermit wipers will not turn off and if you turn the washers on the wipers stay on and will not shut off until you shut the car off then they stop. I replaced the switch and module and wiper motor and still did not fix the problem. I did not see any cuts or pinched wires. I also ran a ground wire from the wiper motor to the - side of battery and still did not fix it.

    Thank You
    Pepper :cry:
  • hi i am having problems with my cars battery draining after it is turned off. the first thing that it does is when I get out of the car I take the key out of the ignition and open the door and the chime comes on, and the lights aren't on. the chime goes off when I close the door. after it sits for about eight hours the battery is dead. I checked the battery and the battery is good. there is no courtesy lights on to drain the battery(removed the light bulbs), we removed the radio(so the antenna is not trying to go up). if I remove the main start fuse then the battery will not drain and the door chime will not chime. please help I would like to fix this problem w/o spending a ton of money...
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,425
    Only thing I can think of is if you are parking on a steep slope, either the trunk light or hood light stays on due to the Mercury switch.

    Hope it is that simple for you. :)
  • What was the solution? My 99 get wet on passenger side front and I can't find cause.
    Thanks
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,425
    the Mexichrome peeling off. What is the best First Aid treatment to improve the appearance without the expense of a professional body shop?
  • bc95bc95 Posts: 2
    I'm struggling with the same problem, I've replaced the PCM/EEC and Fuled Shut Off relays. The only thing that works is jumping the fule shut off relay 3 ways, when I do that the car starts and runs fine. I have 196k on the car and want to get it back on the road the right way. Any suggestions??
  • I'm dingy on this, but the part(s) we replaced that fixed our problem was: (Ford Motor Company, one pkg. of 2 pcs. FOAZ-14N089-A relay AF30E W/O 812231 02/25/05) This is what is print on the package. Cost was $15.00.
    I tried searching the web and can't seem to find info on it.
  • you might check out the messages numbered 409 through 420. I also had battery drain problems. the problems and solutions i ran into are mentioned there. good luck
    earlene
  • I fixed the problem, it was the cowl vent, cost me $5.00 for some clear silicone and an hour of my time.
  • Recently, when I try to turn right (as in turning right into a parking lot from a main road - and it is under some speed and is not from a stopped position) the automatic braking system activates and scares me to death! :) I am always able to regain control (so far) - and then the light comes on.

    This ONLY happens with a right-hand turn.

    Second problem - passenger side door. It is becoming increasingly harder to close. Husband tried to shim it, I believe, but make little difference. I had this happen to an older Lincoln and eventually the door stopped closing all together. What a pain.

    Last problem - when I activate the trunk release (either from the hand-held keyless entry thingy or the switch inside the glove box ) I hear the SOUND of something releasing, but the trunk does not release. I hear that big "Click" - but nothing happens. The trunk closing mechanism still works fine.

    I sure would appreciate your help on this. I just paid $3500 for a complete engine overhaul on this vehicle and I truly would like to keep it!

    Thanks!
    Neauxbunny :confuse:
  • This seems to be a problem with lots of 99's. I took my 99 Town Car in to dealer for fix. They cleaned and repaired the right cowl screen, sealed cowl and air intake. However, after 2 rains this past week, there was still a leak (much smaller than before)into right front passenger carpet; there appears to be no leak as before in right rear passenger carpet. I plan to take it back in for redo tomorrow.
  • I've only posted on here a couple times, but I figured someone on here could help me out!

    I have a '92 Lincoln Town Car. I've had the car for 3 years and kept up the maintenance. All the sudden, everything starts going wrong at once.

    Here are the problems:

    1. My windows quit rolling up and down. I have the replacement parts, but I can't get the door panel off. I have to get someone else to do that.

    2. I think I have an electrical problem. My windshield wipers do not work unless I put them on the fastest setting. Then they only run once and I have to turn them off and put them back on the fastest setting for it to run again. My headlight is out, but my brights work just fine.

    3. I have to have my antenna replaced, it broke and the pulley doesn't work anymore.

    4. There are several flushes, etc I need to get done (About $600 worth.) I plan on getting those done. There is a rattling in the engine when I accelerate at times.

    Questions:

    Does any of this sound familiar? Do I have a full blown electrical problem? How much will it cost to get all of this repaired?

    Thanks!
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,425
    Before taking door panels off it appears that when you fix the other electrical challenges the windows may work as well. It is very rare all four windows stop at the same time. Usually it is the driver window that goes.
  • peachpie5254peachpie5254 FloridaPosts: 14
    I think you need to prioritize your problems. First off, if the engine is making rattling noises get that checked out. What if you need a new engine? Are you going to get one? The other items are secondary. $600 for flushes? Get another mechanic. My two rear windows don't work. I'm glad they don't as I left the keys inside the locked car the other day. Just pulled down the glass and I was in. They stay up on their own. Saved me time and money for a locksmith. My windshield wiper doesn't run on all speeds and sometimes turns off when I use the signal. I'm assuming that's the switch itself that needs replacing. You say one headlight is out. The low beam could be out and the high beam ok. Two different filaments involved. Check the wiring with your good headlight to make sure. But get that engine checked out first. If it is a major repair/replace you might not want to keep the car.
  • I have an air bag light on - code 32.
    Says driver side - circuit open.
    Is this something for the dealer to address?
    Or is there a wire loose under the seat somewhere.
    Mike
  • What did the dealer charge and is it fixed yet?
  • miki3miki3 Posts: 2
    The engine won’t keep running without accelerator. It seems to be ok after warmed up but I don’t see any other warning messages. Could someone give me an advice please? :cry:
  • izaclown1izaclown1 Posts: 118
    My 2k was doing the same thing a couple of weeks ago. It was a idle sensor. Either IAC or IEC was the reference used by the tech. It is annoying when it cold and you are trying to make a turn and the engine dies... :blush:
  • I believe the problem is something called an Idle Control Valve. Top rear of engine. It is connected by two 3/8 bolts and one wire. It is connected to a larger exhaust breather type hose that projects into the top of the engine manifold. You will find this device sticking up dead center at the back of the engine. It is silver in color and looks like two pie pans stuck together about 2 1/4 in in diameter. Good Luck its and easy fix.
  • swabswab Posts: 1
    im sorry i could not find the right place to post

    i have a lincoln towncar 1990, My fuel pump isnt turning on, this happended before the wires that went into the alternator melted, i had to replace the alternator plug, but this time it wasnt the problem, i followed the alternator wires to the battery and saw that some wires were bare and they might have touched some metal, what would that short out?? i checked the fuelpump relay and found out that is wasnt getting power, but some were, what exactlly do i need to replace it?
  • miki3miki3 Posts: 2
    I took it to a mechanic two two days ago but they said nothing wrong as it didn't have "Check the Engine" light. They just cleaned the battery area and told me to wait and see. Well, it’s been fine so far but the problem happens only once a two week. I will keep both replies for next time. (I hope it won't happyen but...)
    Thank you so much for your input!!!! :)
  • I have a 1990 lincoln town car with 120k miles. it had a bad oil leak. i have replaced the oil switch valve cover gaskets and rear main seal. it is still leaking granted a lot less than it was but still a leak. i heard something about the oil pressure relief valve sticking and causing the filter to baloon and leak. has anyone had this problem or have any suggestions? please help me am going crazy chasing leaks. :mad:
  • mhelselmhelsel Posts: 11
    I have a 93 town car, not have any problem with the cluster,mine has started to smoke at idling,what is causing this,thank for any help
  • mhelselmhelsel Posts: 11
    Hi I have a 93 town car it has begun to smoke at idle.the car runs great,no problems other than smoking at idle,running it dont smoke,help :sick: ">
  • that is how my oil leaks started the smoke at idle came from a small oil leak leaking onto the engine. eventually it turned into everything leaking.
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,425
    What color is the smoke coming out the exhaust? White or light gray is good, but dark smoke indicates a rich fuel mixture. Often replacing the Barametric Manifold Air Pressure Sensor will correct the rich fuel problem.

    Your engine is completely changed from the power plant in the 90 Lincoln.
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,425
    The 302 c.i. engine has an oil pressure sending unit easy to get to. Usually the neoprene seal cracks with age and enables oil to escape. An easy fix & not expensive. :)
  • garkevgarkev Posts: 1
    hi, i am trying to replace my wiper motor on my lincoln town car but having a problem removing the wiper arm, any advice? thanks
  • On my 92 92 Lincoln Town Car, my drivers side window had stopped working altogether.
    I recently had a new window motor installed.
    Now my problem is, that it works just fine at times, while at other times, either works very slowly in up or down, or not at all.
    When it is working at times, the window will stop working in attempting to roll it up.
    Then if I wait awhile, it will start to roll up again.
    Someone mentioned, that Relay maybe Bad.
    My question is, does anyone know the location of the window relay?
    Thank you
  • I have a 1990 Lincoln TC and I have a short somewhere that I cannot locate. I pulled into an unfamiliar drive way yesterday and bottomed out pretty hard. Nothing was damaged, however, when I tried to use my turn signal just minutes later it would not flash; it would just turn on... Also, when I turned on the signal the radio would turn off. When I hit the brakes the radio would turn off. Last night it rained very hard and I was again reminded of my electrical short by how rough my car was running. This morning is was still raining and she didn't start very smooth, but I figured she would be fine. Well, on my way to work I turned on my interior light, which was already dim, and the entire cluster went black. I pulled over because I wasn't even sure if my brake lights were working. When I pulled over I realized that my car wasn't running. Any idea where my short could be located??? :confuse:
  • I am really really frustrated! I replaced the motor on my 1995 TC 2 months ago and haven't driven it very much as we were on holiday for 6 weeks. When I picked the car up from the shop and drove it home it just didn't feel right. The gear change lever was sooooo tight and difficult to move and when driving it was a hard change from first to second and second to third. Also there was hesitation when accelerating. I went back to the mechanic and told him about this. He told me the cable from the shifter probably needed to be replaced as sometimes that happens and it was just coincidence it happened now. However we returned from holidays and yesterday on my way home there was this awful noise accompanied by clouds of smoke from the back of the car! Needless to say I stopped pretty quick called the mechanic and had the car towed. He now tells me that there was a leak in the transmission and all the oil leaked out and I probably need to replace the pump and a bunch of other stuff. I have a bit of a problem with this as a month before the motor was replaced I had the yearly tranny check done and everything was all good. My question here is... when the motor was replaced is it possible that the tranny was not fitted properly which has caused the oil to leak out? Am I being given a snow job to hide a mistake? I have no problems with the transmission prior to this. HELP!!!! :cry:
  • Do you see an oil slick in your garage?

    I suspect they took off your torque convertor, lost the oil and then put it back together without refilling it.
  • Nope no oil slick. after I replaced the motor we power washed the concrete and no more oil slick!
  • Hi, on my 99 TC Executive, I have two problems that I think are related. First the courtesy light won't shut off unless fuse is removed. Also dash light don't work at all when the headlights are on or off. Appear to be related problems. What should I Do?
    Thanks
  • lmj1lmj1 Posts: 1
    It could also be the regulator causing your problem. Does it stick in a certain spot, if it does, you probably need to grease the regulator. The regulator is the device attached to the window motor, that looks like it has to bike brake lines coming out of it.

    The relay is located under the hood, one of the square boxes, like where your fuses are located. If it's not labled, ask a dealer for a diagram or the numbers to identify it.
  • This my question that got no replies.
    I took the airbag light on solid problem to the dealer.
    My research (from this forum) told me that if the horn and cruise control do not work, it is most likely the clockspring. They replaced it at the tune of $260.
    A $65 part and $195 labor. My radio stations were the same,
    so I guess they did not touch the battery.
    Problem solved.
  • Lately, when it rains, water is getting into the backseat passenger side of my 98 Lincoln Towncar. I have a sunroof but don't know if it's leaking, I can't see any obvious signs. There is about an inch or more on the floor after it rains.
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,425
    When the rain trough above the trunk is clogged, dirty, or otherwise blocking drainage or if the car is parked facing downhill on a slope - could be the source of entering water.

    If the floor of your trunk area is not wet, that's a good sign it is coming from another source.
  • Thank you. I'll look and see if that area is clogged. I just hop it's not the sunroof.
  • Could be a coil needs to be replaced or maybe the torque converter.
  • sometimes when i start my car it shuts right back off within maybe 2 seconds, and the only way to keep it running is to keep my foot on the gas, now this problem only happens maybe once every 2-3 weeks but it is very annoying. it is usually ok after i drive the car for about 10 minutes, but tonight it did it all the way home(about a 30 minute drive) the check engine light does not come on, and taking it to a shop is probably useless because like i said it does it at randon. anybody else had this problem or know what it could be
  • ok this is kinda making me mad now, right after i posted i went outside jus to see would it stay running, and it did. i dont know what to do about it. im almost scared to drive it i may get somewhere and get stuck. oh yea and i forgot to mention in my first post im running about 1500 watts of memphis car audio stereo equipment. would this have anything to do with it
Sign In or Register to comment.