Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!

Jeep Liberty Diesel Maintenance and Repair

1678911

Comments

  • Hey everyone,
    My first post on this issue, thought I could get some help. My EGR valve keeps messing up. My check engine light keeps going off every time this happens and it always codes for an EGR problem. This will be the 3rd time I replace the EGR valve in the past 2 years. The second time it was replaced under warranty, but I'm tired of having to change this same part so many times. Why does it keep going out? and what can I do to prevent it? :sick:
  • siberiasiberia Posts: 520
    At 22K miles engine codes indicted that EGR valve had failed and dealer replaced under warrantee. I saw the part that was replaced and it did not look bad having only a light coating of soot, apparently stuck in closed position. Anyway, over the past 43K miles the engine light has occurred several times and the codes indicated EGR valve problem. I used my scan tool to clear the codes and just drove it. Right now I am at around 12K miles since the last engine light. My guess is that (in my case) under certain conditions when systems are in transition the computer reads information that indicates a problem when none really exists.

    Also, I drive sometimes to clean out the valve. What I do is run 55 MPH with overdrive off for a few miles. According to my scan tool, intake manifold input air temperature is high under this condition indicating that the EGR valve is pretty much wide open. Then I floor it up to around 70 MPH to fully close the valve – still overdrive off.

    I am just telling you my situation and not trying to say that this is your problem or that what I am doing will work in your case. You could have a different problem and replacing the EGR valve is not the solution.
  • caribou1caribou1 Posts: 1,354
    Hi Siberia,
    Last week I cleaned the engine compartment for the first time ;) : this is my 150,000 Km service.

    I desperately checked for leaks and inspected the Boost Pressure Sensor. Since I disconnected the EGR (about 5 years ago) there is no soot on the sensor anymore.

    I have a slight diesel fuel smell after one hour of travel but no trace of leak around the engine. All injector connections were tight and dry.

    The only corrective action I had to take was to clean a 'solid' deposit that had formed inside the fuel filter bowl, under the heating element. This took me 15 minutes and one dozen Q-Tips :shades:
  • tony_eyetony_eye Posts: 1
    Hi,
    I'm new to this forum and also have problems with the EGR valve on my 2005 Jeep Liberty. At 50,000 miles the check engine light came on and there was a loss of power at low RPM. When the engine was cold there was almost no throttle response from a stop, then a huge power surge and an equally huge black cloud behind me. My local Jeep dealer (where I am employed) replaced the EGR and cleaned the system. Everything worked great until 68,000 miles. I now have the exact same problem. I have noticed on this forum that several people have disconnected their EGR valve. I talked to our technician about that and he said he could do it but that the check engine light would be on continually. Is there a way around that?
  • carwashcarwash Posts: 1
    Farout
    Re engine light remaining on (after 3 warmups) If it is a glitch in the system, try this: Hold the mileage rest button in and turn the key to the stop before starting. You will see a self test occur with lights, and dials sequencing, and if a glitch, may cancet the engine light.. It worked on mine on a couple of occasions in the past.
    Not this time though, as I have a P1140 code, but have not tried all the suggestions mentioned above. Hope it cures your engine light on, problem.
  • ddvmanddvman Posts: 2
    Hi,
    It's time to change the timing belt on my 06 CRD Liberty.
    The dealer quotes almost $900 in parts to do the job.
    In light of all the current problems at Chrysler, I'm looking for sources for parts for this engine. I'm open to any suppliers in the U.S. or Europe. Was this engine used by any other manufacturers? It is the 2.8L 4-Cyl. Turbo Diesel Engine (CRD).

    Any help would be greatly appreciate.

    Thanks!

    Dan
  • caribou1caribou1 Posts: 1,354
    Hi ddvman,
    You're being asked 1/2 of what I had to pay to have the work done at 60,000 miles, so welcome to Jeep's rich owners club :sick:
    This morning I met a retired couple from Great Britain who got rid of their Liberty because of prohibitive cost of maintenance beyond 100,000 miles. They were looking at my CRD because their brand new Honda CRV had a problem and no parts were available yet on the continent. Sad but true, they have to drive 700 miles to get back home in a rental Fiat. The lady said she preffered the Jeep to the Honda.
  • My white driving lights in the front grill of my 2005 2.8 crd don't work and I don't remember them ever working.
    I replaced the relay and pulled one of the bulbs and it ohm'ed out fine.
    Anybody else experience those lights not working?
  • Cripes...I just learned something. They are not driving lights, they are fog lights. I thought they were marker lights that came on with the ignition. I read some posts and found out they are a switched light. The "half on, then pull" function of the switch got past me. So for two years I have driving "Little Bully" and didn't know he had functioning fog lights. :shades:
  • HOLY CRIPES... ok...so I read to clean the turbo sensor behind the fuel pressure sensor. It was totally easy and my milage jumped from 22mpg back up to 27.2 on a city 30 mile round trip doing errands.
    I should have known that because I would clean the O2 sensor on my Cadillac and the performance and mpg would jump back up.
    Now, I'm wondering what other sensor I can clean.?!?
    :shades:
  • Ok, Yall...here's the story on the oil light coming on at revs over 1,500 when cold.
    88,000 miles and it was the sensor.
    Easy to replace. It's on the back side where the oil filter screws on and you have to take to skid plate off to get to it. The skid plate it's very simple with 4 bolts and a short 3/8" extension.
    The dealer had a sensor in stock for $65 bucks (I could have bought it cheaper on eBay.)
    I love this damn Jeep.
    I read a post by a european bragging about how "BULLET PROOF" these VM Mitori engines are and they drive them all over their continent for decades. Their only complaint it the government mandated crap on the exterior.
    Now... I know... that an oil sensor in not government mandated but 88,000 miles ain't bad.
    I have a set of tires that are rated for 60,000 miles and I remember back in the 60's when we couldn't make the whole damn car go 60,000 miles...lol... :shades:
  • andrewjake,

    That's funny! I did the same thing when I bought my CRD too. Okay, just to let you know, (cuz I had no clue) that when your fox lights don't work anymore... just replace the fuse. I had no idea that they were on the fuse. :blush:
  • Tony_eye,

    I have the same problems as you do. My turbo has been replaced and my EGR valve has been replaced twice and the fuel pump too, I believe. I had no idea how to describe what was going on, and you have described all my issues. Recently, my CRD has been stalling. I figured out it's a loss of fuel pressure. I have to prime it about 20 times and than it will start. My problems don't seem to be going away. Is there something I can clean to prevent this from happening?

    DieselKimmie
  • andrewjake,

    Hi again,

    Can you tell me how to clean the turbo sensor behind the fuel pressure sensor? Or tell me where I can find instructions on how to clean it? Is there anything else I can clean to improve my CRD? I have a loss of fuel pressure and by this, I'm stalling frequently, I'll have to prime it about 20 times than I'll get her running again. But it's a pain in my butt to keep having to do this, and it's not reliable...

    My turbo, ERG (twice) and the fuel pump have been replaced. It's getting old. My mileage is around 22 also, when it should be more towards 30.

    Any help would be greatly appreciated.

    DieselKimmie
  • Point that I remember...For a Happy CRD 2.8 Turbo Diesel...
    A. Use Chevron "white" diesel (it's easier on the expensive fuel filters and cleaner on the EGR and CAT).
    (bio-fuel would be fun, cool, feel and smell better but where can we get that, right?)
    B. Drain the water from the fuel filter every 10k.
    C. Bleed the air from the top of filter with pump every 10k.
    D. Clean the MAP sensor every 10k.
    E. Clean the MAF sensor every 10k (I suggest a tooth brush and MAF cleaner for both).
    F. Clean the Turbo filter with a different clean tooth brush and compressed air every 10k or sooner if you drive a lot of dusty roads or follow on the same.
    G. Get a 5/8" bailer plug from marine store for the oil pan plug because some moron is going to strip it out.
    H. add this to the regular schedule of maintenance and I could not point to one that would be more important than the other because just about either of one of them (excluding the bailer plug) will make your CRD run like CRUD and make you think you have a lemon. BUT YOU DON'T...The VM Mitori engine is bullet proof...it's the American emissions, sensors and dirty fuel that we have to clean up and think diesel.
    I. "I" is for what "I" don't know yet...

    DieselKimmie...The MAP (manifold absolute pressure) sensor is behind the fuel pressure sensor on the right rear top side of the motor. Take the motor cover off by removing the oil cap and pull the entire cover up and off. Disconnect both the fuel sensor plug and the MAP sensor plug. Do not remover the fuel pressure sensor, you just need the extra room to work. You can pull up the wiring harness to get better access. Use an allen wrench to remove the one allen screw that holds in the sensor. Be careful not to drop the screw. The sensor pushes in and pulls out with a donut gasket. Clean it with MAP sensor cleaner or break parts cleaner and an old tooth brush. Put it back in.
    The MAF (mass air flow) sensor is located in front of the airbox filter. Take it out , clean it, put it back in.
    The turbo air filter is behind the air box. It looks like an inline fuel filter but bigger and is open to air. Take it off...use compressed air to clean or replace.

    let me know how it goes...
  • Hi All,
    I could use some help and direction. The Jeep dealer says my EGR valve has failed and they want to charge me $850.00 U.S. that I don't have. Is this necessary? I haven't noticed any performance problems other than the check engine light. I have 41,500 miles on the 2005. What do you recomemend? Can this be done by a novist mechanic? Jeep told me they have to calibrate it when the EGR valve is replaced (not surewhat that means exactly). The part lists for $220.00 U.S. can the original be cleaned? I doubt it had anything cleaned on it I bought it with 30,400 about 8 months ago and I've done nothing except for change the oil (mobil 1 0w-40) and wix oil filter and rotate the tires. Typicall I only get 23 to 24 mpg. Of course I'd like to increase that if possible.

    Thanks in advance
  • If you look on eBay under "CRD EGR" I saw four egr's for sale cheap.
    Or maybe someone near you can do the bypass thing.
  • Does anyone know where I can buy beg borrow or steal a 05 -06 Jeep Liberty CRD Repair Manual? I have been not able to locate a haynes or chilton manual etc.
  • How do you bypass it?
  • steverstever Posts: 52,683
    Sometimes you can find good stuff online.

    Online Repair Manuals
  • eBay...search your year and make...$15.00
    I have the CD and they are helpful.
    It won't tell you how to do a egr bypass.
    but worth the fifteen bucks.
  • gh1961gh1961 Posts: 30
    what's a PCM?
  • tidestertidester Posts: 10,059
    PCM = Powertrain Control Module

    tidester, host
    SUVs and Smart Shopper
  • Our CRD has 42,000 miles on it. For the last several months we have had surging when try to accelerate from stopped, engine ided a couple of times, a feeling that the torque converter was grabbing when you let off the accelerator at speed.

    I changed the fuel filter a couple of thousand miles ago and ran 2-3 of tanks of injector cleaner through it which seemed to help.

    Now the OBD light has come on and stayed on for the last week and several startups. We took it to the local Jeep dealer, that doesn't work on Diesels, and they plugged it into the computer and got the following fault codes: P0093 "fuel ststem large leak", P0299 "turbo underboost" and P0300 "multiple cylinder misfire" - all fault codes are fuel system related.

    I'm in Cal e fornia and since the diesels were never sold here none of the local dealers have ever been trained to work on them. I'm told ours is the only one they have ever seen.

    Can anyone tell me more about the 3 fault codes. Is there anything I can do or do I need to take it to a dealer that works on the Dodge Sprinter, which uses the same engine? It seems to be running great right now. Will it hurt anything to continue driving it with the OBD light on? Does anyone know how to reset the OBD light?
  • Autozone will check and clear codes for free, that is if you have an Autozone store in your area.
  • OK, Thanks....I do have an Autozone in the area - good to know. The dealer read the "codes' for me for free....I was told that the Jeep computer reads the various sensors each time the engine is started and unless the problem causing the fault code is fixed the error will reoccur and that if the problem is fixed the computer will turn off the OBD light the next time the engine is started.

    Back to my original question. Does anyone have any experience with the three codes I listed, and if so, what did you do to clear them?

    Thanks
  • Following one of the suggestions on the web I tried to purge any air from the fuel filter by pumping the top of the filter "purge pump" or whatever it's called. Sure enough the feel was soft for the first 3-4 pumps then became solid. Then I noticed fuel leaking from the front electrical connection! I took the Jeep back to the dealer and told them about the s computer codes and the filter fuel leak.

    They called saying they needed to replace the fuel filter assembly and electrical connector then retest for the three codes......well replacing the filter and connector took care of all the codes and $ 331 later the Jeep is purring again!
  • Want help please. The warning light for the warning there is water in the diesel filter did come on. So i look by the filter and find a screw under the filter, then i take it out but there was noting coming out. But instead it seem like the diesel drains out of the filter, and now i can not find the manual pomp that is always present in diesel enjins to fill it again. So i just want to know what must i do to fill the diesel filter because it don`t want to start now?
  • Hey guys, hope everyone is having a good new year.
    now for my problem. I am having an issue with diesel being sent to ( limp in mode)
    quite often. I have removed and cleaned the boost sensor around 5 times in the last
    3 years. However the other day I removed it and as I was cleaning it noticed that the
    sensor probe tip has what looks like a 2 piece contact probe arrangement.
    my question is does anyone know if the probe is suppose to be a solid tip (soldered) or a 2 piece contact configuration.

    Thanks in advance
    Tnilc
  • Can anyone help? I need a service/ repair manuel fro my 2006 jeep liberty crd. I can only find gas
Sign In or Register to comment.