Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Oldsmobile Alero Starting-Stalling Problems



  • I have spent a long time reading these forums and tried just about everything mentioned...I have yet to replace anything except the battery because money is tight and I need to make sure and get it right the first time. Here's what's going on...
    an 02 i bought in feb 10 with 104K (i saw right away the ignitioin lock cylinder was bad and had to learn how to giggle it just right in order to start). i put 4K on it and it has sat for the majority of the last 3 or 4 months.First started shutting down in the middle of driving, and then not starting at all. my first success at starting it again was with quick starting fluid, ran for one day and then wouldnt start again, then i found this forum and tried wd40 on my keys, manually locking and unlocking both doors, turning the key in the on position for 10 min (that worked like 4 times).
    So today i decide to take another shot at it after not starting for a month...i turned the key and floored the accelerator pumping it and it started maybe 7 back to nothing.
    i have dreamed of owning this car since the first time i saw it, finally i had the means but i put everything i had into buying the car :cry:
    so has anyone thought of the ignition cylinder or switch? i havent really seen it mentioned on here but i know they turn on systems such as the fuel system
  • burdawgburdawg Posts: 1,524
    Nowhere on your post did I see anything about the security light coming on and blinking when you try to start it. If that's not happening, then it's probably not the passlock system. Has the fuel supply been checked? Your symptoms sound a lot like a weak, failing fuel pump, or clogged fuel filter. The ignition switch is a possibility also especially if you had to "jiggle" it to get it to work.
  • the security light does not come on or blink anymore, but reseting it did get it to start a few times with no hesitation. how do i go about checking the fuel supply? that was initially what i thought until the security came about...but i guess it is a good place to start. could u also tell me where i could find info on how to change it? i never worked on anything past the mid 90's so i am pretty lost with this car. tyvm. :shades:
  • I bought my 2000 Oldsmobile Alero as of a week and two days ago. It has been legally on the road for maybe five days. Yesterday, it wouldn't start. I turned the key but there was no noise, no nothing. The lights inside would come on, but there was no clicking, knocking, humming, coughing, anything. After about an hour, we went back to the car and with a little trick that I don't know, my father-in-law got it started so that we could go somewhere. He said something about moving it so that the brushes were in the moving position. (I'm a chick that is passable in figuring out basic, major things wrong with a car so I don't know WHAT he was talking about.)

    Anyway, I went out to start my car later that night and after some cranking, it turned on. This morning, no go. It's cranking like it wants to start but it's not going the full distance. I don't know what is going on and it's so frustrating after not having a car for six months, getting one, and only using it a handful of times before it cuts out on me.

    Please help.
  • burdawgburdawg Posts: 1,524
    To check the fuel supply the pressure needs to tested with a gauge and the flow measured by volume pumped in a specified time.
    If you mean changing the fuel pump, it's in the tank. The tank needs to be removed for access.
  • I am in the same situation as you. I started driving my 04 Alero one week ago today. Went in the grocery store for less than 19 minutes and came out to a car that will not start. All the lights worked, radio, horn everything. It just would not make an attempt to start. I live in a small town so 3 mechanics I knew actually stopped by to help but were all puzzled by the situation. My uncle (a mechanic) took the starter off and had it tested. It was lock up and had no power, totally shot! So I spend $140 on the starter and stood through the embrassment of having my car worked on in the grocery store parking lot. And still that did not work. So everyone is now thinking it must be the security system. I had a new battery installed 4 days ago. Did it reset the system or something. I need some ideas.
  • My problem was the battery. Something was on and it had drained it down to half its voltage.

    The mechanic we took it to to be sure it was the battery informed us about a little snick in the security system: For whatever reason, the starter chip in your key won't be recognized and the car won't start. The mechanic said that you had to leave the key in the starter for like ten to fifteen minutes before the problem corrects itself. Hope that might help.
  • I learned this trick from this site, and it has been working for 2 years. I drive a 2003 Alero 2-door. Turn the key to ACC leave it there in the ignition for at least 25 minutes. When the time has elapsed, try starting it. If it starts it is the security passlock system locking up and not recognizing your key. Doing this resets it and reprograms your key. It is the only starting problem I've ever had with my car. Thank goodness mine is paid for now. So, I'll just drive it until it dies, and then will get something else. Am tucking monies away and hoping nothing major goes out. A mechanic told me that this usually starts happening between 75,000 and 85,000 miles, not sure how many miles are on your car, but the previous owner could have been nice enough to let you know. Hmmmm?! Hope this is it, as this is an easy fix. Good luck!
  • burdawgburdawg Posts: 1,524
    1. "It just would not make an attempt to start". Do you mean it would do nothing? The engine wouldn't spin when you turned the key to the start position?

    2. "My uncle (a mechanic) took the starter off and had it tested. It was lock up and had no power, totally shot! So I spend $140 on the starter and stood through the embrassment of having my car worked on in the grocery store parking lot. And still that did not work". So I guess it's safe to say the starter wasn't the problem?

    3. "So everyone is now thinking it must be the security system". Did the "security" light come on and flash when you tried to start it?

    Your Alero has Passlock II. The key deosn't have anything to do with it like in the "Passkey" security systems used in the past.
    If the "security" light is coming on and flashing when you try to start it then turn it to the "on" position, wait 10 minutes and see if the light goes out. If so, then try to start it (this is in the owners manual for reference).
    If there's been no security light, and the engine spins when you try to start, then the first place I would look is the fuel supply (pump/filter) and then the ignition switch.
    If nothing happens when you turn the key to "start", I would look at the ignition switch & battery cables first (would say battery, but it's new, make sure it's not dead or rundown). Also check that the power to the solenoid on the starter is present when the key is turned to the "start" position. Unless the solenoid on the starter engages when you try to start it the starter will never turn.
  • I have 2003 alero and I have same issue where everything generates on car but there is no sound period. It has happened to me twice this year once in March, and most recent 2 weeks ago. I had to get car towed to an auto repair shop so they could reset my keys both times. Is there anyway this issue can be resolved w/o the expenses?
  • I had problems with my Alero not wanting to start and then when it did it would stall. My mechanic figured out that it was the Ignition switch. I had it replaced yesterday and now it starts and runs great. I hope this helps you out.
  • burdawgburdawg Posts: 1,524
    I can't figure out what you mean by "everything generates on car but there is no sound period".
    Also, what does "reset my keys both times" mean? The keys in a Passlock II car don't have anything to do with the security system.
    Is the security light coming on and flashing when you try to start it?
  • I have a 99 Alero with a V-6. When it's cold, it starts and idles fine. When it's warm, I have to give it some gas to get it to start and I have to hold the gas pedal partially down after it starts or else it dies. Once it's running for 5 or 10 seconds, I can release the gas pedal and it idles on its own, but it isn't a stable idle. Once I put it in gear, it idles and runs fine. Any ideas of where to start looking?
  • For those of you who have a 1999 - 2004 Alero and have been having problems with the Security system keeping you from starting the car, read on....

    I am a retired GM Electrical Engineer. I own a 2002 Grand Am, and had this problem two years ago. I bought a Shop Manual for my car ($130.00), and worked out a way of bypassing the Passlock II system on my vehicle. After making the modification on my car, I have not had a single instance of No start caused by the Security system.

    Last week, as a favor to a friend, I performed the same modification on a 2003 Alero. It took less than an hour. (not counting the time I spent taking photos of my progress) The modification was successful on that vehicle.

    Details of the modification are posted on my personal website at:

    There are instructions on how to do the modification using two methods. Both methods bypass the security module in the ignition circuit. One bypasses it at the connector to the Body Control Module, which is under the glove box. The other does the bypass near the ignition switch, which can be reached by removing the radio.

    Please post back if you find the instructions useful.

    Richard Berger
  • Mr Berger
    My local Radio Shaq only supplies 2.2 and 3.3 resistors. I'm needing a 2.7 resistor. Is it o.k. to use the 3.3 resistor? I serously doubt that I'll be able to find a .5 resistor; to add to the 2.2.

    All help is needed. So far, I've taken out the radio, located the yellow, black and white wires. I've straped the insulation off of the black wire.
  • Question: Sometimes when cranking, it's like I messed up the process, it will kick over for a sec. or two then not crank. It then acts like it's not getting gas. My mechanic said turn on the ignition and let it stay in the on position for 15-20 min. This resets the computer I think? But it'll start then. Is this what your talking about?
  • I don't hace a chip in my key(2003 model) or anything remotly electronic inside my key. I was told that it will reset the computer after 15-20 min.
    Also, if I press hard on the brake, turn on the wipers, radio, raise a window all at the same time of trying to crank, it willllll sometimes crank. NO JOKE!. :confuse:
  • burdawgburdawg Posts: 1,524
    Does the "security" light come on and flash? Also, the passlock won't keep it from cranking, just cuts off the fuel.
  • Myalero,
    I should have mentioned in my instructions that you can use any resistor from about 1000 ohms to about 4000 ohms. I chose a 2.7 Kohm because it's closest to the center of the allowable range. On my Grand Am, I used a 2.2 Kohm resistor, and it worked just fine.
  • lovemygrandamlovemygrandam Posts: 330
    edited October 2010

    I'm talking about when the security light comes on and flashes, or comes on and stays on solid. Read my website:

    Your answer should be there.

    Definitions: CRANK - The starter motor makes the engine turn over. Rr-rr-rr-rr-rr.
    START - Engine roars into life - Vvrrooooooommmmmmm!
    DOESN'T CRANK - No "rr-rr-rr-rr-rr"
    DOESN'T START - No "Vvrrooooooommmmmmm!"
  • lovemygrandamlovemygrandam Posts: 330
    edited October 2010
    Well, here you are in the Alero forums too. Did you get tired of helping out people with Grand Ams? (just kidding)
    Dick Berger
  • burdawgburdawg Posts: 1,524
    No, but they're so similar that most things apply to both.
  • Yeah, especially the Passlock problem. So far, I've fixed two Grand Ams, One Alero, and two Chevy's.


    1800- 630- 2439

  • I actually found the resistor that you used. I took a 30 min drive find it....
    Needless to say, I was so happy. ;)
    Followed your instructions to a {T} :blush:
    The wiring/work look beautiful. :P
    To make a long story short, it didn't work. :sick:
    My security light no longer flashes......
    Today, it stays on consistantly... controlling my battery; as to wear it will not crank
  • I actually found the resistor that you used. I took a 30 min drive find it....
    Needless to say, I was so happy. :blush:
    Followed your instructions to a {T}
    The wiring/work look beautiful.
    To make a long story short, it didn't work.
    My security light no longer flashes......
    Today, it stays on consistantly... controlling my battery; as to wear it will not crank
    :sick: :sick: :sick: :sick:
  • lovemygrandamlovemygrandam Posts: 330
    edited October 2010
    I'm not sure what you mean by "Controlling my battery; as to wear it will not crank"
    If the light is on solid, it means that the BCM has found a fault with the security system. This could happen if you soldered the resistor to the wrong end of the yellow wire...You can check to see if that is the case as follows.
    * Remove the kick panel on the passenger side so you can get to the BCM. (see instructions on my website for Pontiac Fix.)
    * disconnect the center connector from the BCM
    * find the connector pin that has the yellow wire going into it. It should be the center pin on one side of the connector. Directly across from that pin, should be a pin with a black wire connected to it.
    * measure the resistance between the above two pins. They should read very near to the same resistance as the resistor you soldered into the circuit.

    If your ohmmeter reads a very high resistance or an open, you didn't make a good connection on the ground (black) wire, or you connected the other end of the resistor to the wrong end of the yellow wire. If it reads near zero ohms, the wires are shorted together. If the ohmmeter reads the correct resistance, the BCM is at fault.

    There is one other possibility. In my original instructions, I recommended using a 2.7kohm resistor. That means 2700 ohms. If you soldered in a 2.7 ohm resistor, that is the wrong size. Remove it and replace it with one of the following:
    2000 ohms - color code- red black red
    2200 ohms - color code- red red red
    2700 ohms - color code- red violet red
    3300 ohms - color code- orange orange red
    All of which should be available at any Radio Shack store. After you mentioned in another post that you could not find a 2.7 resistor, I edited my website to make it clear that any of several resistors would work.
    If the color codes for the resistor you used are red-violet-black, you have used a 2.7 ohm resistor, which will not work.
  • burdawgburdawg Posts: 1,524
    Even if the BCM finds a fault with the passlock, it shouldn't keep the starter from working...........
    I suspect there's more going on here.
  • My Alero has now been into the shop twice for this same problem. The car turns over, but doesn't start. Eventually I get it to start, but then it might stall out while driving. The security light is not flashing, I learned about that problem several months ago and my mechanic figured it out by reading my owner manual then told me what to do if it happened again. So the first time I took the car in, they changed the crank sensor and this fixed the problem for a week. Then they took out the security system and it drove home just fine. A day later it starts fine and then stalls a few blocks from my house. I got it restarted and drove it home. Not sure what to do, but reading all these posts I'm wondering if it's time to get a new car. Any advice? I just read somewhere that changing out the fuel pump fuse might help?
  • A day later it starts fine and then stalls a few blocks from my house.

    This is the classic symptom of a clogged fuel filter. Have that checked first. Fuel filters are much cheaper than new cars.
Sign In or Register to comment.