Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Chevy Blazer GMC Jimmy Electrical Problems



  • Could you post a photo of where the hole is and ID the year of your vehicle? I have searched a few times w/o any luck. Congrats on your success so far.

  • I will take some pics tomorrow and try to post them. I have a 2000 model. I also figured out a way to release the hatch without taking off the panel but it's difficult to explain. The pics would show the process much much better than I could explain it.
  • Okay, I figured out what the problem was! By the way, it is a 2000 Jimmy that I have. Once I was able to open the window and hatch (the small gold piece with the hole for the plastic piece I got a hold of it and manually moved it to the left with a screw driver), I popped off the plastic piece, and then grabbed my 7mm socket/ratchet thing (sorry I am not very mechanically inclined) and popped the inner metal panel off and surveyed that the small plastic piece, indeed, broke.

    I used a Dremel tool to create a new hole in the remaining piece of plastic and went and got a nylon screw and nut and created my own mechanism to open the window. Worked great, but now the window latch catches some of the time when closing, but most of the time it does not. I sprayed some WD40 on the latch portion and it seemed to work pretty well, but still had trouble catching to keep the window closed. I then started my vehicle and then the mechanism popped itself and the battery went ka-put!!!

    Not exactly sure what I may have done wrong...I was so proud of my handiwork! It got too late and so I figured I would see if it starts in the morning. There is a clicking noise when I start the car so I may have drained the battery? Or maybe for some reason the hatch is not thinking it is closed and something is messing up the electrical system. Not to offend anyone, but I hate vehicular problems! I guess tomorrow I will try and jump the vehicle and see if the hatch pops itself again, I may have to take it into the dealer since something may be draining the battery (not sure what) unless someone can provide some suggestions.

    Thanks for all your help and responses, I wouldn't have gotten as far as I did without your posts, they were a huge help...stay tuned!!!!
  • The world awaits your pics.... ;)
  • Hopefully someone will be able to help with this problem. Recently my my 98 blazer started having problems. Whenever I am driving, I can hear the turn signal clicking, even though the turn signal is not on. Has anyone else had this problem?
  • There's been some question about the top secret access hole that might let you open the glass/hatch manually without having the break out a B.F.H. If you look in the owner's manual you will find a paragraph talking about this hole. It's labeled as a emergency release access hole and it's located behind the carpet of the tail gate, on the top side (when closed) and in the center. You have to pull the carpet away from the tail gate to see it.

    I tried this and did find the hole. With a flash light I was able to see the "workings" of the latch and manually operate the electic lock actuator. You'll get the same results when you push the button on the outside of the tail gate or the appropriate button on the key fob........ lot's of noise but no worky.

    Some say you can use a bent rod of some kind and "fish" for the broken part of the latch. I'm no fisherman. Couldn't make it work. Some say you can pull the plastic panel back from the tail gate at the top to gain just enough access to manually open it. Well, it happened to be 103 degrees OUTSIDE that day and was about 130 inside the Blazer when I lost what was left of my temper and pulled a bit to much and made plastic go crack!! My compliments to those who had the patience to take it easy.

    Hope this extra bit of info helps someone else "Stick it to the Man!!"
  • Sorry they have so search on multifunction switch - its in the steering column and may be shorting so you hear the flasher relay behind the glove box. Try replacing the relay thats clicking first - left side of glove box put your hand in there and gently bend the corner of the glove box down and it will drop open to access behind it.
  • I have no idea which one of the following tricks worked, but I wanted to pass this note along in reference to the problems folks have discussed about the Jimmy/Blazer rear door/window latch.
    After having my 2000 Jimmy's rear window button jam in the pushed-in position this morning (I work in a secure building where the guards have to search our cars each day and the guard must have used a little too much umph in pushing in the button), I crawled inside and worked the inside latch on the door a few times. I also used the heel of my hand to pound all around the button on the outside. None of this worked, so I called my local dealership. They confirmed that this is a common problem, and suggested that I pound around the outside to jiggle everything back into place (I love them, and their practical advice!). When I went back to my Jimmy this afternoon to see if I could try one of the solutions posted on this website, or the pounding-jiggling trick, I was delighted to find that the button had popped out on its own.
    So, I am passing this along to those who, like me, might have rushed off to the dealership or to a toolbox to fix this ... try pounding around the area from the outside and then let it sit for a little while. Of course, none of this fixed the problem that I've had for most of the six years I've owned the Jimmy: the remote key fob doesn't unlock the rear door/window.
  • No longer had the owners manual for my 2002 ZR2. Below is a link where it can be downloaded. You'll need adobe 7.0.something. Look for 2.16. You'll find the solution there. No need to break anything. :) Thanks for all the feedback.

  • I tried to defrost my windows this morning for about 15 minutes before I realized that it was only blowing freezing cold air. Then I switched it to the heater and it was still just freezing. Any suggestions on where to start with the issue? Maybe something I could try at home before lugging it back into the shop?? Anything? The mornings are freezing now!
    Thanks! :mad:
  • if the temp gage is normal at 190-200 then not a stuck open thermostat but could be the fun clogged heater core. Have you changed the dex cool ever - so if temp is OK then but 3' of 5/8 and 3/4 heater hose. Open hood and place a rag and plastic bag to cover the dist and plug wires and then disconnect the 2 heater hoses at the firewall and hold them up so coolant lose is min. Attach the 2 pieces you just got and with a garden hose flush the heater core in both directions till it runs freely - just hold the garden hose to the heater hose with your hand so you do not blow the core out (small radiator in there and they are a piece of junk). After clean reattach the originals run and refill water and you should have heat.
    This assumes the controls move so make sure the vac line 5/32" under the hood on the drivers side, intake to reservior, is not rotted out and it Ts off to a plastic line to the controls. Good luck and its 90 here!!
  • problem is when you drill the hole out before the broken part it bottoms or tops out in the slot on the bracket that opens the window. you have to extend the arm out about 1/2" with 2 pieces of plastic, sloted to the center rise on the part that's left on the motor assy. when glue is dry add a piece of plastic between the 2 plastic parts you added. when dry i bored a 1/4" whole about 1/4" from the end of the broken part and added a 1/4" nylon rod in the hole and glued ( all with instant glue ). leave about 3/8" above the sloted hole in the window slide bracket and you should be good to go. my 2002 blazer broke about a year ago and after the fix so far so good. ron
  • I have a 98 Jimmy had the same problem. The problem is in the turn signal switch, small particles of metal (from the contact points) get mixed with the di-electric grease. You can either buy a new switch or remove the old switch and take it apart, clean-out the old grease then apply new di-electric grease. According to the repair manuals you have to pull the stearing wheel but I managed to remove steering column cover without removing the wheel just be careful.
  • I have a 98 Blazer with the same problem. It started with the clicking behind the glove box, then the cruise control stopped working, and now the windshield wiper works only when it wants to. Does it sound like cleaning out the di-electric grease and replacing it will fix these problems, or do you think I need to get a new switch? Is replacing the grease complicated?
  • I have a 98 Blazer, suddenly the speedometer/gauge lights, radio display light and compass/thermometer light are not working. Also, when I turn off the car and leave the headlight switch on, the audible notifier that your lights have been left on, does not make noise. I have tried the dimmer switch and is not helping...the light behind displaying what gear I am in, the tachometer and the 2WD indicator lights are the only ones that do work...any suggestions?
  • Sounds like a fuse. Open the drivers side door, and pull the panel off at the lower dash (push and turn knob). On the back side is a fuse map. Check for Inst pnl (instrument panel) and replace with the same size spade type fuse (should be spares attached to the cover).
  • It cut in and out a few times which leads me to believe it isn't a fuse, but I will certainly take a look and appreciate your advice. I looked at the fuse panel layout in the owner's manual when it happened and the instruments that are out seem to be on several different fuses, but again, I will take a look.
  • I would suspect the headlight switch assembly - its about $55 and after you pull the dash bezel off (center screw above gauges into dash top, recall 2 on the lower trim under steering wheel , then bezel snaps out and you change the switch by unscrewing 4 more screws) but watch out you do NOT break the hazard switch on top of the steering column when you remove the bezel! The dimmer section is a rheostat with a heat sink and they fail and then it has the auto headlight on/off feature in it too. Most auto stores carry these in stock.
  • Taking the switch out isn't hard as long as are careful, taking the switch apart isn't too bad but can be fun to put back together. Look at this way, you can try to fix the switch first, worst-case you will need to buy a new switch.
  • Hi,
    My 2000 Blazer started making an electrical whinning noise which corresponded to the rpm. Soon after the noise started, my original alternator died. I replaced it with a NAPA reman, and it worked fine for 3 days. On the forth day, it too died. I brought it back and got another one. After installing the second reman, the electrical winning sound returned and the voltage is fluctuating from 12.8~14.0 depending on the rpm. I have also recently replaced my battery with an Optima yellow top. Am I looking at some sort of short. Help!!
  • repairdogrepairdog Posts: 948
    Get the system tested - free at most auto stores and it will do a load test and amp draw. I skip the rebuilts now due to the problems you have (or had) and for $15 more get the new one - about $150 vs $135. Could be the tensioner pullet or idler pulley or water pump so listen closely and get the free test and check the main cables too.
  • My jimmy wasn't working awhile back and to get it going we had to jump the relay. Now i when i turn on the right turn signal the fuse blows and when i touch the brake pedal the fuse blows, Also no 4 ways. I'am not good with electic wires,but i will try. Just not sure where to start looking.
  • Finally found a minute to work on this issue. Found the hole at the top edge of the carpet. Poked a tool inside. Seemed to have found the actuator though. As I move it left the sound is familiar and that of the actuator. The lever you are referring, what exactly is it?

  • It all began with the battery. The positive cable connection at the battery got horribly green and white corrosion, so I cleaned that out. Solved the no start problem.

    Since then I've had several very weird problems.

    1. When I start the truck, the rear hatch opens! The only reason I know this is because the "hatch open light" comes on.

    2. The radio doesn't remember the correct time anymore, but does remember preset radio stations.

    3. This morning I drove the 25 highway miles to work, then got called back home for a small family emergency. When I started the truck back up, the IDLE speed was 3000 RPM!!! If I nudged the throttle it would increase, then drop back down to 3000RPM. Thought maybe the air filter was dirty, it looked fine. The throttle didn't seem to be stuck, manipulated it by hand under the hood. Interestingly enough when I put the car into reverse or drive, the RPMS would drop to 1500rpm. If put back into Park or Neutral, they would rocket back up to 3000rpm. About 10 miles into my trip back home from work the RPM issue went away...idle speed was around 500rpm in any gear.

    Whats causing all of this craziness? This is my family's only vehicle and with my wife being 5 months pregnant I dread the thought of not having a reliable vehicle at the ready!
  • repairdogrepairdog Posts: 948
    Now that BOTH battery terminals are clean and cables are good is the voltage correct on the gage about 14 volts? Blazers act screwy with low voltage so have a battery load test done and make such the alternator is good - that would be an easy #1. The computer does have a canned program it defaults to after battery disconnection and it then relearns from driving and actual sensor readings so is the SES light on and if so what codes #2. Then clean the air intake of the throttle body and the valve with spray and old toothbrush so no deposits and free operation (don't spray the whole can or will start really hard but then OK)as #3. On from there.
  • Well I got a new switch and finally got it put in. Everything works except I'm still having problems with the windshield wipers. The pulse works, and high speed wipe, and the spray wipe work, but regular speed wipe and delay wipe still don't work. Any suggestions?
  • repairdogrepairdog Posts: 948
    Yep, that's the circuit card in the wiper motor (drivers side under hood)- it can be burned traces or a simple remove, clean the grease off and install again not over tightening the 3 cover torx screws that can distort the card. Common problem and many stores carry the card at approx $50. if required.
  • I tapped the motor and and the wipers go on and off, so thats definately the problem. I'll try to clean the card, but if that doesn't work could I replace just the card (looks like they cost about $20 - they call it a wiper motor pulse board), or do you recommend replacing the entire motor?

    Thanks for all your help!
  • repairdogrepairdog Posts: 948
    Normally just the card goes bad and never had to do a motor. As you will see the torx screws may be hard to reach without a bit and a 1/4" drive and add a thin bead of silicon sealer to the cover edge to seal the moisture out and gently snug the screws so you don't flex the card,
  • budgalbudgal Posts: 3
    Service engine light keeps coming on and says that my tranny is stuck in 3rd gear. I have changed both cylinoids and the light still keeps coming on. I have also been having problems with getting the key out of the ignition ever since the light came on. The tranny works fine if I switch gears manually. I have changed the cylinder in the ignition and that hasn't helped either. Any suggestions of where to check now?
Sign In or Register to comment.