Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently switched from a luxury sedan to a luxury SUV?
A reporter would like to talk to you; please reach out to [email protected] by 7/25 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

GMC Yukon XL and Yukon XL Denali

1126127128130132

Comments

  • obyoneobyone Posts: 8,054
    That's amazing!! I would figure you wouldv'e blown your 4L60E or rear end by now.
  • Recently our Yukon XL has begun to surge and stall especially soon after start-up and occurs more often in wet/damp weather. It felt like a transmission slippage at first but we had the trannie inspected and it was ok.
    Does anyone have any ideas? Thanks in advance.
    jt
    [email protected] : :confuse:
  • Just purchased 2003 Yukon XLSLT 4WD with 67K, my second... the first was a 2001 XL SLE 2WD purchased new. so this is a step up for me. Really wanted a Denali for the 6liter engine but it came down to the AWD which I did not like the ride feel for some reason. So new to the forum and wanted some opinions on a few issues.
    1. Has anyone had an oil smell after driving the truck hard as in mod stop and go and highway traffic. Like when I am late picking up the kids.
    2. Anyone willing to share experience with the cold air and/or exhaust kits would be helpful as I want to give this 5.3 some more low end and maybe help the gas milage. I know...I want my cake !
  • My problem is with a 2003 Yukon XL's transmission. It began to whine at ~80,000 miles and progressively got louder. First the dealer played dumb on the issue (my wife took the XL to the dealer who probably assumed they could bumfoozel her) telling her they heard nothing. I took it in myself yesterday morning and told the service manager to get in and ride around the parking lot with me. He did so and recognized the loud whine right away. Unfortunately, my extended warranty ran out on January 1st and now I'm stuck with paying the bill to replace it!

    Where is the justice ? My first extended warranty and I find out that it terminated on the beginning of the 5th year, not the date of purchase.
  • I was curious to how(kit name, cost?) you had your truck lowered and the pros and cons of doing this when using larger wheels/tires. Now for the vent

    My 03 YXL SLT plush package 4x4 has an occasional "humming" after going over mod speed bumps as I accelerate and I am wondering if rear end is indicating something. Bought used w/ 67k and although an extremely clean looking truck when I changed to the Gibson freeflow exhaust I was appalled at the condition of the underside of this truck. I did not suspect anything as it drove and stopped OK and the dealer assured me this was a truck they had sold and had just taken back in on trade..."has our pedigree"
    When the wheels wre off I checked the brakes and barely got some new pads on before the rotors would have been chewed up. Now it stops like new. The parking brake shoe just disintegrated in my hand.Is it the weight and size of these trucks that make them use more rear brakes atypically than other vehicles?
    So much for the vehicle having the dealer pedigree and passing their 127 point inspection. Why do they lie? The previous owner obviously lived on a farm in Georgia because its caked with mud. If intentional water ever was used I'd be surprised. I was just keeping my finger crossed and now the SIHTF.
    1. Speedo now dead. Anybody had this happen
    2. windows shuddder when you let them down on passenger side.
    3. Factory CD player skips on everything you put in it(as I understand it these radios can't be replaced because they are coded to each vehicle[is this true? or can GM code another one].
    4. Homelink won't set to garage door opener. WHo says buying some type of warranty isn't good so hopefully Premier One will take care of these things. I am used to taking care of my vehicles not just for my piece of mind but because of resale and these are machines. I guess it takes all kinds to make the world go round right. Any help appreciated
  • I've had this car for 3 years with no problem. Today I go out to start the car and the ignition key will not turn. I also cannot move the gear shift. The internal lights work fine, the security system is working fine. If I turn on the headlight override I hear a beeping sound (?). I am at a loss as to what happened or what to do. The car worked perfect last night. Any help is much appreciated. I am NOT a car person just a woman in need of some 'simple' car advice. Thanks.
  • Wiggle the steering wheel back and forth while your foot is on the brake and you turn the ignition key.
  • i have an 01 yukon xl with the 5.3 liter i am looking to get a fitch fuel catalyst. so i went to the website and they dont have one for that year only 2006-2008.. but there is one for the chevy suburban in my year what is the difference if any .. could i purchase that one and be alright or wat? and does this product actually work? any mods to help the gas mileage and power that actually work?
    thanks
  • The Keyless Entry feature on my 2007 Yukon XL has quit working correctly. I've changed to the spare keyfob and made sure that the DIC was programmed to original factory settings. Neither tactic helped.
    The entrance door must be opened manually......but once inside, the keyfob will actuate the Keyless Entry system (it'll unlock or lock the doors). When I park the Yukon, the Keyfob will lock the doors as I leave......but will fail to unlock the doors if I'm gone for more than a minute or two. In other words, the system fails if I don't use the Keyfob for a minute or two. So long as I actuate the Keyfob every 15-seconds, it'll keep on working. Anybody got ideas?
  • A funny thing happened the other day to my 2003 Yukon XL. My speedometer just stopped registering speed.The Homelink won't set and the power seat adjustment are confused...i.e. when I push up the seat goes down. My point...the brains on these trucks have got too much on the mind. I disconnected my battery for a change to an optima red top and to install an intake kit and Gibson exhaust last month. and it hit me that thats when things started going wacky. I disconnected the battery again and allowed the brain to reset itself. Now speedometer works fine. Homelink still won't set so it may be my garage door opener system and the seats I figured out. Truy to disconnect your battery for a few minutes and see what happens.
    Does anyone know if I can get the factory radio to turn on an aftermarket amp. I want to add a subwoofer and have been told I can use a output control converter(line output converter) but what is going to turn on the amp. I have the Bose system so something must turn that amp om.
  • I recently had the same problem on mine and found the solution right here on Edmunds.com. See Post 499 in the "GMC Yukon and Yukon Denali Problems" forum, which refers to:

    "Tech confirmed failure key fobs using recommendation doc 1861180 put system to sleep removed rcdlr reinstalled fuse retested all OK"

    I took this info to my dealer and they repaired it--working fine now. One oddity--the service desk person said that they fixed the problem by replacing the remote keyfob--said there were a bad batch of keyfobs and mine was one of those. I don't think this is the case as my other original keyfob is now working whereas it wasn't before the repair. I think the fix is a software configuration thing on the car itself and has nothing to do with the keyfobs--there may be other problems with certain batches of keyfobs, but it's not the cause of this particular issue.

    Good luck.
  • 2004 Yukon XL. There seems to be grinding in the rear of the vehicle. It is intermittent and often goes several weeks without surfacing. It usually happens at low speeds and etiher during the first few minutes after driving or after a long drive.
    This past week, the 4WD Check light has illuminated.
    Anyone out there with a similar scenario? thanks jt
  • rkg1rkg1 Posts: 13
    Lately, my driver side Seat controls (on our 2003 Yukon XL) are working in reverse. If you press the seat to go forward, it goes back. If i press it to go back, it goes forward.

    Any advice???

    I took it to the dealer, because when it's working properly (not reversing) the seat won't go all the way forward. I originally thought something might be stuck under the seat. The dealer said I need a "seat extender" and that costs $700.00 !!!

    When the switches are in reverse-mode, the seat does go all the way forward.. .so I know that it can.

    It's just I never know which way the seat will move, and how far it will go. It's annoying because when I turn the car off, the seat automatically moves back (for easy exiting), and then I lose any good settings I may have had.

    Has anyone encountered this????
    All advice welcome!!
  • My 2003 Yukon does the same thing and I am also having trouble with the
    1. Homelink not pairing(Could be my model of garage door opener).

    2. Radio is on the blink intermittently but off more than on) Dealer said the radio was bad but I am wondering if its the amp because its all sources that won't deliver sound when it drops out. Display works, etc. but no sound.

    3. DVD player now won't load

    4. Power seat driver does the opposite of what direction I push it in. The driver memo and exit functions seems to work but I am wondering if this 700.00 seat extender is mechanical or electrical. If electrical could it have anything to do with other circuits. In my experience with GM vehicles they seem to tie in a lot of electronics/electricals i.e. "multifunction" switches. The problem is when they go screwy not one but all systems tied in get effected. These are great trucks but they hace issues that are annoying. Maybe why Consumer reports won't recommend even the new beautiful 2007/8
  • rkg1rkg1 Posts: 13
    Did you ever fix your seat problems??

    We also have problems with our DVD player (thought I always assumed it was due to the fact that we put it in aftermarket). Sometimes it won't power on or off and the DVD's are always freezing in it.

    I do tend to think that the electrical problems are all somehow related..
  • jafobob1jafobob1 Posts: 1
    Two things: Anyone else disappointed with the poor high beams on this vehicle? Anyone else having the high beams go dead? It's bad enough that the high beams are poor but to switch from low to high only to have pitch black is frightning. This is a Yukon XL Denali but I don't think the lights are any different than a regular Yukon (not like the older Denali's that had the unique projector beam headlights). My older 2005 has much better high beams. Any thoughts on either problem??
  • fixitrodfixitrod Posts: 67
    Interestingly it was eluded to the possibility that somewhere along the line a passenger switch got put on the drivers side. Actually a very reliable source.

    I also had a very long conversation with the installer of the current entertainment system In response to my report of the DVD player being on the blink. "By the time one pays for a repair for $50.00 more; maybe a $100 with installation. a new player could be purchased. So I replaced the dying DVD player and head unit with the Alpine set up and used the Metra/Access GMOS-04 to retain all RAP features, chimes. etc.. Stereo is a lot chrisper(more voltage from the aftermarket model) running through the amp. Next step is add a subwoofer to the head unit. I now have to figure out adding the subwoofer
  • tsf7tsf7 Posts: 31
    Hello. I am shopping for an 04-06 Yukon XL/Suburban, 1/2 ton 5.3 with SLT/LT package. Part of the reason for the purchase will be to tow a travel trailer, so I want to make sure I buy something with the necessary hardware for towing. Does anyone know if there was a "tow package" for trucks in these years, and if so, what parts did it add (trans. cooler, class IV hitch, trailer brake pre-wiring, 3.73 or 4.10 gears, ect). What is the "trailering preparation package", which all the trucks appear to have (I have noticed that every truck I have looked at had a receiver w/ 7-pin harness, but I have not remembered to look for a transmission cooler.)

    Of course, the salesmen are little or no help in answering these questions, and just "assure" me that it will do the trick, so I though I'd ask you all.

    Thanks in advance.
  • Is there a fuse for the accessory power outlet located in the rear near the liftgate? The other outlets work, but this one is dead.
  • fixitrodfixitrod Posts: 67
    Is anything else in the area not working. GM usually clusters things together so check your fuse specs and look for several listed together.You may want to check to make sure the wires behind it are not disconnected or corroded. If its isolated look only at that item. The element may be bad/burned out.

    Now for my questions
    1.I sometimes get a spoiled smell from my climate control outlets. I plan on changing the cabin air filters and see if this helps but is there a HVAC problem going on..
    2. My speedometer goes dead on my 03 YukXL/SLT package and Bose system. The symptoms are that it will register only 50mph and above or will just sit all the way to the right and register nothing. I have disconnected the battery and it rights itself but the repeated incidents of this make me think the brain is on t he way out or something. Anybody else dealt with this?
  • abdielabdiel Posts: 1
    I have a 99 yukon and oil started shooting out of the rear axle it also looks like something has tried to come out of the pan as there are big bulges and cuts in the pan with oil leaking out. Did the gears do this?
  • fixitrodfixitrod Posts: 67
    On my 03 XLT with 6 disc RAP/Bose system(I mention this because it indicates what level of electronics are in the truck) which has a speedometer that just stops registering. Usually I have had success with disconnecting the battery which resets the brain. This time however due to busy schedule I did nothing and its now working fine. This leads me to consider a more local problem like faulty dial bearings. Any thoughts appreciated!
  • The speedometer went bad on my 2004 Yukon XL too. There is a known problem with these in several model years. They replaced mine for free. Be sure to mention that you are aware that there is a technical bulletin on this and ask if they intend to repair it for free.
  • glynetteglynette Posts: 3
    I think on the 2003 they had a recall of the speedometers.
  • fixitrodfixitrod Posts: 67
    Contacted GMC and they responded very favorably and had me go to the dealer of my choice. They replaced the instrument cluster. Funny thing is this particuler dealer tried to get a $100.00 "deductible" from me which I refused to pay reminding them that this has been taken care of for free. Jeez...I had originally put the ball in their court reminding them that they who are suppossed to be on top of taking care of my truck had my truck in at around 70000 and missed this recall. My truck has 83000. Make these dealers back up what they say and rport them to GM when they don't.
  • pemortpemort Posts: 1
    Hi Woody
    I just got this diagnosis. The shoe fits. Mine is an '04 GMC Sierra. only 26000 mi. but out of warranty. they found codes P0171 P0174 and P0300. misfiring on every cylinder in history. # 2 prominently. Help me to understand. My dealer didn't mention Doc id # 1538353. He did show me that there had been a bulletin and I found it via # PIP3022A. Recommendation .... "fuel pump" $ 710.00 P+L. I asked if he knew that it would fix the problem. He said "everything points to it". My responsibility !
    Why aren't these things covered if they're problems known to GM?
    any thoughts ?
    Pete
  • zamraamzamraam Posts: 1
    Same problem with my 2003 yuk xl (sort of). Driver's seat will not travel back past a certain point (cramps me behind the wheel - really unfun). Reverse sensing on the switch sometimes and I can make the seat travel aft to a comfortable position by moving the switch forward but it hasn't done that for awhile. The seat position memory has never worked right on this vehicle. The dealer had supposedly repaired that twice back when the thing was still in warranty but it never held the memory properly and I gave up on it. POS
  • oh1odie1oh1odie1 Posts: 1
    Just to add to the long list of people unhappy with the transmission problems - We have to fork over $3000.00 for a new transmission. This vehicle has been in over the years at least 5 times for transmissions problems - but 36 days after the dealer recommended a "transmission flush" - the entire transmission blows up! Co-incidence? I think NOT! I think it is pretty suspicious that after a recommended procedure of "flushing" is done to have the transmission blow up only after 36 days!!! DO NOT BUY A GMC PRODUCT!!!! Basically, the dealer and GMC complaint department says "too bad, so sad" (I take that as a sign that obviously buying American is NOT what they want us to do- I guess Toyota is what I am looking at now!!) :lemon:
  • rshtrsht Posts: 277
    oh1odie1, I can not disagree with your post about the support we can expect from GM. However, don't think just because its a Toyota, it won't have defects and problems. Yes, I do agree that Toyota vehicles have the highest overall reliability rating, but, I have seen several cases of engine and Transmission failures (in different models, except Corolla) where Toyota will NOT do anything for their customers (So bad, too bad) leaving them to pay out of their own pockets.

    In my case (oh oh, breakout the violin), the short version, with my EX 2000 Toyota Land Cruiser-TLC, I finally throw my keys back to my Toyota dealer and told them to just send me the check for what the TLC's worth (which in mind still is a POS; and YES I walked home that day). The longer version, you would think the TLC is bullet proof, but it leaks in more places than my kid's diaper (at the transfer case and the right-front CV-joint, I have seen that in MANY TLCs and LX-470s around the 2000 to 2003 model years as well)... After a few visits to my Toyota dealer about the leaks, According to the my local Toyota dealer as well as the Toyota of USA Customer/Technical support, "the Transfer Case oil leak is best to leave it until the leak gets worse" (What kind of a support response was that ?? - about several drops each night is not bad enough...??), and as for the CV-Joint grease leak out of its boot, the dealer excused it as normal, they won't even try to fix it (i.e. replace the clamp of something) unless the CV Joint is bad. One mechanic told me off record, that its just too much pain to fix them, and not worth the risk as they are quite difficult to service..), what a shock it was for me to hear that -Wow! Now, you tell me if you were me, would you think from that point that TLC is reliable, especially with the transfer case leak? Would you appreciate the response from Toyota USA? Do you think the support received from Toyota USA and my dealer were helpful and supportive towards solving these leak problems? If you were me, would you drive that TLC for a family vacation?

    FYI, I have a 2007 Yukon Denali since new, so far, except for one computer Re-program recall, it has been 100% problem free. I guess there is always a bad apple in a group, regardless of which we picked just don't expect too much help from the manufacturers... unless all of your years of scheduled maintenance work have been done by your dealership, they may consider offering a couple of hundred dollars of discount on those major repairs.

    Best wish to all !!
  • colesecolese Posts: 1
    Good day,
    I am starting to hear a roaring sound from my SUV in park and in drive. It just happened when I turned the corner a mile ago. I believe it similar to your problem.
    How much does it cost for this repair?
Sign In or Register to comment.