Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Isuzu Trooper



  • atfdmikeatfdmike Posts: 414
    It is pretty hard to give you direction, but when you did the fuel pressure test, did you give the fuel system some off time and watch the guage for leakdown? If it is leaking down, often it is fuel regulator. I really suggest that you search a couple of the Isuzu forums for "fuel regulator" and maybe "check valve" and see what you come up with. I have suggested the most often quoted items to look at but that does not mean the cause could not be elsewhere. PlanetIsuzu is another great forum I check on too.
    good luck, one guys opinion.
  • cgb678cgb678 Posts: 1
    I have a 97 Trooper, when i put the key into the ignition and turn on the electrical systems, everything works fine. I continue to turn the key to engage the starter and I hear a loud click...everthing dies, starter does not engage and all electrical systems shut down. If i remove the key and wait a minute and put the key back into the igintion the electrical systems come back on but the clock and stereo have reset... still no start. Battery is new and fully charged. The starter was replaced last year. Any thoughts?
  • yes it definatly seems to be the regulator, because i have heard from people that normally once a fuel pump goes bad, it stays bad. in other words i dont think that if the fuel pump was bad it would give me such a hard time starting and then work great while running. so im quite sold it being the regulator, plus like you said, if isuzu is saying to replace the regulator from slow starting, then it must be a common issue. thanks i will check out that other site also
  • nope it wasnt the regulator. i changed it today with a new one and the problem continues. as i sat thinking about this problem, the trooper will fire up right away if ive been driving it, and if its been sitting for a half an hour will fire up after about 4 seconds. but if i let it sit overnight it takes alot to get it going. the mechanic had tested the pressure but not for a long period of time. so lets just say that it doesnt sound like the fuel pump because it wouldnt have pressure or be working at all, or over time stop working. so if it;s not the fpr and the pump is fine, then it would seem that there is some bleeding in the line somewhere. as i am not a mechanic firsthand i dont know anything about how or where i would begin with finding the bleeding. the mechanic said that 85% of the line is metal except for whats in the pump area. Is that right? do i want to pull the fuel tank down and look for bleeding there along with just changing the pump at the same time?
  • I have a 95 trooper that i recently crashed, i replaced the passenger side fender but i need the fender flare, with mudflap! It ruins the look of it and i can't find one anywhere!! Does anybody know where i can find one or does anybody have one on a parts trooper? Thanks
  • If anyone is contemplating this one, I did it myself in about three hours. You need a torque wrench and some parts of it are a pain, but it takes about three or four hours. At least for a DIYer.

    I followed directions I found on planetisuzoo.

    I had had a CEL for a while and surging idle. My mechanic told me it was the MAF sensor, but that didn't seem right to me... then I started hearing the engine whistle. Dead giveaway.

    It hasn't run this smoothly in a long time.
  • It's weird how easy it is to find the fender, and how hard it is to find the flare. Is this part still available from the dealer? Others speak highly of St. Charles Isuzu, and I know they mail-order parts.
  • okay, update on my failed startup progress for those interested. my 94 trooper with 168,000 miles runs strong, when its running at least. i have had trouble starting it, especially when its sat overnight or for a few hours. it will turn over but not start up. everything is well maintained, new/ filters, oil, pvc valve, fuel pressure regulator, fuel pump and strainer, fuel filter, spark plugs, well basically you name it ive just about did it. and it still will not fire up, and now its gotten quite bad where i think im going to trash my starter by cranking on it so long before it fires up. i tested my fuel pressure, and over time it looses pressure, but not much, i think that there is a leaking fuel injector and it is flooding my spark plug out, and when i try to start it takes a good minute to burn up that excess fuel, but once done, fires right up and if i turn the trooper off and then back on it will fire right up everythime, once chambers are cleaned and dry.
    so i let the vehicle sit overnight and in the morning pulled all spark plugs out and smelled them all over and over. I found that one spark plug reaked of gasoline, so hopefully my theory is right and its a leaky fuel injector that is flooding the system and is the final cause to this problem. tommorrow i begin the replacement process. i will respond with a conclusion.- jes
  • Howdy folks,
    after the rains this last weekend, I went out to my trooper to discover that the passengers side floor were soaked with water. It's coming in thru the blower motor. I took the garden hose and soaked the windshield and the flow started again. I loosened some of the screws mounting the blower motor, and quite a bit of water came rushing out. Is this a pretty common problem ?. I've had the Trooper for several years and this is a first. Any suggestions as to what to do to rectify this problem. Thanks for any input. John
  • gahlgahl Posts: 7
    a word of advice to any who may think they need to replace the fuel pump in your Trooper - go to the passenger's side of the gas tank & find the electrical connector at the side of the tank - twice now - on two different Troopers I thought the fuel pump was shot - it looks like a well sealed connection but use a small screwdriver to open the snap & pull the connector apart - push it back together & there is a good chance it will now start - sure beats a new fuel pump install
  • 2001 Trooper, 40,800 orig miles, first owner. No problems to date.

    Recently tried to engage shift-on-fly 4x4 but it would not engage. Dash light blinks normally but front wheels do not kick in and dash light just blinks until I give up and turn off shift-on-fly switch.

    No odd noises whatsoever, drives perfectly in 2-wheel drive.

    Have tried to engage 4x4 from dead stop, low speed, 60 mph, but no go. 4x4 has worked perfectly before, this problem just began with the first snowfall. (Typical!)

    What else could I try? :sick:
  • atfdmikeatfdmike Posts: 414
    It sounds like your vacuum operated actuator on the front axle is not working properly. It is attached to the front axle and when 4WD is applied it actuates the spline coupler to lock the front axle into proper mode. You can at least check to see if vacuum is applied when you shift into 4WD by checking the vacuum lines at the actuator. It is not uncommon for these actuators to stick.....the 4WD should be engaged periodically even when not needed to keep these parts working properly. One guys opinion. good luck
    imageSee more Car Pictures at
  • This sounds like a great place to start...

    Question 1: How do I check for vacuum at the actuator? (Engine off/on? Tranny in park or not? etc. Don't want to run over myself.)

    Question 2: How can I "wiggle the actuator free" if it is 'stuck'.?

    Question 3: Where does the other end of the vacuum hose attach? I'd like to check both ends to make sure they are attached properly. Is it possible it might have been knocked off during pressure washing engine bay?

    Thanks for your help. Wes.
  • atfdmikeatfdmike Posts: 414
    Very briefly, need a vacuum source (engine running), park....remember you are just checking to see if vacuum is getting to axle from t-case. Once you establish that vacuum is present and switching with your interior switch, then move on to repair.
    Wiggling as you call it is a little more interesting.
    Go to, enter your vehicle info, then find Illustration figure 4-12, second image. It shows the axle assembly schematic. Before attempting to remove the actuator, I would definitely drive the vehicle long enough to warm it up and repeatedly try to cycle the SOTF system (after completing Question 1and finding the vacuum switching with the switch...I don't know which port has to have vacuum to work right, but obviously it should change when you cycle the switch.)).
    The t case has an electic shift motor and a module sits atop the case where the vacuum is switched by the shifting tcase. If you search you can also identify it. You would want to work your way back to the vacuum source on the engine too....I don't know your motor but I think you should be getting the gist of this.
    The electric switch on the axle actuator is just to turn on or alert the driver and 4WD system as to the status of the axle, it does no other function.
    Also, If you have TOD system, I know even less about that except it can be hard to troubleshoot. Good luck.
  • ddahzddahz Posts: 1
    purchased a 99 trooper w/ 101,000 miles on it about 6 months ago. I had to replace the intake man. gaskets to get it to idle and run correctly. now i would like to get some decent gas mileage. i love the vehicle (its the luxury mod. w/ all the toys) and it does real well in the snow, but i can't live with 10-11 miles per gallon. any ideas on how to get that up to 18-19 mpg? computor chip, o2 sensors, different injectors, new plugs? Thanks in advance
  • domo1domo1 Posts: 1
    when heatis on no wam air is coming out have replaced the thermastat to no avail was told it could be the heater core but can not find the part to buy is there anyway the old one can be worked on to still be able to use it
  • I didn't see what year your Trooper is. I had a 1990 with same problem.

    Like you, I did some things to TRY to solve the problem...engine flush, rad flush, new thermostat...nothing worked.

    It turned out that the problem was with the valve that routes hot water from the engine through the heater core. Hot water was not getting into the heater core at all, so of course no heat would come out into the passenger compartment.

    I can't recall if the valve was actually built into the heater core or if it could be replaced separately, but pull out the heater core and have a look at that valve...I bet that's your problem.
  • atfdmikeatfdmike Posts: 414
    I suggest you eliminate the basic causes of poor mileage......check your tire pressures and regular maintenance items. The plugs may help, but there is no realistic way to raise mileage above the rated MPG from the manufacturer. IF your O2 sensors are bad, then that would cause your ecm to run in the cold mode and enrich the fuel mixture.....not good for mileage. I guess you would have to use your best judgement OR have a technician check the vehicle while operating with the proper Tech2 OBD to make sure it is performing correctly. One guys opinion.
    Good luck.
  • I have dropped the Pan and drained the ATF but the resevour has not emptied out. Also where do I put the ATF fluid back in to fill it up?
  • atfdmikeatfdmike Posts: 414
    Whoaaa.....we need a little more info on what year, model , engine and type of transmission or system you are working on. Once that is posted I am sure you will get some good replies.
  • Under 50K miles - yup. 2WD model. By the time I noticed fluid on the driveway and figured out it was the Trooper, it was too late. Leak found and fixed but the trans was gone - only had 1st and 2nd gear and it was not happy. Long story short, excellent rebuild by Gold Coast Transmissions in Ft. Lauderdale (top notch) so try these guys if you have to. Fuh-ortunately, my mechanical breakdown insurance covered the extensive cost minus deductible. Isuzu's only response (what's left of the dealers) was to inspect and if they felt like it, replace the whole unit under warranty (maybe) - (some mechanic who only knows how to unbolt and bolt on a tranny.) So ... watch the fluid leaks friends. If you need a picnic spot, you can eat off the floors at Gold Coast. Really impressive.
  • Were there any other symptoms of the transmission problem aside from the fluid leak? And where was the leak itself?
    I also have a 2WD 2002 under 50k in South Florida. The only transmission issue I have noticed so far is a small clunk going from Park to Drive or vice versa. Gearshifts seem fine.
    Was thinking of having it checked out (recall the old AAMCO ads), and will run it by Gold Coast - anyone there in particular?
  • matausmataus Posts: 43
    I really hope someone can help me. I ran into a situation today with my 1990 Isuzu Trooper 5 speed manual. With a 2.8 liter V6.

    Today I stopped to wash my car at the car wash. After I did so, I jumped on the hiway. About a miles down the freeway, My vehicle stalled. On the side of the freeway, I went thru the process of problem solving the situation. This is what I had done....

    First and foremost, I checked the distributor and router for moisture. In doing so, I found no moisture. I then checked all the plug wires, and everything was secure and dry. After that, I went ahead and checked to see if I had blown a fuse. In doing so, nothing was blown. I also checked the fabric wire fuses and rearanged the relays next to the fuses. Then I started to think that there was fule pump problem. I went ahead and put some fuel in the carb from a gas can I always keep for safety purposes. I added not too much and not to little. In craking it over, nothing fired. It just turned over. So then I got thinking, maybe my coil was shot. I went ahead and purchased a new one at the auto store and replaced the old one. To all avail, It still woudn't fire up. All it's doing is turning over. In the end, I ended up having to have it towed home.

    So here I am, and I just don't know what to make of it all. When I look back to what I did at the car wash. I didn't open the hood this time to wash down the engine, so I don't know how water could have got anywhere. One thing I did do was spray under the engine and the under carrage. I always do so here in Colorado. Esspecially when the snow and mud collects underneeth.

    If there is anyone out there that can help me troublshoot this problem, It would be soooo greatly appreciated....

    Thanks a bunch....;)

    Maddy :confuse:

  • tidestertidester Posts: 10,059
    Did you check the coils, battery and ground connections or sensors? You could be shorting out some of the sensors giving false reading that prevent the car from running.

    Anyone else have ideas?

    tidester, host
    SUVs and Smart Shopper
  • Hi again... I found the drawings you mentioned...very helpful, thank you!

    UPDATE: I have not crawled under the beast yet, HOWEVER, yesterday when I started up and drove away, I noticed the 4x4 was fully engaged! (Dash light was fully on, traction on ice was obvious.) I switched 4x4 OFF while driving and tried to engage in again, but it did not. This has happened twice...4x4 will engage from a cold start. I tried a few things like putting in park, hit dash switch and drive off, but no 4x4. Engaging in reverse, no. Hitting button multiple times, no.

    What do you think of this, and what else do you think I should try?

    Also, this is an '01 with under 50,000 miles. Do you think a warranty applies?

    Thanks. Wes
  • atfdmikeatfdmike Posts: 414
    Hi, I don't know a bit about warranties, so you would have to contact a dealer or find another owner who might know.
    I don't have your year or type of front axle, but to make a guess on what you describe, I would ask a couple more questions. When you hit the 4X button, do you hear the transfer case shifting in and out of 4X? You can listen with the vehicle sitting still, it does not have to be moving to shift. The electic shift motor should cycle or attempt to when you hit the button.
    If you hear the transfer working consistently, then I would next check the vacuum being applied to the axle.
    It could be that after sitting, the vacuum is gone and on start up, and if the vehicle is in 4X then the axle shift actuator is reacting to that command and does not have to overcome the vacuum that pulls the axle out of engagement. IOW somewhere there may be a sticking valve. It could be the one on the trans case that reacts to the trans case shifting into 4H or 4LO and sends vacuum to one side of the actuator. I am not that familiar with the actuator system, so I don't know if the actuator is spring loaded one way or the other or whether vacuum in the other direction is needed. I would research that a little more, by carefully looking at the axle actuator and pulling the vacuum hoses while the transfer case is shifted into different positions. You should be able to determine what is happening (or not). Remember that to be safe, park on level surface (or ramp) with park brake on and chock the rear wheels at least. You don't have to have the vehicle in drive to operate the transfer case and thus the axle. Vacuum should at least be present or not depending on the button position. Listen before doing anything for vacuum leaks. Have someone you trust shut off the engine while you are listening down there to hear if you hear a leak as might be present.
    I am no expert,but I think this will cover the basic things. Be careful if you elect to do it, good luck
    These are pretty easy things to check first in the event you don't have warranty coverage.
  • renet10renet10 Posts: 13
    I have replace the alternator belt 2 times. I still get the squeal. :mad: I tighten and tighten but still the squeal. :mad: The last belt broke. Is there anything else that controls the tension of the alternator belt that will eliminate the squeal and get my amps up? :sick:
  • The belt might fail prematurely if over tightened.
    Are you having a problem getting enough amps from your alternator? The belt squealing sounds like the alternator, if working properly, is making a lot of amps which is why it is hard to turn. Maybe you have a short circuit or too many loads (120Vac inverter running something big?) demanding excessive current. If you want lots more current there are after market alternators that can be made to fit that can produce 200Amps maybe more, some can act as a welder too.
    It could be excessive mechanical friction preventing the alternator from turning freely, that would make the alternator body hot.
    It could be not enough friction on your pulley. If the pulley is worn out or coming apart then the belt might not fit securely and that could make it slip. If this is the case the slipping pulley will be hot.
  • atfdmikeatfdmike Posts: 414
    Are you sure it is alternator? Reason I ask is Power Steering is right above and sound you hear could be that? . Also I would check the V grooves on the crankshaft...they may be full of melted belt which will have to be removed in order to get the proper friction. I have seen this on the AC belt as well.If not, you may have bearing in fan going.
    Hope this helps. Good luck.
Sign In or Register to comment.