Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Cadillac Escalade Maintenance and Repair

2456

Comments

  • What could be wrong with my trasmission. I have a 2002 6.0 L, AWD Cadillac Escalade. I put my truck into reverse and pressed the gas. I heard the wheels squeal and then a loud Clank, as if something broke. Now my truck will not go into reverse. I mean that it will not move backwards in reverse. It still drives (D) forward but nothing in reverse. What could possibly have broken. Will I need a total new trasmission or some repairs to this one. I know a new transmission will be upwards of $1300-1400 dollars..right?? Any suggestions??
  • I drove my 2003 Escalade home one night. The next day I tryed to start it and it would not engage the starter. I charged the battery but that was not the problem. Everything seems to work when I put the key in but when I turn to start it does nothing. It seems that it is not sending juice to the starter. Any sugguestions? Is there a fuse I should look at? Help. Jeff
  • jjyoojjyoo Posts: 1
    Hi! Just started reading the messages on this forum regarding Escalades because of the many problems I've been having with mine. I've got an '05 Escalade with the same clunking noise from 1st to 2nd & then back from 2nd to 1st gears. I took it to the dealership & got the same catch-all response, "it's normal noise that is characteristic in escalades." My driver side mirror is extremely blurry when the night time glare reducing feature is working. They said they replaced the mirror twice but I still have the same problem. Their temporary fix was to place a piece of black electrica tape over the sensor so that the feature would not be activated by the headlights behind me. Now that's Cadillac quality!!

    I've got 8500 miles on my Escalade and have taken it in for service 9 times! It always takes 3 trips for them to address a problem. And with the exception of a power steering noise, they would keep my vehicle on the average of 7 days or more only to tell me that the problem is normal and that they don't have a fix for it.

    Now I've got a high pitch whining/whistling noise that is noticable at around 700 rpm. The service manager and techs were able to reproduce the sound and they all said, "hmmmm. that's odd!" Then after keeping my car for a total of 18 days or so, they tell me that the noise is "normal and characteristic of Escalades". When I asked him to pull out the Escalade they had in their show room to show me that it's normal, they played a song and dance and wouldn't do it.

    I've had 4 Chevys in my life and loved them. I cannot beleive that this luxury manufacturer is so incredibly horrible to their customers. I'm currently trying to have the dealership do a straight swap of my Escalade with a new one or just hire a lemon law attorney. Don't know yet.

    I think we should just launch a class action lawsuit against Cadillac.

    Good luck with yours.

    janet
  • tdohtdoh Posts: 298
    Man you gotta love their logic--it took them over two weeks to finally tell you that "it's normal"? If something is "normal and characteristic", then that kinda implies that they've experienced that situation before...in which case, why would it take them that long to realize that the issue at hand is "normal"?

    Typical GM service department BS explanation...not so much that they tell you that something is "normal", but that it takes them so long to make that determination. :mad:
  • dapper1dapper1 Posts: 1
    i also have the same problem only it happens to me almost once a month my doors lock and my windows go down but the vehicle will not start we had on star run a test they found nothing wrong it has been to the garage several times and the battery has been replaced. our stablelizer bar light comes on sometimes. this is driving us crazy
  • I was driving my 2003 ext and let off the gas because a car pulled in front of me. When I pushed back on the gas, the truck kicked into the passing gear. I stopped at a store and then realized the truck was not shifting into third. I watched the transmission temp. and it never got near hot. Then when I was close to my house, it felt like I was in neutral and the vehicle started slowing down. I pulled over and now all gears are like I am in neutral. No reverse, low, drive...anything. There have been no prior problems. I check the fluid and it is full. Does not spell burned. Anyone have any ideas??
  • gap2006gap2006 Posts: 20
    Apparently transmission clunks in low gear are pretty common in Escalades. I was just on another site where they mentioned a service bulletin that all Caddy Service Centers should have discussing it. Some of the posts said they could adjust the software if they know what they are doing. Another post said the transmission sometimes does not downshift all the way into 1st at a red light and the clunk is it downshifting when you step on the gas. He said he brakes completely then lets the car roll forward a little and it solved his problem.

    I have been getting some of the same in a new '07 plus the transmission feels like it vibrates a little so I may be taking it back in for a dealer check myself.
  • auto007auto007 Posts: 5
    I brought my new Escalade into the shop for the following:

    1) Driver's side mirror vibrates. They said they tightened it. However, I can still see it vibrate (mirror). I've read somewhere that a fix exists and I assume my dealer has no clue. Is this a service bulletin? If so, can someone lead me to it so I can lead my dealer?

    2) I was constantly getting flashed by other cars thinking my brights were on. My dealer adjusted the lights and now the light focual point is way off. The right side beam is much longer then the left side and it is very distracting. Looks like 1/2 an arc of beam. What are the guidelines and process for them to adjust correctly?

    3) Anyone get vibration in wheel at high speeds, what causes this? Supposely they just did an alignment.

    P.S. Anyone know where I can get a bug net to fit the front? What about cost effective headseat video monitors for 2nd row?

    Thanks
  • gap2006gap2006 Posts: 20
    I read a few posts on the mirror issue. I read that the fix is a piece of foam installed somewhere and it's a known issue. You could try a search on the forum or maybe try reaching the regional manager for Cadillac if all else fails.

    I have not noticed vibration with my 22's. What size wheel do you have. And what speed are we talking about? 60 or 100? I'll try it and see what happens.

    You might try ebay for the bug net and videos. I picked up a new Escalade cargo mat on there plus a nice set of Escalade mud flaps.

    Good luck. It's a great SUV. I'm sure you will be able to work the bugs out.
  • matlincamatlinca Posts: 5
    hello, i work on cadillac's,, i have worked on 15 o7 escalades includeing my own with this problem. my own escalede has this problem but is 5 times worse because i have 28" rims on mine. the problem is simple = the rims. The 22 inch rims make the ride of the escalede bumpy the bumps are absorebed by the frame and the shocks so you cannot feel them. when the frame vibrates it moves back and forth causeing the mirrors to vibrate evan to the extent so you cannot see out of your mirrors. this is commen on cars or trucks or suv's with rims over 20" but not this baddd :mad: i actually had one guy come in because his drivers side mirror fell off, exposeing the wires. cadillac respods with " we have reviewd the vehicle several times and found no such problem , all mirror's work and function properly and are secured properly" truely i think that is a buch of bs. i ahve complained many times but they refuse to respond to my problem. if i come up with a way to stop this or get a good response i will let you all kno. thanks

    matt
  • matlincamatlinca Posts: 5
    also dont get me wrong it is a great suv but the dealer should know of this problem or atleast know how to fix it. also to replie to auto 007 the suv's lights are very bright people are just flashing you because your new headlights are blinding but thats not your problem, you just bought the suv........there just gunna have to deal with the lights.. :shades:
  • awf_axisawf_axis Posts: 136
    The thing about the vibrating mirrors is that it is loose to the touch, and the passenger mirror is rock solid. This problem shows at 50+ mph speed, even on smooth roads.

    As for the lights, I adjusted them downward so that it matches the beam height of my wife's BMW, and no one complains anymore.

    Dave
  • escy07escy07 Posts: 3
    hey Folks. I bought my escy 3 months ago direct fromm texas.
    I was the first in my dealership to notice the whistling noise in the mirrors(the fix is a piece of foam that they ordered and installed- its perfect now)

    Has anyone been expieriencing A low idle and most importantly a deceleration a "hesitation" ? its very noticable when you take your foot off the gas at low speeds around a corner and go to put your foot back on the pedal and theres a buck and a low idle.

    Any suggestions..??? i brought it intoservice 3 times and there was a small adjustment caddy made on a "idle" issue but after programing it only helped about 50%......
    any ideas???
    JP
  • wcb22wcb22 Posts: 1
    I just got my 2007 Escalade about two weeks ago. The only problem I'm having is with vibration/shaking at high speeds (i.e. 60 mph or higher). The car vibrates or shakes, almost like you're going over the rumble strips on the berm of the road, while traveling at 60 mph or more. This happens even on smooth roads. I haven't taken it in yet but was curious if there's an easy fix to things here. I have 22" factory installed wheels on the car.
  • gap2006gap2006 Posts: 20
    That doesn't sound right. I have 3500 miles on my '07 with 22s and even at 90 it's a pretty smooth ride. I know a few people have had vibration problems with their driver side mirrors but I have not noticed that either. Sounds like you better have a dealer take a look and maybe consider 20s or 18s.
  • awf_axisawf_axis Posts: 136
    I would think that it is either a tire balance issue, or worst case, that one of the tires has a flaw. You might want to suggest that the technician at the dealer do a test drive.

    Dave
  • chadmanchadman Posts: 2
    I'm still having the starting problem. Did you get yours fixed? If so what was the problem?
    Jeff
  • cody10cody10 Posts: 3
    I have an 07 Denali. I love it except two issues. I too am getting the throttle hesitation. When I slow down, and then hit the gas again there is a 1 second delay before it begins to throttle up. I sure hope there will be an updated flash for the 6.2L soon. The other issue is a nagging "service suspension" message on the DIC.
  • awf_axisawf_axis Posts: 136
    The hesitation is something that is a mostly a programming issue, of the throttle by wire, and optimal gearing. The transmission needs time to shift into a higher gear before allowing the throttle to open, so this takes time. I've had this "feeling" in my GM's since the '01 Denali. You actually learn to drive with this, meaning you anticipate the delay, and work around the delay.

    As for the suspension, you should go to the dealer. Provided you have not lowered the suspension (shorter springs), or removed the level sensors, you probably have a problem in the air level pump and/or plumbinb. There are two air lines that run from an air compressor (just in front of the spare tire, behind the axle). There are is a small-thin plastic airline running to each rear shock. These can pop off, because GM used in some models, a plastic retaining clip, rather than a metal one.

    Dave
  • rcrick10rcrick10 Posts: 1
    hi, i have a '02 escalade. i've ownd it for one year now. i resently started having problems with my a/c. first my rear a/c quit working and about a week later my compressor went out. i've replaced the compressor and had the a/c charged. the front works great but the rear a/c still won't work. just wondering if any one can tell me where to start. thanx, rick
  • whatsnuwhatsnu Posts: 5
    i have 95,000 miles on my 2002 Escalade and have differential lock-up problems when the trans gets heated up. Has anyone else experienced this? the wheels, when turned cranked all the way to the left or right start 'skipping' on the pavement as if the limited slip differential is locking the wheels. the dealer stated that despite encountering this problem with other cars, they cannot accurately pinpoint the problem without going through a number of 'fixes' as a process of elimination---at MY EXPENSE! (1)this does not seem reasonable and (2) i can't believe the dealer actually expects a customer to pay for their 'R & D'....any suggestions from anyone will be greatly appreciated. i love this car...up until now!!!!
  • kcikci Posts: 1
    Sorry to hear that...it seems that I have the identical problem. Took it to two dealers...neither could diagnose???!!

    Is there a Cadillac complaint hotline?

    Please advise!
  • Hi,
    Does anyone know if part number 0123521 is compatible to 0019911 on a 2002 escalade AWD 6.0 liter. Other numbers on the shocks are:
    old 15058601, T7K new 15762865 T4A
    The air bag on the old shocks leaks and I can buy the new shocks for 1/3 the price of new from an online source.
    Thanks
    jim
  • I have the same issue with my 2007 Escalade. I have talked to the dealer and do not seem to be to concerned about it. I do have a problem paying $60,000 for a suv with this type of a problem
  • escy07escy07 Posts: 3
    I have a huge issue with this hesitation. Yesterday I slammed on the breaks to avoid a car cutting in front of me then put the gas on full. and had no response for a good second when i needed it immediatly.

    Has anyone heard of any fixes for this??
    i am bringing my 07 escy in for the 4th time tommorrow.
    I'm hiring a lemon law attny if they have no fix. Does anyone know caddy's headquarters service #? or where or hot to complain in detroit?
    Thanks
  • I am on your team. If you find a contact let me no and I will also contact. Please post what you find out. I was told be a service underwriter sometimes this is called a "drive wire" issue. A hesitation. There is no throttle cable and the computer controls everything. To me it is like the vehicle "chokes" when you give it the gas and then finally responds.
  • THis is also for KCI. Perhaps the same prob. Cheap [non-permissible content removed] car would occasionally bounce violently just like you said, a sort of skipping except it would also happen while going straight. Rip off dealership said needed to repair front differential for $1900, if it got worse the cost would be 4-5 K. What have you done with your cars? thanks.
  • cody10cody10 Posts: 3
    I just took mine to the dealer last week. I got the phantom wipe fixed on the auto wipers. They updated the Engine computer with newer code. Did not help..in fact.. I think it is a little worse. With the A/C on, half throttle of the line will cause very noticable hesitation. I am trying to be patient since this is a new engine/tranny combo, but doesn't GM road test these darn things before mass producing?
  • OMG :0)...... I thought I was the only ones with vibration at highway sppeds, mirror vibration and hesitation!!!!

    2 trucks, same thing

    Mirrors, been in 3 times, replaced mirror and then tightened it up per bullentin. mirror is worst. I can fix with a peice of cardboard. They claim caused by wind reversion. My question, why not passenger side?

    Phataom Wipe, got that

    Vibrations: Been in 3x times, a little better but over 75-80 vibrates and is driving me crazy. People talk about low profile tires, etc... My vette cruises a 100 without a hint of vibration. so BS about low sidewalls. I am working with Customer Assistance on this.

    Hesistation, they say no fix, but I came across a website that you can search for comupter updates by VIN. If I can find it again, I will post. But, yes, it said my truck needed tow updates.

    I am giving customer assistance another shot before I go lemon law.
  • gap2006gap2006 Posts: 20
    My 2007 Escalade doesn't have the vibration problems with 22" wheels but it does have the hesitation. Not that it helps much, but my Mercedes had the same issue and so do a lot of other luxury vehicles including Infinity and Lexus. Step on the gas and go nowhere while a big truck is coming to wipe you out. I think it's the technology that is the problem, not Cadillac specifically. Of course, that doesn't do us much good now.

    Keep us informed.
  • here is website to check software updates

    http://tis2web.service.gm.com/tis2web

    Also, sorry about my misspells didn't notice until read back
  • Love my new escalade, but each half of the truck from side view are two different colors. Front half darker than rear half. To pay extra for white diamond and get this paint job, not happy. Also right rear door is not flush with body and was adjusted by dealer, then by dealers body shop. Still not aligned. Anyone else have these problems or advice on what I should do?
  • did you ever find out what the problem was? My 2000 caddy dies if I don't drive it for 3 days, something is draining my battery. Any ideas?rebeccaf
  • when i push the gas pedal completely to the floor the vehicle does not move there's this revving up of the engine as if the vehicle is in neutral i've replace o2 sensor catalytic convertor,plugs,fuel filter cleaned the injectors.i've read numerous replies on similar issues is this normal for this vehicle? anyone else experiencing the same problem? have not taking to dealer yet why the hesitation and sputter?
  • The problem you described just happened to me this morning. Did you ever get yours fixed? I've had a number of electrical problems with my 2003 ESV, including several blown fuses, power window and heated mirror malfunctions all within the past year. I am currently working with cadillac.com to resolve. This is just the latest problem.
  • Hello,
    Glad to hear someone is happy with their Escalade. I just bought mine a few days ago. A 2003, I do have one questions for you, if I may ? It didn't come with an owners maual because we bought it privately. We are able to get the DVD player to play, I see it but we cannot hear it. Is your DVD player under the rear passenger seat ? And if so, how do you get audio and adjust the volume ????? My kids are watching with no sound.....please help. I know noone else in the are with one and can't ever get in touch with the previous owner.
    Thank you for any help.
    Kym :)
  • Hi everyone, Just purchased my 07 escalade 2 weeks ago. Haven't had any problems so far, however I'm curious to know if there is some way to play the in-dash DVD while driving? I heard there could be a wire of some sort that can be disconnected. ;)
  • awf_axisawf_axis Posts: 136
    The newer '07 GM's all use computer bus connections between the Nav, Audio, Engine, etc. It takes more than just a wire. Consider that a common bus is like a USB cable. Signals, rather than live wires, do all the work for sensors, NAV and such. Even your stereo handles the beeps and bongs in place of separate devices. Costs less.

    Now, there are two companies that have developed solutions, but both are still buggy. One system creates a situation where the volume doesn't work when the DVD is engaged up front (CoastalTech).

    www.tvandnav2go.com

    www.coastaletech.com

    Dave
  • Hi,
    I realize that your message was from 2 years ago, but I am having this same problem with my escalade. Did they ever figure out whether it was a recall or not?
    Thanks
    Dave
  • Dealer claims phantom wipe is 'by design'. Says Cadillac intended it to do a single wipe up on starting up so that you know the wipers are on. uh huh.

    Hesitation - having issue when I press on gas when cornering or doing between 35-40 - around town speeds - and you press on the gas and the engine actually lowers RPMs and sounds like it's bogging down, until you finally press the gas hard enough for it to kick up a gear. I complained last time it was in and they re-programmed it and now it seems worse.

    Had the '07 now for 6 weeks and it's been in the shop twice now - both over night.
  • awf_axisawf_axis Posts: 136
    The phantom wipe does have a fix. Caddy has a firmware module update that has been available for months, so the dealer is giving you a line.

    http://tis2web.service.gm.com/tis2web shows:

    BCM (Body Control Module), Wiper Control - Part # 15924898 CVN # 0000E48F (New software for improved operation including a fix for phantom wipe when rain sensing is enabled).

    There have been 2 more upgrades since then as well. Current part # is 25779880 CVN # 00008143.

    This is quoted from GM's service site. Go to the address above, and put in your VIN number. It shows all kinds of software upgrades for your specific vehicle. For each category of module you find, the most recent is on the top.

    The transmission is another topic that has numerous upgrades as well. I current have an 4-5 shift flare, which is also identified on the TIS web-site. I have to schedule an appointment for this soon.

    Dave.
  • zzz1zzz1 Posts: 1
    Try tuning the radio to 88.7...
  • I have seen many posts about the 2003 ESV that will without warning, not start. Has anybody determined the cause of the mysterious problems in our top of the line vehicles. I checked fuses, starter, and anything I could without taking much apart. I had it towed today and will report to you when and if the problem is solved. Does anybody know?
  • In my 03 the sound for the entertainment system can be found by going thru the source selection switch with the dvd player on. The option for the DVD player will appear and become available IF the DVD player is on.
  • REAR ACCESS OPEN MESSAGE COMES ON RANDOMLY MORE NOW THAN EVER TURNING DOME LIGHTS ON AND BEEPING WITH MESSAGE REAR ACCESS OPEN MESSAGE REAR WIPER WILL NOT WORK WHEN MESSAGE IS ON HAD TO DEALER 3 TIME TO NO AVAIL
  • tidestertidester Posts: 10,059
    Just a suggestion, but turning off your CAPS LOCK and inserting occasional punctuation marks will make it easier for people to read your message and make it more likely for you to get a reply. :)

    tidester, host
  • awf_axisawf_axis Posts: 136
    Sorry, I couldn't resist...

    image
  • tidestertidester Posts: 10,059
    Sorry, I couldn't resist...

    I noticed you did not reply to jezell's question. Could it be the use of ALL CAPS and lack of punctuation? Sorry, I couldn't resist ...! ;)

    tidester, host
  • Sorry,I couln't resist.. GET A LIFE MORE ON HA HA!!!!
  • I have a 2002 Escalade and I have had it towed 5 times because it just wouldnt start. They put in 2 fuel filters so far, but it keeps happening. The last time I had it towed to the dealer it started when it got there. The other day I went to have it towed, again, and the tow driver said this has happened to him before, so he got under and hit the fuel tank with a 2 x 6 and guess what, it started. Anyone hear of this happening to them?
Sign In or Register to comment.